You are not logged in.

#701 2013-11-09 01:10:28

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: infinality-bundle: good looking fonts made (even) easier

I think I posted my thanks for this in the wrong thread, so thanks again for making fantastic fonts so easy smile. (I discovered the packages and then posted in your fonts thread rather than here so apologies for the misplacement.)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#702 2013-11-11 11:29:29

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: infinality-bundle: good looking fonts made (even) easier

@bohoomil

I found the following disowned (not owned by any package) files. Am I safe to remove them or does your bundle require them?

/usr/share/fonts/local
/usr/share/fonts/local/fonts.dir
/usr/share/fonts/local/fonts.scale
/usr/share/fonts/misc/fonts.dir
/usr/share/fonts/misc/fonts.scale
/usr/share/fonts/OTF
/usr/share/fonts/OTF/fonts.dir
/usr/share/fonts/OTF/fonts.scale
/usr/share/fonts/TTF/fonts.dir
/usr/share/fonts/TTF/fonts.scale
/usr/share/fonts/Type1
/usr/share/fonts/Type1/fonts.dir
/usr/share/fonts/Type1/fonts.scale

Offline

#703 2013-11-11 16:42:06

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: infinality-bundle: good looking fonts made (even) easier

@orschiro, those are the files that are generated by the install scripts of the font packages.

$ pacscripts <one-of-bohoomil's-packages> 

^You can either use the package name, or actually give it the path to the pkg.tar.xz,

Offline

#704 2013-11-11 23:50:09

Jristz
Member
From: America/Santiago
Registered: 2011-06-11
Posts: 918

Re: infinality-bundle: good looking fonts made (even) easier

I cant start fontforge

% fontforge
Copyright (c) 2000-2012 by George Williams.
 Executable based on sources from 14:57 GMT 31-Jul-2012-ML-D.
 Library based on sources from 14:57 GMT 31-Jul-2012.
Help! Server claimed font
	-misc-dejavu serif-medium-r-normal--16-0-0-0-p-0-iso10646-1
 existed in the font list, but when I asked for it there was nothing.
 I may crash soon.
[1]    19222 segmentation fault (core dumped)  fontforge

And not I not have any .Xdefaults, I only usyoyr fonts + the bundle fonts...


Well, I suppose that this is somekind of signature, no?

Offline

#705 2013-11-12 01:05:16

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

That's odd… Here is mine: FontForge screenshot. Did you upgrade your system? Pango has been bumped to 1.36.1 recently. Besides, try removing $HOME/.FontForge and see if it helps.

Edit I think I know what it can be: you probably still have old Xorg font indexes in /usr/share/fonts/{TTF,OTF,Type1} (fonts.{dir,scale} files). FontForge seems to be looking for fonts by metrics and names provided by these files. Try removing them in the first place running

# mkfontdir /usr/share/fonts/{TTF,OTF,Type1}                                 
# mkfontscale /usr/share/fonts/{TTF,OTF,Type1}

and check if FontForge starts up correctly afterwards.

Removing the files altogether is not recommended: if we do so, Xorg will leave a warning in /var/log/Xorg.n.log.

Last edited by bohoomil (2013-11-12 07:42:20)


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#706 2013-11-14 23:22:35

Jristz
Member
From: America/Santiago
Registered: 2011-06-11
Posts: 918

Re: infinality-bundle: good looking fonts made (even) easier

Nope, remain complain about the same issue
System upgraded complettly and I have all the ultimate-bundle-fonts and the possibles extra (whit t1 prefered over the other)


Well, I suppose that this is somekind of signature, no?

Offline

#707 2013-11-15 01:27:16

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

Did you check journalctl output and Xorg.0.log?


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#708 2013-11-15 05:40:37

Jristz
Member
From: America/Santiago
Registered: 2011-06-11
Posts: 918

Re: infinality-bundle: good looking fonts made (even) easier

Interesting....
Xorg.0.log:

[    41.239]
X.Org X Server 1.14.4
Release Date: 2013-10-31
[    41.239] X Protocol Version 11, Revision 0
[    41.239] Build Operating System: Linux 3.11.6-1-ARCH i686
[    41.239] Current Operating System: Linux yiazmat 3.11.8-1-ck #1 SMP PREEMPT Wed Nov 13 15:39:00 EST 2013 i686
[    41.239] Kernel command line: BOOT_IMAGE=/vmlinuz-linux-ck root=UUID=69b866de-b8ee-4135-80ec-43149476cb2b rw quiet pcie_$
[    41.240] Build Date: 01 November 2013  05:13:46PM
[    41.240]
[    41.240] Current version of pixman: 0.30.2
[    41.240]  Before reporting problems, check http://wiki.x.org
  to make sure that you have the latest version.
[    41.240] Markers: (--) probed, (**) from config file, (==) default setting,
  (++) from command line, (!!) notice, (II) informational,
  (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    41.241] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Nov 14 19:00:09 2013
[    42.787] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    42.788] (==) No Layout section.  Using the first Screen section.
[    42.788] (==) No screen section available. Using defaults.
[    42.789] (**) |-->Screen "Default Screen Section" (0)
[    42.789] (**) |   |-->Monitor "<default monitor>"
[    42.789] (==) No monitor specified for screen "Default Screen Section".
  Using a default monitor configuration.
[    42.789] (==) Automatically adding devices
[    42.789] (==) Automatically enabling devices
[    42.789] (==) Automatically adding GPU devices
[    42.949] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    42.949]  Entry deleted from font path.
[    42.949]  (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    42.949] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    42.949]  Entry deleted from font path.
[    42.949]  (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    42.949] (==) FontPath set to:
  /usr/share/fonts/misc/,
  /usr/share/fonts/TTF/,
  /usr/share/fonts/OTF/,
  /usr/share/fonts/Type1/
[    42.949] (==) ModulePath set to "/usr/lib/xorg/modules"
[    42.949] (**) Extension "Composite" is enabled
[    42.949] (II) The server relies on udev to provide the list of input devices.
  If no devices become available, reconfigure udev or disable AutoAddDevices.
[    42.949] (II) Loader magic: 0x8259620
[    42.949] (II) Module ABI versions:
[    42.949]  X.Org ANSI C Emulation: 0.4
[    42.949]  X.Org Video Driver: 14.1
[    42.949]  X.Org XInput driver : 19.1
[    42.949]  X.Org Server Extension : 7.0
[    42.950] (II) xfree86: Adding drm device (/dev/dri/card0)
[    42.954] (--) PCI:*(0:0:2:0) 8086:27ae:103c:1468 rev 3, Mem @ 0xfe980000/524288, 0xd0000000/268435456, 0xfe940000/262144$
[    42.954] (--) PCI: (0:0:2:1) 8086:27a6:103c:1468 rev 3, Mem @ 0xfe880000/524288
[    42.954] Initializing built-in extension Generic Event Extension
[    42.954] Initializing built-in extension SHAPE
[    42.954] Initializing built-in extension MIT-SHM
[    42.954] Initializing built-in extension XInputExtension
[    42.954] Initializing built-in extension XTEST
[    42.954] Initializing built-in extension BIG-REQUESTS
[    42.954] Initializing built-in extension SYNC
[    42.954] Initializing built-in extension XKEYBOARD
[    42.954] Initializing built-in extension XC-MISC
[    42.955] Initializing built-in extension SECURITY
[    42.955] Initializing built-in extension XINERAMA
[    42.955] Initializing built-in extension XFIXES
[    42.955] Initializing built-in extension RENDER
[    42.955] Initializing built-in extension RANDR
[    42.955] Initializing built-in extension COMPOSITE
[    42.955] Initializing built-in extension DAMAGE
[    42.955] Initializing built-in extension MIT-SCREEN-SAVER
[    42.955] Initializing built-in extension DOUBLE-BUFFER
[    42.955] Initializing built-in extension RECORD
[    42.955] Initializing built-in extension DPMS
[    42.955] Initializing built-in extension X-Resource
[    42.955] Initializing built-in extension DPMS
[    42.955] Initializing built-in extension X-Resource
[    42.955] Initializing built-in extension XVideo
[    42.955] Initializing built-in extension XVideo-MotionCompensation
[    42.955] Initializing built-in extension XFree86-VidModeExtension
[    42.955] Initializing built-in extension XFree86-DGA
[    42.955] Initializing built-in extension XFree86-DRI
[    42.956] Initializing built-in extension DRI2
[    42.956] (II) LoadModule: "glx"
[    43.021] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    43.044] (II) Module glx: vendor="X.Org Foundation"
[    43.044]  compiled for 1.14.4, module version = 1.0.0
[    43.044]  ABI class: X.Org Server Extension, version 7.0
[    43.044] (==) AIGLX enabled
[    43.044] Loading extension GLX
[    43.044] (==) Matched intel as autoconfigured driver 0
[    43.044] (==) Matched intel as autoconfigured driver 1
[    43.044] (==) Matched vesa as autoconfigured driver 2
[    43.044] (==) Matched modesetting as autoconfigured driver 3
[    43.044] (==) Matched fbdev as autoconfigured driver 4
[    43.044] (==) Assigned the driver to the xf86ConfigLayout
[    43.045] (II) LoadModule: "intel"
[    43.083] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    43.640] (II) Module intel: vendor="X.Org Foundation"
[    43.640]  compiled for 1.14.2, module version = 2.21.15
[    43.640]  Module class: X.Org Video Driver
[    43.640]  ABI class: X.Org Video Driver, version 14.1
[    43.640] (II) LoadModule: "vesa"
[    43.642] (WW) Warning, couldn't open module vesa
[    43.642] (II) UnloadModule: "vesa"
[    43.642] (II) Unloading vesa
[    43.642] (EE) Failed to load module "vesa" (module does not exist, 0)
[    43.642] (II) LoadModule: "modesetting"
[    43.643] (WW) Warning, couldn't open module modesetting
[    43.643] (II) UnloadModule: "modesetting"
[    43.643] (II) Unloading modesetting
[    43.643] (II) UnloadModule: "modesetting"
[    43.643] (II) Unloading modesetting
[    43.643] (EE) Failed to load module "modesetting" (module does not exist, 0)
[    43.643] (II) LoadModule: "fbdev"
[    43.644] (WW) Warning, couldn't open module fbdev
[    43.644] (II) UnloadModule: "fbdev"
[    43.644] (II) Unloading fbdev
[    43.644] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    43.644] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
  i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
  915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
  Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
  GM45, 4 Series, G45/G43, Q45/Q43, G41, B43, HD Graphics,
  HD Graphics 2000, HD Graphics 3000, HD Graphics 2500,
  HD Graphics 4000, HD Graphics P4000, HD Graphics 4600,
  HD Graphics 5000, HD Graphics P4600/P4700, Iris(TM) Graphics 5100,
  HD Graphics 4400, HD Graphics 4200, Iris(TM) Pro Graphics 5200
[    43.647] (++) using VT number 1

[    43.649] (II) intel(0): Creating default Display subsection in Screen section
  "Default Screen Section" for depth/fbbpp 24/32
[    43.649] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[    43.649] (==) intel(0): RGB weight 888
[    43.649] (==) intel(0): Default visual is TrueColor
[    43.649] (--) intel(0): Integrated Graphics Chipset: Intel(R) 945GME
[    43.650] (--) intel(0): CPU: x86, sse2, sse3, ssse3
[    43.650] (**) intel(0): Framebuffer tiled
[    43.650] (**) intel(0): Pixmaps tiled
[    43.650] (**) intel(0): "Tear free" disabled
[    43.650] (**) intel(0): Forcing per-crtc-pixmaps? no
[    43.651] (II) intel(0): Output LVDS1 has no monitor section
[    43.652] (--) intel(0): found backlight control interface acpi_video0 (type 'firmware')
[    43.652] (II) intel(0): Output VGA1 has no monitor section
[    43.652] (--) intel(0): Output LVDS1 using initial mode 1024x600 on pipe 1
[    43.652] (==) intel(0): DPI set to (96, 96)
[    43.652] (II) Loading sub module "dri2"
[    43.652] (==) intel(0): DPI set to (96, 96)
[    43.652] (II) Loading sub module "dri2"
[    43.652] (II) LoadModule: "dri2"
[    43.652] (II) Module "dri2" already built-in
[    43.652] (==) Depth 24 pixmap format is 32 bpp
[    43.652] (II) intel(0): SNA initialized with Alviso (gen3) backend
[    43.652] (==) intel(0): Backing store disabled
[    43.652] (==) intel(0): Silken mouse enabled
[    43.653] (II) intel(0): HW Cursor enabled
[    43.653] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[    43.658] (==) intel(0): DPMS enabled
[    43.658] (II) intel(0): [XvMC] i915_xvmc driver initialized.
[    43.658] (II) intel(0): [DRI2] Setup complete
[    43.658] (II) intel(0): [DRI2]   DRI driver: i915
[    43.658] (II) intel(0): direct rendering: DRI2 Enabled
[    43.658] (==) intel(0): hotplug detection: "enabled"
[    43.659] (--) RandR disabled
[    47.147] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[    52.714] (II) AIGLX: enabled GLX_INTEL_swap_event
[    52.714] (II) AIGLX: enabled GLX_ARB_create_context
[    52.714] (II) AIGLX: enabled GLX_ARB_create_context_profile
[    52.714] (II) AIGLX: enabled GLX_EXT_create_context_es2_profile
[    52.714] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[    52.714] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[    52.714] (II) AIGLX: Loaded and initialized i915
[    52.715] (II) GLX: Initialized DRI2 GL provider for screen 0
[    52.724] (II) intel(0): switch to mode 1024x600@60.0 on pipe 1 using LVDS1, position (0, 0), rotation normal
[    52.897] (II) intel(0): Setting screen physical size to 270 x 158
[    53.733] (II) config/udev: Adding input device Power Button (/dev/input/event4)
[    53.733] (**) Power Button: Applying InputClass "system-keyboard"
[    53.733] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    53.733] (II) LoadModule: "evdev"
[    53.733] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    54.078] (II) Module evdev: vendor="X.Org Foundation"
[    54.078]  compiled for 1.14.3, module version = 2.8.2
[    54.078]  Module class: X.Org XInput Driver
[    54.078]  compiled for 1.14.3, module version = 2.8.2
[    54.078]  Module class: X.Org XInput Driver
[    54.078]  ABI class: X.Org XInput driver, version 19.1
[    54.078] (II) Using input driver 'evdev' for 'Power Button'
[    54.078] (**) Power Button: always reports core events
[    54.078] (**) evdev: Power Button: Device: "/dev/input/event4"
[    54.079] (--) evdev: Power Button: Vendor 0 Product 0x1
[    54.079] (--) evdev: Power Button: Found keys
[    54.079] (II) evdev: Power Button: Configuring as keyboard
[    54.079] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input4/event4"
[    54.079] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[    54.079] (**) Option "xkb_rules" "evdev"
[    54.079] (**) Option "xkb_model" "pc105"
[    54.079] (**) Option "xkb_layout" "latam"
[    54.079] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    54.355] (II) config/udev: Adding input device Video Bus (/dev/input/event5)
[    54.355] (**) Video Bus: Applying InputClass "system-keyboard"
[    54.355] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[    54.355] (II) Using input driver 'evdev' for 'Video Bus'
[    54.355] (**) Video Bus: always reports core events
[    54.355] (**) evdev: Video Bus: Device: "/dev/input/event5"
[    54.355] (--) evdev: Video Bus: Vendor 0 Product 0x6
[    54.355] (--) evdev: Video Bus: Found keys
[    54.355] (II) evdev: Video Bus: Configuring as keyboard
[    54.356] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:00/input/input5/event5"
[    54.356] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[    54.356] (**) Option "xkb_rules" "evdev"
[    54.356] (**) Option "xkb_model" "pc105"
[    54.356] (**) Option "xkb_layout" "latam"
[    54.356] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    54.358] (II) config/udev: Adding input device Lid Switch (/dev/input/event1)
[    54.358] (II) No input driver specified, ignoring this device.
[    54.358] (II) This device may have been added with another device file.
[    54.359] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[    54.359] (**) Power Button: Applying InputClass "system-keyboard"
[    54.359] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    54.359] (**) Power Button: Applying InputClass "system-keyboard"
[    54.359] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    54.359] (II) Using input driver 'evdev' for 'Power Button'
[    54.359] (**) Power Button: always reports core events
[    54.359] (**) evdev: Power Button: Device: "/dev/input/event3"
[    54.359] (--) evdev: Power Button: Vendor 0 Product 0x1
[    54.359] (--) evdev: Power Button: Found keys
[    54.359] (II) evdev: Power Button: Configuring as keyboard
[    54.360] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input3/event3"
[    54.360] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 8)
[    54.360] (**) Option "xkb_rules" "evdev"
[    54.360] (**) Option "xkb_model" "pc105"
[    54.360] (**) Option "xkb_layout" "latam"
[    54.360] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    54.362] (II) config/udev: Adding input device Sleep Button (/dev/input/event2)
[    54.362] (**) Sleep Button: Applying InputClass "system-keyboard"
[    54.362] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[    54.363] (II) Using input driver 'evdev' for 'Sleep Button'
[    54.363] (**) Sleep Button: always reports core events
[    54.363] (**) evdev: Sleep Button: Device: "/dev/input/event2"
[    54.363] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[    54.363] (--) evdev: Sleep Button: Found keys
[    54.363] (II) evdev: Sleep Button: Configuring as keyboard
[    54.363] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0E:00/input/input2/event2"
[    54.363] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 9)
[    54.363] (**) Option "xkb_rules" "evdev"
[    54.363] (**) Option "xkb_model" "pc105"
[    54.363] (**) Option "xkb_layout" "latam"
[    54.363] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    54.365] (II) config/udev: Adding drm device (/dev/dri/card0)
[    54.366] (II) config/udev: Adding input device HDA Digital PCBeep (/dev/input/event10)
[    54.366] (II) No input driver specified, ignoring this device.
[    54.366] (II) This device may have been added with another device file.
[    54.367] (II) config/udev: Adding input device HDA Intel Headphone (/dev/input/event11)
[    54.367] (II) No input driver specified, ignoring this device.
[    54.367] (II) This device may have been added with another device file.
[    54.367] (II) No input driver specified, ignoring this device.
[    54.367] (II) This device may have been added with another device file.
[    54.368] (II) config/udev: Adding input device HDA Intel Mic (/dev/input/event12)
[    54.368] (II) No input driver specified, ignoring this device.
[    54.368] (II) This device may have been added with another device file.
[    54.369] (II) config/udev: Adding input device HP Webcam-50 (/dev/input/event6)
[    54.369] (**) HP Webcam-50: Applying InputClass "system-keyboard"
[    54.369] (**) HP Webcam-50: Applying InputClass "evdev keyboard catchall"
[    54.369] (II) Using input driver 'evdev' for 'HP Webcam-50'
[    54.369] (**) HP Webcam-50: always reports core events
[    54.369] (**) evdev: HP Webcam-50: Device: "/dev/input/event6"
[    54.370] (--) evdev: HP Webcam-50: Vendor 0x5c8 Product 0x208
[    54.370] (--) evdev: HP Webcam-50: Found keys
[    54.370] (II) evdev: HP Webcam-50: Configuring as keyboard
[    54.370] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.7/usb1/1-4/1-4:1.0/input/input6/event6"
[    54.370] (II) XINPUT: Adding extended input device "HP Webcam-50" (type: KEYBOARD, id 10)
[    54.370] (**) Option "xkb_rules" "evdev"
[    54.370] (**) Option "xkb_model" "pc105"
[    54.370] (**) Option "xkb_layout" "latam"
[    54.370] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    54.372] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[    54.372] (**) AT Translated Set 2 keyboard: Applying InputClass "system-keyboard"
[    54.372] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[    54.372] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[    54.372] (**) AT Translated Set 2 keyboard: always reports core events
[    54.372] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event0"
[    54.373] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[    54.373] (--) evdev: AT Translated Set 2 keyboard: Found keys
[    54.373] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[    54.373] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
[    54.373] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 11)
[    54.373] (**) Option "xkb_rules" "evdev"
[    54.373] (**) Option "xkb_model" "pc105"
[    54.373] (**) Option "xkb_layout" "latam"
[    54.373] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    54.375] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event7)
[    54.375] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Default clickpad buttons"
[    54.375] (II) LoadModule: "synaptics"
[    54.376] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[    55.918] (II) Module synaptics: vendor="X.Org Foundation"
[    55.918]  compiled for 1.14.1, module version = 1.7.1
[    55.918]  Module class: X.Org XInput Driver
[    55.918]  ABI class: X.Org XInput driver, version 19.1
[    55.918] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[    55.918] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    55.918] (**) Option "Device" "/dev/input/event7"
[    55.955] (--) synaptics: SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5806 (res 85)
[    55.955] (--) synaptics: SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4906 (res 145)
[    55.955] (--) synaptics: SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[    55.955] (--) synaptics: SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[    55.955] (--) synaptics: SynPS/2 Synaptics TouchPad: buttons: left right
[    55.955] (--) synaptics: SynPS/2 Synaptics TouchPad: Vendor 0x2 Product 0x7
[    55.955] (**) Option "TapButton1" "1"
[    55.955] (**) Option "TapButton2" "2"
[    55.955] (**) Option "TapButton3" "3"
[    55.956] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    55.956] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    55.974] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio4/input/input7/event7"
[    55.974] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 12)
[    55.974] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[    55.974] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MaxSpeed is now 1.75
[    55.974] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) AccelFactor is now 0.036
[    55.975] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[    55.975] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[    55.975] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[    55.975] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[    55.975] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    55.976] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[    55.976] (**) SynPS/2 Synaptics TouchPad: Ignoring device from InputClass "touchpad ignore duplicates"
[    55.977] (II) config/udev: Adding input device PC Speaker (/dev/input/event9)
[    55.977] (II) No input driver specified, ignoring this device.
[    55.977] (II) This device may have been added with another device file.
[    55.977] (II) No input driver specified, ignoring this device.
[    55.977] (II) This device may have been added with another device file.
[    55.978] (II) config/udev: Adding input device HP WMI hotkeys (/dev/input/event8)
[    55.979] (**) HP WMI hotkeys: Applying InputClass "system-keyboard"
[    55.979] (**) HP WMI hotkeys: Applying InputClass "evdev keyboard catchall"
[    55.979] (II) Using input driver 'evdev' for 'HP WMI hotkeys'
[    55.979] (**) HP WMI hotkeys: always reports core events
[    55.979] (**) evdev: HP WMI hotkeys: Device: "/dev/input/event8"
[    55.979] (--) evdev: HP WMI hotkeys: Vendor 0 Product 0
[    55.979] (--) evdev: HP WMI hotkeys: Found keys
[    55.979] (II) evdev: HP WMI hotkeys: Configuring as keyboard
[    55.979] (**) Option "config_info" "udev:/sys/devices/virtual/input/input8/event8"
[    55.979] (II) XINPUT: Adding extended input device "HP WMI hotkeys" (type: KEYBOARD, id 13)
[    55.979] (**) Option "xkb_rules" "evdev"
[    55.979] (**) Option "xkb_model" "pc105"
[    55.979] (**) Option "xkb_layout" "latam"
[    55.980] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    91.738] (II) intel(0): EDID vendor "INL", prod id 17
[    91.738] (II) intel(0): Printing DDC gathered Modelines:
[    91.738] (II) intel(0): Modeline "1024x600"x0.0   54.20  1024 1072 1104 1434  600 601 605 630 -hsync -vsync (37.8 kHz eP)
[   322.170] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[   322.201] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[   322.213] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[   322.229] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[   322.253] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[   322.278] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[   322.306] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[   322.341] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[   322.398] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansYuanTi-Regular.ttf: 1
[   322.410] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[   322.469] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansYuanTi-Regular.ttf: 1
[   322.517] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[   322.549] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[   322.582] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[   322.640] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansYuanTi-Regular.ttf: 1
[   322.885] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSerif.ttf: 1
[  4890.444] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansYuanTi-Regular.ttf: 1
[  4890.713] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSerif.ttf: 1
[ 27179.059] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[ 27179.213] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[ 27179.225] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[ 27179.241] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[ 27179.265] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[ 27179.291] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[ 27179.319] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[ 27179.370] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[ 27179.441] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansYuanTi-Regular.ttf: 1
[ 27179.453] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[ 27179.513] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansYuanTi-Regular.ttf: 1
[ 27179.563] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[ 27179.597] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[ 27179.634] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1
[ 27179.698] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansYuanTi-Regular.ttf: 1
[ 27180.004] FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSerif.ttf: 1

that file exist?

% pacman -Qo  /usr/share/fonts/TTF/DejaVuSansMono.ttf
error: no se pudo leer el archivo '/usr/share/fonts/TTF/DejaVuSansMono.ttf': No exist

but

extra/ttf-dejavu 2.34-1
    Font family based on the Bitstream Vera Fonts with a wider range of characters
infinality-bundle-fonts/t1-dejavu-ib 2.34-4 (infinality-bundle-fonts) [instalado]
    Font family based on the Bitstream Vera Fonts with a wider range of characters. Re-packed for infinality-bundle-fonts.
    Type 1 version.
infinality-bundle-fonts/ttf-dejavu-ibx 2.34-4 (infinality-bundle-fonts-extra)
    Font family based on the Bitstream Vera Fonts with a wider range of characters. Re-packed for infinality-bundle-fonts.
    TrueType version.
infinality-bundle-fonts/ttf-dejavusans-yuanti-basic-ibx 20110101-2 (infinality-bundle-fonts-extra) [instalado]
    Chinese Yuan Ti family based on DejaVu Sans fonts (basic sans-serif variant).
infinality-bundle-fonts/ttf-dejavusans-yuanti-condensed-ibx 20110101-2 (infinality-bundle-fonts-extra) [instalado]
    Chinese Yuan Ti family based on DejaVu Sans fonts (condensed variant).
infinality-bundle-fonts/ttf-dejavusans-yuanti-mono-ibx 20110101-2 (infinality-bundle-fonts-extra) [instalado]
    Chinese Yuan Ti family based on DejaVu Sans fonts (monospaced variant).

and ttf-dejavu conflict whit t1-dejavu-ib but I use ibfonts-meta-base so I preffer maintain that.
reinstalling not help, maybe I'm a special case


Well, I suppose that this is somekind of signature, no?

Offline

#709 2013-11-15 06:22:14

brebs
Member
Registered: 2007-04-03
Posts: 3,414

Re: infinality-bundle: good looking fonts made (even) easier

FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1

I would exit xorg, then run as root:

fc-cache -rf

Offline

#710 2013-11-15 10:20:25

Jristz
Member
From: America/Santiago
Registered: 2011-06-11
Posts: 918

Re: infinality-bundle: good looking fonts made (even) easier

brebs wrote:

FreeType: couldn't open face /usr/share/fonts/TTF/DejaVuSansMono.ttf: 1

I would exit xorg, then run as root:

fc-cache -rf

yep, this work.
Is strange because in my old instalation I never need to do this....

thanks to all


Well, I suppose that this is somekind of signature, no?

Offline

#711 2013-11-16 20:44:43

psychoticmeow
Member
Registered: 2013-05-01
Posts: 20

Re: infinality-bundle: good looking fonts made (even) easier

I've got a problem on a fresh installation of Arch (+ Gnome 3 + Infinality bundle + Firefox): when a website specifies 'sans-serif' as a font, instead of a sans-serif font I get a serif font. I installed all of the fonts in infinality-bundle-fonts, but none of the extras, here's some info:

↪ fc-match sans-serif
NotoSans-Regular.ttf: "Noto Sans" "Regular"

Noto Sans is definitely not being used in Firefox, in fact using the Firefox web dev tools, it reports that Heuristica Regular is being used.

Offline

#712 2013-11-16 21:32:46

sano
Member
Registered: 2012-02-11
Posts: 113

Re: infinality-bundle: good looking fonts made (even) easier

What default font did you set in Firefox?

Offline

#713 2013-11-16 21:42:41

psychoticmeow
Member
Registered: 2013-05-01
Posts: 20

Re: infinality-bundle: good looking fonts made (even) easier

I've selected serif, sans-serif and monospace respectively.

Offline

#714 2013-11-16 22:26:26

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

You probably didn't set your Default font to sans-serif: this is what sano asked about (second option in Content => Fonts & Colors => Default font).


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#715 2013-11-16 22:51:48

psychoticmeow
Member
Registered: 2013-05-01
Posts: 20

Re: infinality-bundle: good looking fonts made (even) easier

I'm sorry, perhaps I wasn't clear enough - this isn't a problem with the default fonts, but with what the CSS keyword 'sans-serif' actually renders as. But for the record, changing the default font to be sans serif, has no effect.

A quick test-case: http://jsfiddle.net/d9gre/

The result is rendered as Heuristica Regular instead of the font selected. I've looked through some other programmes, it appears this may just be a Firefox issue.

Last edited by psychoticmeow (2013-11-16 22:55:17)

Offline

#716 2013-11-16 23:03:58

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: infinality-bundle: good looking fonts made (even) easier

Works fine here in Firefox. Font Finder says it uses "sans-serif" and it is certainly not Heuristica Regular.

EDIT: Incidentally, I agree that the setting of the default font has no effect - mine is set to serif but it still renders in sans when sans-serif is specified, as I would expect. But have you checked the "advanced" font settings to see what Firefox will use by default for serif, sans and mono?

Last edited by cfr (2013-11-16 23:06:17)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#717 2013-11-16 23:08:40

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

And so it does here, as expected. Can you manually check whether the correct preset files are present in /etc/fonts/conf.d?

[conf.d] $ ls *conf | grep free
37-repl-global-free.conf@
60-latin-free.conf@
65-non-latin-free.conf@
66-aliases-wine-free.conf@
93-final-lang-spec-free.conf@

Edit

cfr wrote:

But have you checked the "advanced" font settings to see what Firefox will use by default for serif, sans and mono?

The 'Proportional Font' should be set to 'sans-serif'.

Last edited by bohoomil (2013-11-16 23:11:17)


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#718 2013-11-16 23:10:31

psychoticmeow
Member
Registered: 2013-05-01
Posts: 20

Re: infinality-bundle: good looking fonts made (even) easier

How strange, I created a new profile in Firefox and compared settings in about:config (searched for font), in my profile I found a reference to Times New Roman, resetting that made the fonts normal again.

Thanks for humouring me anyway wink

Offline

#719 2013-11-23 20:07:05

pablox
Member
From: /home/chile/curico/
Registered: 2008-05-14
Posts: 169
Website

Re: infinality-bundle: good looking fonts made (even) easier

I have found an issue with font awesome, which makes them look weird (you better see it for yourself).

http://i.imgur.com/pVTTs81.png

This only happens on Firefox, in Chrome it looks okay.

Last edited by pablox (2013-11-23 20:11:33)


Geeks & Linux Atelier
An eye for an eye ... ends in making everybody blind -- Mahatma Gandhi
dotfiles

Offline

#720 2013-11-23 20:50:50

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

Nope: everything is fine => fa-bell-o @ awesome.ttf.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#721 2013-11-24 21:00:41

pablox
Member
From: /home/chile/curico/
Registered: 2008-05-14
Posts: 169
Website

Re: infinality-bundle: good looking fonts made (even) easier

It just happens on Firefox... any clue? O.o


Geeks & Linux Atelier
An eye for an eye ... ends in making everybody blind -- Mahatma Gandhi
dotfiles

Offline

#722 2013-11-24 22:47:18

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

I have no idea… My screenshot comes from FF from [extra], freetype2 and Xft settings are ib's default. Is it possible that you are using custom Xft settings? Did you observe other alarming inconsistencies in FF font rendering?

Edit: Does the same happen with a clean FF profile?

Last edited by bohoomil (2013-11-24 22:49:06)


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#723 2013-11-25 05:12:24

pablox
Member
From: /home/chile/curico/
Registered: 2008-05-14
Posts: 169
Website

Re: infinality-bundle: good looking fonts made (even) easier

This is so weird. I haven't made changes and now it looks fine. I'm pretty sure this has happened to me before. I'm gonna keep an eye on it.

What do you mean by custom Xft settings? When I run xrdb -merge it's empty, so I guess I don't have any custom setting.


Geeks & Linux Atelier
An eye for an eye ... ends in making everybody blind -- Mahatma Gandhi
dotfiles

Offline

#724 2013-11-25 06:09:39

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

Yes, I meant custom Xft settings in $HOME/.Xresources. I guess you are using default infinality-settings.sh, though.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#725 2013-11-25 22:55:34

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

freetype2 2.5.1 has been released, so for anyone willing to help testing the new stuff, here it is: Dropbox/misc. I haven't noticed disturbing issues so far, things look fine and pretty stable. Just remember to keep the still official 2.5.0.1 release in your pacman cache for quick downgrade, if necessary.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

Board footer

Powered by FluxBB