You are not logged in.

#1326 2014-08-16 09:57:23

Nordic89
Member
Registered: 2014-05-07
Posts: 49

Re: infinality-bundle: good looking fonts made (even) easier

bohoomil wrote:

Generally, you should enable [infinality-bundle-fonts] and use the packages instead of the corresponding official and AUR ones. The substitution will work exactly the same way as using the patched libraries instead of the stock ones.

You are in no way limited to use fonts from the [infinality-bundle-fonts]. However, you should use font packages from it if it provides the families of your choice (e.g. Adobe Source Code Pro). Bear in mind that several families--like Source Code Pro--come in multiple packages (TTF and OTF are packaged separately). If this is the case, choose the version you prefer.

Last but not least, if a font is not present in my repo, I may consider adding it or at least provide a proper support for it and add necessary config files.

Thanks for the answer. Is there a list to see which fonts are included in infinality-bundle-fonts or infinality-bundle-fonts-extra?

Offline

#1327 2014-08-16 10:34:11

AnAkkk
Member
Registered: 2014-03-03
Posts: 139

Re: infinality-bundle: good looking fonts made (even) easier

awbs wrote:
BobL21 wrote:

I recently updated to the newest version and it resulted in making some of the fonts pretty ugly and unreadable. I haven't had this issue before with other upgrades. I tried "fc-cache -f" but didn't have any luck. I also tried rebuilding ttf-ms-win8, and also tried reinstalling all packages on my system. I also tried the "fc-presets set" and set them to "2 - ms". Any ideas would be appreciated. Here's a picture of what I'm experiencing:

http://i.imgur.com/p2vhaxn.png

I just had to downgrade because the new upgrade made KDE's konsole unusable. Some applications wouldn't use the system wide font, even KDE's own (such as Kate). In konsole their was a weird space between the $ and when you type.

Before Upgrade:

[justin@Arch_Alienware ~]$ sudo|

After Upgrade:

[justin@Arch_Alienware ~]$      sudo|

All of the fonts in konsole were bigger than they usually were, also, when I tried to edit text in konsole it would look like this:

[justin@Arch_Alienware ~]$    su|     do

My cursor is indicated by the |. While erasing text, text would disappear in the blank space, making editing in konsole unusable.

System wide font is Ubuntu and the terminal font ubuntu-monospace.

I have the same issue. I use Plasma 5, the system font is set to Oxygen-Sans.

EDIT: Konsole seems to use Monospace.

EDIT 2: It only happens with Monospace.

Last edited by AnAkkk (2014-08-16 10:37:24)

Offline

#1328 2014-08-16 14:45:49

sleepforlife
Member
Registered: 2011-09-27
Posts: 95

Re: infinality-bundle: good looking fonts made (even) easier

thank you very mach
amazing all your woork

Offline

#1329 2014-08-16 17:40:27

RMorel
Member
Registered: 2013-10-05
Posts: 10

Re: infinality-bundle: good looking fonts made (even) easier

Hi bohoomil,

I am having trouble with displaying Braille characters in the terminal (urxvt). I just displays them as white rectangle outlines (a 'character not found' character).

I have the ttf-ubraille package installed and no matter what I try it fails to display Braille characters.

My urxvt font setup:

URxvt.font: xft:Inconsolata:size=10.5,xft:Droid Sans Mono,xft:DejaVu Sans Mono,xft:Braille,xft:Fixed

After trying to fix it for quite a while, I got urxvt to spit the following error:

$ urxvt -fn xft:Braille
urxvt: unable to calculate font width for 'Braille:minspace=True', ignoring.
urxvt: unable to load base fontset, please specify a valid one using -fn, aborting.

I am reporting it here because in my searching I came across the this post, but it does not state any reason as to why infinality would the cause.

Any assistance/guidance would be appreciated.

Last edited by RMorel (2014-08-16 17:41:43)

Offline

#1330 2014-08-16 19:18:38

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

Nordic89 wrote:

Is there a list to see which fonts are included in infinality-bundle-fonts or infinality-bundle-fonts-extra?

$ pacman -Ss infinality-bundle-fonts

Edit Here is one more listing of the fonts available in the repository, including basic info and previews.

@RMorel

I tested the settings in the screenshot and everything seems to be working fine:

2014-08-16_urxvt-braille.png

@AnAkkk As soon as I am able to reproduce the problem, I will report back.

@sleepforlife I appreciate it: thank you very much!

Last edited by bohoomil (2014-08-17 00:37:16)


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#1331 2014-08-17 09:07:26

RMorel
Member
Registered: 2013-10-05
Posts: 10

Re: infinality-bundle: good looking fonts made (even) easier

Thanks for trying it, bohoomil.

By adding DejaVu Sans to the font list URxvt is able to display the Braille characters (the mono variant does not include these characters).

Offline

#1332 2014-08-17 15:49:51

doggone
Member
Registered: 2013-06-19
Posts: 49

Re: infinality-bundle: good looking fonts made (even) easier

Noto Sans 9 is inconsistent in applications
Qt applications and Chromium's UI (not webpages themselves) display it smaller/differently than other applications

Is there any known fix?

Here's an example with xfce4-settings-manager and qtconfig-qt4
Screenshot_170814_17_45_03.jpg

Offline

#1333 2014-08-17 16:24:19

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

@doggone Qt displays font size in points, Gtk+ in pixels, hence the difference.

For Chromium related stuff, check out this: Google Chrome Issues. (The code snippet can be used locally, too: just paste it in $XDG_CONFIG_HOME/fontconfig/fonts.conf.)


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#1334 2014-08-17 16:56:57

doggone
Member
Registered: 2013-06-19
Posts: 49

Re: infinality-bundle: good looking fonts made (even) easier

bohoomil wrote:

@doggone Qt displays font size in points, Gtk+ in pixels, hence the difference.

For Chromium related stuff, check out this: Google Chrome Issues. (The code snippet can be used locally, too: just paste it in $XDG_CONFIG_HOME/fontconfig/fonts.conf.)

I understand how this hack would work (12px/9pt = 96/72), however, in either file, whether I put this setting on 72, or even 10 or 120, my fonts look exactly the same.

fontconfig doesn't throw any errors, and I have this in my /etc/fonts/ and ~/.config

 <match target="pattern">
  <edit name="dpi" mode="assign">
   <double>72</double>
  </edit>
 </match>

Perhaps the setting is being overwritten somewhere at a later stage?

EDIT: Also, this only happens with Noto at size 9. Other fonts such as DejaVu are fine. Noto 10 is fine too.

Last edited by doggone (2014-08-17 17:04:47)

Offline

#1335 2014-08-17 17:34:54

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

Did you try unchecking 'Custom DPI settings' in Xfce4 control panel?


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#1336 2014-08-17 18:39:23

doggone
Member
Registered: 2013-06-19
Posts: 49

Re: infinality-bundle: good looking fonts made (even) easier

bohoomil wrote:

Did you try unchecking 'Custom DPI settings' in Xfce4 control panel?

Yep. Checked or unchecked looks exactly the same

Offline

#1337 2014-08-17 20:46:06

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

I installed Xfce4 and found out that your issue may be Xfce4 specific. The same applications and fonts (including Noto Sans) seem to work properly in my regular dwm setup. Also, the 72 dpi hack does not work for Chromium. The bad news is that I cannot offer any remedy… You can obviously---at least for Qt4 apps consistent looks---set a different font globally in Xfce4 control panel: for instance, Droid Sans looks fine everywhere. That is not much, but at least one problem can be solved.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#1338 2014-08-17 21:23:26

brebs
Member
Registered: 2007-04-03
Posts: 3,406

Re: infinality-bundle: good looking fonts made (even) easier

XFCE users should see my bug report and patch, to stop XFCE from screwing with the proper DPI. As I reported earlier in this thread wink

Also regarding DPI, it seems it can be calculated slightly wrongly, e.g. it makes more more sense (and fonts look better) if I set my DPI as 130x120, rather than 131x119 (as Nvidia apparently reports it). I can override it to the correct values, using e.g.:

xrandr --fbmm 374x228

In ~/.xinitrc, before the "exec" line. Those 2 magical numbers are arrived at by trial-and-error, to see what is reported by:

xdpyinfo | grep -B1 dot

Offline

#1339 2014-08-17 22:18:59

doggone
Member
Registered: 2013-06-19
Posts: 49

Re: infinality-bundle: good looking fonts made (even) easier

@bohoomil, brebs:
It's not that important, just because of OCD I'll switch back to Clear Sans, which works well. I was simply interested in what was causing it and what was causing the hack not to work. I appreciate the effort you put into it, bohoomil.

I had actually seen your bug report before, brebs. It's a bit sad that it's been open for half a year now even though you submitted a patch --  but let's not go into an off-topic discussion of Xfce's development.

Offline

#1340 2014-08-17 22:43:42

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

@doggone et al. who may be interested: get the slightly modified dpi-unchanged.patch if you still want to check it out.

Edit I only adjusted it a bit to match our version of Xfce4.

Last edited by bohoomil (2014-08-17 22:44:50)


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#1341 2014-08-26 09:20:52

Kaan
Member
Registered: 2009-02-10
Posts: 31

Re: infinality-bundle: good looking fonts made (even) easier

I'm having a problem with gtk applications when I launch them, it started to happen recently but I have no idea why. The fonts look thinner than they should, but it doesn't always happen and if I relaunch the app the fonts look like the rest of kde or qt apps.
I tried everything I know, clearing cache, reinstalling/setting infinality, removing all the fonts settings or maching kde font settings and adding xft settings to gtkrc files. No change. I'm using kde with windows fonts and the only other font installed is kde oxygen.

Two screenshots to show the difference clearly, the second one is how its supposed to look.

https://dl.dropboxusercontent.com/u/196 … _scrot.png
https://dl.dropboxusercontent.com/u/196 … _scrot.png

Offline

#1342 2014-08-26 21:45:22

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

@Kaan I believe that you might have already performed the steps below, but just in case take a look at the checklist.

1. What is the output of `fc-presets check`? If by default you are using Microsoft fonts, you should set the `ms` preset.

2.

adding xft settings to gtkrc files

Xft settings are set in .Xresources and in .gtkrc-2.0 independently. If you have the following in your .gtkrc-2.0:

gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle="hintfull"
gtk-xft-rgba="rgb"

-- that is absolutely fine. Do not remove these lines.

However, make sure that `/etc/profile.d/infinality-settings.sh` has been sourced properly. Run `env | grep INFINALITY` and `xrdb -q | grep Xft` and see if the ouput looks like this:

$ env | grep INFINALITY

INFINALITY_FT_AUTOHINT_HORIZONTAL_STEM_DARKEN_STRENGTH=0
INFINALITY_FT_BOLD_EMBOLDEN_X_VALUE=0
INFINALITY_FT_AUTOHINT_VERTICAL_STEM_DARKEN_STRENGTH=0
INFINALITY_FT_CONTRAST=0
INFINALITY_FT_GRAYSCALE_FILTER_STRENGTH=0
INFINALITY_FT_FRINGE_FILTER_STRENGTH=0
INFINALITY_FT_USE_VARIOUS_TWEAKS=true
INFINALITY_FT_BRIGHTNESS=0
INFINALITY_FT_GAMMA_CORRECTION=15 90
INFINALITY_FT_FILTER_PARAMS=07 26 34 26 07
INFINALITY_FT_USE_KNOWN_SETTINGS_ON_SELECTED_FONTS=true
INFINALITY_FT_STEM_SNAPPING_SLIDING_SCALE=0
INFINALITY_FT_WINDOWS_STYLE_SHARPENING_STRENGTH=0
INFINALITY_FT_CHROMEOS_STYLE_SHARPENING_STRENGTH=30
INFINALITY_FT_STEM_ALIGNMENT_STRENGTH=0
INFINALITY_FT_AUTOHINT_SNAP_STEM_HEIGHT=0
INFINALITY_FT_BOLD_EMBOLDEN_Y_VALUE=0
INFINALITY_FT_GLOBAL_EMBOLDEN_Y_VALUE=0
INFINALITY_FT_STEM_FITTING_STRENGTH=0
INFINALITY_FT_AUTOHINT_INCREASE_GLYPH_HEIGHTS=false
INFINALITY_FT_GLOBAL_EMBOLDEN_X_VALUE=0

$ xrdb -q | grep Xft

Xft.antialias:  1
Xft.autohint:   0
Xft.dpi:        96
Xft.hinting:    1
Xft.hintstyle:  hintfull
Xft.lcdfilter:  lcddefault
Xft.rgba:       rgb

It can be a good idea to re-run this file each time your log on to your DE (e.g. you can add it to the list of startup applications).

3. Make sure there are no conflicting fontconfig config files in your `$XDG_CONFIG_HOME/fontconfig`. I doubt this is the source of the problem, though.

4. Last but not least, make sure there is no other Gtk+ theme setter active in your system (IIRC, there has been a special Gtk module for KDE control panel).

Edit And one more thing: I believe the font family in the first screenshot is not Arial. Compare 'g' letters for instance in both.

Last edited by bohoomil (2014-08-26 21:49:03)


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#1343 2014-08-26 22:05:02

Kaan
Member
Registered: 2009-02-10
Posts: 31

Re: infinality-bundle: good looking fonts made (even) easier

Thanks for all the steps, I love the work you do!

Everything was fine except "xrdb -q | grep Xft", rerunnig infinality.sh fixes that. I guess kde interferes here. I'll try adding this to startup scripts and see what happens.

Output of xft;

Xft.antialias:  1
Xft.hinting:    1
Xft.hintstyle:  hintfull
Xft.rgba:       rgb


As for the other stuff, I don't have .xresources file and adding or removing the xft settings from gtkrc didn't change anything. I did think that the problem may have been the kde gtk module you mentioned, but using lxapperance (lxde gtk setting app) which added some xft lines itself, didn't help either. I'll try disabling this module if it's not solved with infinality.sh.

Edit: Just saw your edit, they do look different. I wonder what other font that is interfering here, any way to find that out?

Last edited by Kaan (2014-08-26 22:07:09)

Offline

#1344 2014-08-26 22:34:37

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

You do not need .Xresources: everything you do need is already in infinality-settings.sh. That is why this single file is pretty important for the Infinality environment to be set up properly.

To see what your font collection looks like, just go to the common locations:

/usr/share/fonts
$XDG_DATA_HOME/fonts
$HOME/.fonts

and see what is living there. To my eye, the 'g' in question, the width of the letters and other details look like you are using Noto Sans family on your system. Is it possible you installed them manually? Does `pacman -Qs infinality-bundle-fonts` really return only Oxygen?

Last edited by bohoomil (2014-08-26 22:35:25)


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#1345 2014-08-26 22:53:58

Kaan
Member
Registered: 2009-02-10
Posts: 31

Re: infinality-bundle: good looking fonts made (even) easier

No, I checked the fonts folder too and the only ttf there is oxygen other than windows folder. The fonts I'm using are direct symlink from my windows install, that folder seems to have some sans fonts like liberation and others. I'll remove them and see what happens. It is so random though, like every other launch at most. Wish there was a way to see what font the application was sourcing.

And the reason I haven't checked my fonts folder was because this started to happen since last month or so, where I didn't even boot to windows. So I checked every other option.

Thanks for the pointers, I may solve this soon. smile


Edit: Looking through fonts I found Nirmala UI, which looks to be the same as the screenshot. It is an ms font though, not 3rd party.

Last edited by Kaan (2014-08-26 23:00:21)

Offline

#1346 2014-08-26 23:13:52

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

Nirmala UI indeed is a better culprit than Noto as it is thinner.

Just for the record: removing Liberation and other fonts should not be necessary. You can have as many families physically present in your system as you wish. Everything should be taken care of by fontconfig's presets (`ms` in this case). You may want to see if there is no interference from, say, `35-repl-custom.conf` which holds different defaults for sans-serif than `/etc/fonts/conf.d/60-latin-ms.conf`. In my opinion this would explain better the randomness of some apps behaviour.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#1347 2014-08-26 23:24:53

Kaan
Member
Registered: 2009-02-10
Posts: 31

Re: infinality-bundle: good looking fonts made (even) easier

Ok, I'll look at those too. I'm have moved the Nirmala fonts for now, to see what happens.

Edit: Nirmala seems to be in the conf files.

[kaan@arch conf.d]$ grep Nirmala *
40-non-latin.conf:    <family>Nirmala UI</family>
65-non-latin-ms.conf:        <family>Nirmala UI</family>
65-non-latin-ms.conf:        <family>Nirmala UI</family>
65-non-latin-ms.conf:        <family>Nirmala UI</family>
90-tt-fonts.conf:      <string>Nirmala UI</string>

Last edited by Kaan (2014-08-26 23:30:28)

Offline

#1348 2014-08-26 23:38:52

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

It is in 65-non-latin-ms.conf (two others should be left as they are). Remove lines 87-88:

<!-- Malayalam, Hindi -->
<family>Nirmala UI</family>

and 106 (the one below <!-- Kannada -->):

<family>Nirmala UI</family>

I must have overlooked the redundant entries. BTW, put Nirmala back where it belongs.

Last edited by bohoomil (2014-08-26 23:39:19)


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#1349 2014-08-26 23:47:28

Kaan
Member
Registered: 2009-02-10
Posts: 31

Re: infinality-bundle: good looking fonts made (even) easier

Haha, thanks. Is it something you did recently?

Offline

#1350 2014-08-26 23:50:58

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle: good looking fonts made (even) easier

Nope. It is all about my eyes. wink

I am now pushing the fix to the repo. It will be available for others first in the git version of fontconfig-infinality-ultimate, and a bit later in the next official release of fontconfig-iu. Thanks a lot for tracking the issue down!


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

Board footer

Powered by FluxBB