You are not logged in.

#2451 2014-08-09 22:56:57

alexis_evo
Member
Registered: 2013-07-04
Posts: 33

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

aldum wrote:
alexis_evo wrote:

I appreciate the help, but I don't think the issue is NTP. I've already disabled NTP in Windows. It's my understanding that there's three clocks on a computer. The RTC (hardware level, set in BIOS, battery backed), the system time (low level, set by the RTC on boot, never changes, used for timing by games/etc), and the local clock (the time displayed, synced by NTP). The problem is the system time is drifting off of the RTC.

Ok, so you tried turning it off, now try the other way: have it update every 5 minutes.

1) that is an ugly hack that will still cause problems (what if an application is affected by a time drift of 1-2 seconds? the time drift is as high as 1-2 seconds per minute, so 5-10 seconds of drift every 5 minutes is unacceptable).
2) public NTP servers will ban for polling that often.
3) AFAIK, NTP syncs the local/visible time, not the system time. With NTP enabled it will just fix the visible clock, leaving the system time to drift until the kernel snaps it back into place. If NTP were to sync the system time, it would break many applications whenever it is ran, so I don't believe they would do that (but who knows, maybe I'm wrong).

I will try it after a couple more attempts, but I really don't like the solution, even if it were to work.

After disabling HPET (passing -no-hpet to qemu), and running it for an hour, Windows' kernel hasn't snapped the time forward. can't tell for sure, but manually comparing the times it does seem to be keeping in sync. Will update if/when it kicks in again, or a couple of hours if it's still synced.

Offline

#2452 2014-08-10 03:40:26

nbhs
Member
From: Montevideo, Uruguay
Registered: 2013-05-02
Posts: 402

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

alexis_evo wrote:
aldum wrote:
alexis_evo wrote:

I appreciate the help, but I don't think the issue is NTP. I've already disabled NTP in Windows. It's my understanding that there's three clocks on a computer. The RTC (hardware level, set in BIOS, battery backed), the system time (low level, set by the RTC on boot, never changes, used for timing by games/etc), and the local clock (the time displayed, synced by NTP). The problem is the system time is drifting off of the RTC.

Ok, so you tried turning it off, now try the other way: have it update every 5 minutes.

1) that is an ugly hack that will still cause problems (what if an application is affected by a time drift of 1-2 seconds? the time drift is as high as 1-2 seconds per minute, so 5-10 seconds of drift every 5 minutes is unacceptable).
2) public NTP servers will ban for polling that often.
3) AFAIK, NTP syncs the local/visible time, not the system time. With NTP enabled it will just fix the visible clock, leaving the system time to drift until the kernel snaps it back into place. If NTP were to sync the system time, it would break many applications whenever it is ran, so I don't believe they would do that (but who knows, maybe I'm wrong).

I will try it after a couple more attempts, but I really don't like the solution, even if it were to work.

After disabling HPET (passing -no-hpet to qemu), and running it for an hour, Windows' kernel hasn't snapped the time forward. can't tell for sure, but manually comparing the times it does seem to be keeping in sync. Will update if/when it kicks in again, or a couple of hours if it's still synced.

Maybe this helps? https://access.redhat.com/documentation … ement.html

Offline

#2453 2014-08-10 08:23:40

alexis_evo
Member
Registered: 2013-07-04
Posts: 33

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

Yeah I saw and tried that. So far the only thing that's worked is disabling HPET. It does work though, so I guess this is 'solved'. I don't think I need HPET for anything...

Offline

#2454 2014-08-10 13:19:12

d3lxa
Member
Registered: 2014-07-16
Posts: 4

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

After a few weeks of test, I can say this is very stable. Had only a crash due to Windows (GPU overheat).

Nonetheless I have found a side problem with suspend/hibernate: After playing a few hours I shutdown Windows but I cannot suspend/hibernate (in Linux) at all. The computer seems to partially shutdown (mouse/keyboard off, monitor off) but it stays up (power on, fans on, etc). I can suspend/hibernate just fine when I freshly rebooted. Until I play using qemu VFIO I don't have such problem. If I use windows without gaming it's fine too (as far I can tell, I don't have tested too long). It seems, after a certain time of gaming, it becomes impossible to suspend, for some unknown reason. It may be related to the D3 state of the card. I tried to eject the VGA card but it's worse (Windows does not always shutdown).

Is it possible the card refuse to let it shutdown if it's still hot (fan at high speed) or until a certain time has passed after the VM is down? Does anyone experience this too? Does someone has any tip that I could try to see if it solve the issue, anything? I have 3.14.12 without patch (is the vga_arbitrer patch useful for this?)

EDIT: After a few tests, it's more simple than that: most of the time I was not able to suspend after running qemu with VFIO (without windows) in fact. What solved this problem (at great cost) is the VGAARB patch as expected. It prevents the color glitches I had until now on my linux screen but I am not able to play on Linux anymore (DRI disabled as described in the details) which is very unfortunate. I prefer DRI over being able to suspend. No other workaround out there?

My hardware+detailed report earlier: https://bbs.archlinux.org/viewtopic.php … 7#p1436677

Last edited by d3lxa (2014-08-11 00:20:09)

Offline

#2455 2014-08-10 17:59:27

das_j
Member
Registered: 2014-08-10
Posts: 4

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

I am currently trying to realize this because I want to get away from Windows.
Arch looks like the best Distribution for me, even if I am using it the first time (I was using SLES at work so I have at least a bit of knowledge).
This looks like the perfect project to keep playing my Windows/DirectX games.
The VM starts perfectly (currently without any drives) and shows up on my second screen.
But when I kill it using Ctrl+C (Output: qemu: terminating on signal 2) and want to start it again, I get the following error:

qemu-system-x86_64: vfio-pci: Cannot read device rom at 0000:04:00.0
Device option ROM contents are probably invalid (check dmesg).
Skip option ROM probe with rombar=0, or load from file with romfile=

The second screen (which kept the last image of the previous run) turned black and I had to kill it.

System information:

I have a Nvidia GTX 460 (to pass to the VM) and a Nvidia GeForce GT 240 for the Host.
My Mainboard is the Gigabyte GA-970A-UD3 and I have a AMD FX-8350.

lspci -k -nn (after binding to vfio):

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GT215 [GeForce GT 240] [10de:0ca3] (rev a2)
	Subsystem: CardExpert Technology Device [10b0:0401]
	Kernel driver in use: nouveau
	Kernel modules: nouveau
01:00.1 Audio device [0403]: NVIDIA Corporation High Definition Audio Controller [10de:0be4] (rev a1)
	Subsystem: CardExpert Technology Device [10b0:0401]
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
02:00.0 USB controller [0c03]: VIA Technologies, Inc. Device [1106:3483] (rev 01)
	Subsystem: Gigabyte Technology Co., Ltd Device [1458:5007]
	Kernel driver in use: xhci_hcd
	Kernel modules: xhci_hcd
03:00.0 SATA controller [0106]: Marvell Technology Group Ltd. 88SE9172 SATA 6Gb/s Controller [1b4b:9172] (rev 11)
	Subsystem: Gigabyte Technology Co., Ltd Device [1458:b000]
	Kernel driver in use: ahci
	Kernel modules: ahci
04:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF114 [GeForce GTX 460 v2] [10de:1205] (rev a1)
	Subsystem: Gigabyte Technology Co., Ltd Device [1458:34fc]
	Kernel driver in use: vfio-pci
	Kernel modules: nouveau
04:00.1 Audio device [0403]: NVIDIA Corporation GF114 HDMI Audio Controller [10de:0e0c] (rev a1)
	Subsystem: Gigabyte Technology Co., Ltd Device [1458:34fc]
	Kernel driver in use: vfio-pci
	Kernel modules: snd_hda_intel

cat /proc/cmdline:

BOOT_IMAGE=/boot/vmlinuz-linux-custom root=UUID=5bccb51e-9801-4086-93d7-535ba06e5bae rw quiet pci-stub.ids=10de:1205,10de:0e0c iommu=pt

Note: I use iommu=pt because Amd-Vi was spamming the log and slowing down the boot process. It still dosen't work when I remove it.

qemu call:

qemu-system-x86_64 -enable-kvm -M q35 -m 4096 -cpu host \
-smp 6,sockets=1,cores=6,threads=1 \
-bios /usr/share/qemu/bios.bin -vga none \
-device ioh3420,bus=pcie.0,addr=1c.0,multifunction=on,port=1,chassis=1,id=root.1 \
-device vfio-pci,host=04:00.0,bus=root.1,addr=00.0,multifunction=on,x-vga=on \
-device vfio-pci,host=04:00.1,bus=root.1,addr=00.1

qemu-system-x86_64 --version:

QEMU emulator version 2.0.0, Copyright (c) 2003-2008 Fabrice Bellard

cat /proc/version:

Linux version 3.15.8-1-custom (root@Acerola) (gcc version 4.9.1 (GCC) ) #1 SMP PREEMPT Sun Aug 10 14:12:21 CEST 2014

Can anybody help me with this?

Offline

#2456 2014-08-10 19:31:18

shrubuntu
Member
Registered: 2012-12-26
Posts: 16

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

kameloc wrote:
shrubuntu wrote:
kameloc wrote:

Oh sorry I don't passthrough my onboard audio, just share it. If you add

-device ac97,bus=pcie.0,addr=1b.0,id=sound0 \
-device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0

It emulates Realtek AC'97 for the guest. It allowed me to use my speakers from the VM or host, and at the same time

Can you show me the whole command? I can't seem to get it to work

This is how I start my VM. Only passthrough my GPU and a USB device. Emulate ac97 at the end.

sudo -E qemu-system-x86_64 -enable-kvm \
-M q35 \
-cpu host \
-smp 4,cores=4,threads=8,sockets=1 \
-m 6122 \
-rtc base=localtime,clock=host \
-balloon virtio \
-boot menu=on \
-bios /usr/share/qemu/bios.bin \
-vga none \
-usbdevice host:0d8c:0008 \
-device ioh3420,bus=pcie.0,addr=1c.0,multifunction=on,port=1,chassis=1,id=root.1 \
-device vfio-pci,host=01:00.0,bus=root.1,addr=00.0,romfile=/home/kameloc/windows7/EVGA.GTX550Ti.1024.121031.rom,multifunction=on,x-vga=on \
-device piix4-ide,bus=pcie.0,id=piix4-ide \
-drive file=/home/kameloc/windows7/windows7.img,id=disk,format=raw -device ide-hd,bus=piix4-ide.0,drive=disk \
-net nic,macaddr=DE:AD:BE:EF:00:00 \
-net bridge,br=br0 \
-soundhw ac97


alsa throws a bunch of errors when I call soundhw. Doesn't work sad

-soundhw ac97

Offline

#2457 2014-08-10 20:09:23

shazeal
Member
From: New Zealand
Registered: 2007-06-05
Posts: 341

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

penetal wrote:

I am trying to create an audio infterface on the VM, but I end up with the scratchy / crackling sound problem that some others have come across in this thread.

I tried to set the sample rate and driver for QEMU, but that resulted in the problem becomming 100 times worse so I commented it out.
Startup Script:

#!/bin/sh

vfio-bind 0000:01:00.0 0000:01:00.1

#export QEMU_PA_SAMPLES=128
#export QEMU_AUDIO_DRV=pa
qemu-system-x86_64 -enable-kvm -M q35 -m 10240 -cpu host \
        -smp 6,sockets=1,cores=3,threads=2 \
        -bios /usr/share/qemu/bios.bin \
        -device ioh3420,bus=pcie.0,addr=1c.0,multifunction=on,port=1,chassis=1,id=root.1 \
        -device vfio-pci,host=01:00.0,bus=root.1,addr=00.0,multifunction=on,x-vga=on \
        -device vfio-pci,host=01:00.1,bus=root.1,addr=00.1 \
        -drive file=/home/USER/vm/GamingWindows.img,id=disk,format=raw -device ide-hd,bus=ide.0,drive=disk \
        -vga none \
        -device ich9-intel-hda,bus=pcie.0,addr=1b.0,id=sound0 \
        -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 \
        -usb -usbdevice host:046d:c52b \
        -monitor stdio

Has anyone been able to solve this problem when those two things didn't help?

Browsing through and saw this, no one replied so I thought I would post my solution for crappy audio in qemu smile

First in the /etc/pulse/daemon.conf (or where ever it is on Arch) set these or change the values you have.

default-sample-format = s16le
default-sample-rate = 48000
default-fragments = 5 
default-fragment-size-msec = 2

This lowers the latency and sets the sample rate to the same as the guest so no resampling is needed.

Then in your QEMU startup use this...

export QEMU_AUDIO_DRV=pa
export QEMU_PA_SAMPLES=1024

The samples value can be tweaked up a bit, but anything under 1024 seems to introduce the choppy audio issue.

I still get the occasional crackle when the guest cpus are loaded but for the most part sound is flawless.

Offline

#2458 2014-08-10 20:55:14

Mardok45
Member
Registered: 2014-08-10
Posts: 5

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

I'm running on Gentoo.

I have successfully passed through an old ATI HD 4850 and a Radeon HD 7470.  These cards have worked great so far, but the one problem is neither are particularly powerful for recent games.  So I tried passing through my NVidia GTX 260 and it pretty much refuses to work.  After installing the drivers, I might be able to boot into a working instance, but after rebooting, Windows permanently BSOD's, even when not passing through the GPU, and I have to reimage the instance to get it working again.

Has anyone else had the same experience?  Any suggestions on getting the NVidia card to work?

If it's not likely to get a Geforce card working, I'm prepared to buy a Radeon 270X.  I really want to get this working because it will solve a lot of headaches, not just with playing games, but with development work as well.  The problem with that, though, is I haven't seen anybody confirm that R9 cards work.  I saw a video claiming that it was a 280X working with KVM VGA passthrough, but I haven't been able to verify it.

Does anyone have any tips for getting a Geforce card to work with VGA passthrough?  If not, can anybody confirm that Radeon R9 cards work with VGA passthrough?

EDIT: Well, I tried a clean installation and tried installing the NVidia drivers again, this time I'm getting that infamous Code 43 error.  I'm running on kernel 3.15 with the i915 arbiter patch and vga arbiter patch, and QEMU 2.1.0.

EDIT 2: Now I'm really confused, I downgraded the NVidia drivers to 275.33 and it's working.  The "3d business and gaming graphics performance" score is 6.9.  I don't understand what's going on.  I'll install and play Dota 2 and see how the performance compares to native and whether or not the VM is stable during play.

EDIT 3: The VM is stable, but the performance could be better.  On bare metal, I can play Dota 2 on max.  On a KVM instance, the FPS drops dramatically.  But hey, at least it works.  Now I can at least have a multi-OS workstation.

EDIT 4: Managed to upgrade the drivers to 334.89, but still having performance problems with Dota 2.

Last edited by Mardok45 (2014-08-11 02:08:23)

Offline

#2459 2014-08-11 04:34:08

shazeal
Member
From: New Zealand
Registered: 2007-06-05
Posts: 341

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

Just wanted to thank everyone in this thread, picked up lots of bits and pieces in here. Been testing for days using -vga std. Finally chucked in a second card today and now have a fully armed and operational OSX 10.9.4 guest smile

My setup.

Gentoo / Custom Kernel 3.16.0 + BFQ / GCC Optimization patches
Host: ASUS Nvidia 760 GTX
Guest: ASUS AMD 6450
CPU: Intel i5 2500 2 cpus in cpuset for guest
Memory: 16G, 2G hugetlbfs for guest.
Network: -netdev user,hostfwd=tcp::6900-:5900,id=user.0 -device e1000-82545em,netdev=user.0,id=mac_vnet0
Sound: Currently using ich9-intel-hda, but will probably switch to a USB stick at some point.
Disks: Preallocated qcow2 on SSD.

Have ordered a KVM Switch so I can just share the host keyboard and mouse and primary monitor. Fingers crossed using -device usb-host,hostbus=x,hostaddr=x assignment should work for the switch.

Offline

#2460 2014-08-11 04:41:56

shazeal
Member
From: New Zealand
Registered: 2007-06-05
Posts: 341

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

Mardok45 wrote:

I'm running on Gentoo.

I have successfully passed through an old ATI HD 4850 and a Radeon HD 7470.  These cards have worked great so far, but the one problem is neither are particularly powerful for recent games.  So I tried passing through my NVidia GTX 260 and it pretty much refuses to work.  After installing the drivers, I might be able to boot into a working instance, but after rebooting, Windows permanently BSOD's, even when not passing through the GPU, and I have to reimage the instance to get it working again.

Has anyone else had the same experience?  Any suggestions on getting the NVidia card to work?

If it's not likely to get a Geforce card working, I'm prepared to buy a Radeon 270X.  I really want to get this working because it will solve a lot of headaches, not just with playing games, but with development work as well.  The problem with that, though, is I haven't seen anybody confirm that R9 cards work.  I saw a video claiming that it was a 280X working with KVM VGA passthrough, but I haven't been able to verify it.

Does anyone have any tips for getting a Geforce card to work with VGA passthrough?  If not, can anybody confirm that Radeon R9 cards work with VGA passthrough?

EDIT: Well, I tried a clean installation and tried installing the NVidia drivers again, this time I'm getting that infamous Code 43 error.  I'm running on kernel 3.15 with the i915 arbiter patch and vga arbiter patch, and QEMU 2.1.0.

EDIT 2: Now I'm really confused, I downgraded the NVidia drivers to 275.33 and it's working.  The "3d business and gaming graphics performance" score is 6.9.  I don't understand what's going on.  I'll install and play Dota 2 and see how the performance compares to native and whether or not the VM is stable during play.

EDIT 3: The VM is stable, but the performance could be better.  On bare metal, I can play Dota 2 on max.  On a KVM instance, the FPS drops dramatically.  But hey, at least it works.  Now I can at least have a multi-OS workstation.

EDIT 4: Managed to upgrade the drivers to 334.89, but still having performance problems with Dota 2.

The R9 270X is just a 7870 card rebranded and overclocked, regardless any video card can be passed through its just a PCI redirect afaik. Its upto the guest to support the video card.

More important than the video card is how are you running CPU/RAM, are you using cgroups and hugetlbfs?

Offline

#2461 2014-08-11 04:48:12

aw
Member
Registered: 2013-10-04
Posts: 921
Website

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

Mardok45 wrote:

I'm running on Gentoo.

I have successfully passed through an old ATI HD 4850 and a Radeon HD 7470.  These cards have worked great so far, but the one problem is neither are particularly powerful for recent games.  So I tried passing through my NVidia GTX 260 and it pretty much refuses to work.  After installing the drivers, I might be able to boot into a working instance, but after rebooting, Windows permanently BSOD's, even when not passing through the GPU, and I have to reimage the instance to get it working again.

Has anyone else had the same experience?  Any suggestions on getting the NVidia card to work?

If it's not likely to get a Geforce card working, I'm prepared to buy a Radeon 270X.  I really want to get this working because it will solve a lot of headaches, not just with playing games, but with development work as well.  The problem with that, though, is I haven't seen anybody confirm that R9 cards work.  I saw a video claiming that it was a 280X working with KVM VGA passthrough, but I haven't been able to verify it.

Does anyone have any tips for getting a Geforce card to work with VGA passthrough?  If not, can anybody confirm that Radeon R9 cards work with VGA passthrough?

EDIT: Well, I tried a clean installation and tried installing the NVidia drivers again, this time I'm getting that infamous Code 43 error.  I'm running on kernel 3.15 with the i915 arbiter patch and vga arbiter patch, and QEMU 2.1.0.

EDIT 2: Now I'm really confused, I downgraded the NVidia drivers to 275.33 and it's working.  The "3d business and gaming graphics performance" score is 6.9.  I don't understand what's going on.  I'll install and play Dota 2 and see how the performance compares to native and whether or not the VM is stable during play.

EDIT 3: The VM is stable, but the performance could be better.  On bare metal, I can play Dota 2 on max.  On a KVM instance, the FPS drops dramatically.  But hey, at least it works.  Now I can at least have a multi-OS workstation.

EDIT 4: Managed to upgrade the drivers to 334.89, but still having performance problems with Dota 2.

Add kvm=off to the -cpu parameter list to make current Nvidia driver not get Code 43.  Also add hv_time to enable hypver-v enlightened time keeping.  Older kernels can have poor performance if the game makes use of debug registers, run something new.  Hugepages, pinning, and vCPU model tuning also help.  All of this is documented in the very, very long thread.


http://vfio.blogspot.com
Looking for a more open forum to discuss vfio related uses?  Try https://www.redhat.com/mailman/listinfo/vfio-users

Offline

#2462 2014-08-11 05:39:39

slis
Member
Registered: 2014-06-02
Posts: 127

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

@mardok45 check your cpu config

    <topology sockets='1' cores='4' threads='1'/>

if u set 2 cores 2 threads dota works 2x slower, also check your cpu model, hvtime option... etc... host cpufreq settings....

Last edited by slis (2014-08-11 05:40:22)

Offline

#2463 2014-08-11 10:51:00

devianceluka
Member
Registered: 2014-05-19
Posts: 44

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

I have 3 GPUs:

Passing through either GPU works flawlessly at any time.
Passing through two GPUs at the same time does not work.

Im using Ubuntu 14.04 with no "patches" whatsoever. What could be the problem?

The error is:
vfio: error opening /dev/vfio/1: Device or resource busy
vfio: failed to get group 1
Device initialization failed.
Device 'vfio-pci' could not be initialized

If I shutdown the other VM and start the one getting error at the moment, it works and then the one that works at the moment is getting the same error. They don't work at the same time in 2 different VMs.
I added "/dev/vfio/1" to /etc/libvirt/qemu.conf and "relaxed_acs_check = 1".

Please help!!

EDIT: When I start 2nd VM its always getting "vfio: failed to get group 1", thats why I added "/dev/vfio/1 to the qemu.conf. Should I do something else? Please help!

Last edited by devianceluka (2014-08-11 10:52:41)

Offline

#2464 2014-08-11 12:24:41

aw
Member
Registered: 2013-10-04
Posts: 921
Website

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

devianceluka wrote:

I have 3 GPUs:

Passing through either GPU works flawlessly at any time.
Passing through two GPUs at the same time does not work.

Im using Ubuntu 14.04 with no "patches" whatsoever. What could be the problem?

ACS override patch...


http://vfio.blogspot.com
Looking for a more open forum to discuss vfio related uses?  Try https://www.redhat.com/mailman/listinfo/vfio-users

Offline

#2465 2014-08-11 13:02:48

devianceluka
Member
Registered: 2014-05-19
Posts: 44

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

aw wrote:
devianceluka wrote:

I have 3 GPUs:

Passing through either GPU works flawlessly at any time.
Passing through two GPUs at the same time does not work.

Im using Ubuntu 14.04 with no "patches" whatsoever. What could be the problem?

ACS override patch...

Thank you.

Doing this command at the moment:
sudo patch -p1 override_for_missing_acs_capabilities.patch

Is this the right command? This machine is booting from a VERY slow USB drive (but it works..), VMs are on fast iSCSI. Is this command "compiling/building" anything? If it is, I guess this will take forever in this situation if I'm not mistaken. After this command there is an empty line after and don't know if its doing anything or not..?

Offline

#2466 2014-08-11 14:12:47

aw
Member
Registered: 2013-10-04
Posts: 921
Website

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

devianceluka wrote:
aw wrote:
devianceluka wrote:

I have 3 GPUs:

Passing through either GPU works flawlessly at any time.
Passing through two GPUs at the same time does not work.

Im using Ubuntu 14.04 with no "patches" whatsoever. What could be the problem?

ACS override patch...

Thank you.

Doing this command at the moment:
sudo patch -p1 override_for_missing_acs_capabilities.patch

Is this the right command?

No, patch takes the diff file on stdin: http://jungels.net/articles/diff-patch-ten-minutes.html


http://vfio.blogspot.com
Looking for a more open forum to discuss vfio related uses?  Try https://www.redhat.com/mailman/listinfo/vfio-users

Offline

#2467 2014-08-11 14:40:03

slis
Member
Registered: 2014-06-02
Posts: 127

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

@aw

one question pls smile

what are options for clock or what clock to use on windows guest to make it "tight" or something like that, i get this weird problem after 30 or 60mins clock on vm is re/set or smth, cause when streaming games logs show frame time in -12312435ms expected is 20-50ms, and it starts to lag, it shows estimated bandwith like 10-40mbps (expected is 400-1000) in steam stats on 1gbps lan (alt-tab, copy-paste at same time 100MB/s) etc.... maybe cause of high cpu load? clock lags?

i did try couple of options that i found here/on internet, but nothing seems to make it go away completely.

problem it is happening after 30mins so its pain to wait for it smile

does hwclock need to be in sync with os clock?


thx

Offline

#2468 2014-08-11 15:38:44

devianceluka
Member
Registered: 2014-05-19
Posts: 44

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

aw wrote:
devianceluka wrote:
aw wrote:

ACS override patch...

Thank you.

Doing this command at the moment:
sudo patch -p1 override_for_missing_acs_capabilities.patch

Is this the right command?

No, patch takes the diff file on stdin: http://jungels.net/articles/diff-patch-ten-minutes.html

You got me all clueless now.. What should I do exactly? Im running Ubuntu 14.04 upgraded everything to the latest. If you could please write those lines down I would really appreciate it.. Please

Offline

#2469 2014-08-11 15:53:17

sinny
Member
Registered: 2014-05-24
Posts: 75

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

devianceluka wrote:
aw wrote:
devianceluka wrote:

Thank you.

Doing this command at the moment:
sudo patch -p1 override_for_missing_acs_capabilities.patch

Is this the right command?

No, patch takes the diff file on stdin: http://jungels.net/articles/diff-patch-ten-minutes.html

You got me all clueless now.. What should I do exactly? Im running Ubuntu 14.04 upgraded everything to the latest. If you could please write those lines down I would really appreciate it.. Please

all the stuff discussed in the thread is still experimental
not everything is working, and what is working at the moment may require great amount of grinding to get it to work

so, you either get to catch-up on basic stuff yourself, or just wait for all the functionality to mature enough not to be considered experimental

people here are too busy fighting non-trivial stuff (==trying to make things more mature) - please consider possibility of not wasting their time to try to explain to you how to patch kernel and why it is needed at all (or anything else that is "entry-level")

p.s. you could start by reading all the thread posts (while googling how to do all the stuff you dont understand) - yes, the thread is pretty long, but there are people here whose time is much more valuable for overall progress than yours or mine is (maturing general vt-d support is much more important than getting your stuff to work)

Offline

#2470 2014-08-11 16:05:09

devianceluka
Member
Registered: 2014-05-19
Posts: 44

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

sinny wrote:
devianceluka wrote:
aw wrote:

No, patch takes the diff file on stdin: http://jungels.net/articles/diff-patch-ten-minutes.html

You got me all clueless now.. What should I do exactly? Im running Ubuntu 14.04 upgraded everything to the latest. If you could please write those lines down I would really appreciate it.. Please

all the stuff discussed in the thread is still experimental
not everything is working, and what is working at the moment may require great amount of grinding to get it to work

so, you either get to catch-up on basic stuff yourself, or just wait for all the functionality to mature enough not to be considered experimental

people here are too busy fighting non-trivial stuff (==trying to make things more mature) - please consider possibility of not wasting their time to try to explain to you how to patch kernel and why it is needed at all (or anything else that is "entry-level")

p.s. you could start by reading all the thread posts (while googling how to do all the stuff you dont understand) - yes, the thread is pretty long, but there are people here whose time is much more valuable for overall progress than yours or mine is (maturing general vt-d support is much more important than getting your stuff to work)

I understand that and I really respect all the work. But if someone got the time to explain a newbie here how to apply this patch, it would be awesome. Do I need the kernel source to do it? Do I need to compile kernel? Or it can be done to the existing kernel? If someone got the time I would really appreciate it.

EDIT: Especially that I got that far that I only need this patch do finish... It would be a real shame if noone got a minute to write down.. sad

Last edited by devianceluka (2014-08-11 16:08:59)

Offline

#2471 2014-08-11 16:30:26

sinny
Member
Registered: 2014-05-24
Posts: 75

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

devianceluka wrote:
sinny wrote:
devianceluka wrote:

You got me all clueless now.. What should I do exactly? Im running Ubuntu 14.04 upgraded everything to the latest. If you could please write those lines down I would really appreciate it.. Please

all the stuff discussed in the thread is still experimental
not everything is working, and what is working at the moment may require great amount of grinding to get it to work

so, you either get to catch-up on basic stuff yourself, or just wait for all the functionality to mature enough not to be considered experimental

people here are too busy fighting non-trivial stuff (==trying to make things more mature) - please consider possibility of not wasting their time to try to explain to you how to patch kernel and why it is needed at all (or anything else that is "entry-level")

p.s. you could start by reading all the thread posts (while googling how to do all the stuff you dont understand) - yes, the thread is pretty long, but there are people here whose time is much more valuable for overall progress than yours or mine is (maturing general vt-d support is much more important than getting your stuff to work)

I understand that and I really respect all the work. But if someone got the time to explain a newbie here how to apply this patch, it would be awesome. Do I need the kernel source to do it? Do I need to compile kernel? Or it can be done to the existing kernel? If someone got the time I would really appreciate it.

EDIT: Especially that I got that far that I only need this patch do finish... It would be a real shame if noone got a minute to write down.. :(

well, sorry to mention that, but you got abslutely nowhere (no way there is some "that far" you are implying) if you neither dont understand the very basics (things discussed here are much much more complex), nor got desire to explore things yourself

is it some kind of shame to google for something like "ubuntu patching kernel"? this way you only "waste" your own time. but no, somehow it seems like you prefer to waste your own AND someone else's time to explain to you things that are written about multiple times all over the internet

upd:
now me gracefully stops doing this holy-war-like thing. i have only one thing to add: respect other peoples' time and work more than your own

Last edited by sinny (2014-08-11 16:32:25)

Offline

#2472 2014-08-11 16:33:55

aw
Member
Registered: 2013-10-04
Posts: 921
Website

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

devianceluka wrote:

EDIT: Especially that I got that far that I only need this patch do finish... It would be a real shame if noone got a minute to write down.. sad

It's already been written down if you'd check.  Maybe start with http://kernelnewbies.org/


http://vfio.blogspot.com
Looking for a more open forum to discuss vfio related uses?  Try https://www.redhat.com/mailman/listinfo/vfio-users

Offline

#2473 2014-08-11 18:52:45

abdullah
Member
Registered: 2014-06-10
Posts: 34

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

Well, I got Ubuntu 14.04 LTS, everything worked great, until I broke the system in order to ( I bought a new card, GTX 760..) getting rid of error 43, which I did! in debian tested! yet everything worked great, until I started copying and pasting cos I freaked out, yet I solved the error, but guss what, the system freeze after a guest starts. Now I'm looking forward for linux mint 17, hope to get everything sorted out this time!.

notes to new folks: it is easy ! just take the time and read here and there, which... will take long time, but knowledged is good.

Edit:

I tested Qemu 2.1.0, it includes the kvm=off patch, no need to re-compile!.

Last edited by abdullah (2014-08-11 18:55:11)

Offline

#2474 2014-08-11 19:10:59

devianceluka
Member
Registered: 2014-05-19
Posts: 44

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

I think I got it how to compile the kernel, read few guides.

What I now get is this:

sudo patch -p1 < override_for_missing_acs_capabilities.patch
patching file Documentation/kernel-parameters.txt
Hunk #1 succeeded at 2490 with fuzz 1 (offset -64 lines).
patching file drivers/pci/quirks.c
Hunk #1 succeeded at 3394 (offset 10 lines).
Hunk #2 succeeded at 3539 with fuzz 1 (offset -45 lines).
Hunk #3 FAILED at 3597.
1 out of 3 hunks FAILED -- saving rejects to file drivers/pci/quirks.c.rej

Could anyone please tell me what I'm doing wrong? The kernel I got is: "linux-image-3.13.0-32-generic" which I got with "sudo apt-get source linux-image-`uname -r`"

Offline

#2475 2014-08-11 19:51:38

sinny
Member
Registered: 2014-05-24
Posts: 75

Re: KVM VGA-Passthrough using the new vfio-vga support in kernel =>3.9

devianceluka wrote:

I think I got it how to compile the kernel, read few guides.

What I now get is this:

sudo patch -p1 < override_for_missing_acs_capabilities.patch
patching file Documentation/kernel-parameters.txt
Hunk #1 succeeded at 2490 with fuzz 1 (offset -64 lines).
patching file drivers/pci/quirks.c
Hunk #1 succeeded at 3394 (offset 10 lines).
Hunk #2 succeeded at 3539 with fuzz 1 (offset -45 lines).
Hunk #3 FAILED at 3597.
1 out of 3 hunks FAILED -- saving rejects to file drivers/pci/quirks.c.rej

Could anyone please tell me what I'm doing wrong? The kernel I got is: "linux-image-3.13.0-32-generic" which I got with "sudo apt-get source linux-image-`uname -r`"

patches fail to apply if source code is significantly different compared to source the patch was originally made for
there are several versions of every patch spread throughout the thread

i may be wrong, but it seems to me that currently most people here use 3.15.x-3.16.x kernels

Last edited by sinny (2014-08-11 19:52:23)

Offline

Board footer

Powered by FluxBB