You are not logged in.

#26 2013-06-28 05:37:25

mjb
Member
From: Germany
Registered: 2012-01-28
Posts: 66

Re: Can't boot with kernel 3.9.X and Grub 2

cfr wrote:
mjb wrote:
heftig wrote:

I think you're suffering from https://bugs.archlinux.org/task/35909 .
There's a working grub package linked in the comments, please try.

I am not suffering from that, as I am still using grub 2.00-1. It works fine for kernel 3.8.x but it doesn't work for 3.9.x. This is a different bug.

That bug concerns grub 2.00-1 according to the report. (But it is odd if it works for 3.8.x.)

Sorry! I completely misread the bug report. If I want to try the version of grub that is linked in the comments, do I just have to do "makepkg -si"? If something goes wrong after that: can I just chroot and downgrade to the version in my "vars/cache/pacman/pkg"?

Offline

#27 2013-06-28 21:39:48

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: Can't boot with kernel 3.9.X and Grub 2

I think you should just update as I am pretty sure whatever is in the linked package is now in the stable repo. My grub is at 2.00.5043-2 and is from stable. I think this is the version mentioned as including the fix.

Last edited by cfr (2013-06-28 21:40:15)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

Board footer

Powered by FluxBB