You are not logged in.

#51 2014-01-25 09:02:44

jaxxed
Member
Registered: 2012-04-21
Posts: 8

Re: KDE Frameworks 5 packages

Stavallo:  I was running from kde4, but it's definitely not my desired approach.  I was running a shell script that set the vars, ran the dbus-launch, and then ran kdeinit and plasma.  The plasma swaps out from kde4 to kde5 and then back.

I checked out your lightdm startkde yesterday, and could get past the qdbus problem if I hardcoded to qdbus-qt5, but then I get a really unstable desktop.  Plasma just seems to keep crashing and re-starting.

Most of this stuff is way over my head, but I can try any solutions that you can think of.

Offline

#52 2014-02-15 21:33:57

Pat0n75
Member
Registered: 2014-02-15
Posts: 2

Re: KDE Frameworks 5 packages

First thanks for you work!
I've installed all the packages but kwallet-framework-git. I can't clone the git tree, it says that I haven't the correct rights.

Offline

#53 2014-02-15 21:36:29

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: KDE Frameworks 5 packages

Pat0n75 wrote:

I've installed all the packages but kwallet-framework-git. I can't clone the git tree, it says that I haven't the correct rights.

Hi,
I already notified stavallo some day ago...anyway to fix that you just need to use kwallet.git as source repository.

Offline

#54 2014-02-16 10:39:49

Pat0n75
Member
Registered: 2014-02-15
Posts: 2

Re: KDE Frameworks 5 packages

That's what I've done. The thing is I have to manually edit the PKGBUILD files to change the dependencies. Anyway, thanks for your great work.

Offline

#55 2014-02-18 16:22:22

desaparecido
Member
From: Liège, Belgium
Registered: 2010-03-14
Posts: 138

Re: KDE Frameworks 5 packages

hi, I try to build from AUR the alpha version (4.96) following the instruction in the first post and all build fine until the kde-workspace package, I have these errors about libattica, that is installed (attica and attica-qt5)

  -> Extracting kde-workspace-0.plasma2tp.tar.bz2 with bsdtar
==> Starting prepare()...
patching file kwin/effects/presentwindows/presentwindows.cpp
patching file ksmserver/screenlocker/CMakeLists.txt
patching file kcontrol/krdb/krdb.cpp
patching file kcontrol/style/kcmstyle.cpp
patching file plasma/desktop/applets/pager/plugin/pager.cpp
patching file plasma/generic/dataengines/notifications/CMakeLists.txt
patching file plasma/generic/dataengines/notifications/notificationsengine.cpp
==> Removing existing pkg/ directory...
==> Starting build()...
CMake Warning at CMakeLists.txt:91 (find_package):
  Could not find a package configuration file provided by "LibAttica" with
  any of the following names:

    LibAtticaConfig.cmake
    libattica-config.cmake

  Add the installation prefix of "LibAttica" to CMAKE_PREFIX_PATH or set
  "LibAttica_DIR" to a directory containing one of the above files.  If
  "LibAttica" provides a separate development package or SDK, be sure it has
  been installed.

and at the end, just before stop build:

-- The following REQUIRED packages have not been found:

 * LibAttica , Support for Get Hot New Stuff related stuff , <https://projects.kde.org/attica>

CMake Error at /usr/share/cmake-2.8/Modules/FeatureSummary.cmake:430 (message):
  feature_summary() Error: REQUIRED package(s) are missing, aborting CMake
  run.
Call Stack (most recent call first):
  CMakeLists.txt:329 (feature_summary)


-- Configuring incomplete, errors occurred!

I have [testing] repo enable.


KF5 & Plasma5 (git versions) - Awesome WM
ASUS Sabertooth 990FX - AMD FX8350 - ATI Radeon HD 7970
[testing] repo

Offline

#56 2014-03-07 08:25:05

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,178

Re: KDE Frameworks 5 packages

Are the -git packages still maintained in AUR? Many of the have been broken for a while, with missing dependencies, some dependencies that have been renamed or don't exist anymore, renamed repos, etc...

Offline

#57 2014-03-07 12:44:08

AnAkkk
Member
Registered: 2014-03-03
Posts: 145

Re: KDE Frameworks 5 packages

Both -git and non git versions seem to be broken. Missing dependencies or build errors.

Offline

#58 2014-03-07 12:52:43

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,178

Re: KDE Frameworks 5 packages

AnAkkk wrote:

Both -git and non git versions seem to be broken. Missing dependencies or build errors.

If you notice missing dependencies in the non git packages, post a comment in AUR, Andrea will usually fix them quickly.

Offline

#59 2014-03-07 12:55:31

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: KDE Frameworks 5 packages

AnAkkk wrote:

Both -git and non git versions seem to be broken. Missing dependencies or build errors.

kde-workspace, kde-runtime and plasma TP are NOT compatible with KF5 Alphas.

Plasma Next alpha 1 will NOT be compatible with KF5 packages, but I'll try to patch them.
Upstream devs will base Plasma Next future releases on KF5 released tarballs.

Offline

#60 2014-03-08 00:44:14

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,178

Re: KDE Frameworks 5 packages

-git packages are all fixed now

Offline

#61 2014-03-08 18:34:52

AnAkkk
Member
Registered: 2014-03-03
Posts: 145

Re: KDE Frameworks 5 packages

Thanks. Is it normal kf5-meta-git, kf5-akonadi-git, and konsole-git no longer have mainteners though? Should I remove these?

EDIT:
extra-cmake-modules-git too.

Last edited by AnAkkk (2014-03-08 18:37:48)

Offline

#62 2014-03-13 02:58:34

ant32
Member
Registered: 2013-03-23
Posts: 24

Re: KDE Frameworks 5 packages

I created a repo https://www.dropbox.com/sh/tmel7e8yampexp2/Yq-7JsVfZH

[ant32-kf5]
SigLevel = Optional TrustAll
Server = https://dl.dropboxusercontent.com/u/276543319

I'm still working on compiling kde-workspace, kde-runtime, and plasma-nm. There may be packages that I missed that would also fit into the repo. All packages are compiled in a clean chroot.

I've run into the following with kde-workspace and plama-nm

CMake Error at /opt/kf5/lib/cmake/KF5/KF5Config.cmake:28 (find_package):
  Could not find a package configuration file provided by "KF5Style" with any
  of the following names:

    KF5StyleConfig.cmake
    kf5style-config.cmake

  Add the installation prefix of "KF5Style" to CMAKE_PREFIX_PATH or set
  "KF5Style_DIR" to a directory containing one of the above files.  If
  "KF5Style" provides a separate development package or SDK, be sure it has
  been installed.

Offline

#63 2014-03-13 09:30:22

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,178

Re: KDE Frameworks 5 packages

ant32 wrote:

I've run into the following with kde-workspace and plama-nm

kde-workspace is too old and doesn't build anymore with the latest KF5 alpha. Right now you need to use the git version (but then you also need the git versions of at least plasma-framework and kwindowsystem)

Offline

#64 2014-03-13 18:19:36

Akuma
Member
From: France
Registered: 2010-10-26
Posts: 30

Re: KDE Frameworks 5 packages

Hello, and thanks a lot for the AUR packages smile

I could successfully build and run KF5 some weeks ago, but today I have troubles building kde-runtime-git :

==> Making package: kde-runtime-git r20481.ed63e00-1 (Thu Mar 13 18:53:36 CET 2014)

<- snip ->

[ 90%] Built target kde4-menu
[ 90%] Generating index.cache.bz2
Could not locate file "customization" in standard dirs 
Could not locate file "customization" in standard dirs 
index.docbook:8: warning: failed to load external entity "dtd/kdedbx45.dtd"
]>
  ^
index.docbook:10: parser error : Entity 'language' not defined
<book id="kdesu" lang="&language;">
                                 ^
<- snip (a lot of similar errors) ->

index.docbook:331: element book: validity error : No declaration for element book
</book>
       ^
doc/kdesu/CMakeFiles/doc-kdesu-handbook.dir/build.make:56: recipe for target 'doc/kdesu/index.cache.bz2' failed
make[2]: *** [doc/kdesu/index.cache.bz2] Error 1
CMakeFiles/Makefile2:6790: recipe for target 'doc/kdesu/CMakeFiles/doc-kdesu-handbook.dir/all' failed
make[1]: *** [doc/kdesu/CMakeFiles/doc-kdesu-handbook.dir/all] Error 2
Makefile:116: recipe for target 'all' failed
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...

Anyone knows how to solve this ?

Last edited by Akuma (2014-03-13 18:20:20)

Offline

#65 2014-03-14 07:48:27

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: KDE Frameworks 5 packages

Akuma wrote:

Anyone knows how to solve this ?

Try:

$ export XDG_DATA_DIRS="/opt/kf5/share:$XDG_DATA_DIRS"

Offline

#66 2014-03-14 08:37:59

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,178

Re: KDE Frameworks 5 packages

scarpino wrote:

Try:

$ export XDG_DATA_DIRS="/opt/kf5/share:$XDG_DATA_DIRS"

Yep, that works. I added it to the AUR package.

Offline

#67 2014-03-14 15:49:00

Akuma
Member
From: France
Registered: 2010-10-26
Posts: 30

Re: KDE Frameworks 5 packages

ilpianista wrote:
Akuma wrote:

Anyone knows how to solve this ?

Try:

$ export XDG_DATA_DIRS="/opt/kf5/share:$XDG_DATA_DIRS"

That worked, Thanks !

Offline

#68 2014-03-14 16:13:55

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,178

Re: KDE Frameworks 5 packages

The kde-workspace-git package contains a session file now that allows to start a full KF5-plasma session from any DM, courtesy of TZ86

Offline

#69 2014-03-14 17:03:18

ant32
Member
Registered: 2013-03-23
Posts: 24

Re: KDE Frameworks 5 packages

Thanks to arojas I now successfully build all git packages in a clean chroot https://db.tt/Der6KsDP . I have posted all missing dependencies to the comments of the respective packages and most of them have been fixed already by the maintainers.

[ant32-kf5-git]
SigLevel = Optional TrustAll
Server =https://dl.dropboxusercontent.com/u/276783483

Offline

#70 2014-03-17 11:26:25

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,178

Re: KDE Frameworks 5 packages

ilpianista wrote:

The link needs to be fixed for your new username. Also the list needs updating: kf5-attica-git -> attica-qt5-git, kdnssd-framework-git -> kdnssd-git

Offline

#71 2014-03-21 14:42:09

naervaer
Member
Registered: 2014-03-21
Posts: 1

Re: KDE Frameworks 5 packages

ant32 wrote:

Thanks to arojas I now successfully build all git packages in a clean chroot https://db.tt/Der6KsDP . I have posted all missing dependencies to the comments of the respective packages and most of them have been fixed already by the maintainers.

[ant32-kf5-git]
SigLevel = Optional TrustAll
Server =https://dl.dropboxusercontent.com/u/276783483

There seems to be a lot of file conflicts in Attica. e.g.:

error: failed to commit transaction (conflicting files)
/opt/kf5/include/KF5/Attica/Attica/AccountBalance exists in both 'attica-qt5-git' and 'kf5-attica-git'

Offline

#72 2014-03-21 18:08:49

ant32
Member
Registered: 2013-03-23
Posts: 24

Re: KDE Frameworks 5 packages

kf5-attica-qt5 has been replaced by attica-qt5. Please uninstall kf5-attica-qt5. It might have been nice if the proper conflicts had been added. I'll remove the package later today yet

Offline

#73 2014-03-25 11:04:29

Trieforce
Member
Registered: 2010-12-11
Posts: 88

Re: KDE Frameworks 5 packages

ant32, your repo is 400.

Offline

#74 2014-03-25 13:29:27

ant32
Member
Registered: 2013-03-23
Posts: 24

Re: KDE Frameworks 5 packages

I'll look into it. In the mean time take a look at http://ant32.linuxd.org

Offline

#75 2014-04-01 20:22:11

spider623
Member
Registered: 2013-09-05
Posts: 6

Re: KDE Frameworks 5 packages

Thanks for the repo, my arch laptop was too slow to compile all the packets

Offline

Board footer

Powered by FluxBB