You are not logged in.

#51 2013-08-04 17:50:35

Beelzebud
Member
From: Illinois, U.S.
Registered: 2010-07-16
Posts: 154

Re: root device not read-write warning

I don't use [testing], but I'm getting this message on every boot.   I've tried changing the boot parameter from "ro" to "rw", but the grub-mkconfig always inserts an "ro" no matter what.   For now I assume this is safe to ignore?   The system functions completely normally.

Offline

#52 2013-08-04 17:59:53

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: root device not read-write warning

Beelzebud wrote:

I don't use [testing], but I'm getting this message on every boot.   I've tried changing the boot parameter from "ro" to "rw", but the grub-mkconfig always inserts an "ro" no matter what.   For now I assume this is safe to ignore?   The system functions completely normally.

Yes. The worst that will happen is that your boot will be slightly slower because root gets fsck'ed twice. I believe that an update to grub will fix it so that grub-mkconfig does not override the rw setting. Until then, you either have to edit the template which causes grub-mkconfig to insert ro, edit grub.cfg by hand, or use a different boot loader.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#53 2013-08-06 21:05:12

Fregtux
Member
From: Italy
Registered: 2013-08-01
Posts: 55

Re: root device not read-write warning

I don't use [testing] too, but with the last update i've this warning. I've grub 2 and I see in /boot/grub/grub.cfg at section 10_linux about arch lines as:

linux   /boot/vmlinuz-linux root=UUID=49e4172a-24c6-4d9a-be98-e53ae1e788db ro  quiet splash nomodeset

I don't change 10_linux in /etc/grub.d. I only run a:

# grub-mkconfig -o /boot/grub/grub.cfg

and lines change to:

linux   /boot/vmlinuz-linux root=UUID=49e4172a-24c6-4d9a-be98-e53ae1e788db rw  quiet splash nomodeset

Infact I've no more warning at boot.

Try to upgrade your system and then run grub-mkconfig, this patch should do what i said (autochange ro -> rw).


ASUS P8P67 EVO | i7-2600k |RAM 16GB DDR 3 Vengeance@1600MHz | AMD 7950 Sapphire Dual-X | SSD: Samsung 830 250GB | HD: Western Digital Caviar Blue 1TB

Offline

#54 2013-08-07 06:59:19

Franknd
Member
Registered: 2013-02-25
Posts: 8

Re: root device not read-write warning

In /etc/default  there is a grub.pacsave

I have restored this  file grub.pacsave as the original grub (rename grub file)

grub-mkconfig -o /boot/grub/grub.cfg

The warning message has disappeared

Offline

#55 2013-08-07 07:56:10

Fregtux
Member
From: Italy
Registered: 2013-08-01
Posts: 55

Re: root device not read-write warning

Franknd wrote:

In /etc/default  there is a grub.pacsave

I have restored this  file grub.pacsave as the original grub (rename grub file)

grub-mkconfig -o /boot/grub/grub.cfg

The warning message has disappeared

I've no grub.pacsave in /etc/default. Perhaps, with the last grub update, did patch be integrate in grub?


ASUS P8P67 EVO | i7-2600k |RAM 16GB DDR 3 Vengeance@1600MHz | AMD 7950 Sapphire Dual-X | SSD: Samsung 830 250GB | HD: Western Digital Caviar Blue 1TB

Offline

#56 2013-08-07 10:59:31

Franknd
Member
Registered: 2013-02-25
Posts: 8

Re: root device not read-write warning

This is my /etc/default/grub.pacsave

GRUB_DEFAULT=0
GRUB_TIMEOUT=20
GRUB_DISTRIBUTOR="Arch"
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX="resume=/dev/disk/by-uuid/7df9fa3a-786c-4797-92f1-e032f74d1354"

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable Hidden Menu, and optionally hide the timeout count
#GRUB_HIDDEN_TIMEOUT=5
#GRUB_HIDDEN_TIMEOUT_QUIET=true

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter 
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx" 
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper 
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
GRUB_THEME="/boot/grub/themes/Archxion/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

#GRUB_SAVEDEFAULT="true"

Naturally, it's adapted to my system, and I don't know if it has been the key of the solution.

Try twice:(as sudo)

grub-mkconfig -o /boot/grub/grub.cfg

Last edited by Franknd (2013-08-07 12:51:49)

Offline

#57 2013-08-07 11:21:36

Fregtux
Member
From: Italy
Registered: 2013-08-01
Posts: 55

Re: root device not read-write warning

Post your /boot/grub/grub.cfg using "code" tag.


ASUS P8P67 EVO | i7-2600k |RAM 16GB DDR 3 Vengeance@1600MHz | AMD 7950 Sapphire Dual-X | SSD: Samsung 830 250GB | HD: Western Digital Caviar Blue 1TB

Offline

#58 2013-08-07 21:29:48

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: root device not read-write warning

Fregtux wrote:

I've no grub.pacsave in /etc/default. Perhaps, with the last grub update, did patch be integrate in grub?

You'll only get a .pacsave if you've customised /etc/default/grub. If not, the new version will just be installed automatically and all you need do is regenerate grub.cfg an possibly reinstall grub to disk.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#59 2013-08-08 07:02:43

Fregtux
Member
From: Italy
Registered: 2013-08-01
Posts: 55

Re: root device not read-write warning

Thanks for clarification!


ASUS P8P67 EVO | i7-2600k |RAM 16GB DDR 3 Vengeance@1600MHz | AMD 7950 Sapphire Dual-X | SSD: Samsung 830 250GB | HD: Western Digital Caviar Blue 1TB

Offline

#60 2013-08-08 19:28:44

Magbed
Member
Registered: 2013-06-02
Posts: 25

Re: root device not read-write warning

Same message here, not using testing either, guess ill wait for an update to solve it

Offline

#61 2013-08-08 20:07:30

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,095
Website

Re: root device not read-write warning

Magbed wrote:

Same message here, not using testing either, guess ill wait for an update to solve it

No words can express my aggravation with a post like this.

Offline

#62 2013-08-08 20:48:27

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,020
Website

Re: root device not read-write warning

falconindy wrote:
Magbed wrote:

Same message here, not using testing either, guess ill wait for an update to solve it

No words can express my aggravation with a post like this.

Wat? You mean you aren't going to use your amazing dev powers to fix our machines for us?

Are we really all alone? Were all the tacos for nothing?


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Online

#63 2013-08-09 00:46:35

Jurry
Member
Registered: 2012-04-12
Posts: 12

Re: root device not read-write warning

grub-mkconfig -o /boot/grub/grub.cfg

This did the trick for me.

All done without the need for amazing dev powers! :-)

Last edited by Jurry (2013-08-10 00:31:16)

Offline

#64 2013-08-09 05:24:40

Dashius
Member
Registered: 2013-08-09
Posts: 7

Re: root device not read-write warning

Fregtux wrote:

I don't use [testing] too, but with the last update i've this warning. I've grub 2 and I see in /boot/grub/grub.cfg at section 10_linux about arch lines as:

linux   /boot/vmlinuz-linux root=UUID=49e4172a-24c6-4d9a-be98-e53ae1e788db ro  quiet splash nomodeset

I don't change 10_linux in /etc/grub.d. I only run a:

# grub-mkconfig -o /boot/grub/grub.cfg

and lines change to:

linux   /boot/vmlinuz-linux root=UUID=49e4172a-24c6-4d9a-be98-e53ae1e788db rw  quiet splash nomodeset

Infact I've no more warning at boot.

Try to upgrade your system and then run grub-mkconfig, this patch should do what i said (autochange ro -> rw).

This worked and was actually useful. Thanks.

Offline

#65 2013-08-09 08:13:34

Fregtux
Member
From: Italy
Registered: 2013-08-01
Posts: 55

Re: root device not read-write warning

A question: I installed plymouth and so after grub it start earl, so now I would not be able to read the log written on tty1 at boot, where there was the warning message of this topic. I would have been able to read it in some way? For example, in dmesg or elsewhere? And yes, where?

Thanks.


ASUS P8P67 EVO | i7-2600k |RAM 16GB DDR 3 Vengeance@1600MHz | AMD 7950 Sapphire Dual-X | SSD: Samsung 830 250GB | HD: Western Digital Caviar Blue 1TB

Offline

#66 2013-08-09 11:39:05

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,095
Website

Re: root device not read-write warning

Fregtux wrote:

A question: I installed plymouth and so after grub it start earl, so now I would not be able to read the log written on tty1 at boot, where there was the warning message of this topic. I would have been able to read it in some way? For example, in dmesg or elsewhere? And yes, where?

Thanks.

You could, you know... disable plymouth? Doesn't 'nosplash' do that? Maybe just look at your config files?

If you want the ultimate "duh", then log early boot. The mkinitcpio manpage even explains how to do this.

Last edited by falconindy (2013-08-09 12:35:41)

Offline

#67 2013-08-09 12:39:17

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,984
Website

Re: root device not read-write warning

@Jurry,

For a bit of a reality check, there is only one dev active in this thread, and he is consistently responding with the information needed to solve user's problems.  Even when that same information has already been delivered a dozen times.

Contrast that with the tens, hundreds, or perhaps even more forum members who could help with said problems, but just frankly don't care anymore.  No one can really express true arrogance in a forum post.  That is expressed only by figuring something isn't even worthy of a response.  Case in point here, I think your post is worthy of a response, as I hope that (if I'm not missing the joke in your post) that the above "reality check" may influence your thinking on the subject.

EDIT: I'm glad it seems I misunderstood the joke.  I think the rest of my content though is still worth keeping.  In summary: tacos >> falconindy

Last edited by Trilby (2013-08-10 00:53:40)


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#68 2013-08-10 00:36:21

Jurry
Member
Registered: 2012-04-12
Posts: 12

Re: root device not read-write warning

Trilby wrote:
Jurry wrote:

All done without the need for arrogance and amazing dev powers! :-)

I hope I'm misreading this - and the smily does imply a joke in there, but I don't know who the joke is on.

For a bit of a reality check, there is only one dev active in this thread, and he is consistently responding with the information needed to solve user's problems.  Even when that same information has already been delivered a dozen times.

Contrast that with the tens, hundreds, or perhaps even more forum members who could help with said problems, but just frankly don't care anymore.  No one can really express true arrogance in a forum post.  That is expressed only by figuring something isn't even worthy of a response.  Case in point here, I think your post is worthy of a response, as I hope that (if I'm not missing the joke in your post) that the above "reality check" may influence your thinking on the subject.

Oops.... It was a joke in response of this post:

jasonwryan wrote:
falconindy wrote:
Magbed wrote:

Same message here, not using testing either, guess ill wait for an update to solve it

No words can express my aggravation with a post like this.

Wat? You mean you aren't going to use your amazing dev powers to fix our machines for us?

Are we really all alone? Were all the tacos for nothing?

Don't want to offend anyone. I changed my post.

Last edited by Jurry (2013-08-10 03:28:56)

Offline

#69 2013-08-10 13:40:28

PReP
Member
From: Sweden/Sala
Registered: 2010-06-13
Posts: 347
Website

Re: root device not read-write warning

Lesson #1 in enjoying arch: dealing with any .pacnew and being relieved.

And this said by me being this " " close to doing a post about it not being a news-item,
then realising for myself that i DID have a (syslinux in my case) .pacnew which i missed at first.

: )

Last edited by PReP (2013-08-10 13:40:40)


#1 Main: Intel Core i5 2500k (Sandy) @ 3.9 Ghz, 8 GB DDR2-XMP RAM @ 1600 Mhz, Geforce GTX 570 (Gainward Phantom) - Arch Linux 64-Bit
#2 Server: Intel C2D E8400 @ 3.6 Ghz, 3 GB DDR2-RAM @ 802mhz, XFX GF GTX260 XT -ArchLinux 64-bit.

<- Server Homepage: http://prep.mine.nu ->

Offline

#70 2013-08-13 22:47:24

dwillar
Member
Registered: 2012-08-10
Posts: 5

Re: root device not read-write warning

Simply amazing that it took 63 posts to get the answer. Thanks Jurry!

Offline

#71 2013-08-13 22:51:20

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,068

Re: root device not read-write warning

dwillar wrote:

Simply amazing that it took 63 posts to get the answer. Thanks Jurry!

It didn't. All of the information you needed was in the first few posts of the thread.

Offline

#72 2013-08-13 22:51:35

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: root device not read-write warning

dwillar wrote:

Simply amazing that it took 63 posts to get the answer. Thanks Jurry!

I found the answer in the first post... I'm not sure why you needed to read 63 posts to get the answer here.  An explanation of what is going on has been included over and over and over in this thread.

It rather sounds like you were just looking for a set of commands to blindly copy and paste... which is a terrible idea.

Offline

#73 2013-08-13 22:54:36

karol
Archivist
Registered: 2009-05-06
Posts: 25,430

Re: root device not read-write warning

I think Arch Linux is not the right distro if you want things to 'just work' w/o a bit of understanding of what's going on and why.

Offline

#74 2013-08-15 07:01:43

wstewart90
Member
Registered: 2013-07-13
Posts: 17

Re: root device not read-write warning

This thread probably wouldn't have caused as much frustration had the op not got side tracked with mkinitcpio hooks that weren't related to the actual problem. I typically always use grub-mkconfig -o /boot/grub/grub.cfg to generate my config file so I never ran into this issue.

Offline

#75 2013-08-15 21:56:59

markg85
Member
Registered: 2009-06-27
Posts: 130

Re: root device not read-write warning

Hi,

I tried every single solution provided in this thread. The message is gone but that's due to the mkinitcpio stuff. I have no "ro" anywhere anymore yet grup itself (at boot) shows me a ro..

So here we go, here are my configs:

/etc/default/grub

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Arch"
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable Hidden Menu, and optionally hide the timeout count
#GRUB_HIDDEN_TIMEOUT=5
#GRUB_HIDDEN_TIMEOUT_QUIET=true

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter 
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx" 
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper 
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"
                                                                                                                                                                                                                                             
# Uncomment one of them for the gfx desired, a image background or a gfxtheme                                                                                                                                                                
#GRUB_BACKGROUND="/path/to/wallpaper"                                                                                                                                                                                                        
#GRUB_THEME="/path/to/gfxtheme"                                                                                                                                                                                                              
                                                                                                                                                                                                                                             
# Uncomment to get a beep at GRUB start                                                                                                                                                                                                      
#GRUB_INIT_TUNE="480 440 1"                                                                                                                                                                                                                  
                                                                                                                                                                                                                                             
#GRUB_SAVEDEFAULT="true"                                                                                                                                                                                                                     

and /boot/grub/grub.cfg

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
insmod part_gpt
insmod part_msdos
if [ -s $prefix/grubenv ]; then
  load_env
fi
if [ "${next_entry}" ] ; then
   set default="${next_entry}"
   set next_entry=
   save_env next_entry
   set boot_once=true
else
   set default="0"
fi

if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

if [ x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_gpt
insmod ext2
set root='hd0,gpt4'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt4 --hint-efi=hd0,gpt4 --hint-baremetal=ahci0,gpt4  fb604f9b-5b08-44dd-8dc2-793d2828e67d
else
  search --no-floppy --fs-uuid --set=root fb604f9b-5b08-44dd-8dc2-793d2828e67d
fi
    font="/usr/share/grub/unicode.pf2"
fi

if loadfont $font ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=en_US
  insmod gettext
fi
terminal_input console
terminal_output gfxterm
set timeout=5
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Arch Linux, with Linux core repo kernel' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-core repo kernel-true-fb604f9b-5b08-44dd-8dc2-793d2828e67d' {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_gpt
        insmod ext2
        set root='hd0,gpt4'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt4 --hint-efi=hd0,gpt4 --hint-baremetal=ahci0,gpt4  fb604f9b-5b08-44dd-8dc2-793d2828e67d
        else
          search --no-floppy --fs-uuid --set=root fb604f9b-5b08-44dd-8dc2-793d2828e67d
        fi
        echo    'Loading Linux core repo kernel ...'
        linux   /boot/vmlinuz-linux root=UUID=fb604f9b-5b08-44dd-8dc2-793d2828e67d rw  quiet
        echo    'Loading initial ramdisk ...'
        initrd  /boot/initramfs-linux.img
}
menuentry 'Arch Linux, with Linux core repo kernel (Fallback initramfs)' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-core repo kernel-fallback-fb604f9b-5b08-44dd-8dc2-793d2828e67d' {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_gpt
        insmod ext2
        set root='hd0,gpt4'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt4 --hint-efi=hd0,gpt4 --hint-baremetal=ahci0,gpt4  fb604f9b-5b08-44dd-8dc2-793d2828e67d
        else
          search --no-floppy --fs-uuid --set=root fb604f9b-5b08-44dd-8dc2-793d2828e67d
        fi
        echo    'Loading Linux core repo kernel ...'
        linux   /boot/vmlinuz-linux root=UUID=fb604f9b-5b08-44dd-8dc2-793d2828e67d rw  quiet
        echo    'Loading initial ramdisk ...'
        initrd  /boot/initramfs-linux-fallback.img
}

### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###

### BEGIN /etc/grub.d/60_memtest86+ ###
### END /etc/grub.d/60_memtest86+ ###

As you can see. "rw" where needed yet grub itself is showing me an "ro". How can that be? It's like it's reading some other file somewhere. I'm puzzled, i don't have any other ideas where this might be going wrong.
And yes, i did run "grub-mkconfig -o /boot/grub/grub.cfg" a gazillion times.

Offline

Board footer

Powered by FluxBB