You are not logged in.

#76 2013-10-15 11:13:35

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

@bohoomil

All my fonts are looking great and crispy except for the URL in Chromium. It is far too big and the characters are moving slightly up and down when typing in the URL.

Screenshot: http://i.imgur.com/BC94763.png

This are my default font settings in Cinnamon: http://i.imgur.com/fCwJIyN.png

I did not change any font settings in Chromium. Do I have to change something else?

Offline

#77 2013-10-15 11:52:15

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

orschiro wrote:

the URL in Chromium
<snip>
Do I have to change something else?

Yes: enable "Use GTK+ theme" in Chromium settings.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#78 2013-10-15 11:54:50

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

I see. So your font configuration settings cannot affect Chromium themes such as Adwaita [1], correct?

[1] https://chrome.google.com/webstore/deta … e-ntp-icon

Offline

#79 2013-10-15 12:19:39

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

If I understand the logic behind Chromium UI concept correctly, it doesn't use system-wide Gtk+ settings by default. Hence the answer would be no. However, this is a question to an avid Chromium user in the first place (I'm not one): There may exist some sort of workaround--other than code hacking--that lets you easily achieve what you are asking for.

Last edited by bohoomil (2013-10-15 13:24:39)


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#80 2013-10-15 12:37:34

fantab
Member
From: 3rd Rock from the Sun
Registered: 2011-06-07
Posts: 150

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

I have an issue with fonts. When I open certain GUI applications (Meld, Gedit) as root the default document font is Times Roman. I have set DejaVu Sans as my default font and my MONO font is DejaVu Sans Mono.
Also VLC subtitles are in Times Roman. I am not sure if this has got something to do with Infinality or some other issue. However I start here.

Any ideas?

Regards...


"Evolution is the nature's way of issuing upgrades".
__________________________________________________________
Arch_x64-Gnome-Shell ~ Arch-lts_x64-Xfce ~ Trusty Thar_x64-Unity ~ LMDE_x64-Cinnamon

Offline

#81 2013-10-15 13:23:15

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

This has actually nothing to do with infinality: just some trivial misconfiguration.

If you run an application as root--Gedit for example--it uses root's UI settings. All you have to do is set a font of your choice for Gedit when run as root and everything should be fine. The same with VLC: It most likely uses an alias or a font you don't have in your system. Go to the options and set DejaVu Sans manually.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#82 2013-10-15 17:26:19

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

mitchejj wrote:

I add the repo to pacman.conf, imported and signed the key (again) and updated pacman. However, I keep running into problems.

 infinality-bundle                                                       7.0 KiB   702K/s 00:00 [########################################################] 100%
 infinality-bundle.sig                                                 287.0   B  0.00B/s 00:00 [########################################################] 100%
 infinality-bundle-fonts                                                15.0   B  0.00B/s 00:00 [########################################################] 100%
 infinality-bundle-fonts.sig                                            15.0   B  0.00B/s 00:00 [########################################################] 100%
error: GPGME error: No data
error: failed to update infinality-bundle-fonts (invalid or corrupted database (PGP signature))

I must have forgotten about your post, but here we go:

I believe that you added the repository and started syncing just at the same time that I was updating it and the key files were still not present at the server. What you can do:

1. Remove manually

/var/lib/pacman/sync/infinality-bundle-fonts.db
/var/lib/pacman/sync/infinality-bundle-fonts.db.sig

Since you are already using [infinality-bundle] for libraries, re-fetching the re-signing the key is redundant.

2. Clean your pacman cache, especially if pacman has already tried to download any package from the [infinality-bundle-fonts]. You don't need to remove everything from the cache, just the files from my repository.

3. Re-sync your local database the usual way:

pacman -Syyu

and install whatever you wish.

I hope this helps.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#83 2013-10-15 23:03:40

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

Not sure about this but should t1-tex-gyre-ib also conflict with tex-gyre-fonts? I noticed that's the name of the otf font package in the main repo but conflicts specifies only otf-texgyre.

Last edited by cfr (2013-10-15 23:03:55)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#84 2013-10-16 15:47:59

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

Thanks a lot -- I  missed this one. The package has been updated and re-uploaded.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#85 2013-10-17 06:18:06

wildshu
Member
Registered: 2013-03-25
Posts: 14

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

Please replace Luxi Sans with something else.
I'm using defaults, hintfull and everything looks great so far ( much appreciated! ) except for Luxi, some characters are slightly smeared horizontaly (a and s for example)  fonts aren't symetric vertically (E, S) , or cut off (bottom of the J, top of the T sometimes), bold text (especially huge letters) is just horrible.
As replacement for Lucida it's  quite bad.


Just look at the bold ones.

4eYyoca.png

And what's up with the spacing after k and s?


Btw, DejaVu Sans, it's mostly fine...
but, the "ę"
bc5juef.png
It looks like it's about to die (it suppossed to look just like normal e, plus tail).

Last edited by wildshu (2013-10-17 06:52:23)

Offline

#86 2013-10-17 09:18:37

brebs
Member
Registered: 2007-04-03
Posts: 3,441

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

wildshu wrote:

I'm using defaults, hintfull

Are you using hintfull with Luxi Sans? Maybe that's the problem. I use hintslight and autohint true.

Offline

#87 2013-10-17 13:23:59

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

wildshu wrote:

Please replace Luxi Sans with something else.
<snip>
As replacement for Lucida it's  quite bad.

No, it isn't: click. We're using Type1 version which doesn't have typical drawbacks TTF/OTF versions are notorious for. This is LibreOffice and its libfreetype.so that suck. There used to be a version of the library for Open/LibreOffice with infinality patch set applied (check the AUR): this should fix the problem once LO were able to use global freetype2 settings. Otherwise, you can substitute Luxi with anything you wish on your own: either in LO only, or globally, via fontconfig.

wildshu wrote:

DejaVu Sans, it's mostly fine... but, the "ę"

Use t1-dejavu-ibx (= Type1 version) instead of ttf-dejavu-ib. Both are present in the repository. Then go to /etc/fonts/conf.d and modify two files as follows:

1. 90-tt-fonts.conf -- comment DejaVu section, like this:

  <!--match target="font">
    <test name="force_autohint">
      <bool>false</bool>
    </test>
    <test name="family">
      <string>DejaVu Sans Mono</string>
    </test>
    <edit name="font_type" mode="assign">
      <string>TT Instructed Font</string>
    </edit>
  </match>
  <match target="font">
    <test name="force_autohint">
      <bool>false</bool>
    </test>
    <test name="family">
      <string>DejaVu Sans</string>
    </test>
    <edit name="font_type" mode="assign">
      <string>TT Instructed Font</string>
    </edit>
  </match>
  <match target="font">
    <test name="force_autohint">
      <bool>false</bool>
    </test>
    <test name="family">
      <string>DejaVu Serif</string>
    </test>
    <edit name="font_type" mode="assign">
      <string>TT Instructed Font</string>
    </edit>
  </match-->

2. 90-non-tt-fonts.conf -- paste the code below somewhere in 'D' section:

<match target="font" >
    <test name="family" >
      <string>DejaVu Sans Mono</string>
    </test>
    <edit name="font_type" mode="assign">
      <string>NON TT Instructed Font</string>
    </edit>
  </match>
  <match target="font" >
    <test name="family" >
      <string>DejaVu Sans</string>
    </test>
    <edit name="font_type" mode="assign">
      <string>NON TT Instructed Font</string>
    </edit>
  </match>
  <match target="font" >
    <test name="family" >
      <string>DejaVu Serif</string>
    </test>
    <edit name="font_type" mode="assign">
      <string>NON TT Instructed Font</string>
    </edit>
  </match>

These are common problems with DejaVu Sans and a few letters, dating back to days where it was still Bitstream Vera Sans (there are even bug reports). If you change hinting from full to slight and play with autohinting a bit, you will notice how the rendering changes.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#88 2013-10-17 14:56:18

Perfect Gentleman
Member
Registered: 2012-10-25
Posts: 219

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

bohoomil, is that okay?

Replace ttf-dejavu-ib with infinality-bundle-fonts/t1-dejavu-ibx? [Y/n]

Offline

#89 2013-10-17 15:41:12

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

@Perfect Gentleman, I noticed that too.  So since there have been changes, I did a pacman -S --needed infinality-bundle-fonts{,-extra} and it asked if I now wanted to replace t1-dejavu-ibx with ttf-dejavu-ib.  So which is the more appropriate choice?  Should one have disappeared, or is the presence of both intentional?

Offline

#90 2013-10-17 17:36:21

wildshu
Member
Registered: 2013-03-25
Posts: 14

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

bohoomil wrote:

No, it isn't: click. We're using Type1 version which doesn't have typical drawbacks TTF/OTF versions are notorious for. This is LibreOffice and its libfreetype.so that suck. There used to be a version of the library for Open/LibreOffice with infinality patch set applied (check the AUR): this should fix the problem once LO were able to use global freetype2 settings. Otherwise, you can substitute Luxi with anything you wish on your own: either in LO only, or globally, via fontconfig.


Thank you for taking your time and answering me.
This is not LibreOffice, it's Firefox, I don't have LO installed even.
Your snippet looks better (much improved spacing) but bold/big ones are still horrible.
I'm using hintfull per your suggestion, but I'll try other settings, I'm new to font configs and I'm trying to be careful here.


And as you can see I'm using brighter fonts on darker backgrounds, exclusively, there's no pure white whatsoever.
Any suggestions here, to improve rendering?

Last edited by wildshu (2013-10-17 17:39:01)

Offline

#91 2013-10-17 21:27:02

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

Is there some straightforward way of ensuring I have all the required fonts installed? I was sure that I'd followed the instructions but

$ pacman -Qs luxi
local/font-bh-ttf 1.0.3-1
    X.org Luxi Truetype fonts
$ pacman -Qs dejavu
local/ttf-dejavu-ib 2.34-2 (infinality-bundle-fonts)
    Font family based on the Bitstream Vera Fonts with a wider range of characters. Re-packed for infinality-bundle-fonts.

How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#92 2013-10-17 21:42:15

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

Perfect Gentleman wrote:

bohoomil, is that okay?

Replace ttf-dejavu-ib with infinality-bundle-fonts/t1-dejavu-ibx? [Y/n]

Yes, but I did it the wrong way (because I'm &#@*).

Anyway, I decided to swap Dejavu TrueType for Type 1 version: I've been using it myself, but for the sake of simplicity I left DejaVu TTF in the repo. However, on second thought (and wildshu's case) I changed my mind.

To get everything you need, 1) update your systems (fontconfig-ib => 2.11.0-4), and then install 't1-dejavu-ib' from the infinality-bundle-fonts. You will be asked if either ttf-dejavu-ib or t1-dejavu-ibx should be replaced, hit Yes and you're done.

Sorry for a ride down a bumpy road… wink

@wildshu, there's one thing you can try doing: rebuild Firefox with 'ac_add_options --enable-system-cairo' uncommented in mozconfig. Maybe it helps (a bit, a lot).

And just to defend Luxi a bit: each and every font can reveal a dose of imperfection when put in a critical environment. There are renowned type faces with established reputation (Helvetica for that matter) that simply won't behave whatever you do with them (in Linux). Luxi tended to be a troublemaker, but PostScript version somehow broke through -- and that seemed excellent to me because it is one of the finest designs in the free font realm. Frankly, I can't see where it really renders 'horribly': to me it's fine both in bold and regular variant. However, my eyes are not universal and fortunately don't have to be. That's why I think you should take a look at available fonts (there's a nice Lato in the bundle repo -- see if you like it), test them on your own and share your experience: that's a better approach than relying totally on 'off the peg' stuff, I reckon.

(By the way, as far as LO is concerned, it's more about its use of fontconfig rules than freetype2 that makes it deaf to rendering nuances. And it happens to be a pain, really…)


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#93 2013-10-17 22:32:58

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

What is the package for type1 Luxi? A search for luxi didn't turn up any results other than the ttf package from the standard repos (font-bh-ttf).


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#94 2013-10-17 23:44:20

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

Check this:

[~] $ fc-match "Luxi Sans"
l048013t.pfa: "Luxi Sans" "Regular"
[~] $ pkgfile l048013t.pfa
extra/xorg-fonts-type1

:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#95 2013-10-17 23:45:01

Perfect Gentleman
Member
Registered: 2012-10-25
Posts: 219

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

bohoomil wrote:

To get everything you need, 1) update your systems (fontconfig-ib => 2.11.0-4), and then install 't1-dejavu-ib' from the infinality-bundle-fonts. You will be asked if either ttf-dejavu-ib or t1-dejavu-ibx should be replaced, hit Yes and you're done.

done with that.

Offline

#96 2013-10-17 23:59:00

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

bohoomil wrote:

Check this:

[~] $ fc-match "Luxi Sans"
l048013t.pfa: "Luxi Sans" "Regular"
[~] $ pkgfile l048013t.pfa
extra/xorg-fonts-type1

Thanks. Here's what I get:

$ fc-match "Luxi Sans"
luxisr.ttf: "Luxi Sans" "Regular"
$ pacman -Qo /usr/share/fonts/Type1/l048013t.pfa
/usr/share/fonts/Type1/l048013t.pfa is owned by xorg-fonts-type1 7.4-2
$ pacman -Qo /usr/share/fonts/TTF/luxisr.ttf 
/usr/share/fonts/TTF/luxisr.ttf is owned by font-bh-ttf 1.0.3-1

So should I uninstall font-bh-ttf?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#97 2013-10-18 01:05:55

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

Yes, you should remove font-bh-ttf since fontconfig-ib settings are tuned for the PostScript version of the font. (That's why xorg-fonts-type1 should be installed as a part of ib-fonts collection.)


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#98 2013-10-18 01:22:25

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

OK. I already had xorg-fonts-type1 installed. Just that the ttf version of Luxi is apparently preferred to the type1 version (and the packages don't conflict).

Thanks. Should everyone make the changes to 90-(non)-tt-fonts.conf?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#99 2013-10-18 01:29:45

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

If you mean, changes to DejaVu status, than no, this is not necessary anymore: Everything you need you have already installed with fontconfig-ib update. Instead of introducing the changes manually to particular files on a per-user basis, I split the section which should be different for TTF and T1 formats and made them a part of font packages. This means that when you install either of the two, you will get the right rendering instructions for each. I think this is a better solution because user can choose a preferred format and if it is not the recommended default, re-installation won't introduce conflicting rendering instructions but will replace them. That's basically it. smile


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#100 2013-10-18 01:32:51

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: infinality-bundle-fonts: a free multilingual font collection for Arch

Brilliant - thanks very much!


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

Board footer

Powered by FluxBB