You are not logged in.

#326 2014-12-17 22:50:50

Kamek
Member
Registered: 2013-05-24
Posts: 10

Re: Macbook Pro Late 2013 Retina

I tried pavucontrol, it works now ...
PulseAudio and kmix can be weird hmm

Offline

#327 2014-12-19 06:03:15

guidob
Member
Registered: 2007-05-28
Posts: 10

Re: Macbook Pro Late 2013 Retina

Just a small tip, but you can install kernel 3.18 by enabling the testing repository. This should improve thunderbolt support even more. smile

Offline

#328 2015-01-01 20:14:09

hrod
Member
Registered: 2013-10-24
Posts: 57

Re: Macbook Pro Late 2013 Retina

ryzion wrote:

@hrod what did you change to lower your power consumption. Did you disable pstates? My CPU is running at full frequency unless I disable turbo and set /sys/devices/system/cpu/intel_pstate/max_perf_pct to something low

Nothing special. Maybe try kill your wm and run powertop in a free tty to see if there is something causing higher gpu usage than my i3? It might just be brightness idk.
Right now with chrome and 20% brightness: details.

Last edited by hrod (2015-01-01 20:14:28)

Offline

#329 2015-01-03 18:24:55

Kamek
Member
Registered: 2013-05-24
Posts: 10

Re: Macbook Pro Late 2013 Retina

Anyone else experiencing slow wake ups ?
If I try to wake up right after I close the lid, it take about 30 seconds. Otherwise it wakes up in about 2 seconds, that's odd.
I'm using systemd and this happens with both gnome and KDE, so I don't think it's DE related.

Also, sometimes after wake ups the screen seems to turn off after a few seconds of inactivity. See https://bugs.freedesktop.org/show_bug.cgi?id=86105

Any fix ?

Last edited by Kamek (2015-01-03 19:27:04)

Offline

#330 2015-01-14 14:50:54

Sc0rian
Member
Registered: 2014-01-06
Posts: 41

Re: Macbook Pro Late 2013 Retina

Yup, don't ever wake the laptop up, then close the lid again. It will take AGES to come back around sad

For me, still the worse problem is the terrible IO wait. I watch the IO wait a lot, and it causes such a performance knock its unreal. Its the worse thing about this MBP on Linux.

Can be fixed by turning barrier off, but I'd rather not risk a corrupt hard drive.

Offline

#331 2015-01-17 01:17:35

hrod
Member
Registered: 2013-10-24
Posts: 57

Re: Macbook Pro Late 2013 Retina

just a note: careful with upgrading now, broadcom-wl + linux 3.18 = kernel panic: https://bbs.archlinux.org/viewtopic.php?id=192287&p=1

to restore (use ethernet):

$ aurget -S downgrade
$ downgrade linux linux headers
$ aurget -S broadcom-wl

i selected linux-3.17.6

Last edited by hrod (2015-01-17 01:35:04)

Offline

#332 2015-01-21 18:06:32

Kamek
Member
Registered: 2013-05-24
Posts: 10

Re: Macbook Pro Late 2013 Retina

hrod wrote:

careful with upgrading now, broadcom-wl + linux 3.18 = kernel panic

This is now fixed with the -dkms version (which makes things easier anyways, since it'll rebuild the module automatically on kernel upgrades)

sudo pacman -Rnsc broadcom-wl
packer -S broadcom-wl-dkms
sudo pacman -Syu
reboot
Sc0rian wrote:

Yup, don't ever wake the laptop up, then close the lid again. It will take AGES to come back around sad

This also seems to be resolved on 3.18.2-2, great big_smile

Last edited by Kamek (2015-01-21 18:47:54)

Offline

#333 2015-02-04 10:40:47

fixel
Member
Registered: 2009-03-27
Posts: 19

Re: Macbook Pro Late 2013 Retina

Just wondering if anyone has this issue:

Closing lid (1st time after reboot) - computer properly suspends.
Opening lid - properly resumes no problem

Closing lid (2nd time after reboot) - computer suspends...wait for it... after a couple of seconds (somewhere between 5-20) it wakes while the lid is closed!!

Offline

#334 2015-02-04 10:49:16

ryzion
Member
Registered: 2012-03-20
Posts: 94

Re: Macbook Pro Late 2013 Retina

Yes, I noticed this after 3.18. For me it suspends shortly after waking up again (lid closed).

Offline

#335 2015-02-04 18:20:17

baronmog
Member
Registered: 2013-11-01
Posts: 60

Re: Macbook Pro Late 2013 Retina

fixel wrote:

Just wondering if anyone has this issue:

Closing lid (1st time after reboot) - computer properly suspends.
Opening lid - properly resumes no problem

Closing lid (2nd time after reboot) - computer suspends...wait for it... after a couple of seconds (somewhere between 5-20) it wakes while the lid is closed!!

Yeah, this has been an ongoing issue for some time (long before the 3.18 kernel).

Offline

#336 2015-02-06 06:19:42

sokuban
Member
Registered: 2006-11-11
Posts: 406

Re: Macbook Pro Late 2013 Retina

I just upgraded and my idle temp is around the 90s (and I hear my fans running). Anyone else get this? Know what might be the cause?

Offline

#337 2015-02-06 06:22:57

frank604
Member
From: BC, Canada
Registered: 2011-04-20
Posts: 1,174
Website

Re: Macbook Pro Late 2013 Retina

@sokuban, Could be gpe66 acpi interrupt. Did you install yosemite on your macbook even once? If not, could be something else.


github       bible       screenshot

Offline

#338 2015-02-06 06:30:33

sokuban
Member
Registered: 2006-11-11
Posts: 406

Re: Macbook Pro Late 2013 Retina

Nope, no yosemite, I meant I pacman -Syu'd. (Never heard of this bug, but good thing I found out now; I'll hold off from updating OS X then.) I had been holding off on -Syu-ing for a while because of the broadcom bug, so I only managed to get it in now.

I just rebooted and actually I don't see this problem now. After a bit of use I'll let you know if this continues.

Offline

#339 2015-02-06 07:42:32

frank604
Member
From: BC, Canada
Registered: 2011-04-20
Posts: 1,174
Website

Re: Macbook Pro Late 2013 Retina

Next time run htop.  Could of been a runaway if it cleared after a reboot?


github       bible       screenshot

Offline

#340 2015-02-06 09:53:17

regulament
Member
Registered: 2014-02-15
Posts: 67

Re: Macbook Pro Late 2013 Retina

@frank604: I had a kworder thread for gpe06 at full load resulting in high temperatures so I disabled it( echo disable > /sys/firmware/acpi/interrupts/gpe06 )

Is it because of OS X? Any chance I could revert it?

Also, when I'm turning the notebook on, half the time( literally, first time works, second not) it's unresponsive. I can't login, can't startx, can't change TTY, noting. No input works and I have to hold the power button to forcibly reboot the machine. And the second time it works with no hangs. It's a new issue, anyone experiencing this or having nay idea why/ how to fix it?

Last edited by regulament (2015-02-06 10:03:13)

Offline

#341 2015-02-06 13:58:30

frank604
Member
From: BC, Canada
Registered: 2011-04-20
Posts: 1,174
Website

Re: Macbook Pro Late 2013 Retina

I'm on an mba so it's a little different. First of all,  you can't revert the firmware to my knowledge. There is a new update in Yosemite 10.10.2 that fixed gpe66. But for me gpe4e still was a little crazy.  As to the black screen, it is called flipping. I added i915 in my mkinitcpio to resolve this, not sure which video card is used on boot for mbp.


github       bible       screenshot

Offline

#342 2015-02-28 19:45:40

anssi
Member
Registered: 2015-02-28
Posts: 2

Re: Macbook Pro Late 2013 Retina

How's the sound from the speakers for you guys? I'm aware that you can control the "Bass Speaker" (as named e.g. in alsamixer) separately to make the sound less tinny and trebly, but the speakers still sound much better when used under OS X. I mean, of course laptop speakers sound bad anyway, but there's still a very notable difference in performance between Arch and OS X.

Cheers,
anssi (I guess my old account got deleted due to inactivity big_smile)

Offline

#343 2015-03-04 05:51:19

trusktr
Banned
From: .earth
Registered: 2010-02-18
Posts: 907
Website

Re: Macbook Pro Late 2013 Retina

Hey guys, any success using a Thunderbolt storage drive? I've booted the live media on my MacBook, then I've put a second MacBook into Target Disk Mode. I don't see the drive anywhere in

/dev/disk/by-*

. For example, I was hoping to see "Macintosh HD" appear in

/dev/disk/by-label

.

Last edited by trusktr (2015-03-04 05:57:37)


joe@trusktr.io - joe at true skater dot io.

Offline

#344 2015-03-06 21:08:18

regulament
Member
Registered: 2014-02-15
Posts: 67

Re: Macbook Pro Late 2013 Retina

@anssi: speakers sound good for me. I actually like them more in Linux because they are a bit less, uhm, I think 'spacious' would describe it. That's the only( small) difference for me.

From 3.19( no idea if it's the kernels' fault or something else) I am experiencing some problems: the interrupts( discussed above), lower battery life( also reported by one other user in the MacBook Air thread. Anyone else experiencing this? I went from around 6 hours to 4 hours with the same usage) and systemctl-suspend not working at all, but pm-suspend works without any problems.

Unfortunately due to IRL work load, I haven't been able to look into any of the issues.

Offline

#345 2015-03-06 21:52:38

anssi
Member
Registered: 2015-02-28
Posts: 2

Re: Macbook Pro Late 2013 Retina

@regulament: Thanks for your answer mate! Sounds like we have the same "problem" then, only for you it's not a problem! smile The speakers don't sound that bad on linux, but IMO the "tone" the speakers have on OS X  just sound better. Also, I have a triple boot setup and the sound on windows is similar to linux. Your description about more "spacious" sound on OS X sounds accurate though! I'm just looking to find out if it's even possible to make the speakers sound similar like in OS X because that is a tone that I personally highly prefer!

Considering your issue, I personally haven't experienced that with an up-to-date system, but I'm using 3.18 kernel still. Are you using [testing] then? I've only disabled gpe4e and gpe66 and done nothing else to improve the battery life etc. I'm not using suspend since after waking up from it the number in /sys/class/power_supply/BAT0/current_now seems to increase and the battery drains itself faster after that.

Offline

#346 2015-03-07 09:23:05

regulament
Member
Registered: 2014-02-15
Posts: 67

Re: Macbook Pro Late 2013 Retina

I am not using testing. I'll look into the issues once I get some free time.

Offline

#347 2015-03-14 01:01:36

kyawaiiv
Member
Registered: 2014-08-11
Posts: 9
Website

Re: Macbook Pro Late 2013 Retina

Anyone else having an issue with the SD reader not being detected? If I boot normally, the hardware device isn't detected but everything works fine if I boot into the fallback initramfs. I'm suspecting that there was a change in default kernel modules within the past few months but I haven't been able to solve it.


Github -- Blog
Code is love, Code is life.

Offline

#348 2015-03-14 10:12:57

regulament
Member
Registered: 2014-02-15
Posts: 67

Re: Macbook Pro Late 2013 Retina

I never use my SD Card Reader, but I put a card in now and it wasn't mounted. Also, the device doesn't seem to be detected(nothing in dmesg output).

What's happening with Linux on this notebook? It worked pretty much great up until a month ago. Now ACPI interrupts( ok, that may be because of OS X), lower battery life and now no SD Card Reader.

Offline

#349 2015-03-24 17:40:57

dougphy
Member
From: Durham, NC
Registered: 2013-01-27
Posts: 7

Re: Macbook Pro Late 2013 Retina

My cores idle at about 70 to 80 C and fan isn't audible.  Any recommendations to bring these temps down?

Last edited by dougphy (2015-03-29 20:49:31)

Offline

#350 2015-03-30 22:00:12

hrod
Member
Registered: 2013-10-24
Posts: 57

Re: Macbook Pro Late 2013 Retina

dougphy wrote:

My cores idle at about 70 to 80 C and fan isn't audible.  Any recommendations to bring these temps down?

It shouldn't be getting that hot by itself, maybe applesmc is not loaded for you, or maybe you have set the fans to manual... See this post, specifically:

Yup applesmc is loaded. /sys/devices/platform/applesmc.768/fan1_manual was set to 1. I set this to "0", ran stress and got the same results as you. So looks like its being controlled by applesmc now.

(Remember if you have the 15", it has two fans tongue)

When I have it on my lap I like to boost the min fan speed (without changing the whole profile to manual) so it's a bit cooler:

echo 3500 | sudo tee /sys/devices/platform/applesmc.768/fan1_min
echo 3500 | sudo tee /sys/devices/platform/applesmc.768/fan2_min

Last edited by hrod (2015-04-16 02:39:07)

Offline

Board footer

Powered by FluxBB