You are not logged in.

#26 2014-03-12 05:53:06

Ville
Member
From: Espoo, Finland
Registered: 2014-02-03
Posts: 13

Re: Wine and PulseAudio 5.0

Have to go and read what good and new features this 5.0 version of pulseaudio brought. Since atleast for me it has been nothing but trouble.

Offline

#27 2014-03-17 16:44:16

Ville
Member
From: Espoo, Finland
Registered: 2014-02-03
Posts: 13

Re: Wine and PulseAudio 5.0

/etc/pulse/daemon.conf
default-fragment-size-msec = 5


settings this setting to 5 finally solved my sound problems with pulseaudio 5.0 and wine.

works with diablo 3, world of warcraft and starcraft 2 big_smile

Last edited by Ville (2014-03-27 06:55:45)

Offline

#28 2014-03-17 17:00:25

Daerandin
Member
From: Norway
Registered: 2013-05-07
Posts: 149

Re: Wine and PulseAudio 5.0

Thanks a lot! This actually fix the problems I had with getting Timidity to output sound to my headset. Munt also work correctly with my headset now.

The only problem remaining is PlayOnLinux, which still crashes upon launching, unless I first set .asoundrc to let Alsa bypass Pulseaudio, instead of being handled by Pulseaudio.

Offline

#29 2014-03-17 20:51:51

V1del
Member
Registered: 2012-10-16
Posts: 1,253

Re: Wine and PulseAudio 5.0

Because of http://www.playonlinux.com/en/commentaires-1213.html I took some more interest into this. Turns out this issue only happens if you run your wine using a 32bit build, if you explicitly use an amd64 build it works just fine, there are probably some slight librarypath mismatches when using a pure 32bit build as opposed to a multilib'd amd64 build

TL:DR use amd64 variants of your respective wine versions

Sidenote: A shot in the dark, but your pulse-alsa problems and fix sound awfully like you're using tsched=0, is that the case?

Last edited by V1del (2014-03-17 20:53:56)

Offline

#30 2014-03-17 21:07:43

Daerandin
Member
From: Norway
Registered: 2013-05-07
Posts: 149

Re: Wine and PulseAudio 5.0

Did a quick test and it does appear that using 64-bit wine versions in PlayOnLinux works. I install some games during this week and give it a try. Thanks for the tip.

As for my other issues, I am not using tsched=0

Offline

#31 2014-03-19 14:50:24

LucetLux
Member
Registered: 2013-08-16
Posts: 131

Re: Wine and PulseAudio 5.0

Downgrading pulseaudio libpulse and lib32-libpulse to 4.06 isn't fixing PoL for me, I still get errors when I try to use a non-system wine version.
BTW, is there a way to switch a PoL wineprefix to 64-bit without having to create a new one ?

Offline

#32 2014-03-19 15:44:53

Daerandin
Member
From: Norway
Registered: 2013-05-07
Posts: 149

Re: Wine and PulseAudio 5.0

LucetLux, did you restart pulseaudio after downgrading?

Offline

#33 2014-03-19 15:45:46

Ville
Member
From: Espoo, Finland
Registered: 2014-02-03
Posts: 13

Re: Wine and PulseAudio 5.0

Is there a 64bit wine available on official repos?

Offline

#34 2014-03-19 15:53:22

V1del
Member
Registered: 2012-10-16
Posts: 1,253

Re: Wine and PulseAudio 5.0

It's the standard one in multilib and it never had this issue. The issue you had is different from this and I told you how to fix it here https://bbs.archlinux.org/viewtopic.php … 7#p1390477

Last edited by V1del (2014-03-19 15:56:50)

Offline

#35 2014-03-19 15:55:28

Daerandin
Member
From: Norway
Registered: 2013-05-07
Posts: 149

Re: Wine and PulseAudio 5.0

It might be more appropriate if this topic changed name to "PlayOnLinux and PulseAudio 5.0" as this problem is only present with PlayOnLinux, and not wine in repos.

Offline

#36 2014-03-19 22:53:44

LucetLux
Member
Registered: 2013-08-16
Posts: 131

Re: Wine and PulseAudio 5.0

Daerandin wrote:

LucetLux, did you restart pulseaudio after downgrading?

Yes, I even rebooted, it still doesn't work.

Offline

#37 2014-03-25 08:29:30

logge
Member
Registered: 2014-03-25
Posts: 1

Re: Wine and PulseAudio 5.0

The workaround that worked for me is z1lt0id #6: using "system" wine, and ville: #27 adjusting default-fragment-size to 5msec in pulseaudio.conf (and restart pulse)

Just using "system" wine gave me too fast playing sound and very crackling music in GSTD

Offline

#38 2014-03-25 15:49:48

fettouhi
Member
Registered: 2007-05-07
Posts: 657

Re: Wine and PulseAudio 5.0

Not to highjack this thread but in my case with wine I'm trying to run Diablo 3 with wine 1.7.14 in a 32 bit prefix and the sound is crackly and speed in game and cinematics are also sped up. Using pulseaudio 5.0 with KDE 4.12.3.

Offline

#39 2014-03-26 03:42:33

LucetLux
Member
Registered: 2013-08-16
Posts: 131

Re: Wine and PulseAudio 5.0

fettouhi wrote:

Not to highjack this thread but in my case with wine I'm trying to run Diablo 3 with wine 1.7.14 in a 32 bit prefix and the sound is crackly and speed in game and cinematics are also sped up. Using pulseaudio 5.0 with KDE 4.12.3.

I don't know if it'll help, but I have similar problems with many games, it only happens with the more recent wine versions, eg, in wine 1.7.0 it is just fine, it's usually games which use xaudio, like with skullgirls I need to do winetricks xact to get audio, then it'll run too fast and after that for the sound to run properly I also need to override dsound, that in 1.7.0, in 1.7.14 the audio gets choppy.

It would seem like Diablo III is on the platinum list at wine hq, so I don't think the dll overrides would help, you could give it a try anyway, also you can check this out http://appdb.winehq.org/objectManager.p … &iId=28849, it might help you, in order to run games with older wine versions I use playonlinux which is currently broken by pulse, hence this thread, but you can also build it on your own if you don't want to downgrade pulse in order for pol to work ---> BTW, that didn't work for me. <--- as it has been said here 32bit prefixes should work, but I have no way to try that right now anyway, as I'm using fglrx at the moment and most wine stuff won't run with it.

Good luck with that.

Last edited by LucetLux (2014-03-26 03:44:49)

Offline

#40 2014-03-26 08:08:15

fettouhi
Member
Registered: 2007-05-07
Posts: 657

Re: Wine and PulseAudio 5.0

LucetLux wrote:
fettouhi wrote:

Not to highjack this thread but in my case with wine I'm trying to run Diablo 3 with wine 1.7.14 in a 32 bit prefix and the sound is crackly and speed in game and cinematics are also sped up. Using pulseaudio 5.0 with KDE 4.12.3.

I don't know if it'll help, but I have similar problems with many games, it only happens with the more recent wine versions, eg, in wine 1.7.0 it is just fine, it's usually games which use xaudio, like with skullgirls I need to do winetricks xact to get audio, then it'll run too fast and after that for the sound to run properly I also need to override dsound, that in 1.7.0, in 1.7.14 the audio gets choppy.

It would seem like Diablo III is on the platinum list at wine hq, so I don't think the dll overrides would help, you could give it a try anyway, also you can check this out http://appdb.winehq.org/objectManager.p … &iId=28849, it might help you, in order to run games with older wine versions I use playonlinux which is currently broken by pulse, hence this thread, but you can also build it on your own if you don't want to downgrade pulse in order for pol to work ---> BTW, that didn't work for me. <--- as it has been said here 32bit prefixes should work, but I have no way to try that right now anyway, as I'm using fglrx at the moment and most wine stuff won't run with it.

Good luck with that.

Thanks for the suggestion I got it fixed. It was pulseaudio I had to edit daemon.conf with this option turned on now

default-fragment-size = 5

Offline

#41 2014-04-05 05:15:05

benjamin
Member
Registered: 2013-10-15
Posts: 13

Re: Wine and PulseAudio 5.0

Thanks guys, setting the default-fragment-size = 5 worked for me too.

Offline

#42 2014-04-05 11:49:53

Phreakazoid
Member
Registered: 2009-03-07
Posts: 8

Re: Wine and PulseAudio 5.0

Daerandin wrote:

It might be more appropriate if this topic changed name to "PlayOnLinux and PulseAudio 5.0" as this problem is only present with PlayOnLinux, and not wine in repos.

I had the exact same issue with stock wine in the repositories, and the exact same fix worked.

Offline

#43 2014-04-12 18:44:18

gsilvers
Member
Registered: 2013-06-22
Posts: 11

Re: Wine and PulseAudio 5.0

Daerandin wrote:

This really is just a dirty fix to get PlayOnLinux working, and you should not keep using this config for other purposes. I was thinking to set up a quick script that will allow me to toggle between default settings and these modifications for using PoL. Note that these settings prevent Pulseaudio from using the same audio device. It will show up in pavucontrol, but it will not be able to play any sounds while it is in use by an application that use Alsa.

Hey Daerandin,

This fix worked perfectly for me and my single wine application ( a game ofc). I'm fine with no sound from another application while wine is locking the alsa output to my USB speakers but you mentioned turning this setting on and off. What executable/command loads/unloads .asoundrc.

I am going to write these scripts but to be honest this is my first foray into fighting with Alsa/Pulse my knowledge here is a bit lacking.

Offline

#44 2014-04-12 19:23:30

Daerandin
Member
From: Norway
Registered: 2013-05-07
Posts: 149

Re: Wine and PulseAudio 5.0

The simplest way to do this could be to create the .asoundrc file in your home folder, but you could name it something like .asoundrc.bak so it is not used normally.

One method would be with the use of a very simple bash script

#! /bin/bash
# This script was written for the purpose of being able to start PoL applications with PulseAudio 5.0
FILE=/home/username/.asoundrc
TEMP_FILE=/home/username/.asoundrc.bak

if [ -f $FILE ];
then
    mv $FILE $TEMP_FILE
else
    mv $TEMP_FILE $FILE
fi

Then you could set an alias to run this script.

Another method would be to edit the PlayOnLinux shortcut for all games. Since I discovered that using 64-bit win in PoL also solves the issue, I have simply reinstalled most games in 64-bit virtual drives. However, I have encountered a couple of games where this turned out to be problematic. For those cases I simply edited the shortcut found in ~/.PlayOnLinux/shortcuts

I added the line

mv /home/username/.asoundrc.bak /home/username/.asoundrc

Before wine is started, and I did the reverse as the last line of the shortcut script. You may want to make sure that the executable initially launched by the shortcut does not close before the game starts running. Certain games, like StarCraft 2 use a seperate game launcher/updater. Those cases are a bit more complicated and you should instead create a little loop in the script until wineserver has closed before reverting the change.

Edit: I fixed one little oversightt I did in the final code line above, I had forgotten the destination for the mv command.

Last edited by Daerandin (2014-04-13 08:23:49)

Offline

#45 2014-04-13 03:24:07

gsilvers
Member
Registered: 2013-06-22
Posts: 11

Re: Wine and PulseAudio 5.0

Excellent, so basically this file gets looked at as ALSA is called. So if I just have the right file in place when I run the game through wine and then swap it back afterwards I should be in business.

Thanks Daerandin, while i think we can all agree that wine and pulse playing nice would be best, this is a good fix. I swap between Gnome shell and I3 so removing pulse is a no go.

Thanks again!

Offline

#46 2014-04-13 14:24:41

V1del
Member
Registered: 2012-10-16
Posts: 1,253

Re: Wine and PulseAudio 5.0

If it's just wine, couldn't you simply set it within the winecfg to use the USB card, without having to fiddle with loading/unloading different asound.confs? Didn't check as I never had issues you are describing, but in theory this should have the same effect

Offline

#47 2014-04-13 14:45:36

Daerandin
Member
From: Norway
Registered: 2013-05-07
Posts: 149

Re: Wine and PulseAudio 5.0

V1del wrote:

If it's just wine, couldn't you simply set it within the winecfg to use the USB card, without having to fiddle with loading/unloading different asound.confs? Didn't check as I never had issues you are describing, but in theory this should have the same effect

Unfortunately this does not seem to make any difference with PlayOnLinux. I gave it a try with one of my virtual drives, but it still crashes unless I use my .asoundrc workaround.

Offline

#48 2014-04-13 15:07:50

V1del
Member
Registered: 2012-10-16
Posts: 1,253

Re: Wine and PulseAudio 5.0

Hmm that sucks hmm

Would be cool if PoL allowed to install the 64bit variant regardless of what the script says which almost always defaults to 32bit... Still very strange that this leads to a crash, PA lowered the ALSA requirements and it works for every other case except for this one, it's seriously weird (especially as there is no real difference afaik, 64bit wine still uses the lib32 versions of programs)

Offline

#49 2014-04-13 15:17:17

Daerandin
Member
From: Norway
Registered: 2013-05-07
Posts: 149

Re: Wine and PulseAudio 5.0

In my case it is not that much of a problem, I use custom installs for the most part anyway.

But it is as you say a bit odd. I did have problems with two other programs too, Timidity as well as Munt from AUR. The odd thing with those was that they only had problems if I used my USB headset. Without the headset things worked as it should. Thankfully that could be solved by setting default-fragment-size = 5 in daemon.conf

When next PA updates, I will try it out without any of these workarounds to see if anything has changed.

At least we've found functioning workarounds.

Offline

#50 2014-04-22 10:52:57

ceri
Member
Registered: 2013-10-12
Posts: 50

Re: Wine and PulseAudio 5.0

Is anybody actually working on this? As far as I can tell, there isn't.

Arch bug tracker - No recent work indicated
PlayOnLinux tracker - no bug filled. I doubt they would help considering they hate pulse
PulseAudio tracker - no bug filled. Would they even help considering this is probably a PoL issue?

All the workarounds are crap besides downgrading, but it's almost not worth the hassle.

Offline

Board footer

Powered by FluxBB