You are not logged in.

#1 2014-03-05 18:18:53

Amanda S
Member
Registered: 2013-09-21
Posts: 276
Website

A start job is running for dev-mapper-home

Hello.

Today I re-installed Arch on my machine, using the same procedure as always. When rebooted, the following message appears:

A start job is running for dev-mapper-home (1s / no limit)

It doesn't prevent me from booting and log in, but it never happened before. I read many people having this problem and also having problems to boot.

I'm using syslinux with dm-crypt. My partition scheme is:

/dev/sda1 for /boot
/dev/sda2 for /dev/mapper/root
/dev/sda3 for /dev/mapper/swap
/dev/sda4 for /dev/mapper/home

What changes from the default install procedure:

# modprobe dm-crypt
# cryptsetup -c twofish-xts-plain64 -y -s 512 --iter-time 3500 luksFormat /dev/sdaX
# cryptsetup open --type luks /dev/sdaX group_name
# genfstab -L -p /mnt >> /mnt/etc/fstab

fstab

# 
# /etc/fstab: static file system information
#
# <file system>	<dir>	<type>	<options>	<dump>	<pass>
# /dev/mapper/root UUID=92550d7e-6e23-4d6d-9b4a-a5ed30f36705
/dev/mapper/root    	/         	ext4      	rw,relatime,data=ordered	0 1

# /dev/sda1 UUID=6b1bd500-1890-4045-af80-8cc2b9f3dc24
/dev/sda1           	/boot     	ext4      	rw,relatime,data=ordered	0 2

# /dev/mapper/home UUID=e14e8e6b-0cb6-44e1-af34-e3ef2083afce
/dev/mapper/home    	/home     	ext4      	rw,relatime,data=ordered	0 2

# /dev/mapper/swap UUID=e1ac70f1-0e39-4938-a8fa-0f4732d07911
/dev/mapper/swap    	swap      	swap      	defaults  	0 0

tmpfs   /tmp    tmpfs   nodev,nosuid,size=15G     0  0

crypttab

home         /dev/sda4 none       luks
swap         /dev/sda3 none       luks

syslinux.cfg

LABEL arch
    MENU LABEL Arch Linux
    LINUX ../vmlinuz-linux
    APPEND root=/dev/mapper/root cryptdevice=/dev/sda2:root rw
    INITRD ../initramfs-linux.img

mkinitcpio.conf

MODULES="dm_mod ext4"
HOOKS="base udev autodetect modconf block keymap encrypt filesystems keyboard fsck"

Any help is appreciated.


If it ain't broke, you haven't tweaked it enough...

Offline

#2 2014-03-05 19:38:58

dennis123123
Member
Registered: 2009-07-02
Posts: 72

Re: A start job is running for dev-mapper-home

Same here, it shows that instead of "Enter password for blah blah...." prompt

Since yesterday's updates (possibly including cryptsetup, can't really remember to be honest!)

Offline

#3 2014-03-05 19:43:59

Amanda S
Member
Registered: 2013-09-21
Posts: 276
Website

Re: A start job is running for dev-mapper-home

For how long have you been using Arch? Has this ever happened before?

Also, could you post the contents of the files I posted here?

Last edited by Amanda S (2014-03-05 19:46:53)


If it ain't broke, you haven't tweaked it enough...

Offline

#4 2014-03-06 17:41:42

dennis123123
Member
Registered: 2009-07-02
Posts: 72

Re: A start job is running for dev-mapper-home

For around 4 years perhaps? I was on debian before that. Presume you're asking about this specific installation though, which has been since I got my new laptop around a month ago. Clean install on a brand new drive.

It has never happened before. Before evil systemd took over and I was on initscripts, I would mount using rc.local. Since that changeover however, it has just worked fine using /etc/crypttab. Never had this issue before. Only since the updates 2 days ago.
It boots fine (even mounts the encrypted /home directory) if I blindly type my passphrase and hit enter. It is purely a visual problem of it showing the wrong message instead of the "enter password" prompt.

As requested... (UUID removed, and home dir name changed for privacy reasons.)

/etc/fstab

# 
# /etc/fstab: static file system information
#
# <file system>	<dir>	<type>	<options>	<dump>	<pass>
/dev/sda2           	/         	ext3      	rw,noatime,data=ordered	0 1
/dev/mapper/secret	/home/secret	ext3		rw,noatime 0 0

/etc/crypttab

secret /dev/sda3 none

/etc/mkinitcpio.conf

MODULES=""
HOOKS="base udev autodetect modconf block filesystems keyboard fsck"

Last edited by dennis123123 (2014-03-06 17:45:45)

Offline

#5 2014-03-08 17:12:49

dennis123123
Member
Registered: 2009-07-02
Posts: 72

Re: A start job is running for dev-mapper-home

Still broken after today's systemd and kernel upgrade.

Offline

#6 2014-03-08 21:14:40

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: A start job is running for dev-mapper-home

What happens when you add "quiet" to your kernel options? It waits with a blank line, i.e. without the prompt?

Offline

#7 2014-03-12 19:13:30

dennis123123
Member
Registered: 2009-07-02
Posts: 72

Re: A start job is running for dev-mapper-home

I already have "quiet" on my kernel options, still happenning, system fully up-to-date as of right now.

Offline

#8 2014-03-15 10:03:05

~lynks
Member
Registered: 2013-10-14
Posts: 14

Re: A start job is running for dev-mapper-home

Just noting that I also have this same issue. Good to see others have it too - I was worried I was seeing an artefact of someone pwning my password prompt.

Offline

#9 2014-03-18 22:57:42

Amanda S
Member
Registered: 2013-09-21
Posts: 276
Website

Re: A start job is running for dev-mapper-home

But all of us can boot, right?


If it ain't broke, you haven't tweaked it enough...

Offline

#10 2014-03-20 17:31:45

dennis123123
Member
Registered: 2009-07-02
Posts: 72

Re: A start job is running for dev-mapper-home

Yep, still happens every time, but blindly typing password while it "does its thing" and it lets me in

Offline

#11 2014-03-21 10:17:18

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,137
Website

Re: A start job is running for dev-mapper-home

Offline

#12 2014-03-31 20:45:53

XazZ
Member
From: Munich, Germany
Registered: 2006-12-30
Posts: 72

Re: A start job is running for dev-mapper-home

Seems to be working again.
It looks like the systemd 212 update fixed it.

Can anyone confirm this?

Offline

#13 2014-03-31 21:53:54

dennis123123
Member
Registered: 2009-07-02
Posts: 72

Re: A start job is running for dev-mapper-home

Nope, still doing it today on a fully updated system

Offline

#14 2014-04-01 09:26:38

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,137
Website

Re: A start job is running for dev-mapper-home

XazZ wrote:

Seems to be working again.
It looks like the systemd 212 update fixed it.
Can anyone confirm this?

For me the issue still remains.

Offline

#15 2014-04-01 15:12:56

Amanda S
Member
Registered: 2013-09-21
Posts: 276
Website

Re: A start job is running for dev-mapper-home

I installed Arch with LVM (much better than separate encrypted partitions) and it's no longer present for me. What ISO are you guys using? I'm using the 3.1.2014 version.


If it ain't broke, you haven't tweaked it enough...

Offline

#16 2014-04-01 16:18:40

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,137
Website

Re: A start job is running for dev-mapper-home

Amarildo wrote:

I installed Arch with LVM (much better than separate encrypted partitions) and it's no longer present for me.

I assume that you have only one encrypted partition with LVM on it. That means not systemd, but the initramfs unlocks your encrypted partition. This bug is about systemd, not the initramfs.

What ISO are you guys using? I'm using the 3.1.2014 version.

The arch ISO version does not matter, the package versions do.

Offline

#17 2014-04-01 17:15:18

dennis123123
Member
Registered: 2009-07-02
Posts: 72

Re: A start job is running for dev-mapper-home

I don't use LVM or anything complicated. I have an unencrypted root partition, an encrypted /home/myusername partition (in /etc/crypttab), and a Windows 7 partition. Using plain old GRUB2 and MBR.

Still getting the message spamming up today as well. (I update daily)

Offline

#18 2014-04-04 19:14:47

Amanda S
Member
Registered: 2013-09-21
Posts: 276
Website

Re: A start job is running for dev-mapper-home

teateawhy wrote:
Amarildo wrote:

I installed Arch with LVM (much better than separate encrypted partitions) and it's no longer present for me.

I assume that you have only one encrypted partition with LVM on it. That means not systemd, but the initramfs unlocks your encrypted partition. This bug is about systemd, not the initramfs.

What ISO are you guys using? I'm using the 3.1.2014 version.

The arch ISO version does not matter, the package versions do.

I guess you're right. I don't use separate encrypted partitions anymore since it doesn't make a lick of sense. It's much easier to just use a big encrypted LVM IMO.

dennis123123 wrote:

I don't use LVM or anything complicated.

How come you find LVM more complicated than separate partitions? It's much less complicates, specially to me who use a 64 random-character passphrase, I just type it once.

Last edited by Amanda S (2014-04-04 19:15:45)


If it ain't broke, you haven't tweaked it enough...

Offline

#19 2014-04-10 17:16:21

dennis123123
Member
Registered: 2009-07-02
Posts: 72

Re: A start job is running for dev-mapper-home

OK brand new kernel, brand new systemd, all kinds of new stuff today.... and it STILL does this! What's going on? How come more people aren't having this issue?

Offline

#20 2014-04-10 18:49:01

penguin
Member
From: Gotham City
Registered: 2010-12-31
Posts: 142

Re: A start job is running for dev-mapper-home

I have the same issue.

I just did a my first encryption (just for /home). I thought not using LVM would be "one thing less" to install/maintain/worry about/overhead/thing that can go wrong.

Now I'm not sure if I should redo the formatting/encryption of the drive.

Offline

#21 2014-04-10 18:52:31

dennis123123
Member
Registered: 2009-07-02
Posts: 72

Re: A start job is running for dev-mapper-home

penguin wrote:

I have the same issue.

I just did a my first encryption (just for /home). I thought not using LVM would be "one thing less" to install/maintain/worry about/overhead/thing that can go wrong.

Now I'm not sure if I should redo the formatting/encryption of the drive.

Don't go for one of the "workarounds"! The less people that complain, the less likely they'll actually fix this any time soon.

The other bloated workaround is apparently to install some GUI boot thing taken from Fedora, packaged in the AUR.

Bring back initscripts sad

Offline

#22 2014-04-10 20:15:43

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: A start job is running for dev-mapper-home

dennis123123 wrote:

Don't go for one of the "workarounds"! The less people that complain, the less likely they'll actually fix this any time soon.

Imho you should cross-check your attitude, dennis123123.

Anyhow, I looked up the relevant bug report upstream and in https://bugs.freedesktop.org/show_bug.cgi?id=73942#c2
it is mentioned that for now a work-around may be to add "systemd.show_status=0" to mute output.

Offline

#23 2014-04-10 20:18:48

dennis123123
Member
Registered: 2009-07-02
Posts: 72

Re: A start job is running for dev-mapper-home

It wasn't meant as an "attitude" thing - surely it's just a fact? yikes

for example, fslint package in AUR. I guess not many people use it, the current version doesn't work, and me and 1 other have just manually downloaded the previous version as a "workaround".
If 10000 people used that package, it would be no doubt resolved in a matter of hours.

Offline

Board footer

Powered by FluxBB