You are not logged in.

#126 2006-01-21 12:53:42

potentials
Member
Registered: 2004-01-04
Posts: 130

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

dibblethewrecker wrote:

There will be a new initscripts-gensplash pkg out today which is updated to the latest initscripts

Yaba Daba Doo!

Offline

#127 2006-01-21 15:52:52

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,640

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

Somewhere I've read that one day the archck kernel may will become a maintained package in extra. Maybe as a replacement for kernel-ck. Any news about that?

Offline

#128 2006-01-21 17:48:27

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

Iphitus;

In past year, the order in which the snd-usb-audio was entered in modules determined whether it responded and established kde mixer option. The arch boot has it entered such as to provide correct response thru kde.

Assuming, assuming...archck sets up the same arrangement and has the same kde, it should be properly connected with correct driver.  In fact, kde mixer has the usb option appearing.

In arch, USB audio is initiated automatically during kde start-up.

The cmipci mixer option rules in archck.  Selection of USB mixer is ineffective and it isn't activated during kde startup.

Perhaps...the order of module loading in archck is different?

Archck is doing well otherwise

8)

Thanks for the kernel, mate!


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#129 2006-01-21 19:56:32

wt
Member
From: Poland
Registered: 2006-01-17
Posts: 14

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

hello,
i cannot make the "silent" mode working. "verbose" is ok, I have a background for # and everything is fine.

# (2) Arch Linux Archck Kernel
title Arch Linux Archck Kernel
kernel /boot/vmlinuz26archck root=/dev/hda6 ro video=vesafb:ywrap,mttr,1024x768-32@70 splash=silent,theme:darch
initrd /boot/initramfs-2.6.15-archck.img

if I start like that, the splash screen comes up with logo, progress bar and "initalizing kernel", and then a black screen.

Offline

#130 2006-01-21 23:57:27

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

wt wrote:
kernel /boot/vmlinuz26archck root=/dev/hda6 ro video=vesafb:ywrap,mttr,1024x768-32@70 splash=silent,theme:darch
wiki grub sample* wrote:
kernel /boot/vmlinuz26archck root=/dev/hda6 ro video=vesafb:ywrap,mtrr,1024x768-32@70 splash=silent,theme:darch console=tty1 quiet

Spot the difference .... smile

* N.B. The actual wiki grub sample uses devfs naming - the quote above has been amended to highlight the comparison with wt's version.

Offline

#131 2006-01-22 00:42:03

wt
Member
From: Poland
Registered: 2006-01-17
Posts: 14

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

didn't change anything... still is crashing after "initializing kernel"...

edit: well, it's not crashing smile, I have to press alt+1 to go to vc1, and then it works. Could it be done automatically?

Offline

#132 2006-01-22 01:31:38

kozaki
Member
From: London >. < Paris
Registered: 2005-06-13
Posts: 652
Website

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

mpie wrote:

what's in your bootloader config?
Have you updated you  rc.conf..... it relies on the new one , if you try with the old rc.conf it will not work

Pliz what do you mean ?
I for exemple have added gensplash to the Dameons () line, and that's all I've done.

BTW i've followed wiki & _gandalf exemple on my Dell Latitude 400 (ati 4mb) & boot is pretty now wink still, how comes it won't show any line nor prompt as soon as started to boot ?
I have to log in & startx blindly to have some usable I/O device (i.e. the screen wink )


Seeded this month: Arch 80 gig (and Talking~ 2, ~-anywhere 46, Apricity 16)
Desktop @3.3GHz 8 gig RAM, linux-ck
laptop1 Atom 2 gig RAM, Arch linux stock i686 (6H w/ 6yrs old battery smile) & 2: ARM Tegra K1, 4 gig RAM, ChrOS
Atom Z520 2 gig RAM, OMV (Debian 7) kernel 3.16 bpo on SDHC | PGP Key: 0xFF0157D9

Offline

#133 2006-01-22 09:52:57

wt
Member
From: Poland
Registered: 2006-01-17
Posts: 14

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

kozaki wrote:

BTW i've followed wiki & _gandalf exemple on my Dell Latitude 400 (ati 4mb) & boot is pretty now wink still, how comes it won't show any line nor prompt as soon as started to boot ?
I have to log in & startx blindly to have some usable I/O device (i.e. the screen wink )

isn't it the same as i said above? there is a blank screen after splash, and the progress bar doesn't make any 'progress' wink

Offline

#134 2006-01-22 10:09:27

mpie
Member
From: 404 Not found
Registered: 2005-03-06
Posts: 649

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

do you have initscripts-gensplash installed or silent wont work..

Offline

#135 2006-01-22 11:09:13

wt
Member
From: Poland
Registered: 2006-01-17
Posts: 14

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

i completely forgot about it, thx, now it works...  :oops:

Offline

#136 2006-01-22 14:54:18

MartinZ
Member
From: Chiloé, Chile
Registered: 2005-06-10
Posts: 378

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

I guess I've followed every single wiki i've found, but still can't get any splash when booting. I tryed with both grub and lilo and i also installed initscripts-gensplash.
Actually i use a graphical lilo (it works like a charm!!), but after that i get the error message saying

You have passed an undefined mode number

then some random text and display freezes. X is loaded well, but every console stay with that text. I never get the image from fbsplash, wherever i try silent or verbose mode.

/var/log/errors.log gives me this

Jan 22 02:18:57 myhost vesafb: mode switch failed (eax: 0x14f)
Jan 22 02:18:59 myhost dhcpcd[3526]: terminating on signal 15
Jan 22 11:31:05 myhost vesafb: mode switch failed (eax: 0x14f)

This is my actual /etc/lilo.conf, but i modified it many many times (i used grub before with same results). This is what i got from a gentoo wiki, a little different of seen in arch's wiki.

image=/boot/vmlinuz26archck
        label=Arch
        root=/dev/hda2
    append="video=vesafb:1024x768-16@60,mtrr,ywrap splash=silent,fadein,theme:darch quiet CONSOLE=tty1"
        read-only
    initrd=/boot/initramfs-2.6.15-archck.img

I don't know if /etc/mkinitramfs.conf or /etc/rc.conf may be usefull to post.

This is what hwd says about my video card (just an integrated one)

VGA compatible controller
  vesa            : S3 Inc.|VT8751 [ProSavageDDR P4M266] VGA Controller

However, i use savage driver instead of vesa with xorg.

I would really appreciate some help to get this fully working. I really like kernel-archck and will switch to reiser4 soon, but this fbsplash just gave headache.

I forgot to say that i have this whole stuff (archck kernel and fbsplash) working in other computer for a week or so and i guess i did same on both of them.  (???)


All your base are belong to us

Offline

#137 2006-01-22 18:19:54

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,751

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

Woaahhh!!!! out of the mists a logo appears ;-)


Mr Green

Offline

#138 2006-01-22 23:44:52

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

Yuh, you should get that logo if you dont use fbsplash. Though for some reason its appearing twice here, and I suspect it is causing probs with fbsplash sad

Offline

#139 2006-01-23 02:23:24

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

iphitus wrote:

Yuh, you should get that logo if you dont use fbsplash. Though for some reason its appearing twice here, and I suspect it is causing probs with fbsplash sad

iph, two logos appear because you have dual processors.

Offline

#140 2006-01-23 04:59:12

_Gandalf_
Member
Registered: 2006-01-12
Posts: 735

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

I passed to Testing release (to be with Xorg 7) but there's something weird with kernel26archck and IPW2200

using kernel26archck i didn't have wireless connection then

[wael@nasreddine pkg]$ sudo /etc/rc.d/network restart
:: Stopping Network                                                                                                                  [DONE]
:: Starting Network                                                      [BUSY] Error for wireless request "Set ESSID" (8B1A) :
    SET failed on device eth1 ; Invalid argument.

but using kernel26arch i do have internet, they are both IPW2200 V.1.0.8 i tried 1.0.10 (which i was running it on archck b4 updating the system) and it didn't work neither, what could be the problem?
thx

Offline

#141 2006-01-23 15:18:44

RobbeR49
Member
From: Columbus, OH
Registered: 2006-01-17
Posts: 178

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

After a little effort, I finally got silent splash working. The only problem is it doesn't work consistently. Half of the time it works, the other half of the time a black screen comes up and I get nothing. As far as I can tell I have everything configured correctly, and the fact that it sometimes works seems to confirm this. I have seen that a few others have gotten this black screen but has anyone else seen splash work intermittently?

Offline

#142 2006-01-23 15:26:53

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

Gandalf: Use the ipw2200 drivers that come with archck, not a seperate package.

RobbeR49: please tell us what you have done to try and make it work, so that I can investigate further.

Cerebral, i never knew that, lol. I thought it was a wierd bug of some sort.

Offline

#143 2006-01-23 16:22:19

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,436
Website

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

99% of people who have problems with fbsplash/gensplash have misconfigured settings - see the gensplash thread for a good "expansion" of the usual problems smile

I think I should also stress that we are now working in a broader initramfs env than before so more problems may have been inherited.  I'm just hoping to make sure we all have the basics right.  Though the post below would seem to suggest an "issue" big_smile

Offline

#144 2006-01-23 16:24:00

RobbeR49
Member
From: Columbus, OH
Registered: 2006-01-17
Posts: 178

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

I have the newest archck (2.6.15.archck2-4). mkinitramfs, gensplashutils, and initscripts-gensplash.

initscripts-gensplash did overwrite my rc.conf, I took the rc.conf.pacsave and  manually added the verboseonfail section for gensplash, also gensplash was added to daemons list.

nothing special in my grub config:

video=vesafb:ywrap,mtrr,1024x768-32@70 splash=silent,theme:darch console=tty1 quiet
initrd /boot/initramfs-2.6.15-archck.img

I looked in mkinitramfs.conf, everything looked ok
and I ran:

mkinitramfs kernel_version=2.6.15-archck

and as far as I can remember, that was it. It worked well the first few times, then stopped working and I got a black screen, then it worked a few more times after not applying any changes to it. I have also had problems getting a black screen on rebooting as well, only in archck and also really without any rhyme or reason, although it seems to happen more when I am in X than when I type reboot in a VC.

Offline

#145 2006-01-23 18:34:16

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

Just a heads up from the ML:

ALL 2.6.15-ck1 and 2.6.15-ck2 users, a mismerge bug causing serious
degradation to performance was noted by Bren (thanks!) on the mailing list.

I recommend everyone upgrade with the patch here:

http://ck.kolivas.org/patches/2.6/2.6.1 … prio.patch

which is referred to as hotfix on my http://kernel.kolivas.org homepage

Sorry about any inconvenience. This will be rolled into a ck3 in the future.

Cheers,
Con

I assume this effects archck as well, since it uses the ck patchset.

Offline

#146 2006-01-23 20:58:57

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

I recommend everyone upgrade with the patch here:

http://ck.kolivas.org/patches/2.6/2.6.1 … prio.patch

Well, I've applied it and rebuilt, and I'd love to say it makes a noticeable difference, but it doesn't - maybe you need to be iphitus to see it.  tongue

Offline

#147 2006-01-23 21:58:22

citral
Member
Registered: 2005-05-07
Posts: 87

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

Is anyone else having instability with the latest archck and ati-drivers? Perhaps the ati-drivers are just too much out of date, but I constantly get:

Jan 23 22:42:26 electra ------------[ cut here ]------------
Jan 23 22:42:26 electra kernel BUG at mm/swap.c:49!
Jan 23 22:42:26 electra invalid operand: 0000 [#1]
Jan 23 22:42:26 electra PREEMPT SMP 
Jan 23 22:42:26 electra Modules linked in: ipw2200 ieee80211 ieee80211_crypt eeprom i2c_isa i2c_dev usblp idmouse fglrx agpgart usb_storage usbhid i2c_i801 i2c_core yenta_socket rsrc_nonstatic pcmcia_core snd_intel8x0 snd_ac97_codec snd_ac97_bus snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_page_alloc snd soundcore cpufreq_userspace cpufreq_powersave cpufreq_ondemand speedstep_centrino freq_table r8169 hci_usb bluetooth uhci_hcd ehci_hcd usbcore nls_cp437 vfat fat evdev xfs reiserfs jfs ext3 jbd sata_vsc sata_uli sata_via sata_sx4 sata_svw sata_sis sata_sil24 sata_qstor sata_promise sata_sil sata_nv sata_mv mptspi mptsas mptfc mptscsih mptctl mptbase tmscsim sym53c8xx st sg sr_mod scsi_transport_sas raid_class qlogicfas408 qla6312 qla2322 qla2300 qla2200 qla2100 qla2xxx pdc_adma qla1280 osst nsp32 megaraid_sas megaraid_mbox megaraid_mm lpfc iscsi_tcp scsi_transport_iscsi ipr imm parport dmx3191d dc395x atp870u ata_piix aic7xxx aic79xx ahci libata aha152x aacraid a100u2w BusLogic 3w_xxxx 3w_9xxx sd_mod ide_floppy ide_cd cdrom ide_disk via82cxxx trm290 triflex slc90e66 sis5513 siimage serverworks sc1200 rz1000 piix pdc202xx_old pdc202xx_new ns87415 it821x hpt366 hpt34x generic cy82c693 cs5535 cs5530 cmd64x atiixp amd74xx alim15x3 aec62xx ide_core
Jan 23 22:42:26 electra CPU:    0
Jan 23 22:42:26 electra EIP:    0060:[<c014bcb7>]    Tainted: P    B VLI
Jan 23 22:42:26 electra EFLAGS: 00010256   (2.6.15-archck) 
Jan 23 22:42:26 electra EIP is at put_page+0x4f/0x6b
Jan 23 22:42:26 electra eax: 00000000   ebx: c17bf504   ecx: c17bf504   edx: c17bf504
Jan 23 22:42:26 electra esi: c17bf504   edi: f6a3dc50   ebp: b7f14000   esp: f6991eb4
Jan 23 22:42:26 electra ds: 007b   es: 007b   ss: 0068
Jan 23 22:42:26 electra Process xscreensaver-gl (pid: 4132, threadinfo=f6990000 task=f6980070)
Jan 23 22:42:26 electra Stack: c014fde4 c17bf504 f704b3c0 ffffffff 00000000 c17af0a0 b7f14000 f6a48b7c 
Jan 23 22:42:26 electra b7f15000 f6a48b7c c014ff81 c1905900 f6a66c24 f6a48b7c b7f14000 b7f15000 
Jan 23 22:42:26 electra f6991f34 00000000 f6a48b7c c1905900 b7f14000 f6a66c24 b7f15000 c015002b 
Jan 23 22:42:26 electra Call Trace:
Jan 23 22:42:26 electra [<c014fde4>] zap_pte_range+0x182/0x24b
Jan 23 22:42:26 electra [<c014ff81>] unmap_page_range+0xd4/0xe3
Jan 23 22:42:26 electra [<c015002b>] unmap_vmas+0x9b/0x1aa
Jan 23 22:42:26 electra [<c0153d24>] exit_mmap+0x6e/0xf8
Jan 23 22:42:26 electra [<c011c031>] mmput+0x21/0x7a
Jan 23 22:42:26 electra [<c01207be>] do_exit+0x16f/0x372
Jan 23 22:42:26 electra [<c0120a82>] sys_exit_group+0x0/0x11
Jan 23 22:42:26 electra [<c0102d93>] sysenter_past_esp+0x54/0x75
Jan 23 22:42:26 electra Code: 32 ff 31 c0 f0 83 42 04 ff 0f 98 c0 84 c0 74 36 8b 4a 38 89 54 24 04 ff e1 8b 02 89 d1 f6 c4 40 74 03 8b 4a 0c 8b 41 04 40 75 08 <0f> 0b 31 00 32 ff 31 c0 f0 83 42 04 ff 0f 98 c0 84 c0 74 07 89 
Jan 23 22:42:26 electra <1>Fixing recursive fault but reboot is needed!
Jan 23 22:42:26 electra scheduling while atomic: xscreensaver-gl/0x00000002/4132
Jan 23 22:42:26 electra [<c0302037>] schedule+0x43/0x6da
Jan 23 22:42:26 electra [<c014bccb>] put_page+0x63/0x6b
Jan 23 22:42:26 electra [<c011e4e6>] printk+0x12/0x16
Jan 23 22:42:26 electra [<c0120708>] do_exit+0xb9/0x372
Jan 23 22:42:26 electra [<c0103f24>] do_trap+0x0/0xc1
Jan 23 22:42:26 electra [<c0104197>] do_invalid_op+0x0/0x98
Jan 23 22:42:26 electra [<c0104223>] do_invalid_op+0x8c/0x98
Jan 23 22:42:26 electra [<c014bcb7>] put_page+0x4f/0x6b
Jan 23 22:42:26 electra [<c012cf97>] rcu_check_quiescent_state+0x53/0x64
Jan 23 22:42:26 electra [<c012d154>] __rcu_process_callbacks+0x92/0xab
Jan 23 22:42:26 electra [<c012d1b1>] rcu_process_callbacks+0x44/0x4a
Jan 23 22:42:26 electra [<c0122b0a>] tasklet_action+0x54/0xae
Jan 23 22:42:26 electra [<c014681d>] bad_range+0x11/0x31
Jan 23 22:42:26 electra [<c01038ef>] error_code+0x4f/0x54
Jan 23 22:42:26 electra [<c014bcb7>] put_page+0x4f/0x6b
Jan 23 22:42:26 electra [<c014fde4>] zap_pte_range+0x182/0x24b
Jan 23 22:42:26 electra [<c014ff81>] unmap_page_range+0xd4/0xe3
Jan 23 22:42:26 electra [<c015002b>] unmap_vmas+0x9b/0x1aa
Jan 23 22:42:26 electra [<c0153d24>] exit_mmap+0x6e/0xf8
Jan 23 22:42:26 electra [<c011c031>] mmput+0x21/0x7a
Jan 23 22:42:26 electra [<c01207be>] do_exit+0x16f/0x372
Jan 23 22:42:26 electra [<c0120a82>] sys_exit_group+0x0/0x11
Jan 23 22:42:26 electra [<c0102d93>] sysenter_past_esp+0x54/0x75

Which is referred a few times as a problem with fglrx. So I guess I should knock at  ati-drivers, but surely I'm not the only one using archk with ati-drivers?


One of the main causes of the fall of the Roman Empire was that, lacking zero,
they had no way to indicate successful termination of their C programs.

Offline

#148 2006-01-23 22:02:44

mouse256
Member
From: Antwerpen, Belgium
Registered: 2005-08-24
Posts: 247

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

You should be able to spot some posts of me in the thread with the same issues concerning ATI and archck 2.6.15
But it's not archck related, every 2.6.15 kernel has problems with the ati drivers.
More info here
maybe it would be nice if iphitus included the patch in the pkgbuild for ati in community?

Offline

#149 2006-01-23 22:11:42

citral
Member
Registered: 2005-05-07
Posts: 87

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

Oops, didn't search properly. Thanks for the pointer though.


One of the main causes of the fall of the Roman Empire was that, lacking zero,
they had no way to indicate successful termination of their C programs.

Offline

#150 2006-01-24 23:12:09

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,640

Re: 2.6.15-archck3: Community PKG + PKGBUILDs

So here is my little problem with latest archck kernel: I don't see the background image while booting. But framebuffer resolution is ok. And when it comes to the gensplash daemon the background appears. Hm.

cat /boot/grub/menu.lst
...
# (1) ArchLinux CK
title  ArchLinux 32Bit ArchCK [/boot/vmlinuz26archck]
root   (hd0,1)
kernel /boot/vmlinuz26archck root=/dev/hda2 video=vesafb:ywrap,mtrr,1280x1024-32@70 splash=verbose,theme:darch console=tty1 ro
initrd = /boot/initramfs26.img

dmesg output:

vesafb: unrecognized option mtrr
vesafb: NVidia Corporation, NV17 () Board, Chip Rev A2 (OEM: NVidia)
vesafb: VBE version: 3.0
vesafb: protected mode interface info at c000:eac0
vesafb: pmi: set display start = c00ceb05, set palette = c00ceb8a
vesafb: pmi: ports = b4c3 b503 ba03 c003 c103 c403 c503 c603 c703 c803 c903 cc03 ce03 cf03 d003 d103 d203 d303 d403 d503 da03 ff03
vesafb: VBIOS/hardware supports DDC2 transfers
vesafb: monitor limits: vf = 75 Hz, hf = 69 kHz, clk = 110 MHz
vesafb: scrolling: ywrap using protected mode interface, yres_virtual=2457
Console: switching to colour frame buffer device 160x64
fbsplash: console 0 using theme 'darch'
vesafb: framebuffer at 0xc8000000, mapped to 0xf8880000, using 6144k, total 65536k
fb0: VESA VGA frame buffer device

Bootsplash before kernel 2.6.15 was fine. So my DualHead with 2x17"TFT shouldn't be the problem.

gensplashutils and initscripts-gensplash are installed.

Any idea?

Offline

Board footer

Powered by FluxBB