You are not logged in.

#26 2014-05-22 13:14:53

HardcoreWR
Member
Registered: 2014-05-21
Posts: 4

Re: [SOLVED] Audio playing bad except with high CPU load

Maybe it's useful to know that I'm using SPDIF instead of HDMI for audio.
Forgot to mention that smile

Offline

#27 2014-05-22 16:23:36

HardcoreWR
Member
Registered: 2014-05-21
Posts: 4

Re: [SOLVED] Audio playing bad except with high CPU load

Unfortunately I didn't have any luck with

options snd-hda-intel snoop=0

and

options snd-hda-intel vid=8086 pid=8ca0 snoop=0 power_save=0 index=0
[    2.308130] snd_hda_intel: unknown parameter 'vid' ignored
[    2.308133] snd_hda_intel: unknown parameter 'pid' ignored

Offline

#28 2014-05-22 17:44:57

emeres
Member
Registered: 2013-10-08
Posts: 1,570

Re: [SOLVED] Audio playing bad except with high CPU load

I do not know if this is Ubuntu specific, but usually these options should have been accepted. You can go through the steps presented on the wiki. or try setting options for both cards. Again might be Ubuntu specific, which I used a very long time ago for a short period of time and is not supported here either way (too many variables and differences). Might be ubuntu kernel related also. (look at your dmesg in alsa-info)
Look through the rest of dmesg and other logs, search for that error and ask the Ubuntu community.

Offline

#29 2014-05-22 20:02:28

ArthurBorsboom
Member
Registered: 2014-05-20
Posts: 51

Re: [SOLVED] Audio playing bad except with high CPU load

Just FYI:

When applying a patch to the Linux kernel (hda_intel.c - module snd-hda-intel) it fixed my problem without the snoop=0.
This patch adds the new PCI Vendor and Device ID to the list, making sure the Intel PCH workarounds are applied.
The issue is not the codec but the controller.

Offline

#30 2014-05-22 22:13:25

benimnetz
Member
Registered: 2014-05-22
Posts: 2

Re: [SOLVED] Audio playing bad except with high CPU load

Hi Arthur,

would you mind sharing this patch with us? Thanks alot!

Btw. Is there an entry in the upstream alsa bugtracker so i cand add that to the ubuntu bucktracker?

Last edited by benimnetz (2014-05-22 22:14:45)

Offline

#31 2014-05-22 22:20:38

benimnetz
Member
Registered: 2014-05-22
Posts: 2

Re: [SOLVED] Audio playing bad except with high CPU load

@HardcoreWR:
The parameters describe by @ArthurBorsboom and @emeres work great for my!

Thanks! You are great big_smile

Offline

#32 2014-05-22 22:36:15

emeres
Member
Registered: 2013-10-08
Posts: 1,570

Re: [SOLVED] Audio playing bad except with high CPU load

ArthurBorsboom wrote:

Just FYI:

When applying a patch to the Linux kernel (hda_intel.c - module snd-hda-intel) it fixed my problem without the snoop=0.
This patch adds the new PCI Vendor and Device ID to the list, making sure the Intel PCH workarounds are applied.
The issue is not the codec but the controller.

Which explains why I could not find the 8ca0 pid but did find the vendor and device id 0x10ec0900.

@benimnetz Glad I could help.

Offline

#33 2014-05-23 06:42:43

ArthurBorsboom
Member
Registered: 2014-05-20
Posts: 51

Re: [SOLVED] Audio playing bad except with high CPU load

Below the (temporary) patch which adds this new chipset. This is probably not the final patch.
I have tested this on kernel 3.15.0-rc6 and it worked for me without the snoop=0.

My guess is that in 3.16 this issue might be fixed.
So until then the workaround as suggested above is advised.

diff --git a/sound/pci/hda/hda_intel.c b/sound/pci/hda/hda_intel.c
index 2c54629d62d1..36b98b89c4c0 100644
--- a/sound/pci/hda/hda_intel.c
+++ b/sound/pci/hda/hda_intel.c
@@ -1743,6 +1743,9 @@ static DEFINE_PCI_DEVICE_TABLE(azx_ids) = {
        /* Lynx Point */
        { PCI_DEVICE(0x8086, 0x8c20),
          .driver_data = AZX_DRIVER_PCH | AZX_DCAPS_INTEL_PCH },
+       /* ?? New chip */
+       { PCI_DEVICE(0x8086, 0x8ca0),
+         .driver_data = AZX_DRIVER_PCH | AZX_DCAPS_INTEL_PCH },
        /* Wellsburg */
        { PCI_DEVICE(0x8086, 0x8d20),
          .driver_data = AZX_DRIVER_PCH | AZX_DCAPS_INTEL_PCH },

Last edited by ArthurBorsboom (2014-05-23 10:05:07)

Offline

#34 2014-05-23 07:21:52

ArthurBorsboom
Member
Registered: 2014-05-20
Posts: 51

Re: [SOLVED] Audio playing bad except with high CPU load

Update: the patch *might* even make it in 3.15.

Offline

#35 2014-05-23 08:28:52

ArthurBorsboom
Member
Registered: 2014-05-20
Posts: 51

Re: [SOLVED] Audio playing bad except with high CPU load

Offline

#36 2014-05-23 09:27:17

emeres
Member
Registered: 2013-10-08
Posts: 1,570

Re: [SOLVED] Audio playing bad except with high CPU load

Great news. Please put the patch into code tags though.

I think you can mark this thread as solved.

Last edited by emeres (2014-05-23 10:34:44)

Offline

#37 2014-05-23 11:47:05

ArthurBorsboom
Member
Registered: 2014-05-20
Posts: 51

Re: [SOLVED] Audio playing bad except with high CPU load

If I only knew how... smile

Offline

#38 2014-05-23 11:49:07

emeres
Member
Registered: 2013-10-08
Posts: 1,570

Re: [SOLVED] Audio playing bad except with high CPU load

Edit the first post.

Offline

#39 2014-05-23 11:51:14

ArthurBorsboom
Member
Registered: 2014-05-20
Posts: 51

Re: [SOLVED] Audio playing bad except with high CPU load

Okay.... And then? smile

I don't see a 'Resolved' button or something like that.

Offline

#40 2014-05-23 12:01:18

emeres
Member
Registered: 2013-10-08
Posts: 1,570

Re: [SOLVED] Audio playing bad except with high CPU load

Offline

#41 2014-05-23 12:03:21

ArthurBorsboom
Member
Registered: 2014-05-20
Posts: 51

Re: [SOLVED] Audio playing bad except with high CPU load

Oh no... metadata in a subject line. Well, whatever, no problem.
Thanks all for helping to find the solution.

Offline

#42 2014-05-26 21:52:47

wawawawa
Member
Registered: 2014-05-26
Posts: 3

Re: [SOLVED] Audio playing bad except with high CPU load

emeres wrote:

@HardcoreWR and others You should try:

options snd-hda-intel vid=8086 pid=8ca0 snoop=0

Since you have two sound cards using snd-hda-intel module, it is better (and sometimes necessary) to specify the vendor and product id, so that the correct card uses the correct options..

Yes, yes, yes!

Thank you - this worked for me too.

[New Arch install on a Xeon E3-1240 v3, Asus H97M-E Mobo with 16GB RAM and an Nvidia 760.]

Now it sounds perfect.

Offline

#43 2014-05-28 19:47:19

ArthurBorsboom
Member
Registered: 2014-05-20
Posts: 51

Re: [SOLVED] Audio playing bad except with high CPU load

A last update regarding the release of this patch in the Linux kernel.
It has been merged in the mailine kernel 3.15-rc8: https://git.kernel.org/cgit/linux/kerne … 409d828b1b

Offline

#44 2014-06-27 06:27:14

Elrico
Member
Registered: 2014-06-27
Posts: 1

Re: [SOLVED] Audio playing bad except with high CPU load

Hi there.

I've got the same Problem with my Asus Z97 Deluxe and the ALC1150 Audio Controller. In search for a solution i found this thread and added
to my /etc/modprobe.d/alsa-base.conf as follows

"options snd-hda-intel vid=8086 pid=8ca0 snoop=0"

If that not works and you have a  ALC883 or similar soundchip you may need to add
to your /etc/modules

"snd-hda-intel vid=8086 pid=8ca0 snoop=0"

After that reboot.

It works fine with my board and i'm happy to hear my music in fine quality.

Best regards

Elrico

Offline

#45 2014-07-03 06:00:33

Darkk
Member
Registered: 2014-07-03
Posts: 1

Re: [SOLVED] Audio playing bad except with high CPU load

I too was having this exact same issue with Linux Mint 17 Cinnamon running on ASRock Extreme6 Z79 with Intel i7 4970 processor.  Kernel version3.13.0-24-generic

Per Elrico suggestion below it totally fixed this issue.  As of this writing Linux Mint haven't released the latest kernel so using the patch took care of it.

Thanks!!

/etc/modprobe.d/alsa-base.conf as follows:

options snd-hda-intel vid=8086 pid=8ca0 snoop=0

Offline

#46 2015-02-02 22:24:23

3n3low
Member
Registered: 2015-02-02
Posts: 1

Re: [SOLVED] Audio playing bad except with high CPU load

I would also like to confirm that Elrico's option works on mint 17 xfce x86_64 with 3.13.0-24-generic kernel. Motherboard is Gigabyte Z97-HD3.

Offline

#47 2016-01-08 16:54:29

PedroReina
Member
From: Madrid, Spain
Registered: 2016-01-08
Posts: 1
Website

Re: [SOLVED] Audio playing bad except with high CPU load

Debian user here. (But archlinux forum rocks!)

I've an Asus Z97-Pro Gamer mobo (very good mobo, by the way) with ALC1150 audio.

With Debian 7.9, stock kernel 3.2.0 (32 bits) and ALSA 1.0.25 I had the very same problems ArthurBorsboom explained in the first post.

Thanks to this thread, my sound is perfect now. This worked for me:

$ cat /etc/modprobe.d/alsa-base.conf | grep snd-hda-intel
options snd-hda-intel bdl_pos_adj=1,64 snoop=0

Tnx, guys.

Offline

Board footer

Powered by FluxBB