You are not logged in.

#26 2014-06-27 15:12:39

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,414

Re: Using systemd-timesync instead of NTP

qinohe wrote:

... but you could have a look at 'journalctl -b|grep timesyncd'

journalctl -u systemd-timesyncd.service -b

Offline

#27 2014-06-27 15:36:36

qinohe
Member
From: Netherlands
Registered: 2012-06-20
Posts: 1,125

Re: Using systemd-timesync instead of NTP

WonderWoofy wrote:
qinohe wrote:

... but you could have a look at 'journalctl -b|grep timesyncd'

journalctl -u systemd-timesyncd.service -b

wink Nice, thanks, get a better output with it.

Offline

#28 2014-06-27 16:14:25

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,279

Re: Using systemd-timesync instead of NTP

qinohe wrote:
WonderWoofy wrote:
qinohe wrote:

... but you could have a look at 'journalctl -b|grep timesyncd'

journalctl -u systemd-timesyncd.service -b

wink Nice, thanks, get a better output with it.

Logs begin at (8 months ago), end (today) ?

Last edited by nomorewindows (2014-06-27 16:15:27)


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#29 2014-06-27 16:17:17

qinohe
Member
From: Netherlands
Registered: 2012-06-20
Posts: 1,125

Re: Using systemd-timesync instead of NTP

nomorewindows wrote:
Logs begin at (8 months ago), end (today) ?

You mean there are no logs?
Are you a member of systemd-journal group?, otherwise use sudo.

Last edited by qinohe (2014-06-27 16:22:12)

Offline

#30 2014-06-27 17:19:10

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,279

Re: Using systemd-timesync instead of NTP

qinohe wrote:
nomorewindows wrote:
Logs begin at (8 months ago), end (today) ?

You mean there are no logs?
Are you a member of systemd-journal group?, otherwise use sudo.

Nothing other than messages stating it started the systemd-timesyncd.service from after rebooting with setting the hardware clock through BIOS.


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#31 2014-06-27 17:38:32

qinohe
Member
From: Netherlands
Registered: 2012-06-20
Posts: 1,125

Re: Using systemd-timesync instead of NTP

Maybe I come up with something, later, but atm. I have no clue what the problem could be

Offline

#32 2014-06-27 18:15:14

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,279

Re: Using systemd-timesync instead of NTP

Sometimes there would be a couple minutes of delay before ntpd would set the clock the way it was supposed to be, but it would eventually do it.  Doesn't appear that systemd-timesync is playing catch up.  Maybe if I have some of the older logs somewhere, but systemd is a little different.


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#33 2014-06-27 18:19:33

qinohe
Member
From: Netherlands
Registered: 2012-06-20
Posts: 1,125

Re: Using systemd-timesync instead of NTP

Hmm, you could set a delay on the timesync daemon of say 5 min., could be worth trying.

Offline

#34 2014-06-27 18:34:29

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,279

Re: Using systemd-timesync instead of NTP

Even OpenBSD says that their OpenNTP isn't necessarily atomic time accurate, but close enough for government work.  I did change the default time servers in /etc/systemd/timesyncd.conf to the ones I preferred to use.  Ntpd uses what looks like to be the same ones FreeBSD uses (at ntp.org) by default.

Last edited by nomorewindows (2014-06-27 18:36:57)


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#35 2014-06-27 18:46:47

qinohe
Member
From: Netherlands
Registered: 2012-06-20
Posts: 1,125

Re: Using systemd-timesync instead of NTP

Yes, if it's a normal time server, systemd-timesync should be able to use it,
I too use a different one than the default, works fine since it was upgraded (Systemd), the one with timesyncd.conf.pacnew patch, no problems since then.

Q:Do the default time servers also fail?

Offline

#36 2014-06-27 19:47:22

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,279

Re: Using systemd-timesync instead of NTP

qinohe wrote:

Yes, if it's a normal time server, systemd-timesync should be able to use it,
I too use a different one than the default, works fine since it was upgraded (Systemd), the one with timesyncd.conf.pacnew patch, no problems since then.

Q:Do the default time servers also fail?

I don't think so, I sometime get the IP numbers backwards (manually, ntpdate -s), but other than that it should work.


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#37 2014-06-29 16:10:41

Moviuro
Member
Registered: 2012-06-03
Posts: 53

Re: Using systemd-timesync instead of NTP

Hi all,

I tried to use it, and strangely on 2 very similar machines, on starts without complaining and without putting anything into the logs:

root@schizophrenia ~ # systemctl status systemd-timesyncd.service
● systemd-timesyncd.service - Network Time Synchronization
   Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; disabled)
   Active: active (running) since Sun 2014-06-29 17:17:11 CEST; 50min ago
     Docs: man:systemd-timesyncd.service(8)
 Main PID: 7073 (systemd-timesyn)
   Status: "Using Time Server 216.239.32.15:123 (time1.google.com)."
   CGroup: /system.slice/systemd-timesyncd.service
           └─7073 /usr/lib/systemd/systemd-timesyncd
root@schizophrenia ~ # journalctl -u systemd-timesyncd.service -b
-- Logs begin at Tue 2014-05-27 23:56:50 CEST, end at Sun 2014-06-29 18:05:39 CEST. --
1 root@schizophrenia ~ #

But the second one floods me with failures

root@psychoticdelirium ~ # systemctl start systemd-timesyncd
Job for systemd-timesyncd.service failed. See 'systemctl status systemd-timesyncd.service' and 'journalctl -xn' for details.
1 root@psychoticdelirium ~ # journalctl -u systemd-timesyncd.service -b                                                             :(
-- Logs begin at Wed 2014-06-04 02:02:18 CEST, end at Sun 2014-06-29 18:08:31 CEST. --
Jun 29 13:56:30 psychoticdelirium systemd-timesyncd[2180]: Failed to listen to networkd events: No such file or directory
Jun 29 13:56:30 psychoticdelirium systemd[1]: Failed to start Network Time Synchronization.
Jun 29 13:56:30 psychoticdelirium systemd-timesyncd[2186]: Failed to listen to networkd events: No such file or directory
Jun 29 13:56:30 psychoticdelirium systemd[1]: Failed to start Network Time Synchronization.
Jun 29 13:56:30 psychoticdelirium systemd-timesyncd[2201]: Failed to listen to networkd events: No such file or directory
Jun 29 13:56:30 psychoticdelirium systemd[1]: Failed to start Network Time Synchronization.
Jun 29 13:56:30 psychoticdelirium systemd-timesyncd[2205]: Failed to listen to networkd events: No such file or directory
Jun 29 13:56:30 psychoticdelirium systemd[1]: Failed to start Network Time Synchronization.
Jun 29 13:56:30 psychoticdelirium systemd-timesyncd[2209]: Failed to listen to networkd events: No such file or directory
Jun 29 13:56:31 psychoticdelirium systemd[1]: Failed to start Network Time Synchronization.
Jun 29 13:56:31 psychoticdelirium systemd[1]: systemd-timesyncd.service start request repeated too quickly, refusing to start.
[many times the same messages, because I tried to start it many times]
[...]
root@psychoticdelirium ~ # systemctl status systemd-timesyncd.service
● systemd-timesyncd.service - Network Time Synchronization
   Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; disabled)
   Active: failed (Result: start-limit) since Sun 2014-06-29 18:08:31 CEST; 23s ago
     Docs: man:systemd-timesyncd.service(8)
  Process: 7469 ExecStart=/usr/lib/systemd/systemd-timesyncd (code=exited, status=1/FAILURE)
 Main PID: 7469 (code=exited, status=1/FAILURE)
   Status: "Idle."

Jun 29 18:08:31 psychoticdelirium systemd[1]: Failed to start Network Time Synchronization.
Jun 29 18:08:31 psychoticdelirium systemd[1]: systemd-timesyncd.service start request repeated too quickly, refusing to start.
Jun 29 18:08:31 psychoticdelirium systemd[1]: Failed to start Network Time Synchronization.

My both machines use systemd-networkd... so that's weird. And really, the services are exactly the same.

Last edited by Moviuro (2014-06-29 16:12:52)


bspwm, BTRFS over LUKS
Archlinux a lot, FreeBSD more and more...
Murphy's rule: The day you need a backup, you tell yourself you should have created some.

Offline

#38 2014-07-01 16:57:46

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,279

Re: Using systemd-timesync instead of NTP

Doesn't appear that the time is being set.  It's 10 minutes behind.


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#39 2014-07-01 17:12:48

stevenhoneyman
Member
From: England
Registered: 2014-05-25
Posts: 241

Re: Using systemd-timesync instead of NTP

Busybox has a simple ntpd inbuilt. Just symlink it and then

ntpd -qp $NTPSERVER

Offline

#40 2014-07-01 19:27:47

Moviuro
Member
Registered: 2012-06-03
Posts: 53

Re: Using systemd-timesync instead of NTP

Moviuro wrote:

My both machines use systemd-networkd... so that's weird. And really, the services are exactly the same.

Hmmmm, I just forgot to reboot after upgrading systemd (shame on me...).


bspwm, BTRFS over LUKS
Archlinux a lot, FreeBSD more and more...
Murphy's rule: The day you need a backup, you tell yourself you should have created some.

Offline

#41 2014-08-16 17:42:45

keepitsimpleengineer
Member
From: San Joaquin Valley, CA
Registered: 2012-06-25
Posts: 355

Re: Using systemd-timesync instead of NTP

I have four Linux systems, two for MythTV which are Xubuntu (64bit), one a very competent Archlinux 64bit workstation and one an inexpensive laptop with 32bit Archlinux.

Being lazy (and retired), I set up the Arch systems with systemd-timesync.  I used the default NTP for the MythTV systems.

When MythTV started getting the timing off on some recordings, I checked the clocks on all.  Surprise yikes, the NTP systems were dead on, and the systemd-timesync systems were 15-20 seconds off, and not even synced to each other.  Even my unrooted Android smartphone was more accurate.

So I eschewed lassitude, adopted autocracy, put them all on NTP and used the newly recommended  "server [0,1,2,3].north-america.pool.ntp.org iburst" for timeservers.

I even went to the extreme of turning ntpd off and on depending on LAN connection for the laptop.

Now they all play together like a great quartet.

Also, turns out the television stations were jockeying start times to gain viewership advantage, sans PBS, the gold standard here in central California. big_smile


Al Einstein: "Man soll die Dinge so einfach machen wie möglich ~ aber nicht einfacher." (Things should be as simple as possible ~ but not too simple.) ~ Al (Einstein) war ein Cousin von Albert, "Al" ist die Abkürzung für Aloysius

Offline

#42 2014-08-16 20:55:47

firecat53
Member
From: Lake Stevens, WA, USA
Registered: 2007-05-14
Posts: 1,532
Website

Re: Using systemd-timesync instead of NTP

FWIW, I've got 3 Arch systems (laptop and 2 servers in 2 different locations) setup with systemd-timesync and they are all exactly in sync with each other and a web-based atomic clock (well, given the limits of looking at it over VPN and SSH smile ). The logs should look something like:

~ $ journalctl  -r -u systemd-timesyncd.service
-- Logs begin at Sat 2014-07-05 11:20:35 PDT, end at Sat 2014-08-16 11:41:08 PDT. --
Aug 16 11:10:16 homeserver systemd-timesyncd[292]: interval/delta/delay/jitter/drift 2048s/+0.000s/0.019s/0.002s/+7ppm
Aug 16 10:36:08 homeserver systemd-timesyncd[292]: interval/delta/delay/jitter/drift 2048s/+0.003s/0.018s/0.002s/+7ppm
Aug 16 10:02:00 homeserver systemd-timesyncd[292]: interval/delta/delay/jitter/drift 2048s/+0.003s/0.021s/0.001s/+6ppm (ignored)
Aug 16 09:27:52 homeserver systemd-timesyncd[292]: interval/delta/delay/jitter/drift 2048s/-0.000s/0.017s/0.000s/+6ppm
Aug 16 08:53:43 homeserver systemd-timesyncd[292]: interval/delta/delay/jitter/drift 2048s/-0.000s/0.017s/0.000s/+6ppm

If not, there's an issue somewhere...

Scott

Last edited by firecat53 (2014-08-16 20:56:42)

Offline

#43 2014-10-22 14:27:24

nTia89
Banned
From: varese, italy
Registered: 2008-12-22
Posts: 1,230

Re: Using systemd-timesync instead of NTP

in the hope I will not be marked as necrodumper....

I correctly configured systemd-timesync, indeed:

Oct 22 16:14:18 arch-desktop systemd-timesyncd[246]: interval/delta/delay/jitter/drift 32s/+0
Oct 22 16:13:45 arch-desktop systemd-timesyncd[246]: interval/delta/delay/jitter/drift 32s/+0
Oct 22 16:13:12 arch-desktop systemd-timesyncd[246]: interval/delta/delay/jitter/drift 32s/+0
Oct 22 16:12:39 arch-desktop systemd-timesyncd[246]: interval/delta/delay/jitter/drift 32s/+0
Oct 22 16:12:06 arch-desktop systemd-timesyncd[246]: interval/delta/delay/jitter/drift 32s/-0
Oct 22 16:11:00 arch-desktop systemd-timesyncd[246]: interval/delta/delay/jitter/drift 64s/-0
Oct 22 16:08:51 arch-desktop systemd-timesyncd[246]: interval/delta/delay/jitter/drift 128s/+
Oct 22 16:04:34 arch-desktop systemd-timesyncd[246]: interval/delta/delay/jitter/drift 256s/+
Oct 22 16:02:26 arch-desktop systemd-timesyncd[246]: interval/delta/delay/jitter/drift 128s/+
Oct 22 15:58:09 arch-desktop systemd-timesyncd[246]: interval/delta/delay/jitter/drift 256s/+
Oct 22 15:56:01 arch-desktop systemd-timesyncd[246]: interval/delta/delay/jitter/drift 128s/+
Oct 22 15:54:56 arch-desktop systemd-timesyncd[246]: interval/delta/delay/jitter/drift 64s/-0
Oct 22 15:54:24 arch-desktop systemd-timesyncd[246]: interval/delta/delay/jitter/drift 32s/+0
Oct 22 15:54:24 arch-desktop systemd-timesyncd[246]: Using NTP server 10.32.208.1:123 (10.32.
Oct 22 15:53:54 arch-desktop systemd-timesyncd[246]: Network configuration changed, trying to
Oct 22 15:53:54 arch-desktop systemd-timesyncd[246]: Network configuration changed, trying to
Oct 22 15:53:54 arch-desktop systemd-timesyncd[246]: Network configuration changed, trying to
Oct 22 15:53:51 arch-desktop systemd[1]: Started Network Time Synchronization.
Oct 22 15:53:51 arch-desktop systemd[1]: Starting Network Time Synchronization...
-- Reboot --

now, I have a question: how can you see my PC syncs itself about once per minute, instead yours every about 30 minutes.
how can I edit that setting?

thank you


+pc: custom | AMD Opteron 175 | nForce4 Ultra | 2GB ram DDR400 | nVidia 9800GT 1GB | ArchLinux x86_64 w/ openbox
+laptop: Apple | MacBook (2,1) | 2GB ram | Mac OS X 10.4 -> DIED
+ultrabook: Dell | XPS 13 (9343) | 8GB ram | 256GB ssd | FullHD display | Windows 8.1 64bit ArchLinux x86_64 w/ Gnome

Offline

Board footer

Powered by FluxBB