You are not logged in.

#26 2014-08-17 12:45:32

ens
Member
From: Italy
Registered: 2013-03-13
Posts: 4

Re: [SOLVED] After xorg-server update backlight is not behaving

kelloco2 wrote:

@iskandr , @ens  about backlight and fn keys:
keys work (I checked by xmodmap) and backlight control works, but only by:

/sys/class/backlight/intel_backlight/brightness

old scripts which used for example:

/sys/class/backlight/acpi_video0/brightness

stopped works.

I wonder if this is a BUG or new feature? Where are handlers in clean Linux / systemd responsible for action to acpi keys which controlls backlight? ( I checked and it's not acpid /etc/acpi/handler.sh - acpi keys backlight controll works without it ). (moreover,acpid is external application as well as xbacklight, gbacklight etc... It should work OOTB, without these applications and also in the console.)

to turn on old interface as before 3.16 try add

video.use_native_backlight=0

to GRUB_CMDLINE_LINUX_DEFAULT line in /etc/default/grub  ( remember about grub-mkconfig -o /boot/grub/grub.cfg )

Thanks, that did the trick!

Offline

#27 2014-08-23 16:53:34

OB4Life
Member
Registered: 2014-08-07
Posts: 15

Re: [SOLVED] After xorg-server update backlight is not behaving

Still not fixed for me. Alas.
Screen is dimmed on logout on my Thinkpad R400 and brightness state is forgoten across reboots.
Using the kernel parameter "acpi_backlight=vendor". Which sets screen to full brightness on logout, instead. Doesn't rememeber states across reboots though.

Hoping a future update will fix the issue.

Offline

#28 2014-08-24 12:03:33

NorthAntrim
Member
Registered: 2012-09-09
Posts: 46

Re: [SOLVED] After xorg-server update backlight is not behaving

Thanks for the fix, kelloco2! This issue has been driving me mad for the past couple of days, and adding video.use_native_backlight=0 to the kernel parameters worked. I can now control brightness again in Cinnamon using the FN keys.

Offline

#29 2014-08-26 09:51:13

Neitsab
Wiki Maintainer
Registered: 2013-12-05
Posts: 20

Re: [SOLVED] After xorg-server update backlight is not behaving

interstellar wrote:

Similar issue here on a lenovo yoga 2 pro laptop. The difference is that brightness is set to maximum at each boot, as well as after each relogin. I'm working with Gnome and gdm as the login manager.

Same issue here. Brightness is set to maximum at each boot (and probably relogin), thus not remembering previous state. I can however use the Fn keys to set brightness without any problem.
Running default kernel 3.16.1-1 and xf86-video-intel 2.99.914-4 on a Clevo W540EU laptop using only Intel Graphics (i915 driver). It's been like that for a month or so.

Anybody having a fix for this configuration?

Offline

#30 2014-08-26 12:09:26

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,131
Website

Re: [SOLVED] After xorg-server update backlight is not behaving

Thank you kelloco2, adding the native backlight parameter restores the function of the Fn keys on the thinkpad x220.
Is there a bug report about the Fn keys issue?

Offline

#31 2014-08-28 09:25:33

OB4Life
Member
Registered: 2014-08-07
Posts: 15

Re: [SOLVED] After xorg-server update backlight is not behaving

Hi, Neitsab. Your issue sounds similar to mine. For now i am using xf86-video-intel 2.99.912-4 (note: *912* not *914*) with no grub kernel parameters and everything is behaving normally.
This is the latest version I could use without issue.
I got it from http://seblu.net/a/arm/packages/x/xf86-video-intel/ as I didn't have that version in cache anymore.

Offline

#32 2014-08-31 06:41:41

ubone
Member
Registered: 2014-08-31
Posts: 42

Re: [SOLVED] After xorg-server update backlight is not behaving

New kernel (3.16.1) broke fn + f9/10 brightness keys for my laptop (HP Compaq 8510p) as well.
Grub param video.use_native_backlight=0 and the other did not help (vendor broke boot).
All worked with 3.15.5 and 3.15.8.1, for now regression is a solution, not sure where/what to report.

Offline

#33 2014-09-10 23:44:08

OB4Life
Member
Registered: 2014-08-07
Posts: 15

Re: [SOLVED] After xorg-server update backlight is not behaving

Here's a one: since the latest driver update (xf86-video-intel-2.99.916-1-x86_64) brightness state is now remembered across reboots, but screen is still dimmed on logout. Interestingly, previously, post login, any adjustment (up or down) would set the screen to full brightness. Now, post login, any adjustment brings the brightness state from a dim state back to the previous state, which is better.
So... incremental improvement.
Also, previously video playback and Mupen64 would sometimes crash with the following error:

intel_do_flush_locked failed: Invalid argument
Segmentation fault (core dumped)

But not always and a reboot would always fix the problem. Well now that problem seems not to occur at all. Great.

[edit: grammar]

Last edited by OB4Life (2014-09-11 00:25:16)

Offline

#34 2014-09-11 22:35:34

OB4Life
Member
Registered: 2014-08-07
Posts: 15

Re: [SOLVED] After xorg-server update backlight is not behaving

Actually, this:

intel_do_flush_locked failed: Invalid argument
Segmentation fault (core dumped)

problem has just occurred again. I cannot play video. Bit unrelated, i suppose.

Offline

Board footer

Powered by FluxBB