You are not logged in.

#26 2014-08-05 20:55:20

drautb
Member
Registered: 2014-08-04
Posts: 13

Re: [SOLVED] Unable to startx as user

Yep, the default one is there, I haven't touched it: .xinitrc

Offline

#27 2014-08-05 21:04:58

drautb
Member
Registered: 2014-08-04
Posts: 13

Re: [SOLVED] Unable to startx as user

Haha, I realized that .xinitrc wasn't starting anything! I added 'exec xterm' to the end, and now it works!

I removed Xwrapper.config, and it still works...so maybe it was installing xf86-video-modesetting that fixed it?

Thanks so much for all your help, I really appreciate it!

Last edited by drautb (2014-08-05 21:08:58)

Offline

#28 2014-08-05 21:13:42

rebootl
Member
Registered: 2012-01-10
Posts: 430
Website

Re: [SOLVED] Unable to startx as user

I haven't touched it:

*glad* That's the problem big_smile it's actually 'empty'. There are a few example entries but they are commented out by the '#' at the beginning of the lines.

If there is an ~/.xinitrc then it will be used but if there's not (as it is probably the case on your root account) startx will use the system-wide default /etc/X11/xinit/xinitrc ('man startx').

You may test by moving your ~/.xinitrc to another name.

But for your config it's usual not to adapt the system-wide but your personal ~/.xinitrc.
Also see the link I gave above.
If everything works well you should be able to continue to set up your environment now, choose a window manager/ desktop environment etc.

Have fun.

Edit: Ah, I see you figured it out. Yeah, I was asking myself what the actual fix was now...

so maybe it was installing xf86-video-modesetting that fixed it?

Yeah looks like, so thanks to SiroccoFR as well. Maybe either this or then Xwrapper.config is needed, but honestly, I don't know. Maybe test it, if you want.

And please don't forget to mark the thread as [SOLVED] then by editing your first post.

Last edited by rebootl (2014-08-05 21:40:59)


Personal website: reboot.li
GitHub: github.com/rebootl

Offline

#29 2017-09-14 15:27:12

zulqurnain
Member
Registered: 2016-11-15
Posts: 17

Re: [SOLVED] Unable to startx as user

lol. so much trouble to do a simple thing, there have been cases when isntalling the drivers before the first reboot after install arch is a prefered method. The times where i have done this i was force to type sudo startx to invoke xorg-server or else it would negate with some error.
if you installed the video drivers before the first reboot i suggest install arch again by installing the drivers after the first reboot and NOT under root.
in my experience having a black screen with the symbol on the corner is usually a driver realted issue or KDMS. go with open source drivers before you start using proprietary drivers, this will allow you to see what can work. usually xorg is simple now especially if you are using just one monitor on just ONE gpu.
ive dealt with multiple gpu mutliple monitor and xscrees and usually have to resort to sacrificing a cat to the xorg gods for results

Offline

#30 2017-09-14 15:58:21

fsckd
Forum Fellow
Registered: 2009-06-15
Posts: 4,173

Re: [SOLVED] Unable to startx as user

zulqurnain, please do not necro-bump. https://wiki.archlinux.org/index.php/Co … bumping.22
Closing.


aur S & M :: forum rules :: Community Ethos
Resources for Women, POC, LGBT*, and allies

Offline

Board footer

Powered by FluxBB