You are not logged in.

#1 2014-09-03 05:14:14

snovik
Member
Registered: 2012-05-06
Posts: 140

[SOLVED] lightdm cannot login

I started having problem with lightdm logging in. It says "incorrect password. please try again". However tty works just fine.

Journalctl says: lightdm[320]: ** (process:398): WARNING **: Error getting user list from org.freedesktop.Accounts

Google did not help with a solution

Last edited by snovik (2014-09-27 11:56:46)

Offline

#2 2014-09-03 09:49:52

dice
Member
From: Germany
Registered: 2014-02-10
Posts: 413

Re: [SOLVED] lightdm cannot login

A little more info would be nice.
Especially the contents of /etc/lightdm/lightdm.conf and /var/log/lightdm/lightdm.log could provide some useful information


I put at button on it. Yes. I wish to press it, but I'm not sure what will happen if I do.  (Gune | Titan A.E.)

Offline

#3 2014-09-03 17:10:12

snovik
Member
Registered: 2012-05-06
Posts: 140

Re: [SOLVED] lightdm cannot login

sure! here we go

/etc/lightdm/lightdm.conf

[LightDM]
minimum-vt=1
run-directory=/run/lightdm

[SeatDefaults]
session-wrapper=/etc/lightdm/Xsession
pam-service=lightdm-autologin

/var/log/lightdm/lightdm.log

[+0.09s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.09s] DEBUG: Starting Light Display Manager 1.10.1, UID=0 PID=320
[+0.09s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.09s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.09s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.09s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.09s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.23s] DEBUG: Registered seat module xlocal
[+0.23s] DEBUG: Registered seat module xremote
[+0.23s] DEBUG: Registered seat module unity
[+0.23s] DEBUG: Registered seat module surfaceflinger
[+1.51s] DEBUG: Adding default seat
[+1.51s] DEBUG: Seat: Starting
[+1.51s] DEBUG: Seat: Creating greeter session
[+1.56s] DEBUG: Seat: Creating display server of type x
[+1.56s] DEBUG: Could not run plymouth --ping: Failed to execute child process "plymouth" (No such file or directory)
[+1.56s] DEBUG: Using VT 1
[+1.56s] DEBUG: Seat: Starting local X display on VT 1
[+1.56s] DEBUG: DisplayServer x-0: Logging to /var/log/lightdm/x-0.log
[+1.58s] DEBUG: DisplayServer x-0: Writing X server authority to /run/lightdm/root/:0
[+1.58s] DEBUG: DisplayServer x-0: Launching X Server
[+1.58s] DEBUG: Launching process 328: /usr/sbin/X :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt1 -novtswitch
[+1.58s] DEBUG: DisplayServer x-0: Waiting for ready signal from X server :0
[+1.58s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+1.58s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+1.60s] WARNING: Error getting user list from org.freedesktop.Accounts: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Accounts was not provided by any .service files
[+1.60s] DEBUG: Loading user config from /etc/lightdm/users.conf
[+1.69s] DEBUG: User sergei added
[+5.34s] DEBUG: Got signal 10 from process 328
[+5.34s] DEBUG: DisplayServer x-0: Got signal from X server :0
[+5.34s] DEBUG: DisplayServer x-0: Connecting to XServer :0
[+5.35s] DEBUG: Seat: Display server ready, starting session authentication
[+5.35s] DEBUG: Session pid=398: Started with service 'lightdm-greeter', username 'lightdm'
[+5.84s] DEBUG: Session pid=398: Authentication complete with return value 0: Success
[+5.84s] DEBUG: Seat: Session authenticated, running command
[+5.84s] DEBUG: Session pid=398: Running command /usr/sbin/lightdm-gtk-greeter
[+5.86s] DEBUG: Creating shared data directory /var/lib/lightdm-data/lightdm
[+5.86s] DEBUG: Session pid=398: Logging to /var/log/lightdm/x-0-greeter.log
[+6.38s] DEBUG: Activating VT 1
[+6.38s] DEBUG: Activating login1 session /org/freedesktop/login1/session/c1
[+7.77s] DEBUG: Session pid=398: Greeter connected version=1.10.1
[+9.91s] DEBUG: Session pid=398: Greeter start authentication for sergei
[+9.91s] DEBUG: Session pid=408: Started with service 'lightdm', username 'sergei'
[+11.07s] DEBUG: Session pid=408: Got 1 message(s) from PAM
[+11.07s] DEBUG: Session pid=398: Prompt greeter with 1 message(s)
[+1089.04s] DEBUG: Session pid=398: Continue authentication
[+1091.28s] DEBUG: Session pid=408: Authentication complete with return value 7: Authentication failure
[+1091.28s] DEBUG: Session pid=398: Authenticate result for user sergei: Authentication failure
[+1091.29s] DEBUG: Session pid=408: Exited with return value 1
[+1091.29s] DEBUG: Seat: Session stopped
[+1091.32s] DEBUG: Session pid=398: Greeter start authentication for sergei
[+1091.33s] DEBUG: Session pid=1141: Started with service 'lightdm', username 'sergei'
[+1091.33s] DEBUG: Session pid=1141: Got 1 message(s) from PAM
[+1091.33s] DEBUG: Session pid=398: Prompt greeter with 1 message(s)

Offline

#4 2014-09-03 18:11:32

midixinga
Member
Registered: 2014-01-18
Posts: 187

Re: [SOLVED] lightdm cannot login

[nonsense]

Last edited by midixinga (2014-09-03 18:16:42)


[Desktop | Intel i4570 CPU |  Internal Graphics HD4600 |  ASRock H87M Pro4 | 8 GB RAM | UEFI/GPT | Samsung SSD 850 | Single-Boot Arch 64 Bit | sytemd-boot | KDE 4 xfce Plasma5]

Offline

#5 2014-09-03 20:38:55

dice
Member
From: Germany
Registered: 2014-02-10
Posts: 413

Re: [SOLVED] lightdm cannot login

[+1.60s] WARNING: Error getting user list from org.freedesktop.Accounts: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Accounts was not provided by any .service files

This looks actually as if accountsservice is needed.
Although this is listed as optional dependency you could check if it is installed. If not try installing it.
I have it installed but it came in as dependency for cinnamon in my case.


I put at button on it. Yes. I wish to press it, but I'm not sure what will happen if I do.  (Gune | Titan A.E.)

Offline

#6 2014-09-04 04:54:09

snovik
Member
Registered: 2012-05-06
Posts: 140

Re: [SOLVED] lightdm cannot login

Hm, I never had accountsservice installed and yet lightdm worked all fine until some days ago

Digging through journalctl I found this

Jul 30 20:03:20 sergei lightdm[3278]: pam_succeed_if(lightdm-autologin:auth): requirement "user ingroup autologin" not met by user "sergei"
Jul 30 20:03:20 sergei lightdm[3278]: pam_unix(lightdm-autologin:auth): conversation failed
Jul 30 20:03:20 sergei lightdm[3278]: pam_unix(lightdm-autologin:auth): auth could not identify password for [sergei]
Jul 30 20:03:20 sergei lightdm[318]: Stopping PAM conversation, interaction requested but not supported

Looks like it is related to the last xorg-server update. Damn it, I had so many problems with it. Will dig more tonight

Last edited by snovik (2014-09-04 05:20:25)

Offline

#7 2014-09-04 08:06:16

berbae
Member
From: France
Registered: 2007-02-12
Posts: 1,297

Re: [SOLVED] lightdm cannot login

Offline

#8 2014-09-04 16:56:10

snovik
Member
Registered: 2012-05-06
Posts: 140

Re: [SOLVED] lightdm cannot login

The whole thing gets very interesting because I actually never used autologin since I use several DE. So I turned it off completely. 

The problem remains. I have not changed any lightdm config since the beginning of time and I cannot get through lightdm authentication.

Last edited by snovik (2014-09-04 16:58:29)

Offline

#9 2014-09-05 16:00:55

ssivil
Member
Registered: 2011-09-23
Posts: 28

Re: [SOLVED] lightdm cannot login

I played around with light.conf, and got it to work my putting the login info under the heading [SeatDefaults].

Here's my conf file:

[LightDM]
minimum-vt=1
run-directory=/run/lightdm

[SeatDefaults]
autologin-user=larry
autologin-user-timeout=0
session-wrapper=/etc/lightdm/Xsession
pam-service=lightdm-autologin

Hope it works for you too!

Offline

#10 2014-09-05 18:17:16

midixinga
Member
Registered: 2014-01-18
Posts: 187

Re: [SOLVED] lightdm cannot login

snovik wrote:

sure! here we go

/etc/lightdm/lightdm.conf

[LightDM]
minimum-vt=1
run-directory=/run/lightdm

[SeatDefaults]
session-wrapper=/etc/lightdm/Xsession
pam-service=lightdm-autologin

Hmm, seems to be ok for a standard lightdm-gtk2-greeter (which is installed ?)

Are you sure, that you have the same Keyboard-Settings for X as for tty ?

When lightdm-screen appears, you can choose "other/more" (I don't know in english) instead of your username and check your password in the login-name field


[Desktop | Intel i4570 CPU |  Internal Graphics HD4600 |  ASRock H87M Pro4 | 8 GB RAM | UEFI/GPT | Samsung SSD 850 | Single-Boot Arch 64 Bit | sytemd-boot | KDE 4 xfce Plasma5]

Offline

#11 2014-09-27 09:59:57

snovik
Member
Registered: 2012-05-06
Posts: 140

Re: [SOLVED] lightdm cannot login

Turned out to be a keyboard layout issue. Lightdm uses US layout regardless of the system settings. If I type my password assume US layout (I have DE by default) then it lets me in. It is a lightdm issue since lots of people seem to complain about it on google.

Still have no other solution rather than login in "virtual" US layout

Offline

#12 2014-09-27 11:03:18

Morn
Member
Registered: 2012-09-02
Posts: 613

Re: [SOLVED] lightdm cannot login

snovik wrote:

Turned out to be a keyboard layout issue. Lightdm uses US layout regardless of the system settings

Set your keyboard layout in the X11 config, e.g. /etc/X11/xorg.conf.d/10-evdev.conf (may depend on X version, I'm still using 1.15 because of Catalyst), and LightDM will use it:

Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
	Option "XkbLayout" "de"
EndSection

Offline

#13 2014-09-27 11:50:36

snovik
Member
Registered: 2012-05-06
Posts: 140

Re: [SOLVED] lightdm cannot login

Wow. That was it!
Tnx. While lightdm still shows it is using US at least the actual layout is DE

Offline

Board footer

Powered by FluxBB