You are not logged in.

#76 2015-11-26 20:19:14

helix
Member
Registered: 2013-02-17
Posts: 177

Re: Debtap - A script to convert .deb packages to Arch Linux packages

From man xz:

"-9 requires 674 MiB of memory for compression"

Offline

#77 2015-11-26 20:33:18

kevdog
Member
Registered: 2013-01-26
Posts: 99

Re: Debtap - A script to convert .deb packages to Arch Linux packages

From man xz:
"-9 requires 674 MiB of memory for compression"

Don't I have that between real memory and swap?

$ free -h
              total        used        free      shared  buff/cache   available
Mem:           3.5G        1.1G        276M        448M        2.1G        1.9G
Swap:          3.5G         12M        3.5G

Last edited by kevdog (2015-11-26 20:45:08)

Offline

#78 2015-11-26 20:54:01

helix
Member
Registered: 2013-02-17
Posts: 177

Re: Debtap - A script to convert .deb packages to Arch Linux packages

Try to free some memory first or change "xz -9" to a smaller value, like "xz -1". If that fails too, comment the xz line. Then change "mv *.xz" to "mv *.tar". This will produce a .pkg.tar package instead of the normal .pkg.tar.xz.

Offline

#79 2015-11-26 21:29:25

kevdog
Member
Registered: 2013-01-26
Posts: 99

Re: Debtap - A script to convert .deb packages to Arch Linux packages

I freed up enough memory that it said over 2G free but that still failed -- seems like I'm not in rare company as I've seen others complain about this as well with various other processes with xz.

Anyway I ended up modifying your script and changed the xz -9 option to xz -1 and the package built correctly.  I tried with the xz -8 option and that complained about the memory allocation error as well, so I'm sure there is a sweet spot somewhere between 1 and 8 I'm just missing.  Does xz have to be used?  I guess I could modify the script to use something like gzip or something.   Thanks for your help.

Offline

#80 2015-11-26 21:36:01

helix
Member
Registered: 2013-02-17
Posts: 177

Re: Debtap - A script to convert .deb packages to Arch Linux packages

You can use gzip compression as an alternative. Or no compression at all, just .tar, like I described before. Anyway, I'm glad I helped.

Offline

#81 2015-12-01 23:44:47

dex1
Member
From: Ireland
Registered: 2015-12-01
Posts: 2

Re: Debtap - A script to convert .deb packages to Arch Linux packages

Just want to say big thank you for your script.
I was trying to build and compile from source cryptote package and I wasn't able to success when I came
across dabtap and it worked like a charm.
Cheers.

Offline

#82 2015-12-02 02:18:02

helix
Member
Registered: 2013-02-17
Posts: 177

Re: Debtap - A script to convert .deb packages to Arch Linux packages

Welcome

Offline

#83 2015-12-03 17:48:20

spencer_brown
Member
Registered: 2015-08-21
Posts: 37

Re: Debtap - A script to convert .deb packages to Arch Linux packages

First, I just wanted to thank you for creating this extremely helpful program.  I also wondered if you could perhaps help me?
I created a package from a .deb file for adobe connect.  I got this warning

Warning: These dependencies (depend =   fields) could not be translated into Arch Linux packages names:
ia32-libs

edit:
After some research it seems to be a debian/ubuntu specific file.  Does anyone know if there is an Archlinux equivalent?

Last edited by spencer_brown (2015-12-03 17:50:46)

Offline

#84 2015-12-03 17:56:17

helix
Member
Registered: 2013-02-17
Posts: 177

Re: Debtap - A script to convert .deb packages to Arch Linux packages

Either try to find what is the equivalent package for Arch and edit .PKGINFO to replace ia32-libs with the correct name or remove depend = ia32-libs line from .PKGINFO and hope it works

Offline

#85 2015-12-18 06:04:17

kitsuna
Member
Registered: 2015-12-18
Posts: 6

Re: Debtap - A script to convert .deb packages to Arch Linux packages

I cant use this every time i try to do the -u every single link gives 404 then it terminates.

Offline

#86 2015-12-18 06:08:20

helix
Member
Registered: 2013-02-17
Posts: 177

Re: Debtap - A script to convert .deb packages to Arch Linux packages

What is your distro?

Offline

#87 2015-12-18 06:11:05

kitsuna
Member
Registered: 2015-12-18
Posts: 6

Re: Debtap - A script to convert .deb packages to Arch Linux packages

helix wrote:

What is your distro?

Netrunner rolling

Offline

#88 2015-12-18 06:15:58

helix
Member
Registered: 2013-02-17
Posts: 177

Re: Debtap - A script to convert .deb packages to Arch Linux packages

kitsuna wrote:
helix wrote:

What is your distro?

Netrunner rolling

Sorry, this script only supports Arch

Offline

#89 2015-12-18 06:22:02

kitsuna
Member
Registered: 2015-12-18
Posts: 6

Re: Debtap - A script to convert .deb packages to Arch Linux packages

As in base arch or something? sorry i dont know as much as i probably should about these kind of things. AFAIK netrunner rolling is a arch based distro so i figured it would work.

Offline

#90 2015-12-18 06:27:27

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,290

Re: Debtap - A script to convert .deb packages to Arch Linux packages

Netrunner rolling is Manjaro based, which is based on Arch but is not Arch. It doesn't have the tools needed for this.

Last edited by Scimmia (2015-12-18 06:31:35)

Offline

#91 2015-12-18 06:30:33

helix
Member
Registered: 2013-02-17
Posts: 177

Re: Debtap - A script to convert .deb packages to Arch Linux packages

I never tested if this script works on any Arch-based distro, except Arch, so I can't quarantee if it works for these . FYI I just tested it on my Arch and it works fine.

Offline

#92 2015-12-18 06:31:33

kitsuna
Member
Registered: 2015-12-18
Posts: 6

Re: Debtap - A script to convert .deb packages to Arch Linux packages

Scimmia wrote:

Netrunner is Manjaro based, which is based on Arch but not Arch. It doesn't have the tools needed for this.

ah ok thanks, guess i am just fucked as far as these scanner drivers go. ty for the info.

Offline

#93 2016-02-03 12:56:05

gatonero
Member
From: Aachen
Registered: 2010-08-01
Posts: 9

Re: Debtap - A script to convert .deb packages to Arch Linux packages

When running debtap -u and after that deptap package.deb (both as root)I get this;

[root@tux Downloads]# debtap -u
[....]
==> All steps successfully completed!

[root@tux Downloads]# debtap KODAKVERITE55-v1171-150827-printer-utility.amd64.deb 
Error: You must run at least once "debtap -u" with root privileges (preferably recently), before running this script

Where is the error?

Offline

#94 2016-02-06 14:44:17

helix
Member
Registered: 2013-02-17
Posts: 177

Re: Debtap - A script to convert .deb packages to Arch Linux packages

Sorry for my late reply, I had and still have network issues related to my ISP that kept me away from internet for about a week. Try to delete (as root) /var/cache/debtap and retry.

Offline

#95 2016-02-09 12:46:57

eNTi
Member
Registered: 2006-04-30
Posts: 109

Re: Debtap - A script to convert .deb packages to Arch Linux packages

great idea, great script. got the following though:

Warning: These provisions (provides =   fields) could not be translated into Arch Linux packages names:
varicad

==> Generating .INSTALL file...

:: If you want to edit .PKGINFO and .INSTALL files (in this order), press (1) For vi (2) For nano (3) For a custom editor or any other key to continue: 3
:: Enter command for running custom editor: 
/usr/bin/debtap: line 3636: .PKGINFO: command not found
/usr/bin/debtap: line 3636: .INSTALL: command not found

and even though the script states that the package was created sucessfully the following happens when i try to install the package:

:: Processing package changes...
(1/1) installing varicad2015-en                    [----------------------] 100%
postinst called with unknown argument `3.03-1'
error: command failed to execute correctly

Last edited by eNTi (2016-02-09 12:52:38)

Offline

#96 2016-02-09 13:18:15

helix
Member
Registered: 2013-02-17
Posts: 177

Re: Debtap - A script to convert .deb packages to Arch Linux packages

In the ":: Enter command for running custom editor:" prompt you must type a command that runs your preferred editor, for example "kwrite" and then press Enter. You can also use one of the two default editors, vi and nano.

Offline

#97 2016-03-10 10:36:12

helix
Member
Registered: 2013-02-17
Posts: 177

Re: Debtap - A script to convert .deb packages to Arch Linux packages

Update 2.6

Changelog:

* "Here-Document terminators broken during conversion in .INSTALL" bug fixed
* Added choice for using default editor to edit .PKGINFO and .INSTALL metadata files
* Now removes "debconf" from both dependencies and all lines containing it in .INSTALL
* Added "ttf-liberation" and "ttf-ms-fonts" to ready translated packages names
* Minor improvements and optimizations
* Other bug fixes

Offline

#98 2016-04-17 08:46:11

helix
Member
Registered: 2013-02-17
Posts: 177

Re: Debtap - A script to convert .deb packages to Arch Linux packages

Update 2.7

Changelog:

* Fixed broken link, useful for updating debtap database
* Virtual packages list has been removed from both debtap and debtap-p64 and now is downloaded as part of the database with "debtap -u" from my github page. This was done for 2 reasons: i) Much less code in both scripts (approximately 800 lines in both scripts) ii) Easier updating of the list. If you update to this version you must run again "debtap -u" before using it.

Offline

#99 2016-04-23 09:42:09

helix
Member
Registered: 2013-02-17
Posts: 177

Re: Debtap - A script to convert .deb packages to Arch Linux packages

Update 2.8

Changelog:

* Now downloads ubuntu packages list for its database for stable version of ubuntu instead of development version

Last edited by helix (2016-04-23 09:43:04)

Offline

#100 2016-04-26 00:12:45

dex1[one]
Member
Registered: 2015-12-18
Posts: 1

Re: Debtap - A script to convert .deb packages to Arch Linux packages

I was using debtap to install Bitsquare-64bit-0.4.3.deb and although I managed to run it, I got some errors before installation completed:

[contrite@archbox AURbuilds]$ sudo pacman -U /home/contrite/AURbuilds/Bitsquare-0.4.3-1-x86_64.pkg.tar.xz
loading packages...
resolving dependencies...
looking for conflicting packages...

Packages (1) Bitsquare-0.4.3-1

Total Installed Size:  217.74 MiB

:: Proceed with installation? [Y/n] 
(1/1) checking keys in keyring                                                                       [############################################################] 100%
(1/1) checking package integrity                                                                     [############################################################] 100%
(1/1) loading package files                                                                          [############################################################] 100%
(1/1) checking for file conflicts                                                                    [############################################################] 100%
(1/1) checking available disk space                                                                  [############################################################] 100%
:: Processing package changes...
preinst called with unknown argument `0.4.3-1'
error: command failed to execute correctly
(1/1) installing Bitsquare                                                                           [############################################################] 100%
postinst called with unknown argument `0.4.3-1'
error: command failed to execute correctly
[contrite@archbox AURbuilds]$

Besides not having a shortcut added to the menu in the postinst called with unknown argument `0.4.3-1' is there
anything else I am short of ? How about preinst called with unknown argument `0.4.3-1' ? Is there any drawback?

I'd be grateful when adviced how to fix it. Cheers.

P.S.
I use debtap 2.7-1

Offline

Board footer

Powered by FluxBB