You are not logged in.

#26 2014-11-29 06:43:39

aurelieng
Member
Registered: 2010-02-02
Posts: 99

Re: [SOLVED] gnupg 2.1.0-4 upgrade breaks passphrase via STDIN

ignorant wrote:

Wow this is weird, at least I can sign emails again. Thank you TE for clearing this up. It didn't work at first until I edited my config files. That wasn't mentioned on the mailing list.

I have no luck so far with enigmail+thunderbird, despite the instructions on the wiki. I can dig further if I know it can work, otherwise I'll just wait. Are you using Enigmail+TB too ? Can you enrypt mails too?

Offline

#27 2014-11-30 10:53:29

chaonaut
Member
From: Kyiv, Ukraine
Registered: 2014-02-05
Posts: 382

Re: [SOLVED] gnupg 2.1.0-4 upgrade breaks passphrase via STDIN

TE wrote:

I've closed out the Arch bug report and GnuPG bug report - I tried to describe the change with a new wiki subsection:
https://wiki.archlinux.org/index.php/Gn … passphrase
Please clean it up with more info from your own testing/usage scenarios. I can only confirm duply/duplicity are working...

as for me, gpg-preset-passphrase still not working with those new options.
after restarting gpg-agent and running /usr/lib/gnupg/gpg-preset-passphrase -c XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX,  the damn thing asks passhrase again anyway.
as a workaround, i set default-cache-ttl to 86400 (24h), but that's an ugly crutch.

Last edited by chaonaut (2014-11-30 12:17:16)


— love is the law, love under wheel, — said aleister crowley and typed in his terminal:
usermod -a -G wheel love

Offline

#28 2014-12-01 14:23:40

Kooothor
Member
From: Paname
Registered: 2008-08-02
Posts: 223
Website

Re: [SOLVED] gnupg 2.1.0-4 upgrade breaks passphrase via STDIN

TE wrote:
$ grep loop ~/.gnupg/*.conf
~/.gnupg/gpg-agent.conf:allow-loopback-pinentry
~/.gnupg/gpg.conf:pinentry-mode loopback

This worked for me, with mutt for signing emails. Thanks! smile

Offline

#29 2014-12-07 12:42:00

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 10,016
Website

Re: [SOLVED] gnupg 2.1.0-4 upgrade breaks passphrase via STDIN

Thank you all for this thread.  The solution provided also work for detach-sign operations... although in my case, it was enough to just added the line to a freshly created ~/.gnupg/gpg-agent.conf and not use the extra switch.  In fact, the extra switch throws errors:

% gpg --detach-sign --pinentry-mode loopback --local-user 5EE46C4C md5sums.txt                       :(
gpg: setting pinentry mode 'loopback' failed: Not supported
gpg: skipped "5EE46C4C": No secret key
gpg: signing failed: No secret key

CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#30 2014-12-07 12:57:19

Allan
Member
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,941
Website

Re: [SOLVED] gnupg 2.1.0-4 upgrade breaks passphrase via STDIN

Just create a new root key:

		sudo rm -fr /etc/pacman.d/gnupg
		sudo pacman-key --init
		sudo pacman-key --populate archlinux

You probably want to install and start haveged to speed up key generation.  The add and lsign any additional keys needed.

Offline

#31 2014-12-07 13:02:34

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 10,016
Website

Re: [SOLVED] gnupg 2.1.0-4 upgrade breaks passphrase via STDIN

@Allan - Sorry, I don't understand your suggestion.  How does the contents of /etc/pacman.d/gnupg affect detach-sign operations?


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#32 2014-12-07 13:37:37

Allan
Member
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,941
Website

Re: [SOLVED] gnupg 2.1.0-4 upgrade breaks passphrase via STDIN

graysky wrote:

@Allan - Sorry, I don't understand your suggestion.  How does the contents of /etc/pacman.d/gnupg affect detach-sign operations?

Sorry - I thought this was the pacman-key thread...  I'll stop drinking now...

Offline

#33 2014-12-09 14:18:00

Dirk Sohler
Member
From: Hamburg, Germany
Registered: 2009-10-03
Posts: 109

Re: [SOLVED] gnupg 2.1.0-4 upgrade breaks passphrase via STDIN

TE wrote:
$ grep loop ~/.gnupg/*.conf
~/.gnupg/gpg-agent.conf:allow-loopback-pinentry
~/.gnupg/gpg.conf:pinentry-mode loopback

Now Gajim and Claws-Mail just fail directly instead of asking for a (non-existent) passphrase and then fail.

Offline

#34 2014-12-09 14:58:19

TE
Member
Registered: 2014-06-21
Posts: 76

Re: [SOLVED] gnupg 2.1.0-4 upgrade breaks passphrase via STDIN

Dirk Sohler wrote:

Now Gajim and Claws-Mail just fail directly instead of asking for a (non-existent) passphrase and then fail.

You may with to visit this thread instead, graysky is having app problems with his package signing:

https://bbs.archlinux.org/viewtopic.php?id=190781

It's highly possible what I had to do to get unattended passphrase to work with duplicity/duply is not enough for other apps, graysky has been trying a number of things over in that thread... sad

Offline

Board footer

Powered by FluxBB