You are not logged in.

#26 2015-11-16 14:32:14

Registered: 2015-11-04
Posts: 5

Re: Booting stops at Loading initial ramdisk...

I might have disrupted the thread for another issue that has similar consequences.

Anyway, I finally solved my issue by modifying a BIOS parameter:
ASROCK z77nITX : Advanced/North Bridge configuration/IGPU Multi-Monitor > DISABLED

It failed exactly after the same updates you had guys, not sure it's related, hopefully, it is.


#27 2015-11-16 16:34:03

From: Athens, Greece
Registered: 2010-04-06
Posts: 214

Re: Booting stops at Loading initial ramdisk...

gdeshors wrote:

If I can find a little free time when my babies have a nap, I'm willing to do a bisect, but I never did it on the kernel, only on other software I develop at work or at home.
I checked … .y&ofs=150 and saw that there are about 550 commits between 4.2.3 and 4.2.4, which makes it about 6 bisect steps. Is it the right repository to do the bisction ?
Also, if it exists I would appreciate a pointer to a more detailed guide to the mentioned step "use the kernel PKGBUILD to create a custom kernel based on the working git commit". I currently don't know how to do that (but didn't search yet, I admit).

Yes, that's the one. It should not be more than 6 or 7 steps indeed. What I would do is create a new package (let's say linux-bisect) using the standard archlinux PKGBUILD. Instead of using the stock kernel package use the git repository as source and "checkout" the commit of the current bisect step before building it (right after cd "${srcdir}/${_srcname}" in prepare() maybe). Don't forget to rename linux.preset to linux-bisect.preset (both the file and its references in the PKGBUILD). Then just mkinitcpio -p linux-bisect as usual. Adding an entry of the initramfs (initramfs-linux-bisect.img) and the kernel binary (vmlinuz-linux-bisect) to a new bootloader entry should allow you to select the newly built kernel in the boot selection menu. It seems like a lot of work but it's actually fairly straightforward.

See also the relevant wiki entry on bisecting for bugs.


#28 2015-11-20 22:34:48

Registered: 2015-01-22
Posts: 34

Re: Booting stops at Loading initial ramdisk...

I tried to setup the bisect, and I could use a little help... I'm a bit stuck making the package. I checked out the git tree in /data/linux-git/src/linuxsrc, put the PKGBUILD in /data/linux-git, and the other needed files like this :

[joebar@bureau64:/data/linux-git] $ ls
linux-git.install  linux-git.install.pkg  pkg  PKGBUILD  src
[joebar@bureau64:/data/linux-git] $ ls src/
config.x86_64     linux-git.preset  linuxsrc/         

Then when I try to build the package, it fails because the directory /data/linux-git/pkg/linux-git/lib/modules/4.2.3-ARCH-dirty/ doesn't exist :

$ makepkg -efs
  INSTALL /data/linux-git/pkg/linux-git/lib/firmware/cpia2/stv0672_vp4.bin
  INSTALL /data/linux-git/pkg/linux-git/lib/firmware/yam/1200.bin
  INSTALL /data/linux-git/pkg/linux-git/lib/firmware/yam/9600.bin
  DEPMOD  4.2.3-ARCH
ln: impossible de créer le lien symbolique « /data/linux-git/pkg/linux-git/lib/modules/4.2.3-ARCH-dirty/extramodules »: Aucun fichier ou dossier de ce type
==> ERREUR : Une erreur s’est produite dans package_linux-git().

And true enough, this directory doesn't exist, nevertheless there exists a /data/linux-git/pkg/linux-git/lib/modules/4.2.3-ARCH/. So there is a discrepancy on the version auto-generated with a "-dirty", and I can't find why. I noticed a "KERNEL_VERSION=4.2.3-ARCH-dirty" in linux-git.install.pkg but that's not something I seem to have control over, it gets regenerated automatically.
How should I correct my build ? Thanks in advance


#29 2016-10-20 20:27:47

From: U.S
Registered: 2013-02-01
Posts: 2

Re: Booting stops at Loading initial ramdisk...

What this issue ever resolved? I am also facing the same issue with the new 4.8 kernel. I have resorted to using the LTS kernel.


#30 2016-10-21 13:24:54

Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 11,835

Re: Booting stops at Loading initial ramdisk...

It's unlikely that you have the exact same issue that was present ~12 months ago. Please open a new topic and provide the relevant information that was requested in this one. … bumping.22


Mobo: MSI MAG X570S TORPEDO MAX // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.


Board footer

Powered by FluxBB