You are not logged in.

#26 2016-03-04 17:00:05

Edska
Member
Registered: 2016-03-04
Posts: 3

Re: Asus GL552V

Hello guys. I am having the same problem with my fan speed and 4.5-rc6 mainline kernel doesn't help for me. My fan goes at max speed (25500 RPM) and I can't find solution how to make it work at normal speeds depending on CPU temperature.

asus-isa-0000
Adapter: ISA adapter
cpu_fan:     25500 RPM
temp1:        +23.0C

I have the same ASUS GL752VW. Only have basic Arch install and newest mainline kernel. No graphical environment, no nvidia drivers. Just fresh install and mainline kernel 4.5-rc6.

Any ideas how to solve this issue with fan speed?

Last edited by Edska (2016-03-04 17:02:49)

Offline

#27 2016-03-04 19:10:23

SHARPY
Member
From: Toronto
Registered: 2014-09-11
Posts: 14
Website

Re: Asus GL552V

Have you done any extra tinkering with sensors? lm_sensors seemed to take control for me. I have the same laptop, however I was on 4.5rc3. Try starting lm_sensors service.

Last edited by SHARPY (2016-03-04 19:35:11)


I like.....stuff

Offline

#28 2016-03-04 19:39:55

Edska
Member
Registered: 2016-03-04
Posts: 3

Re: Asus GL552V

When first time I installed Arch and noticed my fan speed I messed up a lot with sensors, sensors -s, pwmconfig and sesnros-detect. Nothing helped. Then I installed new mainline rc kernel and problem was the same. Then I thought that messing with lm_sensors might be the problem. Then I reinstalled everything without touching anything related with lm_sensors and problem is still the same. Now after that installed lm_sensors again, but I think it is not causing any problems.

Offline

#29 2016-03-04 20:09:29

SHARPY
Member
From: Toronto
Registered: 2014-09-11
Posts: 14
Website

Re: Asus GL552V

So, just so I am clear. You have installed lm_sensors again with a fresh install and have not had any success with fan speeds being controlled?


I like.....stuff

Offline

#30 2016-03-04 20:36:00

Edska
Member
Registered: 2016-03-04
Posts: 3

Re: Asus GL552V

Unfortunately - no. Can't find solution for couple of days hmm

Offline

#31 2016-03-04 20:38:29

SHARPY
Member
From: Toronto
Registered: 2014-09-11
Posts: 14
Website

Re: Asus GL552V

I'll see if I can find some time to load up the latest rc on my laptop, I am afraid to find some regression in regards to this issue in my case. If I can get around to it, I'll report back.


I like.....stuff

Offline

#32 2016-03-04 21:35:55

ClaudioP
Member
From: Portugal
Registered: 2012-03-11
Posts: 60

Re: Asus GL552V

Edska wrote:

Hello guys. I am having the same problem

Unfortunately  this is a painful problem this laptop has whenever NVidia is loaded.
If you have no NVidia blob on your system everything works fine in regards to lm_sensors, nvidia is the point of failure.

SHARPY managed to solve it somehow (he has a slightly different laptop, the 17" version), I also did the same for several times but it always ends up messed up, either by updates or by black magic.

I recommend you to do a work partition and a games/gpu workload partition, for the former deactivate the GPU, for the latter deactivate the iGPU.

I tried to do it (without deactivating the iGPU) with Ubuntu 16.04 beta (the GNOME flavour), but after installing bumblebee and the nVidia driver it just refuses to boot.
Will simply wait for the final release, and if its not solved until then will fill a bug on their launchpad.
Ubuntu is the user friendly and best supported distro, if it is unable to configure a graphic card properly then something is very very wrong.


Ahh... stuff

Offline

#33 2016-03-09 19:33:37

Xwang
Member
Registered: 2012-05-14
Posts: 321

Re: Asus GL552V

SHARPY wrote:

Quick update. I am now running mainline 4.5rc2, so far my Fan problem has gone. The fans start off around 1900rpm and gradually increase and decrease as the temps fluctuate. I was able to run benchmarks via Unigine Heaven with very decent results (I don't recall but it was something around avg 32fps 1080P on medium settings) during this time my temps never rose abouve 77C. Working out some issues now with steam. Optirun is segfaulting with it, seems to be library issues. That's all for now. Thanks for all your help ClaudioP.

Hi, since I'm going to buy a GL752VW-T4157T, can you please tell me if it is possible to use the hdmi and/or displayport to connect an external monitor and if the nvidia card needs to be activated to do so.
Moreover can you tell me if, also in this laptop, it is not possible to deactivate the nvidia card by bios?
Finally is there any problem with the pre installed windows10? Is it installed with UEFI or BIOS? Is there secure boot or something strange which is not possible to deactivate by bios? Is there any issue in having the SDD seen by the OS (I would like to install linux on it)?
Thank you very much,
Xwang


I'm still learning English so please excuse me if my English is not good enough and feel free to correct me via PM if you want.

Offline

#34 2016-03-20 16:21:13

SHARPY
Member
From: Toronto
Registered: 2014-09-11
Posts: 14
Website

Re: Asus GL552V

Xwang wrote:
SHARPY wrote:

Quick update. I am now running mainline 4.5rc2, so far my Fan problem has gone. The fans start off around 1900rpm and gradually increase and decrease as the temps fluctuate. I was able to run benchmarks via Unigine Heaven with very decent results (I don't recall but it was something around avg 32fps 1080P on medium settings) during this time my temps never rose abouve 77C. Working out some issues now with steam. Optirun is segfaulting with it, seems to be library issues. That's all for now. Thanks for all your help ClaudioP.

Hi, since I'm going to buy a GL752VW-T4157T, can you please tell me if it is possible to use the hdmi and/or displayport to connect an external monitor and if the nvidia card needs to be activated to do so.
Moreover can you tell me if, also in this laptop, it is not possible to deactivate the nvidia card by bios?
Finally is there any problem with the pre installed windows10? Is it installed with UEFI or BIOS? Is there secure boot or something strange which is not possible to deactivate by bios? Is there any issue in having the SDD seen by the OS (I would like to install linux on it)?
Thank you very much,
Xwang

Hi Xwang,

I have never tested the display port or HDMI under linux, if I had to guess I would say no to requiring NVIDIA to work. The Intel graphics should take care of everything, the NVIDIA is only there as the 3D Controller. I'll see if I can give this a test today and report back. As for deactivating the NVIDIA card via BIOS, this does not look possible. I was very surprised as to how few options the BIOS on this system actually has. The preinstalled Windows 10 is UEFI and IMHO is trash. I am guessing it is a combo of the non ssd drive it came installed on plus all the extra crapware installed by manufacturer that makes it very sluggish. This is not to say that Windows 10 itself isn't kind of crappy, it works well enough, but updates often fail, I get worse battery life in it than with Arch, not to mention the whole Microsoft spyware thing. You will have to deactivate secure boot to get arch installed.

In regards to installing Linux on it, I'd say give it a shot. Currently I am only dealing with one issue which is the fan speed not being properly controlled. I am hoping this will be fixed soon via kernel releases. I am running 4.5 and have regressed back to having these issues. 4.5-rc2 Had fixed them for me.

Last edited by SHARPY (2016-03-20 16:22:52)


I like.....stuff

Offline

#35 2016-03-20 16:43:53

SHARPY
Member
From: Toronto
Registered: 2014-09-11
Posts: 14
Website

Re: Asus GL552V

I have just tested the HDMI without initializing the NVIDIA controller and have confirmed my theory. It works!


I like.....stuff

Offline

#36 2016-03-20 16:50:24

Xwang
Member
Registered: 2012-05-14
Posts: 321

Re: Asus GL552V

Thanks, even if at the end I've bought an asus n752vx which should arrive tomorrow and which I hope will be very similar if not identical as far as concerns the management of video outputs.


I'm still learning English so please excuse me if my English is not good enough and feel free to correct me via PM if you want.

Offline

Board footer

Powered by FluxBB