You are not logged in.

#26 2016-01-18 13:32:24

arbacle
Member
Registered: 2015-11-16
Posts: 22

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

I just bit the bullet and updated.

Had the same issue - after entering my login credentials, I was thrown back to tty1. After downgrading sddm-kcm to 5.5.2-1 my system worked again.

Then I've installed the new version again and removed (actually just renamed it) SDDM's cache and now things are working.

Thanks arojas!

Offline

#27 2016-01-18 13:57:33

neXyon
Member
Registered: 2015-11-19
Posts: 8

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

Deleting the cache(s) did not work for me even though I tried multiple times to delete, restart sddm and login. I also tried to downgrade sddm-kcm, which didn't help either, only when I also downgraded qt5-base it worked again.

Last edited by neXyon (2016-01-18 13:58:08)

Offline

#28 2016-01-18 14:29:05

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 16,202

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

It would be very weird if sddm-kcm had any effect on this issue. It parses and edits config files, in no way is it directly linked with sddm and will certainly not write any config changes arbitrarily without the user's explicit invocation. (And I'm fairly certain there were no breaking changes in it from the 5.5.2 and 5.5.3 version bump)

Offline

#29 2016-01-18 16:31:28

Rog131
Member
Registered: 2015-08-23
Posts: 90

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

What theme are you using ?
A fresh KDE bug report:   Bug 358171 - Breeze theme breaks sddm - login screen presented three times - https://bugs.kde.org/show_bug.cgi?id=358171

Offline

#30 2016-01-18 16:39:51

lesto
Member
Registered: 2010-07-13
Posts: 115

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

deleting cache does not work, another PC using lightDM works fine.

edit: changing theme SEEMS to solve for me!

Last edited by lesto (2016-01-18 16:42:10)

Offline

#31 2016-01-18 16:59:25

cappuccino
Member
Registered: 2012-12-26
Posts: 97

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

lesto wrote:

edit: changing theme SEEMS to solve for me!

Same here [I hope] smile

Offline

#32 2016-01-18 17:16:51

neXyon
Member
Registered: 2015-11-19
Posts: 8

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

V1del wrote:

It would be very weird if sddm-kcm had any effect on this issue.

Yep, I updated it again and it still works with the old qt5-base.

Rog131 wrote:

What theme are you using ?
A fresh KDE bug report:   Bug 358171 - Breeze theme breaks sddm - login screen presented three times - https://bugs.kde.org/show_bug.cgi?id=358171

Using the default theme solves it for me too!

Offline

#33 2016-01-18 17:19:26

zersaa
Member
From: Pskov, Russia
Registered: 2009-02-09
Posts: 28

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

@Cuke: Confirm, I have no problem with `maui` theme.

arojas wrote:

Everybody: please remove *both* /var/lib/sddm/.cache and ~/.cache and see if it improves things.

Unfortunately it didn't help.

zersaa wrote:

I encountered this problem on desktop and notebook, both with intel graphics.

it works fine on desktop with nvidia-340xx.

Offline

#34 2016-01-18 17:21:17

michis
Member
Registered: 2015-12-12
Posts: 77

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

Hm, on my up-to-date system sddm with breeze theme works.
EDIT: with xf86-video-ati

Last edited by michis (2016-01-18 17:23:09)

Offline

#35 2016-01-18 17:54:00

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 16,202

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

Works here as well with nvidia, likely an intel graphics speciality... I wonder if the driver cached some broken shaders or similar with the breakage from the QT update and now since this was reverted tries to use them and keels over? Weird that

Offline

#36 2016-01-18 21:01:54

prash
Member
Registered: 2011-08-18
Posts: 57

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

Rog131 wrote:

What theme are you using ?
A fresh KDE bug report:   Bug 358171 - Breeze theme breaks sddm - login screen presented three times - https://bugs.kde.org/show_bug.cgi?id=358171

Yes, changing away from breeze theme to something else fixed the problem for me. For the record, I have Intel GMA 4500MHD.

Offline

#37 2016-01-18 23:09:01

halogene
Member
Registered: 2013-05-29
Posts: 45

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

I can now confirm that deleting the cache only worked once for me. I now changed the theme to maui and login works again.

(i915 GPU)

Last edited by halogene (2016-01-18 23:09:22)

Offline

#38 2016-01-19 00:32:49

jrmrjnck
Member
From: USA
Registered: 2011-01-17
Posts: 32

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

I also have good results switching to maui theme.

That bug is filed against kcm_sddm, which doesn't seem like the correct place - it's probably either sddm or the breeze theme, right?

Also, I found that sddm works fine if run directly from a root console, whereas it fails when run through systemd. Whenever the sddm service is running, running startx from another user console returns this error (http://www.x.org/wiki/FAQErrorMessages/#index6h2), but running "startx -- :1" as suggested on that page works. So to me it seems like something in the breeze theme is causing some part of sddm to use X improperly.

Last edited by jrmrjnck (2016-01-19 00:34:37)

Offline

#39 2016-01-20 01:15:15

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,938
Website

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

I will change the theme and retry. (Sorry I have been away -- school started.)


Matt

"It is very difficult to educate the educated."

Offline

#40 2016-01-20 01:49:00

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,938
Website

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

OK, changed theme to Maui and re-updated. I logged in fine. I will mark the thread solved.


Matt

"It is very difficult to educate the educated."

Offline

#41 2016-01-20 06:47:59

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,911

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

This is not a solution, it's a workaround. We still don't know why the Breeze theme is broken

Offline

#42 2016-01-20 13:56:05

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,938
Website

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

I will amend the title accordingly. Thanks for the pointer.


Matt

"It is very difficult to educate the educated."

Offline

#43 2016-01-21 07:55:35

neXyon
Member
Registered: 2015-11-19
Posts: 8

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

According to the bug report (https://bugs.kde.org/show_bug.cgi?id=358171) the recent update (plasma-framework 5.18.0-2) fixed it for some people. Not for me though, just like Jonathan Doman in the bug report, I could never login with the breeze theme.

Offline

#44 2016-01-21 09:09:35

firekage
Member
From: Eastern Europe, Poland
Registered: 2013-06-30
Posts: 609

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

BTW - do you use maybe nvidia cards with nouveau? I wanted to check something, so i installed nouveau instead of nvidia drivers and after reboot...screen was flickering, SDDM could not launch and in console i had massive amounts of sig crash.

Offline

#45 2016-01-22 02:06:04

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,938
Website

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

I have an Optimus setup, so I boot with the Intel card. I usually boot and run only the nVdia card, but there is a bug in the xorg drivers preventing me from doing that at the present.


Matt

"It is very difficult to educate the educated."

Offline

#46 2016-01-22 09:53:52

viperpaulo
Member
Registered: 2012-02-09
Posts: 8

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

I've the exact same problem.
It works fine when booting with lts kernel but unfortunately removing cache directories had no effect..

Offline

#47 2016-01-22 15:48:12

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,938
Website

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

Changing the theme didn't help? I am reluctant to think it is the same issue if changing the theme didn't help.


Matt

"It is very difficult to educate the educated."

Offline

#48 2016-01-22 16:33:30

viperpaulo
Member
Registered: 2012-02-09
Posts: 8

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

You're right, chaging the theme to Maui helped. However Brise theme was working with lts kernel...
I'm using intel driver

Last edited by viperpaulo (2016-01-22 16:33:59)

Offline

#49 2016-02-02 19:54:49

ilyvasile
Member
Registered: 2016-02-02
Posts: 1

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

Enabling DRI 3 in intel driver conf solved problem with sddm login for me.
https://wiki.archlinux.org/index.php/in … .28DRI3.29
I have optimus with bumblebee

Last edited by ilyvasile (2016-02-02 19:57:24)

Offline

#50 2016-02-04 06:19:12

notbuu
Member
From: AUT
Registered: 2014-02-14
Posts: 7

Re: [WORKAROUND] SDDM/Breeze Issue With qt5-* Package Upgrade

@ilyvaile: Enabling DRI 3 solved the issue for me too. Thx!

Offline

Board footer

Powered by FluxBB