You are not logged in.

#26 2017-02-01 19:34:40

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,259

Re: gpg: keyserver refresh failed: No keyserver available

And my initial suspicion was correct. That is not the default nsswitch.conf; you've been neglecting your .pacnew files.

Offline

#27 2017-02-01 23:16:11

titaniumbones
Member
Registered: 2013-12-20
Posts: 47

Re: gpg: keyserver refresh failed: No keyserver available

Thanks @scimmia. For other people following this up https://wiki.archlinux.org/index.php/Pa … cnew_files explains some methods for maintaining conf files.

Offline

#28 2017-02-02 16:45:49

AlexIL
Member
From: Israel
Registered: 2016-01-02
Posts: 45
Website

Re: gpg: keyserver refresh failed: No keyserver available

titaniumbones wrote:

Thanks @scimmia. For other people following this up https://wiki.archlinux.org/index.php/Pa … cnew_files explains some methods for maintaining conf files.

So what did you do?
I'm getting this problem again after  reinstalling arch.

Offline

#29 2017-02-02 16:51:06

titaniumbones
Member
Registered: 2013-12-20
Posts: 47

Re: gpg: keyserver refresh failed: No keyserver available

I used pacdiff to identify un-updated files in /etc, and fix them.  But it didn't actually solve my problem, so I'm not convinced it's the origin of the problem If @scimmia is listening, it could  be that they have ideas?

Last edited by titaniumbones (2017-02-02 16:52:13)

Offline

#30 2017-02-03 01:01:15

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,259

Re: gpg: keyserver refresh failed: No keyserver available

No other ideas, unfortunately. AFAIK, it should work with the default nsswitch and an up-to-date gnupg (with an up to date dirmngr running).

Offline

#31 2017-02-03 14:13:46

AlexIL
Member
From: Israel
Registered: 2016-01-02
Posts: 45
Website

Re: gpg: keyserver refresh failed: No keyserver available

Running pacdiff did nothing for me...
Could it be a bug on pacman?

Offline

#32 2017-02-05 10:24:05

tscs37
Member
Registered: 2016-08-26
Posts: 3

Re: gpg: keyserver refresh failed: No keyserver available

I've had the same issue and it seems to have to do with an incorrectly configured keyserver, atleast for me changing from hkp to http solved the issue *after* killing dirmngr.

Make sure that you are using the correct protocol, switching from hkp to http, then killing dirmngr solved the issue for me (in addition to the things suggested here)

Offline

#33 2017-02-05 16:49:13

AlexIL
Member
From: Israel
Registered: 2016-01-02
Posts: 45
Website

Re: gpg: keyserver refresh failed: No keyserver available

tscs37 wrote:

I've had the same issue and it seems to have to do with an incorrectly configured keyserver, atleast for me changing from hkp to http solved the issue *after* killing dirmngr.

Make sure that you are using the correct protocol, switching from hkp to http, then killing dirmngr solved the issue for me (in addition to the things suggested here)

I tried using http://pool.sks-keyservers.net instead of hkp://pool.sks-keyservers.net but no luck.
Could you post here the keyserver that you use and the exact same steps it took you to solve it?

Offline

#34 2017-02-08 07:56:27

eNauz
Member
Registered: 2014-07-21
Posts: 11

Re: gpg: keyserver refresh failed: No keyserver available

I'm still running into this issue on gnupg version gpg (GnuPG) 2.1.18, no matter if I'm trying to update pacman keys or importing a GPG key:

gpg: refreshing 88 keys from hkp://pool.sks-keyservers.net
gpg: keyserver refresh failed: No keyserver available

I tried all proposed solutions in this thread and on the wiki but none of them worked. On my freshly installed arch system this issue was persistent from the beginning.

Offline

#35 2017-02-11 16:12:09

anserk
Member
Registered: 2015-07-29
Posts: 6

Re: gpg: keyserver refresh failed: No keyserver available

For me changing the keyserver in

.gnupg/dirmngr.conf

from

keyserver hkp://keys.gnupg.net

to

keyserver hkp://pgp.mit.edu

fixed the issue.

Offline

#36 2017-02-11 16:15:53

AlexIL
Member
From: Israel
Registered: 2016-01-02
Posts: 45
Website

Re: gpg: keyserver refresh failed: No keyserver available

anserk wrote:

For me changing the keyserver in

.gnupg/dirmngr.conf

from

keyserver hkp://keys.gnupg.net

to

keyserver hkp://pgp.mit.edu

fixed the issue.

I tried running:

sudo pacman-key --refresh-keys --keyserver hkp://pgp.mit.edu

but I get the same error.
Where exactly is .gnupg/dirmngr.conf located?

Offline

#37 2017-02-11 16:18:59

anserk
Member
Registered: 2015-07-29
Posts: 6

Re: gpg: keyserver refresh failed: No keyserver available

should be in your home directory.

Offline

#38 2017-02-11 16:54:29

AlexIL
Member
From: Israel
Registered: 2016-01-02
Posts: 45
Website

Re: gpg: keyserver refresh failed: No keyserver available

anserk wrote:

should be in your home directory.

Actually pacman-key uses the /etc/pacman.d/gnupg/gpg.conf file, I edited its keyserver but no luck..

Offline

#39 2017-02-13 09:57:26

eNauz
Member
Registered: 2014-07-21
Posts: 11

Re: gpg: keyserver refresh failed: No keyserver available

Same for me, changing the keyserver in

.gnupg/dirmngr.conf

allowed me to receive keys with gpg --recv again. However,

pacman-key

stills fails after changing the keyserver in

/etc/pacman.d/gnupg/gpg.conf

Offline

#40 2017-05-06 20:22:35

Shuk
Member
Registered: 2011-07-05
Posts: 8

Re: gpg: keyserver refresh failed: No keyserver available

I had this issue, and was able to solve it using this: https://bbs.archlinux.org/viewtopic.php … 1#p1703981

I created a file

/etc/pacman.d/gnupg/dirmngr.conf

and put there:

standard-resolver

Then I killed dirmngr:

sudo killall dirmngr

After that pacman-key was able to get new keys, but could not apply them due to this bug: https://bugs.archlinux.org/task/53642

Offline

#41 2017-05-14 20:24:31

DoTheEvolution
Member
Registered: 2014-05-07
Posts: 22

Re: gpg: keyserver refresh failed: No keyserver available

adding DNS servers to my /etc/resolv.conf solved this issue

I was doing quick arch install in virtual box and "No keyserver available" started to happen
I knew I went quickly through network setting, and I went for networkd and static IP, but I did not set DNS there.
when I  later put dns entries in to the .network file it did not help
I do have both networkd and resolved enabled and started

after adding dns servers in to /etc/resolv.conf and rebooting, the  refresh went through fine

Last edited by DoTheEvolution (2017-05-15 20:54:13)

Offline

#42 2017-05-17 06:55:53

dom3k
Member
Registered: 2017-05-17
Posts: 1

Re: gpg: keyserver refresh failed: No keyserver available

My solution:
add to /etc/pacman.d/gnupg/gpg.conf

keyserver hkp://ipv4.pool.sks-keyservers.net:80

I was based on https://github.com/asdf-vm/asdf-nodejs/issues/38
Post author: jtzero

Offline

#43 2017-06-18 23:50:00

Cirelli94
Member
Registered: 2016-12-13
Posts: 35

Re: gpg: keyserver refresh failed: No keyserver available

Shuk wrote:

I had this issue, and was able to solve it using this: https://bbs.archlinux.org/viewtopic.php … 1#p1703981

I created a file

/etc/pacman.d/gnupg/dirmngr.conf

and put there:

standard-resolver

Then I killed dirmngr:

sudo killall dirmngr

After that pacman-key was able to get new keys, but could not apply them due to this bug: https://bugs.archlinux.org/task/53642

Thanks, this solved the issue to me.

Offline

#44 2017-10-01 06:51:25

NIPE-SYSTEMS
Member
Registered: 2017-10-01
Posts: 1
Website

Re: gpg: keyserver refresh failed: No keyserver available

DoTheEvolution wrote:

adding DNS servers to my /etc/resolv.conf solved this issue

I was doing quick arch install in virtual box and "No keyserver available" started to happen
I knew I went quickly through network setting, and I went for networkd and static IP, but I did not set DNS there.
when I  later put dns entries in to the .network file it did not help
I do have both networkd and resolved enabled and started

after adding dns servers in to /etc/resolv.conf and rebooting, the  refresh went through fine

This solved my issue. Thanks!

Surprisingly the keyserver update worked fine until last month. Now it seems to be necessary to add an explicit DNS into the resolv.conf ...

Offline

Board footer

Powered by FluxBB