You are not logged in.

#26 2016-04-18 16:56:20

IMBJR
Member
From: INDCMPLX
Registered: 2014-03-16
Posts: 78

Re: X server does not come up in VirtualBox VM after upgrade to kernel 4.5

oliver wrote:
lyndon wrote:

I tried removing the iomem=relaxed parameter and rerunning grub-mkconfig after updating the packages.
I may also need to update Virtualbox to 5.0.16 as I am at 5.0.14. I will try that later today.

I was on 5.0.16 and the upgrade today didn't fix the issue for me

[2016-04-18 08:55] [ALPM] upgraded virtualbox-guest-dkms (5.0.16-3 -> 5.0.16-4)
[2016-04-18 08:55] [ALPM] upgraded virtualbox-guest-utils (5.0.16-3 -> 5.0.16-4)

The old workaround was still good though.

I can confirm 5.0.16 did not resolve the issue.

Offline

#27 2016-04-18 18:21:44

hsz
Member
Registered: 2009-09-25
Posts: 30

Re: X server does not come up in VirtualBox VM after upgrade to kernel 4.5

From my side - I have installed:

community/virtualbox-guest-dkms 5.0.16-4
community/virtualbox-guest-utils 5.0.16-4
core/linux 4.5-1
core/linux-headers 4.5-1 

And set in `syslinux.cfg` iomem kernel flag:

LABEL arch
    MENU LABEL Arch Linux
    LINUX ../vmlinuz-linux
    APPEND root=/dev/sda1 rw iomem=relaxed
    INITRD ../initramfs-linux.img

But the problem still exists. I have huge performance problems even with only gnome-shell running. If I open IDE based on java - my laptop is going to fly into the space and try to land on the barge. :-(


Edit:

I've tried with linux-lts, linux-lts-headers and downgroaded virtualbox-guest packages to 5.0.14   - still there is a problem.

Last edited by hsz (2016-04-18 19:22:25)

Offline

#28 2016-04-19 07:19:29

pethead
Member
From: RU
Registered: 2015-02-25
Posts: 48

Re: X server does not come up in VirtualBox VM after upgrade to kernel 4.5

After upgrading VBox to 5.0.18 and reinstalling ./VBoxLinuxAdditions X runs without iomem=relaxed in kernel parameters!


This Must Be The Place I Waited Years To Leave

Offline

#29 2016-04-19 07:57:46

hsz
Member
Registered: 2009-09-25
Posts: 30

Re: X server does not come up in VirtualBox VM after upgrade to kernel 4.5

FYI: In VirtualBox  File > Check for updates doesn't show any information about the update, but installer is available on the VBox website.

After installing v5.0.18 and running VBoxLinuxAdditions from mounted ISO (in the repo still there is 5.0.16 guest package), removing iomem flag..  everything is fine !

Offline

#30 2016-04-19 09:28:42

kabonkel
Member
Registered: 2016-04-19
Posts: 1

Re: X server does not come up in VirtualBox VM after upgrade to kernel 4.5

lyndon wrote:

[...]
For those who stumble across this who have never changed their kernel parameters before like me (and are using GRUB) all I did was:
Edit /etc/default/grub and append

iomem=relaxed

to the GRUB_CMDLINE_LINUX_DEFAULT variable so mine now looks like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet iomem=relaxed"

Then I ran:

sudo grub-mkconfig -o /boot/grub/grub.cfg

Thank you! This worked on my Arch VM 5.0.16 r105871.

Offline

#31 2016-04-20 17:41:31

marius-arc
Member
Registered: 2016-04-17
Posts: 42

Re: X server does not come up in VirtualBox VM after upgrade to kernel 4.5

hsz wrote:

FYI: In VirtualBox  File > Check for updates doesn't show any information about the update, but installer is available on the VBox website.

After installing v5.0.18 and running VBoxLinuxAdditions from mounted ISO (in the repo still there is 5.0.16 guest package), removing iomem flag..  everything is fine !

Am I understanding this correctly - you are running 5.0.18 Virtualbox, with 5.0.16 guest additions?
On their website I only see 5.0.16 guest additions

Offline

#32 2016-04-21 08:09:41

Luciddream
Member
From: Greece
Registered: 2014-12-08
Posts: 15

Re: X server does not come up in VirtualBox VM after upgrade to kernel 4.5

marius-arc wrote:
hsz wrote:

FYI: In VirtualBox  File > Check for updates doesn't show any information about the update, but installer is available on the VBox website.

After installing v5.0.18 and running VBoxLinuxAdditions from mounted ISO (in the repo still there is 5.0.16 guest package), removing iomem flag..  everything is fine !

Am I understanding this correctly - you are running 5.0.18 Virtualbox, with 5.0.16 guest additions?
On their website I only see 5.0.16 guest additions

I can confirm this works. However I didn't try with 5.0.16 additions, here is the actual dir / file:

http://download.virtualbox.org/virtualbox/5.0.18/
http://download.virtualbox.org/virtualb … 5.0.18.iso

Offline

#33 2016-04-21 08:55:17

hsz
Member
Registered: 2009-09-25
Posts: 30

Re: X server does not come up in VirtualBox VM after upgrade to kernel 4.5

@marius-arc  - Both app and guest additions are in v5.0.18

Also there is some interesting issue: I had set 4 of 8 CPUs for the guest and there was a huge performace problem with i.e. java. If I reduced it to 2 CPUs or 1 CPU - everything is smoother.

Offline

#34 2016-04-21 13:53:02

Feldmarshall
Member
Registered: 2016-04-21
Posts: 4

Re: X server does not come up in VirtualBox VM after upgrade to kernel 4.5

Installing v5.0.18 guest addition solved the problem partially for me. When I run two monitors, both of them in fullhd the screen freezes with broken image. Sometimes gets unfreezed when one of the monitors is reduced in size.

All is working well with iomem-relaxed in kernel options.

Offline

#35 2016-04-22 14:56:59

hb860
Member
Registered: 2014-09-12
Posts: 81
Website

Re: X server does not come up in VirtualBox VM after upgrade to kernel 4.5

Thank you guys. Solved the issue by using this line in my grub.cfg

GRUB_CMDLINE_LINUX_DEFAULT="iomem=relaxed"

I am still running VB 5.0.16.

Offline

#36 2016-04-25 01:46:05

oliver
Member
Registered: 2007-12-12
Posts: 448

Re: X server does not come up in VirtualBox VM after upgrade to kernel 4.5

The latest upgrade resolved the issue for me.  The iomem=relaxed entry has been removed and Xorg still loads

[2016-04-24 21:42] [ALPM] upgraded virtualbox-guest-dkms (5.0.16-4 -> 5.0.18-1)
[2016-04-24 21:42] [ALPM] upgraded virtualbox-guest-utils (5.0.16-4 -> 5.0.18-1)

Last edited by oliver (2016-04-25 01:46:24)

Offline

#37 2016-04-25 07:26:42

lyndon
Member
Registered: 2016-04-14
Posts: 3

Re: X server does not come up in VirtualBox VM after upgrade to kernel 4.5

I can confirm that the 5.0.18-1 versions in the repository fixed the issue for me on one of my VMs and have removed the iomem=relaxed kernel flag.

For what it's worth I am still running Virtualbox 5.0.14 on the host system.

EDIT: I was having some weird issues in an IDE I use to do with cursor positioning after changing resolution, this seems to have gone away after an update to 5.0.18 on the host system.

Last edited by lyndon (2016-04-25 08:37:37)

Offline

#38 2016-04-25 13:41:34

Feldmarshall
Member
Registered: 2016-04-21
Posts: 4

Re: X server does not come up in VirtualBox VM after upgrade to kernel 4.5

In case of multiscreen setup the problem still exists. It is somehow erratic - the X will start, but at some point will stop updating the screen at all. In console there is following massage printed:

[drm:vbox_bo_push_sysram [vboxvideo]] *ERROR*  pushing to VRAM failed

[drm:vbox_bo_push_sysram [vboxvideo]] *ERROR*  unpin bad f39aa200

P.S: I gave up and rolled back to 4.4 kernel. What is interesting is that once the virtualbox video driver got corrupted I had to turn off the virtual machine - just restarting host system was not enough.

Last edited by Feldmarshall (2016-04-25 14:06:08)

Offline

#39 2016-04-25 17:45:58

pm3840
Member
Registered: 2013-12-16
Posts: 27

Re: X server does not come up in VirtualBox VM after upgrade to kernel 4.5

as usual,

1. pacman -Syu
2. reboot, X breaks, poweroff arch
3. upgrade virtualbox to 5.0.18, install usb extension
4. boot arch, mount guest addition iso, install VBOXLinuxAddition
5. reboot

X is back

Last edited by pm3840 (2016-04-25 17:48:04)

Offline

#40 2016-04-26 03:18:13

aussieevil
Member
Registered: 2014-06-19
Posts: 25

Re: X server does not come up in VirtualBox VM after upgrade to kernel 4.5

Feldmarshall wrote:

In case of multiscreen setup the problem still exists. It is somehow erratic - the X will start, but at some point will stop updating the screen at all. In console there is following massage printed:

[drm:vbox_bo_push_sysram [vboxvideo]] *ERROR*  pushing to VRAM failed

[drm:vbox_bo_push_sysram [vboxvideo]] *ERROR*  unpin bad f39aa200

P.S: I gave up and rolled back to 4.4 kernel. What is interesting is that once the virtualbox video driver got corrupted I had to turn off the virtual machine - just restarting host system was not enough.

Where did you find these logs? My install freezes video and doesn't redraw unless I click on the VirtualBox interface.

Offline

#41 2016-05-04 13:23:42

Feldmarshall
Member
Registered: 2016-04-21
Posts: 4

Re: X server does not come up in VirtualBox VM after upgrade to kernel 4.5

aussieevil wrote:

Where did you find these logs? My install freezes video and doesn't redraw unless I click on the VirtualBox interface.

I'm logging in in text mode, and use startx to run Xorg. When I changed console with Alt+Ctrl+2 it showed those errors.

Last edited by Feldmarshall (2016-05-04 13:24:14)

Offline

#42 2016-05-04 13:35:55

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,288
Website

Re: X server does not come up in VirtualBox VM after upgrade to kernel 4.5

Trilby wrote:

We really don't need a string of "me too" posts now that the solution is confirmed.

And yet that's all we're getting.

This thread is a horrible rat's-nest of nonsense.  There looks to be at least one issue in the last few posts that may be a real issue worth a forum post, but it doesn't belong here as it is a distinct problem - feel free to create a new thread for that issue.  This thread somehow has become a waste-dump resembling a facebook page for virtualbox where everyone feels a need to post vacuous comments akin to "like" or "dislike".

Closed.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

Board footer

Powered by FluxBB