You are not logged in.

#26 2016-10-12 23:41:47

gee
Member
Registered: 2006-11-29
Posts: 276

Re: mesa-git - latest videodrivers & issues

Good idea!
It seems your builds depend now on lib32-lm_sensors (and same with the non 32b, but I already had the package there).
Installing it fixes the issue.

I guess this commit added the optional dependency:
https://cgit.freedesktop.org/mesa/mesa/ … d4e7f0db33
and it's not optional anymore since you added: "--enable-lmsensors --enable-gallium-extra-hud"
You made lib32-lm_sensors a makedepends but it is needed at runtime too smile

Last edited by gee (2016-10-12 23:48:04)

Offline

#27 2016-10-12 23:54:29

Amarildo
Member
Registered: 2013-09-21
Posts: 276
Website

Re: mesa-git - latest videodrivers & issues

lordheavy wrote:

You can try to start steam with LIBGL_DEBUG=verbose

[amarildo@amarildo ~]$ LIBGL_DEBUG=verbose firejail steam
Reading profile /etc/firejail/steam.profile
Reading profile /etc/firejail/disable-common.inc
Reading profile /etc/firejail/disable-programs.inc
Reading profile /etc/firejail/disable-devel.inc
Reading profile /etc/firejail/disable-passwdmgr.inc
Parent pid 11961, child pid 11962
Warning: /sbin directory link was not blacklisted
Warning: /usr/sbin directory link was not blacklisted
Child process initialized
/home/amarildo/.local/share/Steam/steam.sh: line 154: VERSION_ID: unbound variable
/home/amarildo/.local/share/Steam/steam.sh: line 154: VERSION_ID: unbound variable
Running Steam on arch  64-bit
/home/amarildo/.local/share/Steam/steam.sh: line 154: VERSION_ID: unbound variable
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1474415843)
libGL: Can't open configuration file /home/amarildo/.drirc: No such file or directory.
libGL: pci id for fd 7: 1002:6810, driver radeonsi
libGL: OpenDriver: trying /usr/lib32/xorg/modules/dri/tls/radeonsi_dri.so
libGL: OpenDriver: trying /usr/lib32/xorg/modules/dri/radeonsi_dri.so
libGL: dlopen /usr/lib32/xorg/modules/dri/radeonsi_dri.so failed (libsensors.so.4: cannot open shared object file: No such file or directory)
libGL error: unable to load driver: radeonsi_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: radeonsi
libGL: pci id for fd 7: 1002:6810, driver radeonsi
libGL: OpenDriver: trying /usr/lib32/xorg/modules/dri/tls/radeonsi_dri.so
libGL: OpenDriver: trying /usr/lib32/xorg/modules/dri/radeonsi_dri.so
libGL: dlopen /usr/lib32/xorg/modules/dri/radeonsi_dri.so failed (libsensors.so.4: cannot open shared object file: No such file or directory)
libGL error: unable to load driver: radeonsi_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: radeonsi
libGL: OpenDriver: trying /usr/lib32/xorg/modules/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib32/xorg/modules/dri/swrast_dri.so
libGL: dlopen /usr/lib32/xorg/modules/dri/swrast_dri.so failed (libsensors.so.4: cannot open shared object file: No such file or directory)
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
^C
Parent received signal 2, shutting down the child process...

Parent is shutting down, bye...

Child received signal 15, shutting down the sandbox...

The above is while using your repo. I'm compiling mesa-git from AUR now against llvm-svn and [core] and [extra] to see if it makes any difference.

EDIT: Compiling mesa-git and lib32-mesa-git from AUR solves the problem. Steam starts fine now.

Last edited by Amarildo (2016-10-12 23:59:01)


If it ain't broke, you haven't tweaked it enough...

Offline

#28 2016-10-13 00:31:53

gee
Member
Registered: 2006-11-29
Posts: 276

Re: mesa-git - latest videodrivers & issues

See above for the explanation smile

Offline

#29 2016-10-13 00:45:31

Amarildo
Member
Registered: 2013-09-21
Posts: 276
Website

Re: mesa-git - latest videodrivers & issues

Thanks gee, I haven't seen your post before making my own.


If it ain't broke, you haven't tweaked it enough...

Offline

#30 2016-10-13 04:06:15

gee
Member
Registered: 2006-11-29
Posts: 276

Re: mesa-git - latest videodrivers & issues

You're welcome, and I had assumed so when I read your post smile

Offline

#31 2016-10-13 05:37:47

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 276

Re: mesa-git - latest videodrivers & issues

gee wrote:

Good idea!
It seems your builds depend now on lib32-lm_sensors (and same with the non 32b, but I already had the package there).
Installing it fixes the issue.
You made lib32-lm_sensors a makedepends but it is needed at runtime too smile

Ooops, should be fixed now! thanks for tracking the problem

Offline

#32 2016-10-13 09:22:13

gee
Member
Registered: 2006-11-29
Posts: 276

Re: mesa-git - latest videodrivers & issues

It's the least I can do as a user of you repo!

Offline

#33 2016-10-13 13:13:29

Cerbereus
Member
Registered: 2008-10-06
Posts: 40

Re: mesa-git - latest videodrivers & issues

Thanks for this thread I been having this problem like two days ago hahaha (just fixed installing again the official mesa), but today I will try to update to check if I have this same problem. By the way can we make a thread been for report issues, I like the idea of first try with official mesa if happen the same is not problem of mesa git, thanks for the work update the repo.
Cheers.

Offline

#34 2016-10-15 04:05:59

Amarildo
Member
Registered: 2013-09-21
Posts: 276
Website

Re: mesa-git - latest videodrivers & issues

LordHeavy, would you consider adding a patch that makes Mesa display OGL as 4.5 instead of 4.3? Both OGL 4.4 and 4.5 are already done in Mesa.

https://github.com/FireBurn/Overlay/blo … GL45.patch


If it ain't broke, you haven't tweaked it enough...

Offline

#35 2016-10-15 07:46:23

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 276

Re: mesa-git - latest videodrivers & issues

Amarildo wrote:

LordHeavy, would you consider adding a patch that makes Mesa display OGL as 4.5 instead of 4.3? Both OGL 4.4 and 4.5 are already done in Mesa.

https://github.com/FireBurn/Overlay/blo … GL45.patch

I am not really enthusiat with this idea, we can potentially expose bugs. One workaround is to use environment variables like MESA_GL_VERSION_OVERRIDE see http://www.mesa3d.org/envvars.html

Offline

#36 2016-10-15 12:53:57

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 6,429

Re: mesa-git - latest videodrivers & issues

I agree with Lordheavy, overriding something like this should be a user decision.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#37 2016-10-16 03:35:24

gee
Member
Registered: 2006-11-29
Posts: 276

Re: mesa-git - latest videodrivers & issues

Agreed as well!
I remember when 4.3 was *done* but not flipped on yet, flipping it on with the override in /etc/environment would crash some apps.

Offline

#38 2016-10-16 07:32:08

Amarildo
Member
Registered: 2013-09-21
Posts: 276
Website

Re: mesa-git - latest videodrivers & issues

lordheavy wrote:
Amarildo wrote:

LordHeavy, would you consider adding a patch that makes Mesa display OGL as 4.5 instead of 4.3? Both OGL 4.4 and 4.5 are already done in Mesa.

https://github.com/FireBurn/Overlay/blo … GL45.patch

I am not really enthusiat with this idea, we can potentially expose bugs.

Even though Intel's Mesa driver already does this for Broadwell and newer hardware? [1]
AFAIK Mesa developers are waiting to pass Khronos conformance test, that's the only reason upstream hasn't enabled this for everybody yet, I think.
But I completely understand your point of view.

lordheavy wrote:

One workaround is to use environment variables like MESA_GL_VERSION_OVERRIDE see http://www.mesa3d.org/envvars.html

Thanks, I've been using env variables for ~2 days I think https://www.wilderssecurity.com/threads … -3.389258/

Cheers

[1] https://www.phoronix.com/scan.php?page= … esa-GL-4.5

Last edited by Amarildo (2016-10-16 07:40:47)


If it ain't broke, you haven't tweaked it enough...

Offline

#39 2016-10-16 09:20:19

haagch
Member
Registered: 2013-08-17
Posts: 208

Re: mesa-git - latest videodrivers & issues

Offline

#40 2016-10-23 01:12:15

Amarildo
Member
Registered: 2013-09-21
Posts: 276
Website

Re: mesa-git - latest videodrivers & issues

Does anyone have X-plane 10 and mesa-git? If so, can you confirm that setting "Real-world weather" crashes the sim?

Thanks


If it ain't broke, you haven't tweaked it enough...

Offline

#41 2016-10-23 15:35:13

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 6,429

Re: mesa-git - latest videodrivers & issues

I just uploaded a new version of AUR mesa-git .
Upstream had changed the name of some files and this broke the build.
The reason build broke was the fakeinstall / move to pkgdir method AUR mesa-git uses can't handle such a change.
(Stock mesa and LH mesa-git use the same method)

Since i took over AUR mesa-git from Krezji , I've come to dislike the fakeinstall method more and more .

I am considering switching AUR mesa-git from a split package to a single package .
My old mesa-R*-git packages were single packages also,so i know it can be done.

Please tell me what disadvantages / problems you think a single package mesa-git approach will have for users.

Last edited by Lone_Wolf (2016-10-23 15:37:20)


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#42 2016-10-23 16:51:16

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 276

Re: mesa-git - latest videodrivers & issues

Lone_Wolf wrote:

I just uploaded a new version of AUR mesa-git .
Upstream had changed the name of some files and this broke the build.
The reason build broke was the fakeinstall / move to pkgdir method AUR mesa-git uses can't handle such a change.
(Stock mesa and LH mesa-git use the same method)

See:
http://pkgbuild.com/~lcarlier/mesa-git/ … t/PKGBUILD
http://pkgbuild.com/~lcarlier/mesa-git/ … t/PKGBUILD

throught every aur packages should be built in a chroot,
https://wiki.archlinux.org/index.php/De … ean_Chroot

Last edited by lordheavy (2016-10-23 16:54:09)

Offline

#43 2016-10-24 14:04:11

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 6,429

Re: mesa-git - latest videodrivers & issues

Almost same solution as I used.

The "fakeinstall / move to pkgdir method" has nothing to do with building in a changeroot or running system .

In the build() function there's this :

  # fake installation
  mkdir -p "${srcdir}"/fakeinstall
  make DESTDIR="${srcdir}"/fakeinstall install

In the package_* functions files are then moved to $pkgdir .

I would very much prefer mesa as a single package with just one package() function (and "make install" in package() instead of build ).


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#44 2016-11-07 17:13:08

Amarildo
Member
Registered: 2013-09-21
Posts: 276
Website

Re: mesa-git - latest videodrivers & issues

Anyone having problems starting Steam with today's update? I can't start it at all. Deleting libraries, using Steam's native runtime, using LD_PRELOAD.... nothing is working.

[amarildo@amarildo ~]$ LD_PRELOAD='/usr/$LIB/libstdc++.so.6 /usr/$LIB/libgcc_s.so.1 /usr/$LIB/libxcb.so.1 /usr/$LIB/libasound.so.2 '${LD_PRELOAD} steam
/home/amarildo/.local/share/Steam/steam.sh: line 154: VERSION_ID: unbound variable
/home/amarildo/.local/share/Steam/steam.sh: line 154: VERSION_ID: unbound variable
Running Steam on arch  64-bit
/home/amarildo/.local/share/Steam/steam.sh: line 154: VERSION_ID: unbound variable
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1476379980)
libGL error: unable to load driver: radeonsi_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: radeonsi
libGL error: unable to load driver: radeonsi_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: radeonsi
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
[amarildo@amarildo ~]$ find /home/amarildo/.steam/steam/ubuntu12_32/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete
[amarildo@amarildo ~]$
[amarildo@amarildo ~]$ steam-native
/home/amarildo/.local/share/Steam/steam.sh: line 154: VERSION_ID: unbound variable
/home/amarildo/.local/share/Steam/steam.sh: line 154: VERSION_ID: unbound variable
Running Steam on arch  64-bit
STEAM_RUNTIME is disabled by the user
Installing breakpad exception handler for appid(steam)/version(1476379980)
libGL error: unable to load driver: radeonsi_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: radeonsi
libGL error: unable to load driver: radeonsi_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: radeonsi
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

Last edited by Amarildo (2016-11-07 17:18:18)


If it ain't broke, you haven't tweaked it enough...

Offline

#45 2016-11-07 17:21:58

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 276

Re: mesa-git - latest videodrivers & issues

Amarildo wrote:

Anyone having problems starting Steam with today's update? I can't start it at all. Deleting libraries, using Steam's native runtime, using LD_PRELOAD.... nothing is working.

mesa-git is currently broken because of a recent llvm changed the C api. You must revert llvm-svn and lib32-llvm-svn to previous version.

edit: see https://bugs.freedesktop.org/show_bug.cgi?id=98627

Last edited by lordheavy (2016-11-07 17:23:10)

Offline

#46 2016-11-07 18:37:14

Amarildo
Member
Registered: 2013-09-21
Posts: 276
Website

Re: mesa-git - latest videodrivers & issues

Damn, I don't recommend people to upgrade their git/svn packages today, they'll break EVERYTHING. I locked my system (Ctrl Alt L) and when I came back nothing was working.

Here, let me save you the work if some of you did the same as me tongue

Go to /var/cache/pacman/pkg and do the following

pacman -U llvm-svn-286033-1-x86_64.pkg.tar.xz llvm-libs-svn-286033-1-x86_64.pkg.tar.xz lib32-llvm-libs-svn-286033-1-x86_64.pkg.tar.xz lib32-mesa-git-86285.84a74be-1-x86_64.pkg.tar.xz  lib32-mesa-libgl-git-86285.84a74be-1-x86_64.pkg.tar.xz mesa-git-86285.84a74be-1-x86_64.pkg.tar.xz mesa-libgl-git-86285.84a74be-1-x86_64.pkg.tar.xz opencl-mesa-git-86285.84a74be-1-x86_64.pkg.tar.xz clang-svn-286033-1-x86_64.pkg.tar.xz clang-tools-extra-svn-286033-1-x86_64.pkg.tar.xz

If it ain't broke, you haven't tweaked it enough...

Offline

#47 2016-11-08 01:28:22

gee
Member
Registered: 2006-11-29
Posts: 276

Re: mesa-git - latest videodrivers & issues

lordheavy wrote:
Amarildo wrote:

Anyone having problems starting Steam with today's update? I can't start it at all. Deleting libraries, using Steam's native runtime, using LD_PRELOAD.... nothing is working.

mesa-git is currently broken because of a recent llvm changed the C api. You must revert llvm-svn and lib32-llvm-svn to previous version.

edit: see https://bugs.freedesktop.org/show_bug.cgi?id=98627

With this being the case, does it make sense to offer the troublesome llvm packages in your mesa-git repository before mesa gets tstellar's fixes?

Offline

#48 2016-11-08 03:49:42

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 276

Re: mesa-git - latest videodrivers & issues

gee wrote:
lordheavy wrote:
Amarildo wrote:

Anyone having problems starting Steam with today's update? I can't start it at all. Deleting libraries, using Steam's native runtime, using LD_PRELOAD.... nothing is working.

mesa-git is currently broken because of a recent llvm changed the C api. You must revert llvm-svn and lib32-llvm-svn to previous version.

edit: see https://bugs.freedesktop.org/show_bug.cgi?id=98627

With this being the case, does it make sense to offer the troublesome llvm packages in your mesa-git repository before mesa gets tstellar's fixes?

yeah, i'm trying currently to build llvm with offending commit reverted, in case of failure i will downgrade llvm in the git repo

Last edited by lordheavy (2016-11-08 03:59:32)

Offline

#49 2016-11-08 03:56:55

gee
Member
Registered: 2006-11-29
Posts: 276

Re: mesa-git - latest videodrivers & issues

Great!

Offline

#50 2016-11-08 05:01:59

gee
Member
Registered: 2006-11-29
Posts: 276

Re: mesa-git - latest videodrivers & issues

..and it worked!
Thank you!

Offline

Board footer

Powered by FluxBB