You are not logged in.

#26 2016-06-25 13:02:08

ColtonDRG
Member
Registered: 2015-05-20
Posts: 10
Website

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

I have the same problem with the segfaulting. I tried both qt5-styleplugins-git and qt5-styleplugins from AUR, and they both have the same result. When I run Quassel Client...

[coltondrg@rainbowdash ~]$ env QT_STYLE_OVERRIDE=gtk2 quasselclient

(quasselclient:23471): GLib-GObject-WARNING **: cannot register existing type 'GdkDisplayManager'

(quasselclient:23471): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(quasselclient:23471): GLib-GObject-CRITICAL **: g_object_new: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

(quasselclient:23471): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(quasselclient:23471): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(quasselclient:23471): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(quasselclient:23471): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(quasselclient:23471): GLib-GObject-WARNING **: cannot register existing type 'GdkDisplay'

(quasselclient:23471): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(quasselclient:23471): GLib-GObject-CRITICAL **: g_type_register_static: assertion 'parent_type > 0' failed

(quasselclient:23471): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(quasselclient:23471): GLib-GObject-CRITICAL **: g_object_new: assertion 'G_TYPE_IS_OBJECT (object_type)' failed
Segmentation fault (core dumped)

Offline

#27 2016-06-25 16:05:41

nbvcxz
Member
From: Poland
Registered: 2007-12-29
Posts: 202

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

arojas wrote:

Well, of course. gconf needs to ne installed *at build time*. This is what happens when packages misuse the "provides" feature.

Don't want start discussion about the piece of crap (gconf). When I compiled the qt5-styleplugins-git with gconf it really started to work as it should. But after removing gconf I got errors:

symbol lookup error: /usr/lib/qt/plugins/styles/libqgtk2style.so: undefined symbol: gconf_client_get_default

So PKGBUILD is ok and gconf and gtk2 can't be only makedepends. I am curious if it is possible to get rid of having gconf as it was in qt 5.6.

Last edited by nbvcxz (2016-06-25 16:06:19)


Lenovo G50 | LXQT-git | compton | conky

Offline

#28 2016-06-25 17:34:34

GourdCaptain
Member
Registered: 2009-04-18
Posts: 118

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

I'm getting crashes on XFCE with the AUR GIT package and gconf installed. Any suggestions?

(rssguard:8799): GLib-GObject-WARNING **: cannot register existing type 'GdkDisplayManager'

(rssguard:8799): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(rssguard:8799): GLib-GObject-CRITICAL **: g_object_new: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

(rssguard:8799): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(rssguard:8799): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(rssguard:8799): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(rssguard:8799): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(rssguard:8799): GLib-GObject-WARNING **: cannot register existing type 'GdkDisplay'

(rssguard:8799): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(rssguard:8799): GLib-GObject-CRITICAL **: g_type_register_static: assertion 'parent_type > 0' failed

(rssguard:8799): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(rssguard:8799): GLib-GObject-CRITICAL **: g_object_new: assertion 'G_TYPE_IS_OBJECT (object_type)' failed
Segmentation fault (core dumped)

E
EDIT: Command used was: "QT_STYLE_OVERRIDE=gtk2 rssguard". Strace log of it if it will help: https://www.dropbox.com/s/elb1nu92qz74a … h.txt?dl=0

Last edited by GourdCaptain (2016-06-25 17:37:47)

Offline

#29 2016-06-25 20:19:21

xduugu
Member
Registered: 2008-10-16
Posts: 292

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

I've uploaded a package qt5-styleplugins-nogconf-git which does not depend on gconf. The only functionality that required gconf was the possibility to set an option in Gconf to show icons on buttons. This package uses the default that is used when this option is absent in Gconf which is to not show icons on buttons.

Offline

#30 2016-06-25 20:38:14

GSF1200S
Member
Registered: 2008-12-24
Posts: 474

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

I had this problem as well. In my case, I had

QT_STYLE_OVERRIDE=gtk

in /etc/environment hmm I dont know how that happened. After installing qt5-styleplugins-git and setting the above to gtk2 instead of gtk, it works fine again.

Last edited by GSF1200S (2016-06-25 20:38:28)

Offline

#31 2016-06-26 01:23:50

ColtonDRG
Member
Registered: 2015-05-20
Posts: 10
Website

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

I tried installing the nogconf package with a tiny sliver of hope that it might work, but nope, still getting the segfaults. sad

Offline

#32 2016-06-26 01:35:00

kakonema
Member
Registered: 2016-06-25
Posts: 7

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

ColtonDRG wrote:

I tried installing the nogconf package with a tiny sliver of hope that it might work, but nope, still getting the segfaults. sad

try QT_QPA_PLATFORMTHEME=gtk2

Offline

#33 2016-06-26 01:38:09

ColtonDRG
Member
Registered: 2015-05-20
Posts: 10
Website

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

kakonema wrote:
ColtonDRG wrote:

I tried installing the nogconf package with a tiny sliver of hope that it might work, but nope, still getting the segfaults. sad

try QT_QPA_PLATFORMTHEME=gtk2

The application launched, but using the fallback "Fusion" theme that I had set for it. (I need that application to work, even if it does look horrible. My only other option is rolling back to qt 5.6.1. I think I still have the packages in my package cache.)

Offline

#34 2016-06-26 04:20:42

GourdCaptain
Member
Registered: 2009-04-18
Posts: 118

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

ColtonDRG wrote:
kakonema wrote:
ColtonDRG wrote:

I tried installing the nogconf package with a tiny sliver of hope that it might work, but nope, still getting the segfaults. sad

try QT_QPA_PLATFORMTHEME=gtk2

The application launched, but using the fallback "Fusion" theme that I had set for it. (I need that application to work, even if it does look horrible. My only other option is rolling back to qt 5.6.1. I think I still have the packages in my package cache.)

Same. Fusion isn't too bad for me because it looks not incredibly dissimilar to my theme barring the menu bar and menus being the wrong color, so I can deal with it if I have to, but I'd like to get this to work (still better than when a GTK3 update breaks theme backwards compatibility for me.)

Offline

#35 2016-06-26 08:53:29

Cadeyrn
Member
Registered: 2013-04-06
Posts: 147

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

Also experiencing this issue, also running XFCE, also cannot fix it with any suggestion that's been made so far in this thread. I had a golden month or two of Arc-Dark on my entire desktop! I might downgrade back to 5.6 if this doesn't get fixed soon...

Offline

#36 2016-06-26 09:22:30

GSF1200S
Member
Registered: 2008-12-24
Posts: 474

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

This thread hasnt really been specific as to where these variables are being input- lets try to more specific. Most cats in here are relatively new to Arch, so understand that this forum's members usually like to see some discernable path of troubleshooting that we can help you go further with. When you ask, give us as much information as possible...

After upgrading qt5-base to version 5.7.0-1, the widget style GTK is not available for QT5 apps. I tried installing qt5-styleplugins-git and using qt5ct to set the gtk theme, but the gtk theme I use did not show on QT5 apps and as well I had segfaults whenever qt5-styleplugins-git was installed. Any ideas?

(Sometime later a solution is found, such as in my case...)

Problem is solved for me. I did some experimentation trying export QT_QPA_PLATFORMTHEME="qt5ct", export QT_QPA_PLATFORMTHEME="GTK+", export QT_QPA_PLATFORMTHEME="gtk", and export QT_QPA_PLATFORMTHEME="gtk2", but none of them fixed the issue. I also tried setting overrides in ~/.profile, but none of those fixed my issue either.

Eventually I checked /etc/environment and found:

QT_STYLE_OVERRIDE=gtk

Changing it to:

QT_STYLE_OVERRIDE=gtk2

fixed my problems. I use Openbox with Elementary Dark gtk2/3 theme, and start X using 'exec startx' after logging in at the console.

I confess- my last post wasnt this involved either. I did mention the file I edited (/etc/environment), what was in it, and what I changed it to. I did not mention that I restarted X, I did not mention specifically what other environment settings I tried, I did not mention my particular setup, etc- so Im guilty too tongue. Lets try to do that and see if we cant get everyone elses issues with this fixed.

Offline

#37 2016-06-26 09:46:38

nbvcxz
Member
From: Poland
Registered: 2007-12-29
Posts: 202

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

xduugu wrote:

I've uploaded a package qt5-styleplugins-nogconf-git which does not depend on gconf. The only functionality that required gconf was the possibility to set an option in Gconf to show icons on buttons. This package uses the default that is used when this option is absent in Gconf which is to not show icons on buttons.

@xduugu - big big thx: qt5-styleplugins-nogconf-git is exactly I needed to have my system back the same way as it was with QT. So far I checked few apps (both QT5 and GTK+ 2/3) and they works perfectly fine. Thank you for patch and PKGBUILD.


Lenovo G50 | LXQT-git | compton | conky

Offline

#38 2016-06-26 14:03:31

equeim
Member
Registered: 2016-03-27
Posts: 22

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

The reason why Qt5 programs segfault with QGtkStyle in XFCE and other desktop environments is that GTK+ plarform theme (which gets font and icons settings from GTK+ and creates GTK+ file dialogs) which loads in these DEs now builds with gtk3, which is incompatible with QGtkStyle.
There are 4 possible solutions:
0. Don't use QGtkStyle. Use gtk3 (gtk3 font and icon settings and file dialogs) or qt5ct (configures settings independently and uses Qt own file dialogs) platform theme.
Other solutions rely on installed qt5-styleplugins package.
1. Use generic platform theme and set QT_STYLE_OVERRIDE=gtk2. Qt apps will use QGtkStyle but you will not able to configure fonts and icons or use GTK+ file dialogs.
2. Use qt5ct platform theme. You will be able to configure fonts and icons (and some other things), use QGtkStyle, but you will not have GTK+ file dialogs.
3. Modify Qt to build GTK+ platform theme with gtk2. Enable gtk2 platform theme and Qt apps will use gtk2 settings and file dialogs and QGtkStyle.

Last edited by equeim (2016-06-26 14:53:20)

Offline

#39 2016-06-26 15:12:08

ColtonDRG
Member
Registered: 2015-05-20
Posts: 10
Website

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

equeim wrote:

1. Use generic platform theme and set QT_STYLE_OVERRIDE=gtk2. Qt apps will use QGtkStyle but you will not able to configure fonts and icons or use GTK+ file dialogs.

How do I do that? Every time I use QT_STYLE_OVERRIDE=gtk2, it segfaults.

Offline

#40 2016-06-26 15:34:55

equeim
Member
Registered: 2016-03-27
Posts: 22

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

ColtonDRG wrote:
equeim wrote:

1. Use generic platform theme and set QT_STYLE_OVERRIDE=gtk2. Qt apps will use QGtkStyle but you will not able to configure fonts and icons or use GTK+ file dialogs.

How do I do that? Every time I use QT_STYLE_OVERRIDE=gtk2, it segfaults.

Unset XDG_CURRENT_DESKTOP and DESKTOP_SESSION environment variables. If you use XFCE, copy to /etc/xdg/xfce4/xinitrc to ~/.config/xfce4/xinitrc and remove corresponding lines. Then set QT_QPA_PLATOFORMTHEME=gnome (this will enable generic gnome platform theme which sets default icon theme, ok/cancel button order, etc). However you will not be able to configure fonts or icon theme. I would suggest to use qt5ct instead (install qt5ct, set QT_QPA_PLATFORMTHEME=qt5ct and configure Qt settings using qt5ct program. Also you don't need to unset XDG_CURRENT_DESKTOP or DESKTOP_SESSION environment variables to use qt5ct).

Last edited by equeim (2016-06-26 15:36:32)

Offline

#41 2016-06-26 16:06:19

kakonema
Member
Registered: 2016-06-25
Posts: 7

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

ColtonDRG wrote:
equeim wrote:

1. Use generic platform theme and set QT_STYLE_OVERRIDE=gtk2. Qt apps will use QGtkStyle but you will not able to configure fonts and icons or use GTK+ file dialogs.

How do I do that? Every time I use QT_STYLE_OVERRIDE=gtk2, it segfaults.

If you use lxqt you should update lxqt-qtplugin package and that should fix the segfaults.

Offline

#42 2016-06-26 16:15:41

equeim
Member
Registered: 2016-03-27
Posts: 22

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

kakonema wrote:

If you use lxqt you should update lxqt-qtplugin package and that should fix the segfaults.

Yes, lxqt uses its own Qt platform theme plugin (alternative to qt5ct).

Offline

#43 2016-06-26 19:00:57

Cadeyrn
Member
Registered: 2013-04-06
Posts: 147

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

equeim wrote:

The reason why Qt5 programs segfault with QGtkStyle in XFCE and other desktop environments is that GTK+ plarform theme (which gets font and icons settings from GTK+ and creates GTK+ file dialogs) which loads in these DEs now builds with gtk3, which is incompatible with QGtkStyle.
There are 4 possible solutions:
0. Don't use QGtkStyle. Use gtk3 (gtk3 font and icon settings and file dialogs) or qt5ct (configures settings independently and uses Qt own file dialogs) platform theme.
Other solutions rely on installed qt5-styleplugins package.
1. Use generic platform theme and set QT_STYLE_OVERRIDE=gtk2. Qt apps will use QGtkStyle but you will not able to configure fonts and icons or use GTK+ file dialogs.
2. Use qt5ct platform theme. You will be able to configure fonts and icons (and some other things), use QGtkStyle, but you will not have GTK+ file dialogs.
3. Modify Qt to build GTK+ platform theme with gtk2. Enable gtk2 platform theme and Qt apps will use gtk2 settings and file dialogs and QGtkStyle.

We can't do 0-2, because:

0. qt5ct has no option for a "gtk3" theme, and if I say QT_STYLE_OVERRIDE=gtk or QT_STYLE_OVERRIDE=gtk3 (they do the same thing), I get an extremely messed up look. Random UI elements lilke dropdown menus are HUGE, other random UI elements are extremely blocky looking as if qt5's style was set to Windows, all text is white, and all backgrounds are either pure black or almost entirely white (a little gray), making most text unreadable.

1. As we've been constantly saying in this thread, that results in a segfault. For some of us, including me, it still results in a segfault after trying everything suggested: installing gconf and then recompiling qt5-styleplugins, using the nogconf version, restarting X, even restarting the whole computer.

2. Most have reported not seeing a gtk2 option in qt5ct, even after installing qt5-styleplugins. I have a slightly different issue: I can see it, but if I select it, qt5ct immediately segfaults, before I can even see what it would look like or press Apply. The output of that is:

(qt5ct:26117): GLib-GObject-WARNING **: cannot register existing type 'GdkDisplayManager'

(qt5ct:26117): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(qt5ct:26117): GLib-GObject-CRITICAL **: g_object_new: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

(qt5ct:26117): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(qt5ct:26117): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(qt5ct:26117): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(qt5ct:26117): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(qt5ct:26117): GLib-GObject-WARNING **: cannot register existing type 'GdkDisplay'

(qt5ct:26117): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(qt5ct:26117): GLib-GObject-CRITICAL **: g_type_register_static: assertion 'parent_type > 0' failed

(qt5ct:26117): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(qt5ct:26117): GLib-GObject-CRITICAL **: g_object_new: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

As for #3, I don't know how to do that (it's not that I'm a newb to compiling or anything--I just don't know exactly what packages I have to mess with or what flags I have to set, and I don't understand how that process is any different from what we're already doing with qt5-styleplugins), and I'd rather limit how many of my programs have to use the godawful GTK+ file dialog.

As for this reply:

equeim wrote:
ColtonDRG wrote:
equeim wrote:

1. Use generic platform theme and set QT_STYLE_OVERRIDE=gtk2. Qt apps will use QGtkStyle but you will not able to configure fonts and icons or use GTK+ file dialogs.

How do I do that? Every time I use QT_STYLE_OVERRIDE=gtk2, it segfaults.

Unset XDG_CURRENT_DESKTOP and DESKTOP_SESSION environment variables. If you use XFCE, copy to /etc/xdg/xfce4/xinitrc to ~/.config/xfce4/xinitrc and remove corresponding lines. Then set QT_QPA_PLATOFORMTHEME=gnome (this will enable generic gnome platform theme which sets default icon theme, ok/cancel button order, etc). However you will not be able to configure fonts or icon theme. I would suggest to use qt5ct instead (install qt5ct, set QT_QPA_PLATFORMTHEME=qt5ct and configure Qt settings using qt5ct program. Also you don't need to unset XDG_CURRENT_DESKTOP or DESKTOP_SESSION environment variables to use qt5ct).

I'd rather not use GNOME's icon theme or ok/cancel button order or etc., and as I said before, the qt5ct option is not working. Why can't we just do everything the same way we could in 5.6?

Last edited by Cadeyrn (2016-06-26 19:02:53)

Offline

#44 2016-06-26 19:13:36

GourdCaptain
Member
Registered: 2009-04-18
Posts: 118

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

The problem is, and I now feel incredibly dense after I figured this out, you need to have qt5ct handle the QT5 theming and stuff first before you select it so you don't have the segfault.
Add "export QT_QPA_PLATFORMTHEME=qt5ct" to your bashrc or such and then you can pick GTK2 in it just fine. (Log out and log back in to apply the changes or such first).

Offline

#45 2016-06-26 19:26:36

Cadeyrn
Member
Registered: 2013-04-06
Posts: 147

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

Wow, that worked. OK then.

EDIT: Actually, new problem. XFCE seems to be completely ignoring the export line in my .bashrc. For now, I've copied /etc/xdg/xfce4/xinitrc to my home folder and added it to that, but that can't be a permanent solution since XFCE's xinitrc may change in an update, right?

(Note: I know it works without having XFCE use it as a whole because running "env QT_QPA_PLATFORMTHEME=qt5ct qt5ct" worked, and I know that XFCE is not using the variable because "echo $QT_QPA_PLATFORMTHEME" returns nothing and just running qt5ct crashes, whereas running "env QT_QPA_PLATFORMTHEME=qt5ct qt5ct" works again.)

EDIT2: Well, that's weird. Adding it to xinitrc also hasn't made it reflect in my XFCE desktop. How do I make XFCE use this variable???

EDIT3: OK, even weirder. If I manually export it myself, and then echo it in another terminal, it STILL returns nothing. Is some part of my graphical envirnoment constantly resetting this variable?

Last edited by Cadeyrn (2016-06-26 19:52:51)

Offline

#46 2016-06-26 20:52:23

grimi
Member
Registered: 2009-12-27
Posts: 27

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

I think this line in ~/.pam_environment should work:

QT_QPA_PLATFORMTHEME   DEFAULT=qt5ct

Offline

#47 2016-06-26 20:52:54

ANXHaruhi
Member
Registered: 2016-05-30
Posts: 18

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

Thanks GSF1200S for the pointers, that showed me where to look and indeed it is a problem with exporting the proper variables, so it uses qt5ct engine and not whatever it wants. However, I do need to ask this, where does LXQT set QT_PLATFORM_PLUGIN and QT_QPA_PLATFORMTHEME? As much as I look I cannot find where it is declared. Not even a single place listed on the wiki and various posts found in Google contain them, since it seems to be autodeclared on /usr/bin/startlxqt start script. Explicitly declaring them in /etc/environment , ~/.xinitrc or ~/.xprofile doesn't work and I do have to manually use env to execute qt apps. In fact printenv list them as QT_PLATFORM_PLUGIN=lxqt and QT_QPA_PLATFORMTHEME=lxqt. Now I regret a little bit installing LXQT just for trying it out. I do use LXDE, and none of the files shows any mention to lxqt.

EDIT: That doesn't work either grimi, it does still default to lxqt.

Last edited by ANXHaruhi (2016-06-26 21:04:59)

Offline

#48 2016-06-26 21:32:08

Cadeyrn
Member
Registered: 2013-04-06
Posts: 147

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

Yeah, ~/.pam_environment fixed it for me. For anyone who's wanting, I made a little code that you can put in .bashrc to automatically parse ~/.pam_environment so that you don't have to type all these variables out more than once (it also knows to ignore comments that start with #):

# load other environment variables
while read LINE; do
    LINE="$(echo $LINE | sed 's/\#.*//')"
    if [ "$LINE" != "" ]
        then export $(echo $LINE | sed 's/\W.*//')=$(echo $LINE | sed 's/.*DEFAULT=//')
    fi
done < $HOME/.pam_environment

And if you want this for all users, automatically add it to /etc/environment (after making sure it isn't already in there):

while read LINE; do
  LINE="$(echo $LINE | sed 's/\#.*//')"
  if [ "$LINE" != "" ]; then
    LINE="$(echo $LINE | sed 's/\W.*//')=$(echo $LINE | sed 's/.*DEFAULT=//')"
    if ! grep -Fxq "$LINE" /etc/environment ; then
      echo "$LINE" | sudo tee -a /etc/environment
    fi
  fi
done < $HOME/.pam_environment

Last edited by Cadeyrn (2016-06-26 21:35:11)

Offline

#49 2016-06-27 10:12:50

ANXHaruhi
Member
Registered: 2016-05-30
Posts: 18

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

That did not work either for me. I've been digging up why it does set that. Using another DE applies the config without problems, using another user does not fixes them, so it is specific to LXDE. LXDE init script has this command on it, dbus-update-activation-environment --all  which uses dbus for loading a lot of environment variables (using it in a terminal with --verbose confirms that) Looking through /usr/share/dbus-1 and it's session.conf file doesn't show anything that pointed even remotely to environment variables though. Docs are not that helpful either. Any clue what's going on?

Last edited by ANXHaruhi (2016-06-27 10:13:11)

Offline

#50 2016-06-27 10:18:23

hifi25nl
Member
Registered: 2011-05-07
Posts: 240
Website

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

In xfce the only working solution (for me):

1) install breeze and breeze-gtk theme
2) install qt5ct
3) add QT_QPA_PLATFORMTHEME=qt5ct to /etc/environment
4) Set breeze as theme in xfce settings and in qt5ct

Offline

Board footer

Powered by FluxBB