You are not logged in.

#101 2016-09-15 14:26:08

marmistrz
Member
Registered: 2016-01-05
Posts: 108

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

And I resolved it using qgnomeplatform-git and adwaita-qt5

Offline

#102 2016-10-01 17:47:57

manuelschneid3r
Member
From: Baden-Württemberg, Germany
Registered: 2013-04-14
Posts: 138

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

Months later… Is there a "correct" way to go now?


It's _not_ impolite, please feel free to correct my english.

Offline

#103 2016-10-02 00:57:33

mx_joao
Member
From: Brasil
Registered: 2011-12-02
Posts: 46

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

manuelschneid3r wrote:

Months later… Is there a "correct" way to go now?

Only workarounds.

They will enable GTK Theming again in QT 5.8, due november.

Offline

#104 2016-10-20 13:03:52

windozupdate
Banned
Registered: 2015-03-19
Posts: 25

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

For LXDE users, please use lxsession-git package from AUR, then run qt5ct.

You should be able to run qt5ct without error after installing lxsession-git package

choose gtk2 and apply the setting. Enjoy your gtk2 experiance on QT 5.7

Offline

#105 2018-05-09 19:34:23

XenGi
Member
From: berlin, germany, europe, earth
Registered: 2013-02-23
Posts: 35
Website

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

Ok, I'm completely confused now.
I'm running xfce4 with i3 as windows manager. I've set the following vars:

QT_PLATFORMTHEME=qt5ct
QT_PLATFORM_PLUGIN=qt5ct
QT_QPA_PLATFORMTHEME=qt5ct

When I try to launch qt5ct:

$ qt5ct
qt5ct: using qt5ct plugin

(qt5ct:8617): GLib-GObject-WARNING **: 21:32:09.057: cannot register existing type 'GdkDisplayManager'

(qt5ct:8617): GLib-CRITICAL **: 21:32:09.057: g_once_init_leave: assertion 'result != 0' failed

(qt5ct:8617): GLib-GObject-CRITICAL **: 21:32:09.057: g_object_new_with_properties: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

(qt5ct:8617): GLib-GObject-WARNING **: 21:32:09.057: invalid (NULL) pointer instance

(qt5ct:8617): GLib-GObject-CRITICAL **: 21:32:09.057: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(qt5ct:8617): GLib-GObject-WARNING **: 21:32:09.057: invalid (NULL) pointer instance

(qt5ct:8617): GLib-GObject-CRITICAL **: 21:32:09.057: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(qt5ct:8617): GLib-GObject-WARNING **: 21:32:09.057: cannot register existing type 'GdkDisplay'

(qt5ct:8617): GLib-CRITICAL **: 21:32:09.057: g_once_init_leave: assertion 'result != 0' failed

(qt5ct:8617): GLib-GObject-CRITICAL **: 21:32:09.057: g_type_register_static: assertion 'parent_type > 0' failed

(qt5ct:8617): GLib-CRITICAL **: 21:32:09.057: g_once_init_leave: assertion 'result != 0' failed

(qt5ct:8617): GLib-GObject-CRITICAL **: 21:32:09.057: g_object_new_with_properties: assertion 'G_TYPE_IS_OBJECT (object_type)' failed
fish: “qt5ct” terminated by signal SIGSEGV (Address boundary error)

The thread is marked as solved but I can't find a suitable solution for me. Did I miss something? How can we solve this mess?


# got root?█

Offline

#106 2018-05-09 19:54:26

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,871

Re: [SOLVED] Qt 5.7: Widget style GTK is not longer available

It has been 2 years a lot has changed in the meantime, if you want help open your own thread with more up to date details on your software stack and expectations.

Don't necrobump: https://wiki.archlinux.org/index.php/Co … bumping.22

Closing.

Last edited by V1del (2018-05-09 19:55:38)

Offline

Board footer

Powered by FluxBB