You are not logged in.

#51 2017-02-08 19:18:50

Soukyuu
Member
Registered: 2014-04-08
Posts: 844

Re: kernel error in drm_kms_helper, flip_done timed out

I was having something similar on my intel 2000 HD, in the end I just removed xf86-video-intel and went with the generic KMS driver. Seems to be working just fine and I have not noticed any performance issues so far - maybe an option for some people here?


[ Arch x86_64 | linux | ThinkPad X220 | Intel Core i5 2540M@3.3Ghz | Intel HD3000 | 16GB RAM | Main, docked to 2 Monitors ]
[ Arch x86_64 | linux-ck-k10 | Custom-built | AMD Phenom II X4@3,5Ghz | nVidia 260 GTX | 12GB RAM | Retired ]
[ Arch x86_64 | linux | Custom-built | Intel Celeron G3920@2,99Ghz | iGPU | 8GB RAM | Home server ]

Offline

#52 2017-02-09 09:33:19

Bratpfanne
Member
Registered: 2016-11-17
Posts: 2

Re: kernel error in drm_kms_helper, flip_done timed out

Anyone who is affected by this bug could you please add the following kernel boot parameter instead of reverting the bad commit and test if it works?

video=SVIDEO-1:d

This has solved the bug for me on my Latitude D630 with a 4.9 kernel. It disables the SVIDEO connector but my laptop doesen't even have one so it's fine.

Last edited by Bratpfanne (2017-02-09 09:57:09)

Offline

#53 2017-02-11 12:33:43

grzechoo
Member
From: Poland
Registered: 2013-12-02
Posts: 8

Re: kernel error in drm_kms_helper, flip_done timed out

Bratpfanne wrote:

Anyone who is affected by this bug could you please add the following kernel boot parameter instead of reverting the bad commit and test if it works?

video=SVIDEO-1:d

I confirm - the issue is solved with above kernel boot parameter.
Running 4.9.8-1 on Compaq 6510b.

Offline

#54 2017-02-11 14:06:39

vitamin
Member
Registered: 2013-03-11
Posts: 5

Re: kernel error in drm_kms_helper, flip_done timed out

Bratpfanne wrote:

Anyone who is affected by this bug could you please add the following kernel boot parameter instead of reverting the bad commit and test if it works?

video=SVIDEO-1:d

This has solved the bug for me on my Latitude D630 with a 4.9 kernel. It disables the SVIDEO connector but my laptop doesen't even have one so it's fine.

It works for me too. Thank you.
HP 550, kernel 4.9.8

Offline

#55 2017-02-13 15:31:07

step
Member
Registered: 2016-05-09
Posts: 56

Re: kernel error in drm_kms_helper, flip_done timed out

Bratpfanne wrote:

Anyone who is affected by this bug could you please add the following kernel boot parameter instead of reverting the bad commit and test if it works?

video=SVIDEO-1:d

This has solved the bug for me on my Latitude D630 with a 4.9 kernel. It disables the SVIDEO connector but my laptop doesen't even have one so it's fine.

It not solved for me, i add it into systemd-boot so /boot/loader/entries/arch.conf but when i restart it freeze, the only way for me (at this moment) is to unistall xf86-video-intel

Offline

#56 2017-02-18 02:03:02

cdown
Member
From: London, England
Registered: 2013-02-09
Posts: 53
Website

Re: kernel error in drm_kms_helper, flip_done timed out

Bratpfanne wrote:

Anyone who is affected by this bug could you please add the following kernel boot parameter instead of reverting the bad commit and test if it works?

video=SVIDEO-1:d

This has solved the bug for me on my Latitude D630 with a 4.9 kernel. It disables the SVIDEO connector but my laptop doesen't even have one so it's fine.

Thanks, this works for me on a T460s with 4.9.10.

Offline

#57 2017-02-18 08:42:43

collector1871
Member
From: Poland
Registered: 2016-12-05
Posts: 35

Re: kernel error in drm_kms_helper, flip_done timed out

After update to kernel 4.9 in one of my laptop (I am using 2 notebooks with Linux Arch) during boot I have "acpi errors".
But everything is working as usual. It is only blinking for 1-2 seconds during boot.

second notebook is working as usual, no problem at all, boot is clean.

Last edited by collector1871 (2017-02-18 08:43:53)


My: AUR and homepage .

Offline

#58 2017-03-04 22:41:43

sofiasmith
Member
Registered: 2016-02-02
Posts: 7

Re: kernel error in drm_kms_helper, flip_done timed out

Today after pacman -Syu, linux-lts updated from 4.4.52 to 4.9.13.

And the infamous drm_kms_helper error appeared in linux- lts.

And then I aplied: GRUB_CMDLINE_LINUX_DEFAULT="video=SVIDEO-1:d" on /etc/default/grub

grub-mkconfig -o /boot/grub/grub.cfg

Then I delete lts and install linux:

pacman -R linux-lts && pacman -S linux

And all is OK, worked like a charm, without any error and booting in 15 sec.

Thanks to bratpfanne!

Offline

#59 2017-03-05 04:41:16

sobralense
Member
Registered: 2015-08-24
Posts: 8

Re: kernel error in drm_kms_helper, flip_done timed out

Just to let you know, worked for me too.

I have an old Macbook (Early 2007) with an "Intel GMA X3100 integrated graphics".
Since couldn't use linux-lts anymore, had to try the "video=" trick. Worked like a charm.
Funny, Xrandr wasn't listing SVIDEO!

I'm still with the linux-lts kernel (at this time is newer than main linux for arch, waiting 4.10, maybe).

If you don't use grub, but use "systemd-boot" like me, can do this:
Edit: /boot/loader/entries/linux-lts.conf
at the end of "options" line, include the:  video=SVIDEO-1:d
Mine is: options root=/dev/sda2 rw elevator=deadline nosplash resume=/dev/sda3 nmi_watchdog=0 video=SVIDEO-1:d
PS: This is a single line, and please it's an example, don't copy everything.

And update the boot entry with:
sudo mkinitcpio -p linux-lts

If anyone have the same, I changed the video driver too, could keep the Early KMS, removed the xf86-video-intel and the performance it's really good with the "modesetting" driver for my old vga.

Offline

#60 2017-03-08 20:33:55

linux4me
Member
Registered: 2017-01-31
Posts: 12

Re: kernel error in drm_kms_helper, flip_done timed out

Bratpfanne wrote:

Anyone who is affected by this bug could you please add the following kernel boot parameter instead of reverting the bad commit and test if it works?

video=SVIDEO-1:d

This has solved the bug for me on my Latitude D630 with a 4.9 kernel. It disables the SVIDEO connector but my laptop doesen't even have one so it's fine.

Thanks for this! It worked for me on a Toshiba Satellite A205 with the 4.9.11-1 kernel. My boot is now downright peppy.

Offline

#61 2017-03-10 08:55:16

martijn600
Member
Registered: 2017-03-10
Posts: 1

Re: kernel error in drm_kms_helper, flip_done timed out

Thanks Bratpfanne, video=SVIDEO-1:d solved the problem with my slow booting laptop as well.

For people who have only basic knowledge of Linux (like me), this is my account:
-Laptop specs:
HP Compaq 6910p
Duo Core @ 2.00 GHz, 1 GB RAM

I upgraded from Ubuntu 14.04 to 16.04, boot time to login screen after upgrade over 40 sec, which was noticeably slower than before.
Tried Xubuntu, but same problem (which not surprising, as Xubuntu has especially a faster UI).

-Opened terminal and typed: journalctl -b
This shows the boot log.
At subsequent lines with much time difference (about 10 sec) an error message with 'flip_done timed' appeared.
Searching on the internet on this message brought me to this forum.
It said that I needed to change the kernel boot parameters.

-In terminal I typed: sudo mousepad /etc/default/grub

-Changed line
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
into:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d"

-To propagate the changes, I did both (though one of them would probably have sufficed):
sudo update-grub
and/or
sudo grub-mkconfig -o /boot/grub/grub.cfg

-Rebooted machine, booting to log-in screen now 24 sec.

B.t.w.: another cause of this problem might be that I had a second monitor plugged in during installation.

Offline

#62 2017-03-10 14:13:03

dsreyes1014
Member
Registered: 2014-06-28
Posts: 55

Re: kernel error in drm_kms_helper, flip_done timed out

I have a Dell D630 laptop as well and the kernel parameter video=SVIDEO-1:d seems to work.  This is not a solution but rather a workaround for now as my VGA port won't work with the kernel parameter it seems.

Offline

#63 2017-03-12 13:25:54

webspider84
Member
Registered: 2017-03-12
Posts: 1

Re: kernel error in drm_kms_helper, flip_done timed out

Huge thanks to sobralense and Bratpfanne.

This has been annoying me for ages and adding video=SVIDEO-1:d to systemd-boot conf has worked perfectly.

Boot speed it fantastic,

Thanks again guys.

Offline

#64 2017-03-15 13:58:59

kjkinnell
Member
Registered: 2016-11-16
Posts: 2

Re: kernel error in drm_kms_helper, flip_done timed out

Toshiba Satellite L755 laptop now working again.

Just installed 4.10.2-1, and the drm_kms_helper "flip_done timed out" warning is gone, the machine is not hanging for two or three minutes when switching graphics modes.

Changing the SVIDEO boot param did not help on this machine.

I never had a boot speed issue, but switching between vts took forever, and there were random hangs in X.  The 4.9 lts kernel reintroduced all of that, but upstream was making steady progress on this and it looks like older/weird-Toshiba-Intel graphics is supported again in the latest kernel.

And thanks to Soukyuu--removing xf86-intel-video made debugging a tiny bit easier.  Nothing required it, I don't know why I had it installed in the first place.

Last edited by kjkinnell (2017-03-15 14:00:39)

Offline

#65 2017-03-22 22:27:07

tmg
Member
Registered: 2017-03-22
Posts: 1

Re: kernel error in drm_kms_helper, flip_done timed out

Hi,

I faced the same problem installing Arch and Ubuntu on my laptop (zenbook ux31a). I found out this error only appeared when I had it plugged to my second monitor. Everything was fine using only the laptop.

Offline

#66 2017-06-13 10:16:03

giuscri
Member
From: Milan, Italy
Registered: 2013-08-19
Posts: 21

Re: kernel error in drm_kms_helper, flip_done timed out

I can confirm that removing xf86-video-intel fixed the problem, on Thinkpad x220; I didn't need to change the kernel options.

$ uname -a
Linux x220 4.11.3-1-ARCH #1 SMP PREEMPT Sun May 28 10:40:17 CEST 2017 x86_64 GNU/Linux

Last edited by giuscri (2017-06-13 10:16:49)

Offline

#67 2017-09-21 20:33:51

Lenry
Member
From: Szeged, Hungary
Registered: 2010-03-27
Posts: 53
Website

Re: kernel error in drm_kms_helper, flip_done timed out

Bratpfanne wrote:

Anyone who is affected by this bug could you please add the following kernel boot parameter instead of reverting the bad commit and test if it works?

video=SVIDEO-1:d

This has solved the bug for me on my Latitude D630 with a 4.9 kernel. It disables the SVIDEO connector but my laptop doesen't even have one so it's fine.

Thank you!
This reduced my boot time from ~40 seconds to 10!
Thank you again

Offline

#68 2017-09-27 03:31:51

malcontent
Member
Registered: 2017-09-27
Posts: 11

Re: kernel error in drm_kms_helper, flip_done timed out

The message "flip_done timed out" is not the real problem here, it's only a symptom of an underlying problem that needs to be fixed.

There are many potential problems that can cause the timeout, sometimes it's because of a missing interrupt, sometimes the GPU goes haywire and that causes the timeout, it can be different things, but it's important that we fix all those underlying issues.

So, please help with this and file bug reports on https://bugs.freedesktop.org/ (file it against DRM/Intel).

I would advise against adding a temporary workaround to your machine and then forget about it, because that won't help solve the real problem.

We need to fix everything upstream.

Last edited by malcontent (2017-09-27 20:18:47)

Offline

#69 2017-12-30 22:09:09

joelek
Member
Registered: 2017-12-30
Posts: 1

Re: kernel error in drm_kms_helper, flip_done timed out

I am not (currently) running Arch Linux (I have in the past). But your forum helped me. I am installing Linux Mint 18.3 XFCE on an older acer Extensa 7620Z that I was given, and I was experiencing long (around 20 second) delays during boot, after login, and after logout. During the login/logout delays, the mouse cursor was visible but frozen. It made switching users very painful.

I was seeing the following error peppered in my syslog:

[drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:29:pipe A] flip_done timed out

Adding video=SVIDEO-1:d to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub made the issue go away.

I am running Linux version 4.10.0-38-generic.

Offline

#70 2017-12-30 22:28:20

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 8,345
Website

Re: kernel error in drm_kms_helper, flip_done timed out

EDIT: I initially split your post off, but since you aren't asking for support, I don't see any need to. I'm glad you've found our forums useful.

I am going to close this old topic now, however.

Last edited by WorMzy (2017-12-30 22:30:37)


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB