You are not logged in.

#26 2018-05-28 15:09:27

surefire
Member
Registered: 2015-12-16
Posts: 11

Re: Chromium is intermittently very choppy

AlynxZhou wrote:
surefire wrote:

There is another solution I used and it works

--disable-gpu-driver-bug-workarounds

Since most workarounds are too old and have long been solved.
But it is better to highlight specific workarounds for shutdown than all at once.

Is there a way for electron-based app to set this? Thanks.


Yes, of course, but I don't know the only common way. Each electron-based application has its own implementation of the launcher.

Offline

#27 2018-05-28 15:54:55

Martinsos
Member
From: Croatia
Registered: 2015-08-27
Posts: 61

Re: Chromium is intermittently very choppy

AlynxZhou wrote:
Martinsos wrote:

Since Chromium is working fine when run directly on xorg server, and it does not work fine when run on xwayland, I am guessing that the real problem is in xwayland? Maybe multi buffering update in xorg-server is causing problems with xwayland and they have to fix it there? I will consider posting a bug to xwayland then.

@surefire: Thanks for the temporary solution! Where would I set that flag if I am running Chromium on xwayland?

@schmidtbag: Thanks for the tip! However I am not using KDE, I have been using XFCE in the past and now Gnome (due to it's HiDPI support). For my main editor I am actually using Emacs (mostly for C/C++, Python). I use Atom only for Javascript development, because support in Emacs is still not good enough for JSX unfortunately, I guess because not so many JS developers are using Emacs.

Maybe there is a bug when passing data in xwayland? But it seems that downgrade xserver fix the bug, not xwayland...

It is hard to say exactly if problem is in xorg server or in xwayland, since Chromium is working fine when run directly on Xorg. It could be that xorg server updated and part of xwayland is not handling that update correctly. Or maybe xorg server introduced bug in a part of code that is being used by xwayland. Anyway, maybe best to start from xwayland guys and see what they say.

Offline

#28 2018-05-28 17:52:57

schmidtbag
Member
From: MA, USA
Registered: 2011-02-08
Posts: 331
Website

Re: Chromium is intermittently very choppy

First of all, thanks surefire for the tip - it worked great.

It's tough to know what's really the culprit here.  It makes sense how xserver is the problem, because only that needed to be downgraded in order to fix the problem.  On the other hand, I really think the multi-buffering support implemented in xwayland has something to do with it, since the errors Chrome(ium) gave were specific to vsync.
However...
Since multi-buffering is a new implementation in xwayland, perhaps version 1.20 can't utilize it unless xserver supports/allows it.

In other words, I really think xwayland is the problem here, but, it's only a problem if you're using the same version of xserver.


My Arch Setups:
* Lenovo B40-80
* 3.95GHz Ryzen 1500X, Biostar X370GTN (ITX), 16GB DDR4, R9 290, OCZ 120GB SSD + PNY 1TB SSD

Offline

#29 2018-05-28 19:04:08

Martinsos
Member
From: Croatia
Registered: 2015-08-27
Posts: 61

Re: Chromium is intermittently very choppy

I filed a bug on Wayland's Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=106700 .
I can also confirm that using --disable-gpu-driver-bug-workarounds fixes the problem! Thanks everybody.

Offline

#30 2018-08-04 19:59:43

stecklars
Member
Registered: 2013-10-29
Posts: 8

Re: Chromium is intermittently very choppy

I am affected by this as well. Doing --disable-gpu-driver-bug-workarounds works, but if I run chrome via terminal / look into chrome://gpu, it is spammed with the message
"ERROR:gl_surface_presentation_helper.cc(115)] GetVSyncParametersIfAvailable() failed!"

Offline

#31 2018-08-10 14:30:56

Cabbage_c
Member
Registered: 2016-06-24
Posts: 8

Re: Chromium is intermittently very choppy

Thank you very much for the tip, surefire! I've experienced this problem since early this year, but never succeeded to locate it sad

surefire wrote:

There is another solution I used and it works

--disable-gpu-driver-bug-workarounds

Since most workarounds are too old and have long been solved.
But it is better to highlight specific workarounds for shutdown than all at once.

Offline

#32 2018-10-06 00:06:32

abmantis
Member
Registered: 2015-01-08
Posts: 12

Re: Chromium is intermittently very choppy

stecklars wrote:

I am affected by this as well. Doing --disable-gpu-driver-bug-workarounds works, but if I run chrome via terminal / look into chrome://gpu, it is spammed with the message
"ERROR:gl_surface_presentation_helper.cc(115)] GetVSyncParametersIfAvailable() failed!"

Same here, and it is probably wasting CPU doing that. Any workaround?

Offline

Board footer

Powered by FluxBB