You are not logged in.

#101 2020-01-16 12:13:39

dantscher
Member
Registered: 2020-01-16
Posts: 1

Re: i915 Skylake GPU hangs with kernel 5.3.11

I suffered from high-frequent freezes as well (ca every 20min in avg.) but since i disabled the display compositing of my windows manager (xfce) i had no GPU hangs in the last 2 days.

Last edited by dantscher (2020-01-16 15:39:21)

Offline

#102 2020-01-17 07:11:30

Kirurgs
Member
Registered: 2008-10-20
Posts: 144

Re: i915 Skylake GPU hangs with kernel 5.3.11

I'm watching for proper fix for this issue for quite some time for 5.4 kernel, it's not yet ready, however, this helped me to solve hangs on Skylake system for two weeks now (modesetting and intel x11 drivers): https://gitlab.freedesktop.org/drm/inte … ote_376308
I compile my own kernels, but if You want, try this revert until it gets solved properly.

Edit: NVM, it crashed on day 13, so it's not a fix sad

Last edited by Kirurgs (2020-01-21 13:12:01)

Offline

#103 2020-01-20 09:43:19

Forcer412
Member
Registered: 2020-01-20
Posts: 1

Re: i915 Skylake GPU hangs with kernel 5.3.11

Same problem. Rolled back to 5.3.0-arch1.

Offline

#104 2020-01-21 21:50:32

gay
Member
Registered: 2012-12-16
Posts: 86

Re: i915 Skylake GPU hangs with kernel 5.3.11

Just for the record, I have what I believe to be the same problem still with kernel 5.4.13-arch1-1

$ journalctl -xb-1
Jan 20 22:30:51 <hostname> kernel: Linux version 5.4.13-arch1-1 (linux@archlinux) (gcc version 9.2.0 (GCC)) #1 SMP PREEMPT Fri, 17 Jan 2020 23:09:54 +0000
(...)
Jan 21 21:10:01 <hostname> kernel: Rekeying PTK for STA <mac address??> but driver can't safely do that.
Jan 21 21:10:01 <hostname> kernel: i915 0000:00:02.0: GPU HANG: ecode 9:1:0x00000000, hang on rcs0
(...)

We are exactly the people our parents always warned us about.

Offline

#105 2020-01-27 09:28:28

citrus
Member
Registered: 2018-07-04
Posts: 8

Re: i915 Skylake GPU hangs with kernel 5.3.11

Can confirm that this is still an issue in kernel 5.4.14-arch1-1.

Offline

#106 2020-01-27 22:17:26

luntik20120
Member
Registered: 2017-11-25
Posts: 3

Re: i915 Skylake GPU hangs with kernel 5.3.11

citrus wrote:

Can confirm that this is still an issue in kernel 5.4.14-arch1-1.

+1

i5-8265u

Offline

#107 2020-01-27 22:30:44

loqs
Member
Registered: 2014-03-06
Posts: 9,836

Re: i915 Skylake GPU hangs with kernel 5.3.11

Does adding the option i915.enable_dc=0 have any effect on 5.4.14-arch1-1 ?

Offline

#108 2020-01-30 06:31:33

wraptile
Member
Registered: 2020-01-17
Posts: 1

Re: i915 Skylake GPU hangs with kernel 5.3.11

Upgraded to linux-mainline (5.5.0-1) with

intel_idle.max_cstate=1 i915.enable_dc=0

kernel options - no more hangs but many still many freeze ups that don't even show up in journalctl anymore. Trying to play with few more kernel parameters but it seem futile at this point - will report if I find something. 

In the meantime there are some suggestions in the upstream thread: https://gitlab.freedesktop.org/drm/intel/issues/673 though nothing has worked for me so far. Glad to get rid of full on hangs though!

Offline

#109 2020-01-30 06:46:09

whites11
Member
Registered: 2010-03-23
Posts: 26

Re: i915 Skylake GPU hangs with kernel 5.3.11

What is the latest kernel version unaffected by this bug AFAYK?

Offline

#110 2020-01-30 08:33:32

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,716

Re: i915 Skylake GPU hangs with kernel 5.3.11

5.5 should (generally, seems there are some outliers here and there) fix what has been discussed here initially.

There seem to be some other factors than just the GPU, FWIW I haven't been able to reproduce any of this on my skylake based Acer V (granted I did not yet extensively use 5.4 I was out of date for a while due to projects)

Last edited by V1del (2020-01-30 08:36:21)

Online

#111 2020-01-30 08:43:42

kuznetsss
Member
From: Russia, Moscow
Registered: 2018-01-13
Posts: 4

Re: i915 Skylake GPU hangs with kernel 5.3.11

Confirm that kernel  5.4.15 is affected by the issue at i7-8750H. But I have very rare (about 1 per day) freezes maybe because of  DRI option in /etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
	Identifier	"Intel Graphics"
	Driver		"intel"
	Option		"DRI"		"2"
EndSection

Offline

#112 2020-01-30 08:51:31

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,716

Re: i915 Skylake GPU hangs with kernel 5.3.11

You should try without xf86-video-intel and that config file. It does have a few known issues that might stem from it.

Last edited by V1del (2020-01-30 08:55:50)

Online

#113 2020-01-30 09:23:29

kuznetsss
Member
From: Russia, Moscow
Registered: 2018-01-13
Posts: 4

Re: i915 Skylake GPU hangs with kernel 5.3.11

V1del wrote:

You should try without xf86-video-intel and that config file. It does have a few known issues that might stem from it.

Thanks for your reply. I have very strange image colors without  xf86-video-intel and that config file. It's something like brown filter applied or like redshift is on with very red temperature.

Offline

#114 2020-01-30 13:38:22

Fandekasp
Member
From: Japan
Registered: 2012-02-12
Posts: 22
Website

Re: i915 Skylake GPU hangs with kernel 5.3.11

For what it's worth, I haven't had any bugs since I moved to Wayland a month ago, and stopped using chromium on xwayland. Other less resource intensive x11 apps do not trigger this issue.

Offline

#115 2020-01-30 16:39:18

ykonstant
Member
Registered: 2020-01-07
Posts: 9

Re: i915 Skylake GPU hangs with kernel 5.3.11

I am having the same problem; here is my error log:

an 30 07:40:13 ArchSys kernel: i915 0000:00:02.0: GPU HANG: ecode 9:1:0x00000000, hang on rcs0
Jan 30 07:40:13 ArchSys kernel: GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
Jan 30 07:40:13 ArchSys kernel: Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
Jan 30 07:40:13 ArchSys kernel: drm/i915 developers can then reassign to the right component if it's not a kernel issue.
Jan 30 07:40:13 ArchSys kernel: The GPU crash dump is required to analyze GPU hangs, so please always attach it.
Jan 30 07:40:13 ArchSys kernel: GPU crash dump saved to /sys/class/drm/card0/error
Jan 30 07:40:13 ArchSys kernel: i915 0000:00:02.0: Resetting rcs0 for hang on rcs0
Jan 30 07:40:17 ArchSys kernel: Asynchronous wait on fence i915:cinnamon[1116]:14a48e timed out (hint:intel_atomic_commit_ready+0x0/0x50 [i915])
Jan 30 07:40:21 ArchSys kernel: i915 0000:00:02.0: Resetting rcs0 for hang on rcs0

I managed to capture an actual crash dump yesterday, since for some reason for the first time the system was able to recover without hanging.

A couple of things that I observed:

1) 100% of crashes happen while I am browsing with Qutebrowser; it seems many people are crashing while using Chromium.  As far as I understand, these share some aspects of a rendering engine (QtWebEngine?).  Maybe there is a connection?  Of course, this can be just misleading: I spend 90% of my computer time on Qutebrowser or typing things smile

2) A moderator asked me why I use the intel driver rather than the modesetting driver; I don't know how to change the driver I am using.  I was using xf86-video-intel but I uninstalled it and deleted the 20-intel.conf file that configured it some time ago.  Is there anything else I should have done?

Offline

#116 2020-01-31 13:19:48

merc68k
Member
Registered: 2011-08-07
Posts: 16

Re: i915 Skylake GPU hangs with kernel 5.3.11

I've started seeing the same issue (hard hang with an oops in the i915 module, which I did manage to capture). 

I found this bug report which seems like the exact issue; just thought it would be worth posting here as I didn't see anyone else reference it yet.

Offline

#117 2020-01-31 13:23:58

whites11
Member
Registered: 2010-03-23
Posts: 26

Re: i915 Skylake GPU hangs with kernel 5.3.11

merc68k wrote:

I've started seeing the same issue (hard hang with an oops in the i915 module, which I did manage to capture). 

I found this bug report which seems like the exact issue; just thought it would be worth posting here as I didn't see anyone else reference it yet.

I think there might be more than one bug, because I downgraded to 5.3 and I just got an hang a few minutes ago. The bug report you linked talks about 5.4+.

Offline

#118 2020-01-31 13:30:43

merc68k
Member
Registered: 2011-08-07
Posts: 16

Re: i915 Skylake GPU hangs with kernel 5.3.11

I think there might be more than one bug, because I downgraded to 5.3 and I just got an hang a few minutes ago. The bug report you linked talks about 5.4+.

Yeah, agreed, in fact I shouldn't have highjacked this thread with a 5.4 issue, but someone already did and I forgot the OP was talking about 5.3.  Maybe it will still be useful.

Offline

#119 2020-01-31 13:32:24

loqs
Member
Registered: 2014-03-06
Posts: 9,836

Re: i915 Skylake GPU hangs with kernel 5.3.11

@merc68k that issue is fixed in 5.5 https://github.com/torvalds/linux/commi … 99fd1721ed
Edit:
It is not fixed in 5.4 as no backport has been submitted https://lore.kernel.org/stable/15783126 … kroah.com/
See also https://bbs.archlinux.org/viewtopic.php … 3#p1884353

Last edited by loqs (2020-01-31 13:44:27)

Offline

#120 2020-02-02 09:14:44

whites11
Member
Registered: 2010-03-23
Posts: 26

Re: i915 Skylake GPU hangs with kernel 5.3.11

For what it's worth, I report this article talking about this very issue: https://linuxreviews.org/Linux_Kernel_5 … nt_Kernels

Offline

#121 2020-02-02 09:57:37

kikislater
Member
From: Mauritius
Registered: 2016-01-16
Posts: 18

Re: i915 Skylake GPU hangs with kernel 5.3.11

Wow ! Sad ... Last time for Intel chip from my side. Time to switch to AMD

Last edited by kikislater (2020-02-02 09:57:59)

Offline

#122 2020-02-02 10:07:51

whites11
Member
Registered: 2010-03-23
Posts: 26

Re: i915 Skylake GPU hangs with kernel 5.3.11

kikislater wrote:

Wow ! Sad ... Last time for Intel chip from my side. Time to switch to AMD

I've been suffering with intel related bugs for 5 years now. My previous notebook had the CPU hang issue, this one the GPU. I'm really looking towards AMD as well.

Offline

#123 2020-02-02 10:22:45

dcc24
Member
Registered: 2009-10-31
Posts: 731

Re: i915 Skylake GPU hangs with kernel 5.3.11

Guys, once again, a lot of people are subscribed to this thread to get updates on the actual problem & solution. Please refrain from inane offtopic comments so we don't get notifications about them.


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#124 2020-02-03 18:35:28

djidji
Member
Registered: 2007-02-26
Posts: 56

Re: i915 Skylake GPU hangs with kernel 5.3.11

ykonstant wrote:

A couple of things that I observed:

1) 100% of crashes happen while I am browsing with Qutebrowser; it seems many people are crashing while using Chromium.  As far as I understand, these share some aspects of a rendering engine (QtWebEngine?).  Maybe there is a connection?  Of course, this can be just misleading: I spend 90% of my computer time on Qutebrowser or typing things smile

This is very similar to my experience. Vast majority of crashes / hangs happen when using Chromium, although I may have had one or two instances when using Slack. Like you, I spend 90% of my time in these two applications so this may be misleading. However hangs very often seemed to be a direct result of an action in Chromium - clicking on a link, opening new tab, switching tabs, etc. Finally I got tired of forced reboots twice a day and I switched to using Firefox some 7-10 days ago. I'm still on kernel 5.4.15 but I haven't had any hangs since the switch. Don't know if this is a coincidence, dumb luck, or whatever else, but I'll take it.

Offline

#125 2020-02-03 19:25:31

dessaya
Member
Registered: 2015-10-03
Posts: 3

Re: i915 Skylake GPU hangs with kernel 5.3.11

djidji wrote:

This is very similar to my experience. Vast majority of crashes / hangs happen when using Chromium, although I may have had one or two instances when using Slack. Like you, I spend 90% of my time in these two applications so this may be misleading. However hangs very often seemed to be a direct result of an action in Chromium - clicking on a link, opening new tab, switching tabs, etc. Finally I got tired of forced reboots twice a day and I switched to using Firefox some 7-10 days ago. I'm still on kernel 5.4.15 but I haven't had any hangs since the switch. Don't know if this is a coincidence, dumb luck, or whatever else, but I'll take it.

I use Firefox and I also experience the crashes. But I think it's also relevant that I have layers.acceleration.force-enabled=true (ie, hardware acceleration enabled).

Offline

Board footer

Powered by FluxBB