You are not logged in.

#26 2020-09-24 21:53:02

jstitch
Member
From: Mexico city
Registered: 2012-04-16
Posts: 8

Re: [WORKED AROUND] Keyboard doesn't work in linux 5.8 due to Asus hotkeys

IslandC0der wrote:
stecky_ms wrote:
ACTION=="add|change", KERNEL=="event[0-9]*", ATTRS{name}=="Intel Virtual Button driver", ENV{LIBINPUT_IGNORE_DEVICE}="1"

I've just tried that by replacing "Intel Virtual Button driver" with "Asus WMI hotkeys". It does work, though I still have the same problem as described in #18.
But thank you anyways, I think we're on the right track to pinpoint this issue. smile

Same problem here, with an Asus. This worked for me with exaclty the same issues as you...

Offline

#27 2020-09-26 01:02:13

IslandC0der
Member
From: Portugal
Registered: 2020-06-28
Posts: 28

Re: [WORKED AROUND] Keyboard doesn't work in linux 5.8 due to Asus hotkeys

When using the udev rule with a previous kernel (in this case, 5.4.67-1-lts) an error message spams the journal: "Invalid tag name 'Keyboard Switch', ignoring"
To me this suggests that the 'Keyboard Switch' tag didn't exist before; and now that it was added on 5.8, it's getting very confused with our Asus keyboards (more specifically, the hotkeys).

Offline

#28 2020-10-06 03:57:28

XiohAtk
Member
From: Scotland
Registered: 2020-10-03
Posts: 1

Re: [WORKED AROUND] Keyboard doesn't work in linux 5.8 due to Asus hotkeys

stecky_ms wrote:

I experience the same issue on a Acer Aspire E5-511, internal keyboard and touch pad is working on console, but as soon as you start any graphical system (using libinput) neither of the two input devices are working. The problem is present on the 5.8.7 and the 5.7.12 kernel. In my case the problematic input device seems to be the "Intel Virtual Button driver" (at least on the 5.8.7 kernel), which is marked both as a keyboard and a switch:

# libinput list-devices
...
Device:           Intel Virtual Button driver
...
Capabilities:     keyboard switch
...

After creating a udev rule which adds a libinput device configuration to ignore this device both the keyboard and the touch pad are working perfectly fine in GDM, Gnome (Wayland based session) and also in a bare Xorg server. The FN hotkeys are working too. Here is the udev rule I use as a reference, maybe it can be adapted to other machines as well:

/etc/udev/rules.d/99-acer-libinput.rules

ACTION=="add|change", KERNEL=="event[0-9]*", ATTRS{name}=="Intel Virtual Button driver", ENV{LIBINPUT_IGNORE_DEVICE}="1"

Still a work around though, not addressing the underlying problem, but it does the trick for me...


Thank you so much dude I have the same system as you Acer Aspire E5-511 and I've looked for so long for a fix and I found it in a Asus thread


Arch <3

Offline

#29 2020-10-08 10:14:03

wangjie
Member
Registered: 2020-10-08
Posts: 1

Re: [WORKED AROUND] Keyboard doesn't work in linux 5.8 due to Asus hotkeys

dantistnfs wrote:

So I faced the same issue, and found workaround for now.
Before updating kernel:
Edit file /etc/X11/xorg.conf.d/00-keyboard.conf
Add next lines:

Section "InputClass"
        Identifier "Asus WMI hotkeys"
        MatchProduct "Asus WMI hotkeys"
        Option "Ignore" "on"
EndSection

If you use nvidia-xrun, don't forget to add same lines to /etc/X11/nvidia-xorg.conf.d/00-keyboard.conf

Same problem here and it works for me.

Offline

#30 2020-10-08 12:50:00

k0rn1
Member
Registered: 2020-10-08
Posts: 1

Re: [WORKED AROUND] Keyboard doesn't work in linux 5.8 due to Asus hotkeys

dantistnfs wrote:

So I faced the same issue, and found workaround for now.
Before updating kernel:
Edit file /etc/X11/xorg.conf.d/00-keyboard.conf
Add next lines:

Section "InputClass"
        Identifier "Asus WMI hotkeys"
        MatchProduct "Asus WMI hotkeys"
        Option "Ignore" "on"
EndSection

If you use nvidia-xrun, don't forget to add same lines to /etc/X11/nvidia-xorg.conf.d/00-keyboard.conf


Thank you big_smile

Offline

#31 2020-10-08 13:05:52

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 3,401

Re: [WORKED AROUND] Keyboard doesn't work in linux 5.8 due to Asus hotkeys

That's enough "me too" posts -- I am closing this thread now.

Offline

Board footer

Powered by FluxBB