You are not logged in.

#26 2021-07-26 13:14:01

Registered: 2020-09-29
Posts: 3

Re: [SOLVED]Grub cannot find UUID when booting / new_root: DUALBOOT, UEFI

Firebird wrote:

Solved it after finding a few similar posts in this forum. Here is what I did:

From my rescue flash drive:

mount -L arch_p /mnt
mount -L SYSTEM_DRV /mnt/boot
swapon -L swap_p
pacstrap /mnt base base-devel linux linux-firmware dhcpcd nano intel-ucode wpa_supplicant netctl dialog 
genfstab -Lp /mnt > /mnt/etc/fstab
arch-chroot /mnt

Now comes the critical part: I added module "vmd" as follows:
Created file /etc/modules-load.d/customload.conf with content


and in /etc/mkinitcpio.conf edited the line


to look like


then did

mkinitcpio -p linux
grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=Arch-Linux-grub
grub-mkconfig -o /boot/grub/grub.cfg

Then exit chroot, umount everything, shutown, power up and Grub starts and is able to load linux as well as windows

Thank you!
This helped me a lot after months of trying to fix this issue


Board footer

Powered by FluxBB