You are not logged in.

#26 2022-02-19 16:24:29

Abobich
Member
Registered: 2022-02-18
Posts: 3

Re: Missing libcrypt.so.1

seth wrote:

So mixing glibc 2.33 and 2.35 libraries? Dumb idea.
Undo that, install libxcrypt-compat.
If not having libcrypt.so.1, copying the 2.33 version and installing libxcrypt-compat all yield the same error, it's probably not about libcrypt.so.1 at all - please post the coredump.

I found a solution in the sidefx forum:

export LD_PRELOAD="/usr/lib64/libc_malloc_debug.so.0".

With libxcrypt-compat libraries everything works fine. Thank you for your help.

Offline

#27 2022-02-20 02:52:32

mamutal91
Member
From: Brazil
Registered: 2021-01-05
Posts: 1
Website

Re: Missing libcrypt.so.1

This helped me a lot!!! Thank you very much, I was already desperate without being able to solve the error when building custom rom AOSP

https://github.com/mamutal91/dotfiles/c … 64743b1038

Offline

#28 2022-02-23 07:09:59

vgivanovic
Member
Registered: 2011-02-18
Posts: 40

Re: Missing libcrypt.so.1

To get your program that generated this error message

error while loading shared libraries: libcrypt.so.1: cannot open shared object file: No such file or directory

working again, do this

gpg --keyserver keyserver.ubuntu.com --recv-keys 678CE3FEE430311596DB8C16F52E98007594C21D
yay -S libxcrypt-compat

Offline

#29 2022-02-23 17:48:01

endre
Member
Registered: 2020-12-21
Posts: 3

Re: Missing libcrypt.so.1

I compiled and uploaded the package to my webserver. This is for the brave only, I did not read the PKGBUILD, I did not sign the package. It might contain backdoors from upsteam or from myself (intentionally or not).

https://end.re/libxcrypt-compat-4.4.28-2-x86_64.pkg.tar.zst

Offline

#30 2022-02-25 02:33:17

brainiac
Member
Registered: 2007-11-08
Posts: 25

Re: Missing libcrypt.so.1

libxcrypt-compat is not in the aur anymore.

Offline

#31 2022-02-25 02:37:28

loqs
Member
Registered: 2014-03-06
Posts: 17,730

Re: Missing libcrypt.so.1

brainiac wrote:

libxcrypt-compat is not in the aur anymore.

https://archlinux.org/packages/testing/ … pt-compat/

Offline

Board footer

Powered by FluxBB