You are not logged in.

#26 2022-11-06 22:01:09

loqs
Member
Registered: 2014-03-06
Posts: 15,509

Re: OpenSSL update broken Cargo (Rust)

mostlyharmless wrote:

cmake (3.24.3-1) is also broken by this openssl 1.1->3.0.7-2 update,  installing the openssl-1.1 package fixes it. Pity this wasn't coordinated better.

Do you see libcrypto.so.1.1 or libssl.so.1.1 in the output below?

lddtree /usr/bin/cmake
/usr/bin/cmake (interpreter => /lib64/ld-linux-x86-64.so.2)
    libz.so.1 => /usr/lib/libz.so.1
    libarchive.so.13 => /usr/lib/libarchive.so.13
        libcrypto.so.3 => /usr/lib/libcrypto.so.3
        libacl.so.1 => /usr/lib/libacl.so.1
        libexpat.so.1 => /usr/lib/libexpat.so.1
        liblzma.so.5 => /usr/lib/liblzma.so.5
        libzstd.so.1 => /usr/lib/libzstd.so.1
        liblz4.so.1 => /usr/lib/liblz4.so.1
        libbz2.so.1.0 => /usr/lib/libbz2.so.1.0
    libcurl.so.4 => /usr/lib/libcurl.so.4
        libnghttp2.so.14 => /usr/lib/libnghttp2.so.14
        libidn2.so.0 => /usr/lib/libidn2.so.0
            libunistring.so.2 => /usr/lib/libunistring.so.2
        libssh2.so.1 => /usr/lib/libssh2.so.1
        libpsl.so.5 => /usr/lib/libpsl.so.5
        libssl.so.3 => /usr/lib/libssl.so.3
        libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2
            libkrb5.so.3 => /usr/lib/libkrb5.so.3
            libk5crypto.so.3 => /usr/lib/libk5crypto.so.3
            libcom_err.so.2 => /usr/lib/libcom_err.so.2
            libkrb5support.so.0 => /usr/lib/libkrb5support.so.0
            libkeyutils.so.1 => /usr/lib/libkeyutils.so.1
            libresolv.so.2 => /usr/lib/libresolv.so.2
        libbrotlidec.so.1 => /usr/lib/libbrotlidec.so.1
            libbrotlicommon.so.1 => /usr/lib/libbrotlicommon.so.1
    libjsoncpp.so.25 => /usr/lib/libjsoncpp.so.25
    libuv.so.1 => /usr/lib/libuv.so.1
    librhash.so.0 => /usr/lib/librhash.so.0
    libstdc++.so.6 => /usr/lib/libstdc++.so.6
    libm.so.6 => /usr/lib/libm.so.6
    libgcc_s.so.1 => /usr/lib/libgcc_s.so.1
    libc.so.6 => /usr/lib/libc.so.6

Offline

#27 2022-11-07 01:15:42

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,830

Re: OpenSSL update broken Cargo (Rust)

mostlyharmless wrote:

cmake (3.24.3-1) is also broken by this openssl 1.1->3.0.7-2 update,  installing the openssl-1.1 package fixes it. Pity this wasn't coordinated better.

No it isn't. YOUR cmake may be broken, but it's not broken by Arch. Everything was coordinated just fine.

Offline

#28 2022-11-07 10:46:39

dzusan
Member
Registered: 2012-05-18
Posts: 7

Re: OpenSSL update broken Cargo (Rust)

After last system upgrade I ran into a problem.

pacman: error while loading shared libraries: libssl.so.1.1

I leave my solution here because google first link about the problem leads here. I have improved a little the script from top thread of this forum branch https://bbs.archlinux.org/viewtopic.php?id=95007.

#!/bin/bash

arch=x86_64
mirror=http://mirror.rit.edu/archlinux

# link to cache (or download) and extract: openssl,pacman
cd /tmp
mkdir pacmanfix
cd pacmanfix
for pkg in openssl-1.1-1.1.1.s-2 pacman-6.0.2-5; do
    pkgname=${pkg}-${arch}.pkg.tar.zst
    wget ${mirror}/core/os/${arch}/${pkgname} || exit 1
    sudo tar -xvpf ${pkgname} -C / --exclude .PKGINFO --exclude .INSTALL || exit 1
done

# now reinstall using pacman to update the local pacman db 
sudo pacman -S openssl pacman || exit 1

# now update your system
sudo pacman -Syu

Offline

#29 2022-11-07 12:46:32

schard
Member
From: Hannover
Registered: 2016-05-06
Posts: 1,565
Website

Re: OpenSSL update broken Cargo (Rust)

dzusan wrote:
sudo tar -xvpf ${pkgname} -C / --exclude .PKGINFO --exclude .INSTALL || exit 1

Bad idea.


Солідарність з Україною

Offline

#30 2022-11-07 14:07:01

aryklein
Member
From: Cordoba, Argentina
Registered: 2014-02-18
Posts: 4

Re: OpenSSL update broken Cargo (Rust)

With `paru` you only need to recompile the binary (with makepkg -s) and re-install it with `pacman -U paru-xxxx`.
I guess it's the same solution for other packages

Offline

#31 2022-11-08 14:01:09

Greetings
Member
Registered: 2022-11-08
Posts: 1

Re: OpenSSL update broken Cargo (Rust)

Tried on my home and work computer, everything works fine

I solved the problem in this way:

1. Went to /usr/lib

cd /usr/lib

2. Deleted the file

sudo rm -Rf libssl.so.1.1

3. Installed the package again

sudo pacman -S openssl-1.1

Offline

#32 2022-11-08 14:05:18

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,830

Re: OpenSSL update broken Cargo (Rust)

Greetings wrote:

Tried on my home and work computer, everything works fine

I solved the problem in this way:

1. Went to /usr/lib

cd /usr/lib

2. Deleted the file

sudo rm -Rf libssl.so.1.1

3. Installed the package again

sudo pacman -S openssl-1.1

I don't know what 'problem' this was meant to solve, but DO NOT DO THIS.

Offline

#33 2022-11-08 16:50:47

ulidtko
Member
Registered: 2013-05-11
Posts: 10

Re: OpenSSL update broken Cargo (Rust)

Hi all, I guess this is the "OpenSSL update breakage" thread? Am another victim.

Any recourse from this?

sudo: error while loading shared libraries: libcrypto.so.1.1: cannot open shared object file: No such file or directory

I know I know, partial updates are not supported, heard that before. Hearing the mantra again is not helping to recover the system.

I have the downgraded libcrypto.so.1.1 file right before me — vulgarly ripped out of a package openssl-1.1-1.1.1.s-2-x86_64.pkg.tar.zst

But no way to install it & run ldconfig — with broken sudo. Thoughts?

Am pretty darn sure that this is a system state where reboot will be fatal. Hopefully I won't get another power outage & force-shutdown before resolving this!

Offline

#34 2022-11-08 16:57:57

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,830

Re: OpenSSL update broken Cargo (Rust)

Can you log in as root and update your system?

Offline

#35 2022-11-08 17:11:56

ulidtko
Member
Registered: 2013-05-11
Posts: 10

Re: OpenSSL update broken Cargo (Rust)

Scimmia wrote:

Can you log in as root and update your system?

Thinking about this. The only way I see is to prepare a bootable live-usb.

docker is broken.

systemctl is broken. journalctl is broken

As the best practice, I have ssh root login disabled (PermitRootLogin prohibit-password) — which forces to go via sudo — which is broken.

Gah, what a mess. All I needed to do was to install a newer nodejs-lts version. Now all this..

Offline

#36 2022-11-08 17:13:47

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,830

Re: OpenSSL update broken Cargo (Rust)

Switching to a TTY and logging in as root isn't an option? Everything you mentioned shouldn't stop that.

Edit: of course, there's a good chance pacman itself is broken. If so, you'll have to either use pacman-static, or, as you said, boot an install disk and use pacman from there. Extracting the old lib and LD_PRELOADing it would be an option as well.

Last edited by Scimmia (2022-11-08 17:18:21)

Offline

#37 2022-11-08 17:22:57

ulidtko
Member
Registered: 2013-05-11
Posts: 10

Re: OpenSSL update broken Cargo (Rust)

Scimmia wrote:

Switching to a TTY and logging in as root isn't an option? Everything you mentioned shouldn't stop that.

Jeez man, thanks for reminding! That actually worked.

Then simply,

# mv /tmp/usr/lib/lib{crypto,ssl}.so.1.1 /usr/lib
# pacman --overwrite '/usr/lib/lib*.so.1.1' -S openssl-1.1

and I'm back on track. Kudos!

Edit: sudo is resistant to the LD_PRELOAD trick (obviously in retrospect), already tried it smile

Last edited by ulidtko (2022-11-08 17:24:21)

Offline

#38 2022-11-08 17:23:56

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,830

Re: OpenSSL update broken Cargo (Rust)

That's not a fix, that's a workaround. Update your system like you should have done in the first place.

Offline

#39 2022-11-08 17:29:31

ulidtko
Member
Registered: 2013-05-11
Posts: 10

Re: OpenSSL update broken Cargo (Rust)

Scimmia wrote:

That's not a fix, that's a workaround. Update your system like you should have done in the first place.

Here's my df if you're interested:

$ pydf
Filesystem Size Used Avail Use%                                                    Mounted on
/dev/sda2   32G  29G 2116M 92.4 [############################################....] /         
/dev/sda3  202G 198G 3308M 98.4 [###############################################.] /home     

And — no I cannot get a bigger SSD on this laptop. This machine has a proprietary nonstandard ssd connector, and literally 3 models of SSD were ever made supporting it. All 256G capacity.

So as you can imagine, the touted "full system upgrade" is a huge PITA for me. Not fancy myself doing it very often.

Edit: to clarify — because when /tmp space runs out, during the full system upgrade — pacman ruins the system.

Last edited by ulidtko (2022-11-08 17:31:23)

Offline

#40 2022-11-08 17:34:44

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,830

Re: OpenSSL update broken Cargo (Rust)

Then you need to expect to destroy your system every time you do a partial update. It can, and WILL, happen over and over again.

Offline

#41 2022-11-08 17:50:49

ulidtko
Member
Registered: 2013-05-11
Posts: 10

Re: OpenSSL update broken Cargo (Rust)

Scimmia wrote:

Then you need to expect to destroy your system every time you do a partial update. It can, and WILL, happen over and over again.

See, it doesn't matter... I do a partial upgrade — get occasional breakage. I do a full upgrade — get occasional breakage just as well (because pacman handles ENOSPC for /tmp just as disastrously).

No big difference, apart maybe from the time I spend knocking it back into sense.
So all this breakage does — just gradually burns out my will to apply updates ever again. Especially without changelogs. (pacolog? hell no, I'm not going to run it 748 times now, once per each package)

That's just what we get with Arch. It's kinda famous for being "questionably stable".

Offline

#42 2022-11-08 17:53:26

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,830

Re: OpenSSL update broken Cargo (Rust)

Let's put it another way, then.

Not supported means you don't get support. Asking for help on these forums and other places for a partially updated system that you refuse to update isn't going to go over well.

Yes, things on your system are breaking, that's on you so tough shit.

Offline

#43 2022-11-08 17:56:38

ulidtko
Member
Registered: 2013-05-11
Posts: 10

Re: OpenSSL update broken Cargo (Rust)

Scimmia wrote:

Yes, things on your system are breaking, that's on you so tough shit.

Yep, I agree. Thanks for responding anyways!

Offline

Board footer

Powered by FluxBB