You are not logged in.

#26 2022-12-21 04:49:06

Stonegrip
Member
Registered: 2022-12-10
Posts: 20

Re: [SOLVED] System won't start after the post-instalation reboot

Hurray! My issue got resolved: the graphical interface (lightDM) has finally loaded after I added "ibt=off" to the kernel settings.

Here is my xorg log:
Xorg log after graphical reboot

I also connected to the internet through nmcli (I enabled WiFi with "nmcli radio wifi on", after which I set up my net interface and then connected to internet using nmcli). Interestingly, my IWD is still not working, so I can't use "iwctl" commands.

Should I now switch to the graphical target? I'm asking this since I'm firstly getting booted to TTY1 prompt, from where I can start my graphical display manager with "systemctl start graphical.target", but that's an extra step in the logging process.  I tried to switch the default target to graphical with "systemctl enable graphical.target", but got the following message:

$ systemctl enable graphical.target
==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-unit-files ====
Authentication is required to manage system service or unit files.
Authenticating as: stonegrip
Password: 
==== AUTHENTICATION COMPLETE ====
The unit files have no installation config (WantedBy=, RequiredBy=, Also=,
Alias= settings in the [Install] section, and DefaultInstance= for template
units). This means they are not meant to be enabled using systemctl.
 
Possible reasons for having this kind of units are:
• A unit may be statically enabled by being symlinked from another unit's
  .wants/ or .requires/ directory.
• A unit's purpose may be to act as a helper for some other unit which has
  a requirement dependency on it.
• A unit may be started when needed via activation (socket, path, timer,
  D-Bus, udev, scripted systemctl call, ...).
• In case of template units, the unit is meant to be enabled with some
  instance name specified.

But regardless what the answer to my previous question is, HUGE THANKS FOR THE HELP TO SETH AND CFR. GUYS, YOU ARE FANTASTIC!!! We can continue this thread, but let me change the thread's name as [SOLVED].

Offline

#27 2022-12-21 08:29:08

seth
Member
Registered: 2012-09-03
Posts: 35,307

Re: [SOLVED] System won't start after the post-instalation reboot

To make the graphical target the default ("again" - it's the default default target), see the 2nd link below.
The xorg log shows a regular optimus/prime setup, so nothing to concern about.

Offline

#28 2022-12-22 05:57:50

Stonegrip
Member
Registered: 2022-12-10
Posts: 20

Re: [SOLVED] System won't start after the post-instalation reboot

@Seth: Thanks a lot for the response. I think I didn't ask my previous question correctly. The graphical.target has been set up successfully, but if I don't press "e" and capture the  "ibt=off" spell, I'll be greeted by a welcoming black screen.  So what I meant to ask was if I can capture the "ibt=off" somewhere in the bootloader config file, so that I don't need to jump through all these hoops with bootloader at every reboot.

If I can, what exactly do I need to do to make it happen?

I checked /boot/grub directory and its grub.cfg, and noticed that there is a line with linux kernel settings right there, so it feels like I can simply add the "ibt=off" directly in that config, but what spooks me is the header of that config that explicitly states DO NOT EDIT THIS FILE. And it also says that the changes to that grub config are made by grub-mkconfig using various templates and settings. I could delve into it myself, but that would be adjacent to the risks of breaking the bootloader, so if you could navigate me to the right file where I can simply add "ibt=off" or something of similar complexity, that would be greatly appreciated.

Offline

#29 2022-12-22 06:22:53

skunktrader
Member
From: Brisbane, Australia
Registered: 2010-02-14
Posts: 1,502

Re: [SOLVED] System won't start after the post-instalation reboot

Stonegrip wrote:

I checked /boot/grub directory and its grub.cfg, and noticed that there is a line with linux kernel settings right there, so it feels like I can simply add the "ibt=off" directly in that config, but what spooks me is the header of that config that explicitly states DO NOT EDIT THIS FILE. And it also says that the changes to that grub config are made by grub-mkconfig using various templates and settings. I could delve into it myself, but that would be adjacent to the risks of breaking the bootloader, so if you could navigate me to the right file where I can simply add "ibt=off" or something of similar complexity, that would be greatly appreciated.

https://wiki.archlinux.org/title/GRUB#A … _arguments

Offline

#30 2022-12-23 02:45:33

Stonegrip
Member
Registered: 2022-12-10
Posts: 20

Re: [SOLVED] System won't start after the post-instalation reboot

I have added the "ibt=off" parameter to  /etc/default/grub: firstly, to GRUB_CMDLINE_LINUX, and after that didn't work, to  GRUB_CMDLINE_LINUX_DEFAULT.

So now my /etc/default/grub looks as follows:

 
# GRUB boot loader configuration

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Arch"
GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet ibt=off"
GRUB_CMDLINE_LINUX="rootfstype=ext4 ibt=off"

However, I still don't see the change in the "linux" line of my bootloader when I press "e" at the booting, and the "ibt=off" is not getting added there. So if I don't add it manually, the booting results in a black unresponsive screen.

I wonder if the grub config is not getting updated at each reboot, and I need to do it manually by running:

 grub-mkconfig -o /boot/grub/grub.cfg 

Is my understanding correct? Should I run the grub-mkconfig command post the aforementioned changes to /etc/default/grub? I just don't want to screw something up.

Offline

#31 2022-12-23 03:01:25

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 7,127

Re: [SOLVED] System won't start after the post-instalation reboot

Stonegrip wrote:

I wonder if the grub config is not getting updated at each reboot,

That isn't how it works.

Stonegrip wrote:

and I need to do it manually by running:

 grub-mkconfig -o /boot/grub/grub.cfg 

Is my understanding correct? Should I run the grub-mkconfig command post the aforementioned changes to /etc/default/grub?

Yes, you should. Anytime you change the config, you install or remove a kernel (e.g. adding linux-lts or removing it) etc. When grub itself is updated, you should also reinstall it.


CLI Paste | How To Ask Questions

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Wireless 8265/8275 | US keyboard w/ Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#32 2022-12-23 04:12:27

Stonegrip
Member
Registered: 2022-12-10
Posts: 20

Re: [SOLVED] System won't start after the post-instalation reboot

Got it. Thank you.

So, in my case, since I'm not updating the grub itself, I don't need to run "grub-install...", and I just run "grub-mkconfig..." to update /boot/grub/grub.cfg. Right?

Also, do I need to add "ibt=off" to both GRUB_CMDLINE_LINUX and GRUB_CMDLINE_LINUX_DEFAULT, or just GRUB_CMDLINE_LINUX would suffice, since GRUB_CMDLINE_LINUX_DEFAULT is only used for recovery boot?

Last edited by Stonegrip (2022-12-23 04:15:54)

Offline

#33 2022-12-23 04:41:30

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 7,127

Re: [SOLVED] System won't start after the post-instalation reboot

Stonegrip wrote:

So, in my case, since I'm not updating the grub itself, I don't need to run "grub-install...", and I just run "grub-mkconfig..." to update /boot/grub/grub.cfg. Right?

Right.

Stonegrip wrote:

Also, do I need to add "ibt=off" to both GRUB_CMDLINE_LINUX and GRUB_CMDLINE_LINUX_DEFAULT, or just GRUB_CMDLINE_LINUX would suffice, since GRUB_CMDLINE_LINUX_DEFAULT is only used for recovery boot?

I'm not sure whether you want to add it at all as I don't know what it does. That is, I don't know if it is a temporary trouble-shooting thing (like nomodeset or whatever) or whether it is intended as a solution.

Ref.: https://github.com/NVIDIA/open-gpu-kern … 1140425559 - I guess from this you need to add it permanently. Or until the bug gets fixed anyway. If you can boot to multi-user.target without it, I can't see you would need it for a recovery boot, no.


CLI Paste | How To Ask Questions

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Wireless 8265/8275 | US keyboard w/ Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#34 2022-12-23 05:08:10

Stonegrip
Member
Registered: 2022-12-10
Posts: 20

Re: [SOLVED] System won't start after the post-instalation reboot

Thanks, cfr. I've updated the grub config, and now I can boot smoothly without any manual interventions.

Greatly appreciate all the help. Now this thread is completely closed out.

PS: just for the records (in case someone will be reading this thread going forward), I have only updated GRUB_CMDLINE_LINUX line of /etc/default/grub. Otherwise, "ibt=off" was duplicated in the grub config post updating it with "grub-mkconfig...".

Offline

Board footer

Powered by FluxBB