You are not logged in.

#76 2023-01-31 23:04:08

seth
Member
Registered: 2012-09-03
Posts: 52,335

Re: [SOLVED] UT99 not start

The "OpenGL render" actually crashes in the openal library shipped by ut99.
Is that the unpatched version?

The "coredump" is back to xkb…

#13 0xf74e6898 in _XSend (dpy=0xa080500, data=0x0, size=0) at /usr/src/debug/lib32-libx11/libX11-1.8.3/src/xcb_io.c:569
#14 0xf74eba54 in _XReply (dpy=0xa080500, rep=0xfff20f4c, extra=2, discard=0) at /usr/src/debug/lib32-libx11/libX11-1.8.3/src/xcb_io.c:679
#15 0xf7538549 in _XkbHandleGetMapReply (xkb=0xcedf6b0, dpy=0xa080500) at xkb/XKBGetMap.c:553
#16 XkbGetUpdatedMap (xkb=0xcedf6b0, which=7, dpy=0xa080500) at xkb/XKBGetMap.c:575
#17 XkbGetUpdatedMap (dpy=0xa080500, which=7, xkb=0xcedf6b0) at xkb/XKBGetMap.c:562
#18 0xf753863c in XkbGetMap (dpy=0xa080500, which=7, deviceSpec=256) at xkb/XKBGetMap.c:594
#19 0xf75386bf in _XkbLoadDpy (dpy=dpy@entry=0xa080500) at xkb/XKBBind.c:521
#20 0xf7538ed7 in XLookupKeysym (event=0xfff21148, col=0) at xkb/XKBBind.c:218
#21 0xf7a1fe86 in X11_TranslateKey () from ./libSDL-1.1.so.0
#22 0xf7a1f738 in ?? () from ./libSDL-1.1.so.0

The nouveau version fails at

#20 0xf7682217 in _dlerror_run (operate=<optimized out>, args=<optimized out>) at dlerror.c:138
#21 0xf76828b8 in dlopen_implementation (dl_caller=<optimized out>, mode=258, file=0xffffa70c "/usr/lib32/dri/nouveau_dri.so") at dlopen.c:71
#22 ___dlopen (file=0xffffa70c "/usr/lib32/dri/nouveau_dri.so", mode=258) at dlopen.c:81
#23 0xf5ee24e7 in loader_open_driver_lib () at ../mesa-22.3.3/src/loader/loader.c:654
#24 0xf5ee2674 in loader_open_driver () at ../mesa-22.3.3/src/loader/loader.c:697
#25 0xf5ec58d1 in driOpenDriver () at ../mesa-22.3.3/src/glx/dri_common.c:87
#26 0xf5eddf45 in dri3_create_screen () at ../mesa-22.3.3/src/glx/dri3_glx.c:880
#27 0xf5ece758 in AllocAndFetchScreenConfigs () at ../mesa-22.3.3/src/glx/glxext.c:839
#28 __glXInitialize () at ../mesa-22.3.3/src/glx/glxext.c:968

Is that the unpatched version?
You could try to disable DRI3,

LIBGL_DRI3_DISABLE=1 ./ut

If you've xf86-video-nouveau installed, get rid of that first.

Offline

#77 2023-01-31 23:17:17

freeartist
Member
Registered: 2022-09-06
Posts: 69

Re: [SOLVED] UT99 not start

UNpatched

>LIBGL_DRI3_DISABLE=1 ./ut
crash

Offline

#78 2023-01-31 23:20:00

seth
Member
Registered: 2012-09-03
Posts: 52,335

Re: [SOLVED] UT99 not start

UNpatched

Stop doing that. The patch most likely exist for a reason and the reason will be several ABI incompatibilities with more recent software stacks.
(Which is why it's crashing on the bundled libraries and possibly even when dlopening the nouveau mesa dri)

This is probably also addressed in the release notes of the patch.

Offline

#79 2023-01-31 23:26:08

freeartist
Member
Registered: 2022-09-06
Posts: 69

Re: [SOLVED] UT99 not start

>Stop doing that

That question of this topic

>reason will be several ABI incompatibilities with more recent software stacks

Why UNpatched ut working at recent Linux Debian Sid and Fedora 37 at this 340.108 driver?

PS last patch 469c also not working at 340.108

Last edited by freeartist (2023-01-31 23:28:16)

Offline

#80 2023-02-01 07:03:26

seth
Member
Registered: 2012-09-03
Posts: 52,335

Re: [SOLVED] UT99 not start

Why UNpatched ut working at recent Linux Debian Sid and Fedora 37 at this 340.108 driver?

Because, as mentioned many times before, it's a different software stack. This could be down to compiler options to preserve older ABIs in libc.
The unpatched game crashes in its bundled libraries - that has nothing to do w/ the graphics driver.

PS last patch 469c also not working at 340.108

Not working how?
Do you have a coredump?

Offline

#81 2023-02-01 17:26:31

freeartist
Member
Registered: 2022-09-06
Posts: 69

Re: [SOLVED] UT99 not start

>The unpatched game crashes in its bundled libraries - that has nothing to do w/ the graphics driver.

i do not undestand where is problem, in arch system or aur 340xx nvidia driver?

>Not working how?
>Do you have a coredump?

they experementing with renders. 469c. Xopengl gives on linux error not coredump, and opengl working very slow - 2fps. But under windows with 342xx driver and Xopengl all working good. I post at their git issues but have no answers.

Last edited by freeartist (2023-02-01 17:28:00)

Offline

#82 2023-02-01 17:37:36

freeartist
Member
Registered: 2022-09-06
Posts: 69

Re: [SOLVED] UT99 not start

wht difference between nvidia-340xx-utils and lib32-nvidia-340xx-utils from aur?

Offline

#83 2023-02-01 19:50:51

seth
Member
Registered: 2012-09-03
Posts: 52,335

Re: [SOLVED] UT99 not start

i do not undestand where is problem, in arch system or aur 340xx nvidia driver?

The problem is that you're trying to run 20+ year old binaries and 10+ year old HW on a modern software stack.
The PATCHED version of UT99 apparently runs, it's only incapable of controlling the otuput modeline (picks the wrong one)

In order to tell whether that's a problem w/ the 340xx driver you're supposed to run the PATCHED version of UT on nouveau and elaborate on the results. Whatever they are.

wht difference between nvidia-340xx-utils and lib32-nvidia-340xx-utils from aur?

One is a 32bit and the other a 64bit binary. UT99 is a 23 year old game and as such a 32bit binary, but all modern OS use 64bit.
The x86-64 architecture has a compatibility mode that allows 32bit processes, but those need a complete set of 32bit libraries.
In case of lib32-nvidia-340xx-utils it's the 32bit OpenGL library.

I *highly* recommend to ask for help in your native language.
These are basic informations I fail to convey since 80 posts.

https://bbs.archlinux.org/viewforum.php?id=30 is NOT a russian board. You can ask there in Ukrainian and hope for reply.
If anyone thinks that's an opportunity to veer off-topic and into the political realm, they'll very quickly get banned for that.

Offline

#84 2023-02-01 22:13:04

freeartist
Member
Registered: 2022-09-06
Posts: 69

Re: [SOLVED] UT99 not start

>I *highly* recommend to ask for help in your native language.

if a specialist of such a high level as you cannot solve the problem, then even more so they(UA, rus arch users here) will not be able to solve it

>The problem is that you're trying to run 20+ year old binaries and 10+ year old HW on a modern software stack

But modern Debian, Fedora and Windows 10 can do that great, only Arch cant'n

>In order to tell whether that's a problem w/ the 340xx driver you're supposed to run the PATCHED version of UT on nouveau and elaborate on the results. Whatever they are.

patched ut99 runs at nouveau but have graphic glitches - text fonts unreadable and black textures at transparency places at lights

Last edited by freeartist (2023-02-01 22:16:11)

Offline

#85 2023-02-02 04:05:07

freeartist
Member
Registered: 2022-09-06
Posts: 69

Re: [SOLVED] UT99 not start

>The "OpenGL render" actually crashes in the openal library shipped by ut99.
>Is that the unpatched version?

>The "coredump" is back to xkb…

so may be issue with xkb anywhere, because crash happens if anykey pressed?

Offline

#86 2023-02-06 20:42:25

seth
Member
Registered: 2012-09-03
Posts: 52,335

Re: [SOLVED] UT99 not start

patched ut99 runs at nouveau but have graphic glitches - text fonts unreadable and black textures at transparency places at lights

Only in the fullscreen version?
The interesting question is whether w/ nouveau it's reasonably able to switch to fullscreen mode (by itself, not the WM) - and n that case the modes available w/ nouveau.

But modern Debian, Fedora and Windows 10 can do that great, only Arch cant'n

Windows will actually run it in a virtualized environment to imitate an older windows and with the other distributions, I'll try that one last time:

You're running into binary compatibility issues w/ a 20+ year old 32bit binary.
The toolchain to compile the system libraries as well as compiler flags as well as versioned symbols: all that can be a critical factor and boils down to "how much does the compiled library care about legacy stuff"
The apparent answer is that arch doesn't care about backwards compatibility as much as the other distros.

The problem is that it's borderline impossible to say what the proprietary UT99 binary doesn't like.
You could recompile the arch libraries w/ the debian or fedora toolchain and compiler flags and make configuration - but at this time you can just as much use any of those distros.

However: THERE IS A PATCH for Ut99 that makes it run on the Arch software stack.
You dislike the patch because it has trouble setting the fullscreen mode, but the sane implication of that is not to avoid the patched version, but to get it's behavior corrected.

so may be issue with xkb anywhere, because crash happens if anykey pressed?

seth wrote:

Is that the unpatched version?

Offline

#87 2023-02-08 21:50:26

freeartist
Member
Registered: 2022-09-06
Posts: 69

Re: [SOLVED] UT99 not start

>The apparent answer is that arch doesn't care about backwards compatibility as much as the other distros

This is very BIG ISSUE of arch!

I am tired from issues of arch...

ps  so, 100% no way to start unpatched ut? if no, i am going reinstalling it to another distro...

Offline

#88 2023-02-08 21:51:07

freeartist
Member
Registered: 2022-09-06
Posts: 69

Re: [SOLVED] UT99 not start

>so may be issue with xkb anywhere, because crash happens if anykey pressed?
>Is that the unpatched version?

Yes

Offline

#89 2023-03-07 16:26:29

freeartist
Member
Registered: 2022-09-06
Posts: 69

Re: [SOLVED] UT99 not start

Here some cleaner backtrace on Manjaro with same nvidia driver

(gdb) r
Starting program: /home/freeartist/ut/System/ut-bin 

This GDB supports auto-downloading debuginfo from the following URLs:
https://debuginfod.archlinux.org 
Enable debuginfod for this session? (y or [n]) n
Debuginfod has been disabled.
To make this setting permanent, add 'set debuginfod enabled off' to .gdbinit.
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".

Program received signal SIGSEGV, Segmentation fault.
0xeba358e0 in (anonymous namespace)::ctype_c () from /usr/lib32/libstdc++.so.6
(gdb) bt
#0  0xeba358e0 in (anonymous namespace)::ctype_c () from /usr/lib32/libstdc++.so.6
#1  0xf7b2f943 in __dynamic_cast () from ./Core.so
#2  0xeb90f9ce in std::has_facet<std::ctype<char> > (__loc=...) at /usr/src/debug/gcc/gcc-build/x86_64-pc-linux-gnu/32/libstdc++-v3/include/bits/locale_classes.tcc:110
#3  0xeb900f64 in std::basic_ios<char, std::char_traits<char> >::_M_cache_locale (this=0xeba34c04 <std::cout+4>, __loc=...)
    at /usr/src/debug/gcc/gcc-build/x86_64-pc-linux-gnu/32/libstdc++-v3/include/bits/basic_ios.tcc:159
#4  0xeb901121 in std::basic_ios<char, std::char_traits<char> >::init (this=0xeba34c04 <std::cout+4>, __sb=0xeba34800 <__gnu_internal::buf_cout_sync>)
    at /usr/src/debug/gcc/gcc-build/x86_64-pc-linux-gnu/32/libstdc++-v3/include/bits/basic_ios.tcc:132
#5  0xeb898317 in std::basic_ostream<char, std::char_traits<char> >::basic_ostream (__sb=<optimized out>, this=<optimized out>, __in_chrg=<optimized out>, __vtt_parm=<optimized out>)
    at /usr/src/debug/gcc/gcc-build/x86_64-pc-linux-gnu/32/libstdc++-v3/include/ostream:85
#6  std::ios_base::Init::Init (this=0xf3e14218) at /usr/src/debug/gcc/gcc/libstdc++-v3/src/c++98/ios_init.cc:91
#7  std::ios_base::Init::Init (this=0xf3e14218) at /usr/src/debug/gcc/gcc/libstdc++-v3/src/c++98/ios_init.cc:78
#8  0xec27b12c in llvm::orc::ELFNixPlatform::notifyRemoving(llvm::orc::ResourceTracker&) () from /usr/lib32/libLLVM-15.so
#9  0xf7fce21b in ?? () from /lib/ld-linux.so.2
#10 0xf7fce313 in ?? () from /lib/ld-linux.so.2
#11 0xf7fd4fbb in ?? () from /lib/ld-linux.so.2
#12 0xf7fca5c7 in _dl_catch_exception () from /lib/ld-linux.so.2
#13 0xf7fd4f41 in ?? () from /lib/ld-linux.so.2
#14 0xf7fca52d in _dl_catch_exception () from /lib/ld-linux.so.2
#15 0xf7fd52ec in ?? () from /lib/ld-linux.so.2
#16 0xf768131c in ?? () from /usr/lib32/libc.so.6
#17 0xf7fca52d in _dl_catch_exception () from /lib/ld-linux.so.2
#18 0xf7fca659 in ?? () from /lib/ld-linux.so.2
#19 0xf7680d47 in ?? () from /usr/lib32/libc.so.6
#20 0xf76813e8 in dlopen () from /usr/lib32/libc.so.6
#21 0xf5efd587 in ?? () from /usr/lib32/libGLX_indirect.so.0
#22 0xf5efd714 in ?? () from /usr/lib32/libGLX_indirect.so.0
#23 0xf5ee08f1 in ?? () from /usr/lib32/libGLX_indirect.so.0
#24 0xf5ee2948 in ?? () from /usr/lib32/libGLX_indirect.so.0
#25 0xf5ee983f in ?? () from /usr/lib32/libGLX_indirect.so.0
#26 0xf5ee4a61 in ?? () from /usr/lib32/libGLX_indirect.so.0
#27 0xf7f0c5d7 in X11_GL_GetVisual () from ./libSDL-1.1.so.0
#28 0xf7f0ff82 in ?? () from ./libSDL-1.1.so.0
#29 0xf7f1073b in ?? () from ./libSDL-1.1.so.0
#30 0xf7f071af in SDL_SetVideoMode () from ./libSDL-1.1.so.0
#31 0xf7fb867a in ResizeViewport__12USDLViewportUiiii () from ./SDLDrv.so
#32 0xf6a30c21 in SetRes__18USDLGLRenderDeviceiiii () from ./SDLGLDrv.so
#33 0xf6a308a7 in Init__18USDLGLRenderDeviceP9UViewportiiii () from ./SDLGLDrv.so
#34 0xf7fb81ed in TryRenderDevice__12USDLViewportPCciiii () from ./SDLDrv.so
#35 0xf7fb8f97 in OpenWindow__12USDLViewportUiiiiii () from ./SDLDrv.so
#36 0xf7cbc3a2 in Init__11UGameEngine () from ./Engine.so
#37 0x0804d7a6 in _start ()
(gdb) 

Offline

#90 2023-03-07 22:50:36

freeartist
Member
Registered: 2022-09-06
Posts: 69

Re: [SOLVED] UT99 not start

Here backtrace from Artix

Program received signal SIGSEGV, Segmentation fault.
0xf78a67a8 in _XSend () from /usr/lib32/libX11.so.6
(gdb) Killed
home:[freeartist-artix]:/home/freeartist/ut/System$ 

Offline

#91 2023-03-08 18:38:08

freeartist
Member
Registered: 2022-09-06
Posts: 69

Re: [SOLVED] UT99 not start

Found solution

sudo downgrade lib32-libx11
home:[freeartist-artix]:~$ yay -Qs libx11
local/lib32-libx11 1.6.8-1
    X11 client-side library (32-bit)
local/libx11-git 1.8.4.r5.g72eeeb6d-1
    Core X11 protocol client library
home:[freeartist-artix]:~$ 

now UT starting normally

@seth Thank you very much for help!) And sorry to me to bit offensive) Good luck!

Last edited by freeartist (2023-03-08 18:38:48)

Offline

Board footer

Powered by FluxBB