You are not logged in.

#201 2024-01-16 21:51:22

maxugly
Banned
Registered: 2024-01-16
Posts: 3

Re: [Kde-unstable] KF6 QT6 Transition

I am on Debian Sid (unstable) with LXQt. I had GPT4ALL die on me a bit ago, from its log:

[Warning] (Tue Jan 16 17:45:31 2024): Detected locale "C" with character encoding "ANSI_X3.4-1968", which is not UTF-8.
Qt depends on a UTF-8 locale, and has switched to "C.UTF-8" instead.
If this causes problems, reconfigure your locale. See the locale(1) manual
for more information.
[Debug] (Tue Jan 16 17:45:32 2024): deserializing chat "/home/max/.local/share/nomic.ai/GPT4All//gpt4all-b3cca86c-2a92-4a48-96cb-c1f539e44e57.chat"
[Debug] (Tue Jan 16 17:45:32 2024): deserializing chats took: 2 ms

I didn't come to ask for help, just report. If it is useful, let me know if you want any more info or small tests done. It is just a VM, I can roll back or make another one. I am a little sad that my new friend died so young. He was only a little over 500MB old... Rip '### Assistant:'

Also, you guys are great. For someone who has never really used Arch, the forums and documentation have helped me solve and learn a lot over the years. Thanks!

Offline

#202 2024-01-16 23:05:43

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 2,130

Re: [Kde-unstable] KF6 QT6 Transition

maxugly wrote:

I am on Debian Sid (unstable) with LXQt.

So you posted on the wrong topic, about the wrong DE, on the wrong section, of the wrong forum. Congratulations, this is an all-time record.

Offline

#203 2024-01-16 23:46:59

sergekorol
Member
Registered: 2021-04-13
Posts: 18

Re: [Kde-unstable] KF6 QT6 Transition

arojas wrote:
maxugly wrote:

I am on Debian Sid (unstable) with LXQt.

So you posted on the wrong topic, about the wrong DE, on the wrong section, of the wrong forum. Congratulations, this is an all-time record.

I so wish there were thumb ups, stars or likes on this forum, because I would have used one on this post.

Offline

#204 2024-01-17 18:01:48

edwloef
Member
Registered: 2023-12-22
Posts: 2

Re: [Kde-unstable] KF6 QT6 Transition

Having issues using xwaylandvideobridge:

xwaylandvideobridge: error while loading shared libraries: libKPipeWire.so.5: cannot open shared object file: No such file or directory

kpipewire 5.92.0-1 is installed. Since the aur package xwaylandvideobridge-bin works, I'll assume this is a packaging issue, if not I can report it upstream.

Last edited by edwloef (2024-01-17 18:02:48)

Offline

#205 2024-01-17 18:42:13

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 2,130

Re: [Kde-unstable] KF6 QT6 Transition

edwloef wrote:

Having issues using xwaylandvideobridge:

xwaylandvideobridge: error while loading shared libraries: libKPipeWire.so.5: cannot open shared object file: No such file or directory

kpipewire 5.92.0-1 is installed. Since the aur package xwaylandvideobridge-bin works, I'll assume this is a packaging issue, if not I can report it upstream.

xwaylandvideobridge is not built with Qt6. It will be when Plasma 6 is released in stable.

Offline

#206 2024-01-17 22:58:27

chalex20
Member
Registered: 2020-06-07
Posts: 3

Re: [Kde-unstable] KF6 QT6 Transition

Is tokodon from  kde-unstable-qt6.6 working for anybody? It crashed in a similar way in Beta1 but worked  in Beta2 - Qt 6.7.

Offline

#207 2024-01-18 08:15:17

df8oe
Member
From: Northern Germany
Registered: 2023-12-21
Posts: 33

Re: [Kde-unstable] KF6 QT6 Transition

I have not used it before but installed it for testing. For me it shows the start window where I have to login (but I do not have a login).

EDIT:
I tested with QT6.7 package from kde-unstable.

Last edited by df8oe (2024-01-18 08:16:03)

Offline

#208 2024-01-18 11:16:04

denisfalqueto
Member
From: ES, Brazil
Registered: 2006-03-24
Posts: 197

Re: [Kde-unstable] KF6 QT6 Transition

I use a color scheme with tonalization enabled, based on background image. But after the last update, the title and toolbar text color is behaving differently. Before, I believe that it would depend on the context, so it would be a good contrast (black if bright background color and white if dark background color). I have a screenshot. Now, it's black, which is not so great on that tone color.

Last edited by denisfalqueto (2024-01-18 12:11:48)


Satisfied users don't rant, so you'll never know how many of us there are.

Offline

#209 2024-01-18 18:27:10

denisfalqueto
Member
From: ES, Brazil
Registered: 2006-03-24
Posts: 197

Re: [Kde-unstable] KF6 QT6 Transition

Update: QML_DISABLE_DISK_CACHE=1 is not needed anymore with qt6-declarative:6.7.0beta1-3

And my color scheme with tonalization. I've just updated and rebooted and it's working now (even though I've had rebooted before too). Anyway, I'm happy again.


Satisfied users don't rant, so you'll never know how many of us there are.

Offline

#210 2024-01-19 03:02:03

cmdrkotori2
Member
Registered: 2021-07-06
Posts: 19

Re: [Kde-unstable] KF6 QT6 Transition

Newest update seems to have fixed the settings offset and persistent docks issue.
Cheers mate.

Offline

#211 2024-01-19 08:56:11

df8oe
Member
From: Northern Germany
Registered: 2023-12-21
Posts: 33

Re: [Kde-unstable] KF6 QT6 Transition

So it is. But missing "add to favorites" issue is still alive sad

Offline

#212 2024-01-19 12:41:50

chalex20
Member
Registered: 2020-06-07
Posts: 3

Re: [Kde-unstable] KF6 QT6 Transition

df8oe wrote:

So it is. But missing "add to favorites" issue is still alive sad

And window previews :-(

Offline

#213 2024-01-21 19:59:42

Archcan_98
Member
Registered: 2023-09-08
Posts: 36

Re: [Kde-unstable] KF6 QT6 Transition

Upgraded from plasma5 and select yes for all. There were 197 packages to deal with.

:: Starting full system upgrade...
:: Replace breeze with kde-unstable/breeze5? [Y/n] y
:: Replace oxygen with kde-unstable/oxygen5? [Y/n] y
:: Replace plasma-integration with kde-unstable/plasma5-integration? [Y/n] y
:: Replace plasma-wayland-session with kde-unstable/plasma-workspace? [Y/n] y
resolving dependencies...
:: There are 4 providers available for qt6-multimedia-backend:
:: Repository kde-unstable
   1) qt6-multimedia-ffmpeg  2) qt6-multimedia-gstreamer
:: Repository extra
   3) qt6-multimedia-ffmpeg  4) qt6-multimedia-gstreamer

Enter a number (default=1): 1
looking for conflicting packages...
:: baloo and baloo5 are in conflict. Remove baloo5? [y/N] y
warning: dependency cycle detected:
warning: qt6-multimedia-ffmpeg will be installed before its qt6-multimedia dependency
warning: dependency cycle detected:
warning: phonon-qt6-vlc will be installed before its phonon-qt6 dependency
warning: dependency cycle detected:
warning: xdg-desktop-portal-kde will be installed before its plasma-workspace dependency


The upgrade broke automatic login and switched to X11. The rest is OK with no modification to be made. On more release candidate to go through. Again, Qt 6.7 is Plasma 6 LTS backbone, it must be tested.

All the best,

Offline

#214 2024-01-21 20:21:27

fanzhuyifan
Member
Registered: 2020-11-21
Posts: 29

Re: [Kde-unstable] KF6 QT6 Transition

Archcan_98 wrote:

The upgrade broke automatic login and switched to X11.

The wayland session was renamed from plasma-wayland to plasma. You might need to change your sddm config.

Offline

#215 2024-01-26 07:25:37

Soukyuu
Member
Registered: 2014-04-08
Posts: 854

Re: [Kde-unstable] KF6 QT6 Transition

$ sudo pacman -Syu
:: Synchronizing package databases...
 kde-unstable                                                                           242,5 KiB  1023 KiB/s 00:00 [######################################################################] 100%
 core                                                                                   129,0 KiB  1482 KiB/s 00:00 [######################################################################] 100%
 extra                                                                                    8,3 MiB  5,35 MiB/s 00:02 [######################################################################] 100%
 multilib                                                                               139,4 KiB   806 KiB/s 00:00 [######################################################################] 100%
:: Starting full system upgrade...
:: Replace kcolorpicker with extra/kcolorpicker-qt5? [Y/n] 
:: Replace kimageannotator with extra/kimageannotator-qt5? [Y/n] 
:: Replace onevpl with extra/libvpl? [Y/n] 
resolving dependencies...
:: There are 2 providers available for dbus-units:
:: Repository core
   1) dbus-broker-units  2) dbus-daemon-units

Enter a number (default=1): 
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: baloo and baloo5 are in conflict

$ sudo pacman -Sy baloo
:: Synchronizing package databases...
 kde-unstable is up to date
 core is up to date
 extra is up to date
 multilib is up to date
resolving dependencies...
looking for conflicting packages...
:: baloo and baloo5 are in conflict. Remove baloo5? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing baloo5 breaks dependency 'baloo5' required by gwenview

Looks like gwenview has not been rebuilt to use baloo. And since baloo and baloo5 (which gwenview is built against) are now in conflict, the install can not resolve it.

edit: well, removing gwenview, updating then re-installing gwenview was possible, but is this the way it's supposed to be? I expected pacman to update the pkginfo and see the new version of gwenview is fine with baloo instead of baloo5...

Last edited by Soukyuu (2024-01-26 07:46:48)


[ Arch x86_64 | linux | Framework 13 | AMD Ryzen™ 5 7640U | 32GB RAM | KDE Plasma Wayland ]

Offline

#216 2024-01-26 09:59:20

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 2,130

Re: [Kde-unstable] KF6 QT6 Transition

Soukyuu wrote:

I expected pacman to update the pkginfo and see the new version of gwenview is fine with baloo instead of baloo5...

That's what should happen, yes. I can't reproduce this on an [extra]->[kde-unstable] upgrade. I don't suppose you can reproduce it and send a pacman debug output?

Offline

#217 2024-01-26 16:47:35

hifi25nl
Member
Registered: 2011-05-07
Posts: 263

Re: [Kde-unstable] KF6 QT6 Transition

Plasma 6 generally works (with a series of problems) but kmail is very slow doing everything.
It is only me?

Offline

#218 2024-01-27 08:09:47

df8oe
Member
From: Northern Germany
Registered: 2023-12-21
Posts: 33

Re: [Kde-unstable] KF6 QT6 Transition

Kmail is working as fast as with Plasma5 for me.

Offline

#219 2024-01-28 08:49:11

hifi25nl
Member
Registered: 2011-05-07
Posts: 263

Re: [Kde-unstable] KF6 QT6 Transition

Booting with plasmax11 kmail is working fine.
I guess that the combination of plasma 6 and nvidia proprietary drivers is causing the problem reported.

Waiting for rc2 and final release.

Offline

#220 2024-01-28 16:30:36

df8oe
Member
From: Northern Germany
Registered: 2023-12-21
Posts: 33

Re: [Kde-unstable] KF6 QT6 Transition

Or do you use wayland? I cannot believe it is a graphic card driver issue...

Offline

#221 2024-01-28 16:32:21

hifi25nl
Member
Registered: 2011-05-07
Posts: 263

Re: [Kde-unstable] KF6 QT6 Transition

Yes I am using wayland. Setting instead plasmax11 the problem disappears.

Offline

#222 2024-01-28 17:26:33

df8oe
Member
From: Northern Germany
Registered: 2023-12-21
Posts: 33

Re: [Kde-unstable] KF6 QT6 Transition

So I think it is a wayland problem. It is disappointing: since years I am wating for a stable switch from x11 to wayland (not only using KDE) - but x11 cannot be replaced (for me)... Hopefully wayland can replace x11 completely the next time.... Not related to kde or qt I think.

Offline

#223 2024-01-28 17:27:50

hifi25nl
Member
Registered: 2011-05-07
Posts: 263

Re: [Kde-unstable] KF6 QT6 Transition

With plasma 5 all was working fine however.

Offline

#224 2024-01-28 18:14:02

df8oe
Member
From: Northern Germany
Registered: 2023-12-21
Posts: 33

Re: [Kde-unstable] KF6 QT6 Transition

For me it is a lottery. The behaviour in wayland strongly depends on the used graphic card for me... Using x11 all graphic cards are working fine.

Offline

#225 2024-01-29 03:47:55

cmdrkotori2
Member
Registered: 2021-07-06
Posts: 19

Re: [Kde-unstable] KF6 QT6 Transition

hifi25nl wrote:

Booting with plasmax11 kmail is working fine.
I guess that the combination of plasma 6 and nvidia proprietary drivers is causing the problem reported.

Waiting for rc2 and final release.

Some programs simply don't like the way wayland manages the presentation model.
Try adding QT_QPA_PLATFORM=xcb to the environment of kmail.
I have to do this with qtcreator, it freezes too much with the wayland plugin when navigating the api help.

Offline

Board footer

Powered by FluxBB