You are not logged in.

#101 2007-09-29 01:05:53

zenix
Member
From: Earth - Save it!
Registered: 2007-08-05
Posts: 100
Website

Re: Stjerm - yet another quake-like terminal

Hey there, I tried to modify the current SVN and failed to add a couple of options - wether or not to scroll on Output or Keystroke. Quite simple for the core emulator (VTE) but a bit annoying in actuaily trying to get it to set, given the .Xdefaults. I'll post a uni-diff patch for the current SVN once I get it working.

xsdnyd - If you do see this and would like to help me get it working, I could always send you the current modifications, which are incomplete, of course

Update #1
Got it to work with command line options. Something is just missing from the .Xdefaults parser and I can't get it to 'see' the 2 new lines in .Xdefaults correctly. It just skips over those lines. Least it doesn't error out. (Like it did)

Update #2
The F12 Toggle I requested works as expected only when AutoHide is turned OFF. But, I also like being able to just click off and get the same result. I'll work on it as well as the configuration options but it's a bit annoying right now. stjerm is simply NOT seeing the new lines. The command-line options work now, so if anyone wants them, just say hi and I'll release a patch for the options.

Last edited by zenix (2007-09-29 01:41:38)


cat /usr/bin/arson > Arson, the HOT AUR search helper! -- Use Clyde instead smile

Offline

#102 2007-09-29 02:55:13

scj
Member
From: Sweden
Registered: 2007-09-23
Posts: 158

Re: Stjerm - yet another quake-like terminal

Neat, I'm having some issues with tilda and the compiz-git packages, and stjerm seems to be a pretty nice replacement. The only problem I have is that the window size is static and doesn't allow any maximization by the WM.

Offline

#103 2007-09-29 03:10:01

zenix
Member
From: Earth - Save it!
Registered: 2007-08-05
Posts: 100
Website

Re: Stjerm - yet another quake-like terminal

scj wrote:

Neat, I'm having some issues with tilda and the compiz-git packages, and stjerm seems to be a pretty nice replacement. The only problem I have is that the window size is static and doesn't allow any maximization by the WM.

Glad you like it. What WM are you using now? Compiz Fusion?


cat /usr/bin/arson > Arson, the HOT AUR search helper! -- Use Clyde instead smile

Offline

#104 2007-09-29 03:56:34

scj
Member
From: Sweden
Registered: 2007-09-23
Posts: 158

Re: Stjerm - yet another quake-like terminal

zenix wrote:

Glad you like it. What WM are you using now? Compiz Fusion?

Yup. I find it very useful to be able to quickly maximize the window whenever I need to have lots of text displayed on screen. This is actually my favourite "feature" of tilda, compared to the other quake type terminals (yakuake, yeahconsole)

Last edited by scj (2007-09-29 03:57:12)

Offline

#105 2007-10-01 19:48:16

zenix
Member
From: Earth - Save it!
Registered: 2007-08-05
Posts: 100
Website

Re: Stjerm - yet another quake-like terminal

Ah, yay! Another 2 options added against current SVN head!

Skip Pager (stjerm.skippager / -skp) - Should stjerm NOT show up in the application switcher dialogs? Default: True
Skip Taskbar (stjerm.skiptaskbar / -skt) - Should stjerm NOT show up in a task bar? Default: True (This only works with EMWH compliant taskbars, which is the majority of taskbars out there, so no worries)

Again, holler if you want a patch, otherwise enjoy stjerm how it is smile

P.S. They actually work! (Unlike those darn Scroll Output/Keypress options...)

Last edited by zenix (2007-10-01 21:27:12)


cat /usr/bin/arson > Arson, the HOT AUR search helper! -- Use Clyde instead smile

Offline

#106 2007-10-07 10:06:08

xsdnyd
Member
Registered: 2007-04-28
Posts: 110

Re: Stjerm - yet another quake-like terminal

@zenix, the syncronisation between tablabel und terminal title is working.
it has been for a few versions now. i just tested it.

i implemented a scroll on output and background image option just in svn.
update:
now i also added a fullscreen keyboard shortcut and popupmenu item,
also fixed the --toggle option and the weird character bug when eg. opening a new tab.

for the skip pager and skip taskbar i would gladly like to see your patches wink

Last edited by xsdnyd (2007-10-08 06:59:43)


We can't stop here! This is bat country!!

Offline

#107 2007-10-08 20:47:35

zenix
Member
From: Earth - Save it!
Registered: 2007-08-05
Posts: 100
Website

Re: Stjerm - yet another quake-like terminal

Hey, good job on the updates smile

Found a bug though sad
Whenever I have both autohide & --toggle running, I have to call the --toggle key twice, because I think it's "hiding" on the first keypress then showing again. Just using the --toggle key works fine. I think this is what is happening (not sure, I'll study the source & get those patches for ya)

Show Stj - works
Click onto Epiphany - Stj hides
Press F12 (set to "stjerm --toggle") - Stj doesn't show, current state set to "hidden"
Press F12 again - Stj shows, current state set to "visible"
F12 - Stj hides, state = "hidden"
F12 - Stj shows, state = "visibile"
Click onto Epiphany - Stj hides, state still is "visible"

Edit
Of course, this is using the unmodified current SVN

Last edited by zenix (2007-10-08 20:48:18)


cat /usr/bin/arson > Arson, the HOT AUR search helper! -- Use Clyde instead smile

Offline

#108 2007-10-09 09:18:42

xsdnyd
Member
Registered: 2007-04-28
Posts: 110

Re: Stjerm - yet another quake-like terminal

@zenix
i just comitted a patch in svn. it should work now.
but i ran into an issue which i have no idea how to fix it:
if you run stjerm with autohide and let stjerm dissappear because you clicked somewhere. then u need to run --toggle twice to show it up again.
this is primarily because stjerm loose its focus when clicking somewhere, so the window is not visible anymore so --toggle wants to hide the hidden window. i can't use the focus out event to fix it, because the focus out event is also called when the window is visible and --toggle is called sad.

Last edited by xsdnyd (2007-10-09 09:19:35)


We can't stop here! This is bat country!!

Offline

#109 2007-10-17 09:44:54

xsdnyd
Member
Registered: 2007-04-28
Posts: 110

Re: Stjerm - yet another quake-like terminal

So here is the new stjerm version 0.11:
changelog:

- added "autohide" option, this enables/disables the hiding of stjerm when it looses focus
- added scroll on output option
- added background image option
- added fullscreen keyboard shortcut and popupmenu item
- fixed --toggle option
- fixed weird characters appearing when using shortcuts
- updated manpage

the 2 other patches by zenix are not included because he didn't sent them to me...

anyway here is the aur package:
http://aur.archlinux.org/packages.php?d … 1&ID=12324

the autohide option disables/enables the automatic hiding of stjerm when it looses focus. (use with -ah or autohide in .Xdefaults).
the scroll on output option disables/enables the scroll on output in the terminal (use with -sc or scroll in .Xdefaults).
the fullscreen keyboard shortcut is F11 (or the popupmenu item).
the background image option can be used with -bgimg (or bgimage in .Xdefaults).

all option are are explained in:
stjerm --help
or
stjerm --info
or
man stjerm

have fun smile

Last edited by xsdnyd (2007-10-17 10:27:50)


We can't stop here! This is bat country!!

Offline

#110 2007-10-17 17:11:16

luke
Member
From: US
Registered: 2004-06-22
Posts: 54

Re: Stjerm - yet another quake-like terminal

Quick question, but first, THANKS! Great terminal!

Is there a way to switch between tabs with the keyboard?

Offline

#111 2007-10-18 06:44:50

xsdnyd
Member
Registered: 2007-04-28
Posts: 110

Re: Stjerm - yet another quake-like terminal

@luke thanks.
sure you can switch them smile

previous tab: ctrl+shift pagedown
next tab: ctrl+shift pageup

you can also customize the ctrl+shift modifier using the keymod .Xdefaults option or the -km command line option.
to set the shortcuts to use the windows key as modifier (eg. next tab: windows+pageup) use this:
as commandline option: -km windows
or in .Xdefaults:
stjerm.keymod: windows


We can't stop here! This is bat country!!

Offline

#112 2007-10-18 12:38:50

High|ander
Member
From: Skövde, Sweden
Registered: 2005-10-28
Posts: 188
Website

Re: Stjerm - yet another quake-like terminal

Any updated screenshots? The one in the first post is not found sad


When death smiles at you, all you can do is smile back!
Blog

Offline

#113 2007-10-18 13:33:28

luke
Member
From: US
Registered: 2004-06-22
Posts: 54

Re: Stjerm - yet another quake-like terminal

xsdnyd wrote:

@luke thanks.
sure you can switch them smile

previous tab: ctrl+shift pagedown
next tab: ctrl+shift pageup

you can also customize the ctrl+shift modifier using the keymod .Xdefaults option or the -km command line option.
to set the shortcuts to use the windows key as modifier (eg. next tab: windows+pageup) use this:
as commandline option: -km windows
or in .Xdefaults:
stjerm.keymod: windows

Thank you. Is that first part in the documentation anywhere? Also, any chance of making those two commands configurable?

Thanks again.

Offline

#114 2007-10-18 16:43:34

Sander
Member
Registered: 2006-02-26
Posts: 137

Re: Stjerm - yet another quake-like terminal

Hi, I've just been checking out stjerm as a replacement for tilda, seeing as tilda's been acting up lately (it seems to randomly turn grey entirely and become unusable).

I was pleasantly surprised by the true transparency support. However, I cannot get this to work in my .xinitrc file:

#!/bin/sh

#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)
#

source /etc/profile
xscreensaver -no-splash &
numlockx &
beryl-manager &
emerald &
stjerm -k f12 -ah false -o 75 -w 1280 -h 300 &
exec xfce4-session

I think it's because I'm backgrounding everything, and beryl isn't fully loaded yet when stjerm loads. Stjerm functions normally, but the -o parameter is ignored. Is there anything I can do about this? It's only a minor annoyance, but still, it'd be nice to get rid of it smile


You like cheese? You like peas? You'll love cheezy peas!

Offline

#115 2007-10-18 17:21:35

xsdnyd
Member
Registered: 2007-04-28
Posts: 110

Re: Stjerm - yet another quake-like terminal

@luke: not yet. but as you mention it, i will add it smile

@Sander: i will look into this issue


We can't stop here! This is bat country!!

Offline

#116 2007-10-18 17:24:07

Sander
Member
Registered: 2006-02-26
Posts: 137

Re: Stjerm - yet another quake-like terminal

Well, at first sight I don't think it's a stjerm issue; I mean, stjerm can't help it that beryl hasn't started yet smile
I guess I just need to rewrite my .xinitrc file somehow.


You like cheese? You like peas? You'll love cheezy peas!

Offline

#117 2007-10-19 22:45:25

zenix
Member
From: Earth - Save it!
Registered: 2007-08-05
Posts: 100
Website

Re: Stjerm - yet another quake-like terminal

@xsdnyd: Oops... I forgot to send them to you! Sorry about that. Had too much to do right now...still not finished cool Ah well. Unfortunetly I don't think I can send them to you over this weekend, maybe over the next week? Jeez I really need to get off my butt & off this computer and do stuff that'll free up my schedule lol

Great job with the release of stjerm 0.11! I'm still using my SVN modded one. Have you fixed the "Autohide & Double --toggle" call bug yet? Also I notice that when I'm doing a high memory action within stjerm, once it hides I can not make it re-appear! An example session (this really happened, too):

I download Epiphany's source code.
I compile Epiphany to use WebKit instead.
F12 is bound to "stjerm --toggle" and stjerm does not appear.
I press F12 again, thinking it's the Autohide bug, stjerm does not appear
I jam F12 ~50 times and see no flashes of white (which happens when stjerm is rapidly shown/hidden)
I then call "killall -s USR1 stjerm" via Alt-F2 dialog.
Call it again (yay history, less typing). stjerm appears.
I can only make stjerm appear (after it's hidden by any method) by calling "killall -s USR1 stjerm"

Usually after that I just killall stjerm ; stjerm to reset it. The problem does not persist. Really annoying if I'm checking on a compile sequence of some sort. Most of the time (96% of the time) it's after the compiler is greedy and uses 90-100% of my cpu. The last 4%? Dunno what happened, I wasn't around my computer at those times but stjerm would appear after a call to --toggle. At least, at those times, I'm pretty sure that it wasn't doing anything important/memory intensive...

EDIT:
I've also noticed that my font is horribly increased in size; very weird. I've updated to GNOME 2.20 and I currently use "Fixed SemiCondensed 10" as my font of choice. (That's the font XTerm uses as well, which is my reason for using that font) Unfortunetly, the font is expanded to ~2x it's normal size. Restarting stjerm does not fix this. Xterm itself is not affected by the UI updates. I think it may have to do with VTE. Now I use Monospace 9, but I think it uglier that Fixed...please fix it!
Note:
I notice that when I use a "non-standard" font such as Serif or Sans * there is an extra line that is before the displayed line, postioned correctly for a terminal size of 80 which seems to be displayed before the resize happens to accomidate 80 charachers of whatever font size the user has choosen. See this image for reference: 1z3pb15.jpg

Last edited by zenix (2007-10-20 01:52:29)


cat /usr/bin/arson > Arson, the HOT AUR search helper! -- Use Clyde instead smile

Offline

#118 2007-10-21 08:42:12

xsdnyd
Member
Registered: 2007-04-28
Posts: 110

Re: Stjerm - yet another quake-like terminal

@Sander you're right. it seems to be a problem if stjerm is started before compiz is started...
you have to start it after compiz... i don't see another solution.

@zenix
1. the shortcut key does not work at high cpu load: did it work before you upgraded to gnome 2.20?
it does not seem to be a stjerm problem because there is no code in it which ever releases the shortcut key...
for me it also works on high cpu-load. strange... i will try to find some suspicous code and do some testing but i don't think i get somewhere...

2. the weird font problem: as stjerm uses a builtin VTE api call to set the font, i can't do anything about it. seems to be a VTE issue. please try the gnome-terminal or xfce-terminal and tell me if the problem occurs there as well. thanks smile

3. i tested all sorts of fonts, but i couldn't reproduce it... will look into it.


We can't stop here! This is bat country!!

Offline

#119 2007-10-21 13:03:42

zenix
Member
From: Earth - Save it!
Registered: 2007-08-05
Posts: 100
Website

Re: Stjerm - yet another quake-like terminal

I'll look into the problem in other terminal emulators. The shortcut key did not work (after a cpu intensive action) before or after the upgrade to Gnome 2.20. I'm also not able to reproduce that resizing issue (pictured above) easily anymore... This isn't really negative but it does look odd. smile

Feature Request: Some type of command-line option or Xdefault setting to have stjerm send itself to the background instead of staying in the foreground. Reason: I have stjerm starting in my .xinitrc and in order to successfully start it in the bg, I call "nohup stjerm &" Nothing incredibly hard about calling that, but I think it would be nice to have that option present. smile

Last edited by zenix (2007-10-21 13:04:32)


cat /usr/bin/arson > Arson, the HOT AUR search helper! -- Use Clyde instead smile

Offline

#120 2007-11-17 00:58:19

zenix
Member
From: Earth - Save it!
Registered: 2007-08-05
Posts: 100
Website

Re: Stjerm - yet another quake-like terminal

A little bump here, sorry. Thought this would be neccessary. I have an error to report, unfortunetly. sad

With the latest SVN (unmodified) sending SIGKILL (via Ctrl-C) does not only kill the process within the terminal emulator but stjerm itself as well. The graphical ui just sits there, blocking view & mouse (as it's set to the top layer) but is completley unresponsive. There is a stjerm process in the background (which I assume is linked to the unresponsive graphic) but that as well does not respond to anything. Calling "killall stjerm" from another terminal emulator (not from within another tab in stjerm) kills stjerm and clears the graphics from the screen. I then restart stjerm and this problem does not persist.

Last edited by zenix (2007-11-17 00:59:09)


cat /usr/bin/arson > Arson, the HOT AUR search helper! -- Use Clyde instead smile

Offline

#121 2007-11-17 10:39:24

xsdnyd
Member
Registered: 2007-04-28
Posts: 110

Re: Stjerm - yet another quake-like terminal

@zenix
this is really weird, did the error just came up recently? because i never had and even i don't have now a problem with Ctr-C with stjerm.
if i press Ctrl-C the stjerm bash just puts out a new line..

Last edited by xsdnyd (2007-11-17 10:39:47)


We can't stop here! This is bat country!!

Offline

#122 2007-11-17 16:07:30

zenix
Member
From: Earth - Save it!
Registered: 2007-08-05
Posts: 100
Website

Re: Stjerm - yet another quake-like terminal

Well, from within a shell, nothing happens. (in Zsh as well) Try running a memory intensive program (such as "find / | grep blah") then Ctrl-C that processs. This has happened for a while now, stjerm would suddenly stop responding after I kill a process but I only put 2 & 2 together yesterday.


cat /usr/bin/arson > Arson, the HOT AUR search helper! -- Use Clyde instead smile

Offline

#123 2007-11-22 17:12:51

finferflu
Forum Fellow
From: Manchester, UK
Registered: 2007-06-21
Posts: 1,899
Website

Re: Stjerm - yet another quake-like terminal

Hi, I don't know if this has been asked already, but is it possibile to have an option to specify the position (in px or percent) of the terminal?
My problem is that when I put stjerm at the bottom, it appears behind the Gnome panel, so I can't visualize the bottom of the terminal, which is very annoying, especially when you run GNU Screen with hardstatus on.

Also, it would be nice to have it always on top, since when I press the key it appears behind the app I'm currently using, I would like to access the terminal as soon as I press the key...

Thanks a lot smile

Last edited by finferflu (2007-11-22 17:16:17)


Have you Syued today?
Free music for free people! | Earthlings

"Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away." -- A. de Saint-Exupery

Offline

#124 2007-11-22 18:13:55

xsdnyd
Member
Registered: 2007-04-28
Posts: 110

Re: Stjerm - yet another quake-like terminal

@zenix: i can't reproduce it... perhabs it is a problem with vte? i tried your command and it all works fine

@finferflu:
stjerm is always on top but it dissappears if it looses focus. you can disable this behaviour with the "autohide" (or "ah") option.

for the first question:
you can specifiy the height and with and also the popup position (top, left, right, bottom) of stjerm.
that stjerm popups behind the panel is really weird, it should at last be on top of it...
i am gonna look into it if i can force it to be on top...


We can't stop here! This is bat country!!

Offline

#125 2007-11-22 18:21:35

finferflu
Forum Fellow
From: Manchester, UK
Registered: 2007-06-21
Posts: 1,899
Website

Re: Stjerm - yet another quake-like terminal

I don't like the autohide option, but I guess it's the only option I have to enable in order to always have focus on the terminal whenever I invoke it.
As for the position, I already know you can decide where it appears, but I wanted to fine tune the position, so as to have the 24px margin from the bottom, which is my panel's height. If you say it should appear on top on the panel, it's not happening here...

Thanks for your quick reply and for your help smile


Have you Syued today?
Free music for free people! | Earthlings

"Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away." -- A. de Saint-Exupery

Offline

Board footer

Powered by FluxBB