You are not logged in.

#76 2008-11-26 23:53:06

ST.x
Member
From: Sydney, Australia
Registered: 2008-01-25
Posts: 363
Website

Re: Hard drive advanced power management level can kill your laptop drive?

Try

sudo smartctl -a /dev/sda | egrep 'Load_Cycle|Power_On'

Offline

#77 2008-11-27 10:51:41

sidc
Member
Registered: 2008-06-19
Posts: 76

Re: Hard drive advanced power management level can kill your laptop drive?

msid ~  $  sudo smartctl -a /dev/sda | egrep 'Load_Cycle|Power_On'
Password: 
  9 Power_On_Hours          0x0032   098   098   000    Old_age   Always       -       1541

Still no luck sad

Offline

#78 2008-11-27 12:07:18

ST.x
Member
From: Sydney, Australia
Registered: 2008-01-25
Posts: 363
Website

Re: Hard drive advanced power management level can kill your laptop drive?

hmm maybe your hdd doesn't provide that. Have a look at the full output of sudo smartctl -a /dev/sda

Last edited by ST.x (2008-11-27 12:07:35)

Offline

#79 2009-01-18 01:02:35

sokuban
Member
Registered: 2006-11-11
Posts: 406

Re: Hard drive advanced power management level can kill your laptop drive?

So according to slashdot, this bug has now been fixed.

https://bugs.launchpad.net/ubuntu/+sour … +bug/59695

(Copied and pasted from slashdot. That link actually doesn't work for me, timed out. I guess it is the slashdot effect.)

How will this affect Arch users? Anyone know when the fix would be coming to us?

Offline

#80 2009-01-18 01:56:23

arew264
Member
From: Friendswood, Texas, US
Registered: 2006-07-01
Posts: 394
Website

Re: Hard drive advanced power management level can kill your laptop drive?

From what I'm reading, it isn't really a fix, just someone with the confidence to say they've found some sane values. Their solution is actually kind of obvious, but they've thought it out quite thoroughly, and I certainly didn't think of something like this.
It looks like they're just setting the APM to 128 when on battery and 254 when on AC. This is possible in Arch, and I want to say you should use the laptop-mode package, though I'm not sure. Somewhere, there's a laptop package that lets you run a script when the power state changes. I use it to regulate cpufreq.
I've just been running with APM set to 254 for quite some time now, and I've had no problems. Then again, my laptop is rarely exposed to vibration.

Offline

#81 2009-01-18 02:22:23

aglarond
Member
From: Texas, USA
Registered: 2008-11-20
Posts: 123

Re: Hard drive advanced power management level can kill your laptop drive?

buttons wrote:

While we're on the subject, has anyone gotten the power management setting to stick coming out of suspend?  I have OnResume hdparm blah blah in my common.conf but it doesn't appear to do anything.

I couldn't get the resume scripts to work right; the cycle count kept going up. I have hdparm -B 255 set in rc.local and then have it run every few minutes in cron. That's taken care of it for me.

-mS

Offline

#82 2009-01-18 09:12:53

erythrocyte
Member
Registered: 2008-10-21
Posts: 25

Re: Hard drive advanced power management level can kill your laptop drive?

sokuban wrote:

So according to slashdot, this bug has now been fixed.

https://bugs.launchpad.net/ubuntu/+sour … +bug/59695

(Copied and pasted from slashdot. That link actually doesn't work for me, timed out. I guess it is the slashdot effect.)

How will this affect Arch users? Anyone know when the fix would be coming to us?

If you check the bug tracker on https://launchpad.net/ubuntu/+source/ac … +bug/59695 , it clearly states it as being 'triaged' and not 'fix implemented' or 'fix proposed'....and some of the last few comments indicate that it's still being worked upon. This bug could definitely use some collective and organised effort (by all distros) to put clarity into. It's hard to figure out the truth in all the confusion!

Offline

#83 2009-04-07 02:24:55

jason_f
Member
Registered: 2006-08-18
Posts: 78

Re: Hard drive advanced power management level can kill your laptop drive?

What's the consensus on this? 128 on battery and 254 on ac?
what about spindown values?

My main laptop is plugged in most of the time. I already have smartd reporting high temperatures on both drives with apm=128.
I'm worried that setting this to 254 will only make the temperature higher. Higher temp=shorter drive life as well. so whats the best balance? somehow 128 just doesnt seem like it's based on much fact. other than 'its in the middle'.

or will spinning the drive down but not suspending the drive, lower temperatures?

Offline

#84 2009-04-07 02:55:35

kensai
Member
From: Puerto Rico
Registered: 2005-06-03
Posts: 2,479
Website

Re: Hard drive advanced power management level can kill your laptop drive?

This part is of particular interest to me:

"This problem has been confirmed in Ubuntu as well as in other distributions and on MacOS X and Windows."

The problem is not Linux is all the Operating Systems, so we are trying to fix a problem of the Hard Drives, not the operating system. So this may take time to be fixed, still, well, in all I've read is safe to just set APM level to 254, and on battery to 128, as said above.

Last edited by kensai (2009-04-07 03:00:30)


Follow me in: Identi.ca, Twitter, Google+

Offline

#85 2009-04-07 04:08:09

mutlu_inek
Member
From: all over the place
Registered: 2006-11-18
Posts: 677
Website

Re: Hard drive advanced power management level can kill your laptop drive?

The question of whether it is necessary to change what harddrive manufacturers have decided is best for their products aside, I wanted to point out that the raw numbers provided by smart can be confusing but very helpful beyond the simple hour of operations or load cycle counts.

Regarding the Power_On time, one can encounter hours, minutes, half minutes or seconds. My harddrive (a SAMSUNG HM160JI) reports 416271 half minutes, even though the variable is "Power_On_Hours".

The Load_Cycle_Count can be misleading, however. My drive has reached nearly 600,000. Nonetheless, hdsentinel reports 100% health and well over 2 years of lifetime.

$ sudo smartctl -a /dev/sda | egrep 'Cycle|Power_On|Sector'
Password:
  5 Reallocated_Sector_Ct   0x0033   253   253   010    Pre-fail  Always       -       0
  9 Power_On_Hours          0x0032   100   100   000    Old_age   Always       -       416271
 12 Power_Cycle_Count       0x0032   100   100   000    Old_age   Always       -       381
193 Load_Cycle_Count        0x0012   044   044   000    Old_age   Always       -       571482
197 Current_Pending_Sector  0x0012   253   253   000    Old_age   Always       -       0
225 Load_Cycle_Count        0x0012   044   044   000    Old_age   Always       -       571482
$ sudo hdsentinel /dev/sda
[...]
Health       : 100 %
Performance  : 100 %
Power on time: 144 days, 12 hours, 41 minutes
Est. lifetime: more than 1000 days

The most important values are those that measure the imminence of drive failure. You can request them accordingly:

$ sudo smartctl -a /dev/sda | egrep Pre-fail
  1 Raw_Read_Error_Rate     0x000f   100   100   051    Pre-fail  Always       -       0
  3 Spin_Up_Time            0x0007   253   253   025    Pre-fail  Always       -       2560
  5 Reallocated_Sector_Ct   0x0033   253   253   010    Pre-fail  Always       -       0

Quite obviously, sector reallocations (due to 'bad' sectors) are the most obvious sign, but also a high spin up time or read error rate. Note that the Spin_Up_Time is often in milliseconds. In my case, it is 2560/60=42.6 seconds, well below 253. Change in spin up time value, however, is a bad sign as well. If you are paranoid, you may want to monitor it.

I can only recommend to install GSmartControl and check the harddrive from time to time. It offers a thorough test (90 mins) and a quick test (ca. 2 mins) as well as the option to save the smart data as a sheet to observe change in time.

Oh, and make backups! tongue

Last edited by mutlu_inek (2009-04-07 04:10:23)

Offline

#86 2009-10-18 00:14:43

shanipribadi
Member
Registered: 2009-08-14
Posts: 6

Re: Hard drive advanced power management level can kill your laptop drive?

Hello, I'd like to ask other people's opinion about the status of my harddisk. It's a new one (only 2 weeks old). It used to be that I left the hdparm -B at the default 128 value.
This is the result of smartctl:

  1 Raw_Read_Error_Rate     0x000f   111   100   006    Pre-fail  Always       -       40547235
  3 Spin_Up_Time            0x0003   099   099   000    Pre-fail  Always       -       0
  4 Start_Stop_Count        0x0032   100   100   020    Old_age   Always       -       158
  5 Reallocated_Sector_Ct   0x0033   100   100   036    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x000f   100   253   030    Pre-fail  Always       -       477741
  9 Power_On_Hours          0x0032   100   100   000    Old_age   Always       -       120
 10 Spin_Retry_Count        0x0013   100   100   097    Pre-fail  Always       -       0
 12 Power_Cycle_Count       0x0032   100   037   020    Old_age   Always       -       61
184 Unknown_Attribute       0x0032   100   100   099    Old_age   Always       -       0
187 Reported_Uncorrect      0x0032   100   100   000    Old_age   Always       -       0
188 Unknown_Attribute       0x0032   100   100   000    Old_age   Always       -       0
189 High_Fly_Writes         0x003a   100   100   000    Old_age   Always       -       0
190 Airflow_Temperature_Cel 0x0022   056   049   045    Old_age   Always       -       44 (Lifetime Min/Max 26/44)
191 G-Sense_Error_Rate      0x0032   100   100   000    Old_age   Always       -       9
192 Power-Off_Retract_Count 0x0032   100   100   000    Old_age   Always       -       5
193 Load_Cycle_Count        0x0032   095   095   000    Old_age   Always       -       10735
194 Temperature_Celsius     0x0022   044   051   000    Old_age   Always       -       44 (0 24 0 0)
195 Hardware_ECC_Recovered  0x001a   052   051   000    Old_age   Always       -       40547235
197 Current_Pending_Sector  0x0012   100   100   000    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0010   100   100   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x003e   200   200   000    Old_age   Always       -       0
254 Unknown_Attribute       0x0032   100   100   000    Old_age   Always       -       0

And then I changed the setting of laptop-mode tools so that on AC it uses 254 and on battery it uses 128.

 APM_level    = 254
shani@shanihplaptop /e/laptop-mode> sudo smartctl -a /dev/sda |egrep 'Load_Cycle|Power_On'
  9 Power_On_Hours          0x0032   100   100   000    Old_age   Always       -       121
193 Load_Cycle_Count        0x0032   095   095   000    Old_age   Always       -       10767

shani@shanihplaptop /e/laptop-mode> sudo smartctl -a /dev/sda |egrep 'Pre-fail'
  1 Raw_Read_Error_Rate     0x000f   111   100   006    Pre-fail  Always       -       40702547
  3 Spin_Up_Time            0x0003   099   099   000    Pre-fail  Always       -       0
  5 Reallocated_Sector_Ct   0x0033   100   100   036    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x000f   100   253   030    Pre-fail  Always       -       479275
 10 Spin_Retry_Count        0x0013   100   100   097    Pre-fail  Always       -       0

I left it on on AC power for the night, and after a couple of hours this is the result of smartctl:

  1 Raw_Read_Error_Rate     0x000f   111   100   006    Pre-fail  Always       -       41828656
  3 Spin_Up_Time            0x0003   099   099   000    Pre-fail  Always       -       0
  4 Start_Stop_Count        0x0032   100   100   020    Old_age   Always       -       162
  5 Reallocated_Sector_Ct   0x0033   100   100   036    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x000f   100   253   030    Pre-fail  Always       -       486302
  9 Power_On_Hours          0x0032   100   100   000    Old_age   Always       -       126
 10 Spin_Retry_Count        0x0013   100   100   097    Pre-fail  Always       -       0
 12 Power_Cycle_Count       0x0032   100   037   020    Old_age   Always       -       61
184 Unknown_Attribute       0x0032   100   100   099    Old_age   Always       -       0
187 Reported_Uncorrect      0x0032   100   100   000    Old_age   Always       -       0
188 Unknown_Attribute       0x0032   100   100   000    Old_age   Always       -       0
189 High_Fly_Writes         0x003a   100   100   000    Old_age   Always       -       0
190 Airflow_Temperature_Cel 0x0022   048   046   045    Old_age   Always       -       52 (Lifetime Min/Max 26/54)
191 G-Sense_Error_Rate      0x0032   100   100   000    Old_age   Always       -       9
192 Power-Off_Retract_Count 0x0032   100   100   000    Old_age   Always       -       5
193 Load_Cycle_Count        0x0032   095   095   000    Old_age   Always       -       10767
194 Temperature_Celsius     0x0022   052   054   000    Old_age   Always       -       52 (0 24 0 0)
195 Hardware_ECC_Recovered  0x001a   052   051   000    Old_age   Always       -       41828656
197 Current_Pending_Sector  0x0012   100   100   000    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0010   100   100   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x003e   200   200   000    Old_age   Always       -       0
254 Unknown_Attribute       0x0032   100   100   000    Old_age   Always       -       0

Load_Cycle_Count has not increased at all after 5 hours, that means the head is not parked at all. This causes the disk temperature to increase from 44 C to 52 C. So do you think I should keep on using hdparm 254? or maybe I should lower it? to 199 or 128?
One other thing, the raw read error rate is incredibly high 41828656, and the increase over 5 hours is 1126109, that means 225221 increase per hour. Is that something I should worry about.? The seek error rate is also very high.

Offline

Board footer

Powered by FluxBB