You are not logged in.

#76 2008-03-20 12:38:33

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: e17 in community

zenlord wrote:
pressh wrote:

Please file a bug on the community section of the Arch bug tracker so I don't forget to implement below workaround.

Registered in Flyspray and: http://bugs.archlinux.org/task/9877

I'd be glad if some people could test the script I posted on above link (pls provide feedback there) so it can be included on next entrance-cvs update.

Offline

#77 2008-03-21 16:58:29

raul_nds
Member
From: Lisbon, Portugal
Registered: 2007-06-28
Posts: 258

Re: e17 in community

XChrisX wrote:
raul_nds wrote:

I don't know if anyone has this problem, but when I choose "Advanced" in any configuration dialog, E17 freezes and I have to restart the X server.

I have found that this happens to me only when I am using the e17 Taskbar. When I remove the taskbar, "Advanced" works fine.

PS: pressh, thank you for all your hard work wink

confirmed smile

Offline

#78 2008-03-28 22:20:38

aRcHaTe
Member
Registered: 2006-10-24
Posts: 644

Re: e17 in community

what was the last update?

:: Starting full system upgrade...
warning: e-cvs: local (20080328-1) is newer than community (20080327-1)
warning: e_dbus-cvs: local (20080328-1) is newer than community (20080327-1)
warning: e_modules-cvs: local (20080328-1) is newer than community (20080327-1)
warning: ecore-cvs: local (20080328-1) is newer than community (20080327-1)
warning: edje-cvs: local (20080328-1) is newer than community (20080327-1)
warning: eet-cvs: local (20080328-1) is newer than community (20080327-1)
warning: efreet-cvs: local (20080328-1) is newer than community (20080327-1)
warning: embryo-cvs: local (20080328-1) is newer than community (20080327-1)
warning: emprint-cvs: local (20080328-1) is newer than community (20080327-1)
warning: engrave-cvs: local (20080328-1) is newer than community (20080327-1)
warning: entrance-cvs: local (20080328-1) is newer than community (20080327-1)
warning: epeg-cvs: local (20080328-1) is newer than community (20080327-1)
warning: epsilon-cvs: local (20080328-1) is newer than community (20080327-1)
warning: esmart-cvs: local (20080328-1) is newer than community (20080327-1)
warning: etk-cvs: local (20080328-1) is newer than community (20080327-1)
warning: evas-cvs: local (20080328-1) is newer than community (20080327-1)
warning: exhibit-cvs: local (20080328-1) is newer than community (20080327-1)
warning: exml-cvs: local (20080328-1) is newer than community (20080327-1)
local database is up to date


Its a sick world we live in....

Offline

#79 2008-03-29 05:59:27

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: e17 in community

AFAIK, last update was 20080327. Have you rebuilt it locally? If so, by default, makepkg updates the pkgver of SCM packages.

Offline

#80 2008-03-29 07:58:56

aRcHaTe
Member
Registered: 2006-10-24
Posts: 644

Re: e17 in community

Snowman wrote:

AFAIK, last update was 20080327. Have you rebuilt it locally? If so, by default, makepkg updates the pkgver of SCM packages.

yes ive updated them with makepkg...


Its a sick world we live in....

Offline

#81 2008-04-05 10:26:18

Bdede
Member
Registered: 2008-04-04
Posts: 4

Re: e17 in community

I made a clean install with e17-cvs. It was all right. Entrance work. But when I installed as stable DE Xfce, entrance can't start it. I can choose it but I got only black  screen. And got init3 to pres enter. Then I login and startxfce4 start X and xfce4.
I tried to copy under /etc/X11/Xsession the xfce4.desktop and made to executeable with no succes. It can't start xfce.

Offline

#82 2008-04-05 17:23:24

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: e17 in community

Bdede wrote:

I made a clean install with e17-cvs. It was all right. Entrance work. But when I installed as stable DE Xfce, entrance can't start it. I can choose it but I got only black  screen. And got init3 to pres enter. Then I login and startxfce4 start X and xfce4.
I tried to copy under /etc/X11/Xsession the xfce4.desktop and made to executeable with no succes. It can't start xfce.

Does this happen only with xfce or also with other WMs ?

Offline

#83 2008-04-05 19:24:59

Bdede
Member
Registered: 2008-04-04
Posts: 4

Re: e17 in community

I don't know. I have only two WM. Xfce and e17. But I copy the difference the two starts daemon.log

Apr  5 18:29:05 zrinyi entrance: Executing /usr/bin/enlightenment_start
Apr  5 18:29:05 zrinyi entrance: Starting session for user "daddy".
Apr  5 18:29:05 zrinyi entrance: Opened PAM session. daddy : :0.
Apr  5 18:29:05 zrinyi entrance: DEBUG1
Apr  5 18:29:05 zrinyi entrance: DEBUG2
Apr  5 18:29:05 zrinyi entrance: DEBUG3
Apr  5 18:29:05 zrinyi entrance: DEBUG4
Apr  5 18:29:05 zrinyi entrance: DEBUG5
Apr  5 18:29:05 zrinyi entrance: DEBUG6
Apr  5 18:29:05 zrinyi entrance: DEBUG7
Apr  5 18:29:05 zrinyi entrance: entrance_ipc_shutdown: Success
Apr  5 18:29:05 zrinyi entrance: DEBUG8
Apr  5 18:29:05 zrinyi entrance: Replacing Entrance with simple login program to wait for session end.
Apr  5 18:29:35 zrinyi entrance: Exec entrance login replacement: /usr/libexec/entrance/entrance_login 5077 daddy :0
Apr  5 18:29:35 zrinyi entrance_login[5063]: Wait for daddy on :0
Apr  5 18:29:35 zrinyi entrance_login[5063]: Wait for pid 5077
Apr  5 19:11:29 zrinyi init: Switching to runlevel: 6
and
Apr  5 21:10:09 zrinyi entrance: Executing /etc/X11/Xsession startxfce4
Apr  5 21:10:09 zrinyi entrance: Starting session for user "daddy".
Apr  5 21:10:09 zrinyi entrance: Opened PAM session. daddy : :0.
Apr  5 21:10:09 zrinyi entrance: DEBUG1
Apr  5 21:10:09 zrinyi entrance: DEBUG2
Apr  5 21:10:09 zrinyi entrance: DEBUG3
Apr  5 21:10:09 zrinyi entrance: DEBUG4
Apr  5 21:10:09 zrinyi entrance: DEBUG5
Apr  5 21:10:09 zrinyi entrance: DEBUG6
Apr  5 21:10:09 zrinyi entrance: DEBUG7
Apr  5 21:10:09 zrinyi entrance: entrance_ipc_shutdown: Success
Apr  5 21:10:09 zrinyi entrance: DEBUG8
Apr  5 21:10:09 zrinyi entrance: Replacing Entrance with simple login program to wait for session end.
Apr  5 21:10:09 zrinyi entrance: Exec entrance login replacement: /usr/libexec/entrance/entrance_login 5077 daddy :0
Apr  5 21:10:09 zrinyi entranced: The session has ended normally.
Apr  5 21:10:09 zrinyi entrance_login[5063]: Wait for daddy on :0
Apr  5 21:10:09 zrinyi entrance_login[5063]: Wait for pid 5077
Apr  5 21:10:09 zrinyi entrance_login[5063]: Ending PAM session for user "daddy".
Apr  5 21:10:09 zrinyi entrance_login[5063]: Wait done - child exited normally
Apr  5 21:10:10 zrinyi entrance: Cannot initialize requested display ":0". Exiting.

Offline

#84 2008-04-06 19:23:51

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: e17 in community

The problem with xfce4 is that the Xsession name is different from the name in /etc/X11/sessions. Either you could set the correct session name for xfce via ecore_config in /etc/entrance_config.cfg (though I've no time at the moment to figure the correct command), or a dirty solution is to rename (probably symlinking also works) /etc/X11/sessions/xfce4.desktop to /etc/X11/session/startxfce4.desktop

Offline

#85 2008-04-08 07:22:22

Bdede
Member
Registered: 2008-04-04
Posts: 4

Re: e17 in community

I'm sorry, but this solution doesn't work.

Offline

#86 2008-04-08 07:49:01

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: e17 in community

Bdede wrote:

I'm sorry, but this solution doesn't work.

weird, it did work here neutral

Try the following command as root (not sure it works without the rest of the sessions but please try and let me know):

ecore_config -c /etc/entrance_config.cfg -k /entrance/session/5/session -s "/usr/bin/startxfce4"

Offline

#87 2008-04-08 18:25:04

Bdede
Member
Registered: 2008-04-04
Posts: 4

Re: e17 in community

Sorry,sorry, sorry
I don't noticed the main trouble.
in the xfce4.desktop was Exec=startxfce4 only (originally)
and when I changed to Exec=/usr/bin/startxfce4, it start to work.
With original entrance_config.cfg works too.
I must be more careful.
Sorry

Offline

#88 2008-04-20 13:10:13

Mhyrraner
Member
From: South Germany
Registered: 2007-02-14
Posts: 33

Re: e17 in community

First, THANKS reverie! takhis repo was well appreciated ... as far as the I can say you did a very good job. I liked it a lot.
Second, e17 now has a tiling module:
http://sourceforge.net/mailarchive/mess … 014%40mx01
Howto:
https://twice-irc.de/misc/HOWTO-e17-tiling
will it be included in the next update?

Offline

#89 2008-04-24 12:38:58

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: e17 in community

Mhyrraner wrote:

Second, e17 now has a tiling module:
[...]
will it be included in the next update?

No, it most likely will not be included before it is accepted by the e17 devs because:
1. KISS
2. as it is a new 'module' the question is if it will be actively developed in the future so it remains working with future e17 CVS versions
3. the e17 source itself needs to be patched, this may or may not have a destabilizing effect
4. I'm not sure how many people would prefer tiling in e17 over a tiling wm.

Offline

#90 2008-05-13 15:27:44

techprophet
Member
Registered: 2008-05-13
Posts: 209

Re: e17 in community

Hey, is there any chance eclair will make it in? I have e17 setup nicely now and i like eclair as my media player. I have compiled from cvs, but it would be nice to have it in pacman. (especially for those who are scared of cvs/configure/make)

Offline

#91 2008-05-14 03:05:06

SpookyET
Member
Registered: 2008-01-27
Posts: 410

Re: e17 in community

Post it on AUR. And if there is interest, it will be moved.

Offline

#92 2008-05-14 18:59:36

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: e17 in community

Eclair is dead as far as I know: http://www.enlightenment.org/viewvc/e17/apps/eclair/

Offline

#93 2008-05-14 20:32:12

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,931

Re: e17 in community

Hey pressh,

I think this came up a while back, but I don't remember what happened. Now that Eet is at 1.0.0, is there any plans to drop CVS for that package?

Offline

#94 2008-05-14 21:27:23

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: e17 in community

skottish wrote:

Now that Eet is at 1.0.0, is there any plans to drop CVS for that package?

I can't find any information about guidelines for developing against eet, so I assume development is done against eet-cvs. This would mean that we can't move to 'stable' eet as long as we are using cvs versions for the rest of e17.  That said I don't see much point in having all cvs packages except one.

I'm happy to listen to any arguments though.

Offline

#95 2008-05-14 22:13:22

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,931

Re: e17 in community

pressh wrote:

I'm happy to listen to any arguments though.

No argument from me. It just feels good that E17 is beginning to be released finally. The new default theme looks like it's coming around nicely. It's linked to here:

http://www.osnews.com/story/19679/A_Few … _Rasterman

Offline

#96 2008-05-15 20:07:58

nbvcxz
Member
From: Poland
Registered: 2007-12-29
Posts: 195

Re: e17 in community

good news - and new theme from Rasterman is quite nice and super fast (working)


Lenovo G50 | LXQT-git | compton | conky

Offline

#97 2008-05-16 03:18:02

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,931

Re: e17 in community

nbvcxz wrote:

good news - and new theme from Rasterman is quite nice and super fast (working)

Where did you find it?

Offline

#98 2008-05-16 04:33:23

fancris3
Member
Registered: 2007-03-18
Posts: 67

Re: e17 in community

Offline

#99 2008-05-29 07:15:53

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: e17 in community

fancris3 wrote:

Nice theme, a big improvement on the old/current standard theme, but...
did anyone try to run this in a high resolution?

When running it on 1600x1200 both the fonts and window decoration are tiny (I mean really tiny). Increasing the font is not such a problem (that is if you can find it in the menu because you cannot read it tongue). The window decoration you cannot increase in size without touching the code AFAIK.

So before I try to patch it did anyone try to run it in a high resolution and got better results?

Offline

#100 2008-05-29 12:20:20

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,931

Re: e17 in community

pressh wrote:
fancris3 wrote:

Nice theme, a big improvement on the old/current standard theme, but...
did anyone try to run this in a high resolution?

When running it on 1600x1200 both the fonts and window decoration are tiny (I mean really tiny). Increasing the font is not such a problem (that is if you can find it in the menu because you cannot read it tongue). The window decoration you cannot increase in size without touching the code AFAIK.

So before I try to patch it did anyone try to run it in a high resolution and got better results?

3840x1200 = microscopic.

Confirmed.

Offline

Board footer

Powered by FluxBB