You are not logged in.

#26 2008-02-28 17:47:16

reefer
Member
From: Norway
Registered: 2004-11-13
Posts: 14

Re: Wrong keyboard layout with new xorg/evdev version from testing

I have the same keyboard myself (Logitech Media Keyboard 600) model number Y-UQ85.
I've been struggling with the same, but found the solution.

I followed post #8 (from bender02) in this thread, and in addition in KDE's control center
under "Regional & Accessibility" -> "Keyboard Layouts" I enabled keyboard layouts and
chose Evdev-managed keyboard from the list.

(this "bug" is also reported in gentoo: https://bugs.gentoo.org/show_bug.cgi?id=200060)

Works great now!
Thanks everyone!

Last edited by reefer (2008-02-28 17:48:12)

Offline

#27 2008-02-29 10:47:47

maschino
Member
From: Vienna
Registered: 2008-01-01
Posts: 19
Website

Re: Wrong keyboard layout with new xorg/evdev version from testing

reafer your a genius! I changed the keyboard type to "evdev-managed keyboard" and it works for me too!

Thanks a lot smile

Offline

#28 2008-03-01 14:49:12

capthookb
Member
Registered: 2007-12-10
Posts: 120

Re: Wrong keyboard layout with new xorg/evdev version from testing

I am also having problems with the latest xorg, but with the mouse instead of the keyboard.
I had to switch back to using mouse driver instead of evdev.
With the evdev option the pointer cannot move at all, but the buttons seem to work.

Offline

#29 2008-03-04 12:16:33

voidzero
Member
Registered: 2007-06-21
Posts: 108

Re: Wrong keyboard layout with new xorg/evdev version from testing

Whoa, so much problems. I don't have any of them. Besides vmware that seems to be confused when hal is running, that is.

Here's my keyboard policy:

<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
        <device>
                <!-- FIXME: Support tablets too. -->
                <match key="info.capabilities" contains="input.mouse">
                        <merge key="input.x11_driver" type="string">mouse</merge>
                        <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
                                string="Linux">
                                <merge key="input.x11_driver" type="string">evdev</merge>
                        </match>
                </match>

                <match key="info.capabilities" contains="input.keys">
                        <merge key="input.xkb.rules" type="string">base</merge>
                        <!-- If we're using Linux, we use evdev by default (falling back to
                        keyboard otherwise). -->
                        <merge key="input.x11_driver" type="string">keyboard</merge>
                        <merge key="input.xkb.model" type="string">pc105</merge>
                        <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
                                string="Linux">
                                <merge key="input.x11_driver" type="string">evdev</merge>
                                <merge key="input.xkb.model" type="string">evdev</merge>
                        </match>
                        <merge key="input.xkb.layout" type="string">us</merge>
                        <merge key="input.xkb.variant" type="string">dvorak</merge>
                        <merge key="input.xkb.options" type="string">ctrl:swapcaps,altwin:super_win,compose:rctrl,eurosign:5</merge>
                </match>
        </device>
</deviceinfo>

Offline

#30 2008-03-05 20:12:41

Aitch
Member
From: Norway
Registered: 2008-02-19
Posts: 43

Re: Wrong keyboard layout with new xorg/evdev version from testing

Thanks reefer, your post gave me the confidence to try twiddling with the xorg.conf again and things are back working on my x86_64 system on a Lenovo T61 with Norwegian keyboard.

I am just worried that now if xorg gets fixed then all my configs are going to be broken........

Offline

#31 2008-03-17 13:39:57

MAC!EK
Member
Registered: 2005-09-27
Posts: 267

Re: Wrong keyboard layout with new xorg/evdev version from testing

Did something changed with the update:
[2008-03-17 11:10] upgraded xkeyboard-config (1.1-1 -> 1.2-1)
[2008-03-17 11:10] upgraded xorg-server (1.4.0.90-7 -> 1.4.0.90-8)

I had my hal policies changed to set keyboard layout "pl". But now it isn't working and all other policies from /etc/hal/fdi/policy/ disappeared.

Last edited by MAC!EK (2008-03-17 13:40:48)

Offline

#32 2008-03-17 15:06:03

shining
Pacman Developer
Registered: 2006-05-10
Posts: 2,043

Re: Wrong keyboard layout with new xorg/evdev version from testing

MAC!EK wrote:

Did something changed with the update:
[2008-03-17 11:10] upgraded xkeyboard-config (1.1-1 -> 1.2-1)
[2008-03-17 11:10] upgraded xorg-server (1.4.0.90-7 -> 1.4.0.90-8)

I had my hal policies changed to set keyboard layout "pl". But now it isn't working and all other policies from /etc/hal/fdi/policy/ disappeared.

Hm, maybe you missed my post on the first page :
http://bbs.archlinux.org/viewtopic.php? … 78#p334978


pacman roulette : pacman -S $(pacman -Slq | LANG=C sort -R | head -n $((RANDOM % 10)))

Offline

#33 2008-09-05 12:54:47

hardfalcon
Member
From: Luxembourg
Registered: 2008-04-13
Posts: 8
Website

Re: Wrong keyboard layout with new xorg/evdev version from testing

I did it just the way bender02 suggested it in post #8 (although I found it out on myself): Just configure your keyboad to use the evdev driver instead of the kbd driver in xorg.conf. And, as you are already editing your xorg.conf, you could also consider migriting your mouse to evdev as well, if you haven't done so already. For me (Keyboard: IBM Model M via PS/2; Mouse: Logitech RX-250 via PS/2, but also worked via USB before), it looks like this:

Section "InputDevice"
    Identifier     "Keyboard1"
    Driver         "evdev"
    Option         "Device" "/dev/input/by-path/platform-i8042-serio-0-event-kbd"
    Option         "AutoRepeat" "500 30"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc102"
    Option         "XkbLayout" "ch"
EndSection

Section "InputDevice"
    Identifier     "Mouse1"
    Driver         "evdev"
    Option         "CorePointer"
    Option         "Device" "/dev/input/by-path/platform-i8042-serio-1-event-mouse"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection

Of couse, you have to adopt the Option "Device" "/dev/input/XXXXXX" to your needs. It is often suggested to take /dev/input/eventX, but I have found out that this often causes trouble with USB devices which sometimes get another event id (for whatever reason). In /dev/input/bypath/ (and, if you are using USB devices, in /dev/input/by-id/) however, you get a nice symlink for each device which always points to the right /dev/input/eventX.

Offline

#34 2008-09-14 20:56:14

deluminathor
Member
From: Poland
Registered: 2008-09-14
Posts: 16

Re: Wrong keyboard layout with new xorg/evdev version from testing

My first post, so hi to you all smile

I have a problem that concerns keyboard layout in xorg, KDEmod(4.1). First, a short story:
I've installed Arch on my laptop a few days ago [my first time with Arch smile]. Everything was great until I decided to turn on hotplugging [which is necessary for me - laptop without hotplugging is like cigar without the smoke smile]. What's more, I wanted to use all of my mouse buttons, so the only driver to consider was evdev. Then I found that both those things may be 'easily' [:o] achieved by enabling hal support in xorg-server. Thus, I've compiled and installed modified package. After that I spent hours configuring KDE 4.1 to handle changed keycodes but yesterday I've accitentally discovered "Evdev-managed keyboard" option in keyboard layout field in KDE settings. That seemed to solve all my problems... but today i've found another.

I use polish keyboard layout and sometimes need to put some special, diacritical character. It works fine everywhere in KDE but not in Opera, I have no idea why. When i try to e.g. write url/email/anything in Opera and press e.g. right Alt + e (which should produce 'ę'), no character appears. I spent much time trying to find out why that happens and read through this topic but nothing helps sad

Now some more technical info:
My /etc/hal/fdi/policy/10-keymap.fdi

<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">base</merge>

      <!-- If we're using Linux, we use evdev by default (falling back to
           keyboard otherwise). -->
      <merge key="input.xkb.model" type="string">keyboard</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.xkb.model" type="string">evdev</merge>
      </match>

      <merge key="input.xkb.layout" type="string">pl</merge>
      <merge key="input.xkb.variant" type="string" />
    </match>
  </device>
</deviceinfo>

In my xorg.conf all InputDevice sections [but synaptics] are commented out. When I tried to turn the keyboard section in, X server was complaining about duplicated keyboard device info and ignored one of them as it was already assigned [BTW my keybord is 'AT Translated Set 2 keyboard'].

I tried running Opera without KDE [by starting pure xterm and then opera] and it worked good, polish characters was working as expected. What's strange, X server was writing on its output something like that:

expected keysym, got XF86Info: line 914 of inet
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
expected keysym, got XF86Info: line 914 of inet
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
expected keysym, got XF86Info: line 914 of inet
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server

Nevertheless, it worked. If Opera was started with -debugkeyboard switch, right Alt + 'e' was producing following debug output:

X11 keypress: window=0060001d, state=00000000, keycode=0000006c, keysym=0000fe03 (''), focus: ScrollView, context: Edit Widget
Qt  keypress: key:  (16781571), text: , state: 00000000
X11 keypress: window=0060001d, state=00000080, keycode=0000001a, keysym=00000065 ('e'), focus: ScrollView, context: Edit Widget
Qt  keypress: key:  (0280), text: ?, state: 40000000
Qt  keyrelease: key: E (0069), text: e, state: 00000000
Qt  keyrelease: key:  (16781571), text: , state: 00000000

Under KDE, as written above, right Alt + 'e' doesn't produce anything in Opera but the debug output looks as follows:

X11 keypress: window=02000020, state=00000000, keycode=0000006c, keysym=0000fe03 (''), focus: ScrollView, context: Edit Widget
Qt  keypress: key:  (16781571), text: , state: 00000000
X11 keypress: window=02000020, state=00000088, keycode=0000001a, keysym=00000065 ('e'), focus: ScrollView, context: Edit Widget
Qt  keypress: key: ▒ (0280), text: ?, state: 48000000
Qt  keyrelease: key: E (0069), text: e, state: 00000000
Qt  keyrelease: key:  (16781571), text: , state: 00000000

so they look similar...
What's more, I have noticed the same problem in GIMP - polish characters don't work [but in this case it may be caused by the fact that GTK doesn't know about 'Evdev-managed keyboard'... or am I wrong?].
I have no idea why it doesn't work. Please help... sad

Edit: I checked Eclipse and the problem is there too. Special characters seem to work only in native KDE applications [whatever it means...]. What's strange, I tried to switch to kbd driver, even installed standard xorg-server package from repo and special characters still don't work in applications i've written about... Did anybody encounter such problems?...

Edit2: Huh, finally I dealt with the problem. I removed all keyboard layouts but the polish one in System Settings -> Keyboard layout. Then it started to work. Next, I added (previously removed) additional layouts and it still works smile I think there was some mess with the configuration and removing has cleaned it.
So, my problem is SOLVED.

Last edited by deluminathor (2008-09-15 12:41:29)


Order dissolves into chaos and then collapses into a higher form of order. This holds true for galaxies, ecosystems, empires and civilizations. The Universe, society, culture manifests in eternal change, and so should music and art.

Offline

#35 2008-12-12 02:09:12

Dave Cohen
Member
Registered: 2008-09-27
Posts: 126

Re: Wrong keyboard layout with new xorg/evdev version from testing

I've just updated and I don't have any files in /etc/hal/fdi/policy/

My keyboard map is incorrect, for example my arrow keys have no effect.

Another strange side effect of the upgrade is that my screen resolution (normally 1600x1200) is much lower when I start X.  Then I go the KDE system settings, click Display and immediately (without me changing anything) the resolution becomes 1600x1200.

Does anyone have advice for me to solve these problems?  Thanks.

Offline

#36 2008-12-12 18:47:17

Dave Cohen
Member
Registered: 2008-09-27
Posts: 126

Re: Wrong keyboard layout with new xorg/evdev version from testing

I'm still confused about the keyboard map.  I'm using KDE, and find that under System Settings => Regional and Language I can change the keyboard layout.  But there is no choice in the list that works properly.  I'm in the US, using a keyboard purchased in the US.  Still I can't get the arrow keys to work.  Can anyone recommend a layout and/or variant for me to try?

Regarding my screen resolution, I fixed that problem by editing a modes line in my xorg.conf.

Offline

#37 2008-12-12 18:58:06

deluminathor
Member
From: Poland
Registered: 2008-09-14
Posts: 16

Re: Wrong keyboard layout with new xorg/evdev version from testing

Have you tried choosing "Evdev-managed keyboard" in System Settings => Regional and Language => "Keyboard model" field?

Last edited by deluminathor (2008-12-12 18:59:06)


Order dissolves into chaos and then collapses into a higher form of order. This holds true for galaxies, ecosystems, empires and civilizations. The Universe, society, culture manifests in eternal change, and so should music and art.

Offline

#38 2008-12-12 21:07:07

Dave Cohen
Member
Registered: 2008-09-27
Posts: 126

Re: Wrong keyboard layout with new xorg/evdev version from testing

Yes I've done that and I believe the dialog box is working properly.  For example if I select the dvorak variant of the us layout, it does change my keys.  But I'm unable to find a set of settings in which the arrow keys work properly.

Offline

#39 2008-12-12 21:23:15

deluminathor
Member
From: Poland
Registered: 2008-09-14
Posts: 16

Re: Wrong keyboard layout with new xorg/evdev version from testing

As a workaround you could grab arrow keys keycodes [using 'xev' command] and map them to arrow keys using xmodmap so that Xorg would interpret them correctly.
You may also post those keycodes, so we could compare them. Mine are:
Up arrow => 111
Down arrow => 116
Left arrow => 113
Right arrow => 114

And post your /etc/hal/fdi/policy/10-keymap.fdi if you have such file.

Last edited by deluminathor (2008-12-12 21:25:30)


Order dissolves into chaos and then collapses into a higher form of order. This holds true for galaxies, ecosystems, empires and civilizations. The Universe, society, culture manifests in eternal change, and so should music and art.

Offline

#40 2008-12-12 21:44:57

Dave Cohen
Member
Registered: 2008-09-27
Posts: 126

Re: Wrong keyboard layout with new xorg/evdev version from testing

Hmmm... do you know exactly what to put in the .Xmodmap file?

My keycodes are
Up arrow => 98
Down arrow => 104
Left arrow => 100
Right arrow => 102

I have no files at all in /etc/hal/fdi/policy/ (directory exists but is empty).

Offline

#41 2008-12-12 22:21:04

deluminathor
Member
From: Poland
Registered: 2008-09-14
Posts: 16

Re: Wrong keyboard layout with new xorg/evdev version from testing

Your .Xmodmap file would look as follows:

keycode 98 = Up
keycode 104 = Left
keycode 100 = Right
keycode 102 = Down

However, before you try workarounds using xmodmap, try to create 10-keymap.fdi as written in Xorg input hotplugging article. After editing this file remember to restart hal ['sudo /etc/rc.d/hal restart'] and xorg-server [Ctrl+Alt+Backspace]. The article I gave a link to contains several tips that might help you. If it definitely doesn't work, you can try xmodmap.


Order dissolves into chaos and then collapses into a higher form of order. This holds true for galaxies, ecosystems, empires and civilizations. The Universe, society, culture manifests in eternal change, and so should music and art.

Offline

#42 2008-12-13 18:27:14

Dave Cohen
Member
Registered: 2008-09-27
Posts: 126

Re: Wrong keyboard layout with new xorg/evdev version from testing

I copied the 10-keymap..fdi file but I haven't edited it.  I'm in the US, and the default mapping is 'us', so I'm not sure what to change it to.  Copying this file had no effect.

So I created a .Xmodmap file, and added a script to ~/.kde4/Autostart which calls `xmodmap ~/.Xmodmap`.  Now my arrow keys work, making the whole system much more usable.  I am frustrated that this solution works only for my account.  And I'm left with the feeling that something is not right either with my keyboard or my install of Arch.

Still I'm very grateful for the help.  Thank you. 

For the record here's the ~/.Xmodmap I ended up with:

keycode 98 = Up
keycode 104 = Down
keycode 100 = Left
keycode 102 = Right

Last edited by Dave Cohen (2008-12-13 18:27:36)

Offline

Board footer

Powered by FluxBB