You are not logged in.

#26 2008-03-09 23:31:46

markc
Member
From: Gold Coast, Australia
Registered: 2007-05-15
Posts: 496
Website

Re: Daily KDE4 Subversion Packages

Yes, pacman -R kde-svn-all should remove most if not all of them.

Offline

#27 2008-03-10 16:06:53

miggols99
Member
Registered: 2007-06-10
Posts: 424

Re: Daily KDE4 Subversion Packages

Tigertailz wrote:

Hello, I just installed kde from your repo, for fun. Well now I want to remove all the kde packages, is there a way I can do that in one command ?

Try

pacman -Rsc kdelibs

EDIT: Could you make a package for KOffice2? I obviously can't install the regular KOffice...and Abiword isn't that great sad

Last edited by miggols99 (2008-03-10 17:19:59)

Offline

#28 2008-03-11 03:28:27

markc
Member
From: Gold Coast, Australia
Registered: 2007-05-15
Posts: 496
Website

Re: Daily KDE4 Subversion Packages

miggols99 wrote:

pacman -Rsc kdelibs

Yay, good command, thanks for that. -Rsc = recursively cascade and remove all dependencies from kdelibs.

Could you make a package for KOffice2? I obviously can't install the regular KOffice...and Abiword isn't that great sad

To my surprise all of Koffice built okay and mostly seems to run. Nothing crashed in the 30 minutes I played around with a few of the apps. My server repo layout has changed slightly, it's now...

[kde]
Server = http://pkg.eth-os.org/kde/x86_64 (or i686)

The groups are still kde-svn and kde-svn-all. This "kde" repo section is for anything built from the official KDE subversion repo so other Qt desktop apps (and maybe firefox3) will go in [gui] -> http://pkg.eth-os.org/gui/ where qgit and shaman have been moved to. BTW shaman is looking really really good as a binary AND source package manager. I think I'm happy with this new repo layout and will remove the ever increasing stagnant kde-svn/ directory maybe tomorrow.

Last edited by markc (2008-03-13 13:31:36)

Offline

#29 2008-03-11 13:25:33

Belitsky.A
Member
From: Russia, Zelenograd
Registered: 2008-01-10
Posts: 57

Re: Daily KDE4 Subversion Packages

error: failed retrieving file 'kde.db.tar.gz' from pkg.eth-os.org : Not Found
error: failed to synchronize kde: Not Found

Fix it please.

Offline

#30 2008-03-12 01:20:06

markc
Member
From: Gold Coast, Australia
Registered: 2007-05-15
Posts: 496
Website

Re: Daily KDE4 Subversion Packages

Belitsky.A wrote:

error: failed retrieving file 'kde.db.tar.gz' from pkg.eth-os.org : Not Found

Whoa, sorry about that. One little / too many in a rewrite rule for apache. On a positive note I'm using konqueror to type this response in a textarea without it losing characters and getting so messed up I had to swap over to firefox, however, now the mouse pointer dissapears from the page content after activating a textarea and typing a character... heh, makes trying to hit the Submit button quite a challenge... oic, click on the bottom status bar and the pointer reappears until typing another character. At least someone is working directly on form widgets and another day or so may mean that konqueror can finally be used full time. I still have trouble with attachments in kmail. Also, I got a response about Phonon being in both qt-copy and kdelibs, here is that response verbatim...

Subject: Re: libphonon
Date: Tuesday 11 March 2008
From: Matthias Kretz <kretz@kde.org>
To: Mark Constable <markc@renta.net>

Hi,

sorry for the confusion this is causing. I know we need to document this 
somehow...

This is the deal: kdelibs is the official place for libphonon. If you look at 
the Qt srcs directory layout you'll find phonon in the 3rdparty dir.

But Qt4.4 releases a newer version of libphonon (i.e. 4.1) than KDE 4.0 did 
(4.0). KDE 4.1 will release libphonon 4.2. As libphonon itself does not 
depend on kdelibs I suggest to create an extra libphonon package (split it 
out of both kdelibs and Qt so that either source can replace the older 
package).

I'm considering whether there should be an official libphonon release with 
Qt4.4. Do you think that would help to make the issue a little clearer?

Regards,
    Matthias

Last edited by markc (2008-03-12 01:31:30)

Offline

#31 2008-03-12 18:05:20

SoftVision
Member
Registered: 2007-11-12
Posts: 64

Re: Daily KDE4 Subversion Packages

I created a partition which just happened to be sda9 for me so no editing of your script was required. I'll let you know how it goes as I'm running the script now.

Last edited by SoftVision (2008-03-12 18:05:50)

Offline

#32 2008-03-13 20:53:53

miggols99
Member
Registered: 2007-06-10
Posts: 424

Re: Daily KDE4 Subversion Packages

I'd like you to add Arxin to the GUI repo. It isn't in the AUR, but here is the forum topic:

http://www.kdemod.ath.cx/bbs/viewtopic.php?pid=3309

Offline

#33 2008-03-14 10:54:35

markc
Member
From: Gold Coast, Australia
Registered: 2007-05-15
Posts: 496
Website

Re: Daily KDE4 Subversion Packages

miggols99 wrote:

I'd like you to add Arxin to the GUI repo.

Done and thanks for the notice as I was unaware of it's recent development. I also added a simple SQLite manager called "sqlitebroswer" that is really a Qt3 application that just happens to compile and run under Qt4. It's missing some icons but it does actually work without crashing.

Hmm, I think this is the first time I've been able to use konqueror to reply to a forum post.

Offline

#34 2008-03-16 10:41:51

markc
Member
From: Gold Coast, Australia
Registered: 2007-05-15
Posts: 496
Website

Re: Daily KDE4 Subversion Packages

WARNING for 20080316 Plasma is crashing for me with todays update. I've tried recompiling kdesupport, kdelibs and kdebase after another 15 hours but it still crashes. It may be something on my system but more likely it's the current package build for today so, to be safe, don't upgrade to 20080316. Such is life on the bleeding edge.

Offline

#35 2008-03-16 13:49:35

Noneus
Member
From: Munich
Registered: 2006-09-26
Posts: 118
Website

Re: Daily KDE4 Subversion Packages

Well. I installed today with 20080316. Plasma works here. Of course the usual KMail and Konqueror not working correctly.

Offline

#36 2008-03-16 21:58:43

SpookyET
Member
Registered: 2008-01-27
Posts: 410

Re: Daily KDE4 Subversion Packages

I can't get sound to work. Where do you tell phonon to use OSS4?

Offline

#37 2008-03-17 01:39:01

markc
Member
From: Gold Coast, Australia
Registered: 2007-05-15
Posts: 496
Website

Re: Daily KDE4 Subversion Packages

Noneus wrote:

Well. I installed today with 20080316. Plasma works here. Of course the usual KMail and Konqueror not working correctly.

That is good to hear. I just did a fresh x86_64 install using the "alinit" script and it still has the same problem where plasma just crashes. Maybe it's a 64bit issue. So I'm stuck using alt-F2 and alt-tab, heh.

I find konqueror has much improved over the last week, particularly it's form widgets, but I wouldn't even bother trying plugins (like flash). Kmail is usable but viewing attachments does not work for me.

SpookyET wrote:

I can't get sound to work. Where do you tell phonon to use OSS4?

In System Settings -> Sound -> Backend there is a "Show OSS devices:" button. If that does not show your OSS4 devices then it'll be a shortcoming of the Phonon backend.

Offline

#38 2008-03-17 23:38:17

miggols99
Member
Registered: 2007-06-10
Posts: 424

Re: Daily KDE4 Subversion Packages

How do I get my laptop keys to work? KMilo is in SVN, so how do I get it to work?

Offline

#39 2008-03-18 11:15:43

markc
Member
From: Gold Coast, Australia
Registered: 2007-05-15
Posts: 496
Website

Re: Daily KDE4 Subversion Packages

I have no idea how to configure it but starting and stopping the kmilo daemon appears to be in System Settings -> Advanced -> Service Manager -> Startup Services.

Offline

#40 2008-03-18 19:25:08

Milfadoodle
Member
Registered: 2007-05-21
Posts: 26

Re: Daily KDE4 Subversion Packages

Added your repo. Repo synced ok but when I run pacman -S kde-svn it wants to install kde 3.5.9.
What am I doing wrong?

EDIT: Put it above the core repo of course!

Last edited by Milfadoodle (2008-03-18 19:26:40)

Offline

#41 2008-03-19 07:41:45

mini
Member
Registered: 2006-12-18
Posts: 132

Re: Daily KDE4 Subversion Packages

I have installed knetwormanager but I can not find/start it. Which is the way to start knetwormanager in kde4

Offline

#42 2008-03-20 03:24:45

markc
Member
From: Gold Coast, Australia
Registered: 2007-05-15
Posts: 496
Website

Re: Daily KDE4 Subversion Packages

mini wrote:

I have installed knetwormanager but I can not find/start it. Which is the way to start knetwormanager in kde4

You should be able to start it by typing in "knetworkmanager" in the search field of kickoff or by using alt-F2. I'd be interested to know if it works for you.

Offline

#43 2008-03-20 03:51:16

markc
Member
From: Gold Coast, Australia
Registered: 2007-05-15
Posts: 496
Website

Re: Daily KDE4 Subversion Packages

FWIW for nearly a week I personally had a crashing plasma then for a few days a panel but no dashboard, just a default checkered background and no dashboard functionality. On bugs.kde.org there were a few reports of non-working plasma dashboards so I wasn't the only one but no one has complained here about plasma not working. Arron Seigo mentioned something about recent BIC(?) changes with Qt4 and I think there was a large svn update to qt-copy (not 100% as I was asleep). Anyway, just now with 20080320 (still uploading as I type this), I did a fresh install using the "alinit" script and I finally have a working plasma dashboard and, in general, everything seems "better" after nearly a week of an almost totally unusable system which was very distracting. I ended up building a debug version last night but now plasma is not crashing so that was a waste of time and I'll never know where or what was actually at fault (on my x86_64 system) :-)

One change to the package set is that amarok is now renamed to amarok2 so it doesn't clash with the standard extra/amarok-base which uses a replaces=(amarok) and always caused a warning to replace amarok no matter how I tweaked the svn amaroks replaces(), provides() and conflicts() so do a pacman -R amarok && pacman -S amarok2 to get the amarok from svn trunk.

BTW has anyone managed to figure out how to enable a different font-size for non-KDE apps like gimp, inkscape and firefox ?

I've tried messing with ~/.gtkrc-2.0 but no success so far.

Last edited by markc (2008-03-21 03:02:17)

Offline

#44 2008-03-20 09:00:19

ddoan
Member
Registered: 2007-10-26
Posts: 9

Re: Daily KDE4 Subversion Packages

Ah, I will try the new version later... I also had the plasma crash and the checkered background... (x86_64)... Thanks a lot!! :-)

EDIT:
I still have the checkered background... nothing else... no panel, nada, rien... strangely, KDE 4.0.1 works for me.

Last edited by ddoan (2008-03-20 10:31:53)

Offline

#45 2008-03-20 09:04:55

mini
Member
Registered: 2006-12-18
Posts: 132

Re: Daily KDE4 Subversion Packages

Knetworkmanager wil not work. When I typing "knetworkmanager"  I get an error pop up window:

Unknown host www.google.com. Unknown error

My knetworkmanager version is:

community/knetworkmanager 0.2-1 [installed]
    A NetworkManager front-end for KDE

BTW How can I ignore to update all kde-svn pakages, I have tried put "IgnorePkg = kde-svn" into /etc/pacman.conf, but it doas not help.

Last edited by mini (2008-03-20 09:24:41)

Offline

#46 2008-03-20 09:36:32

markc
Member
From: Gold Coast, Australia
Registered: 2007-05-15
Posts: 496
Website

Re: Daily KDE4 Subversion Packages

@mini: I can't help with knetworkmanager because it's a KDE3 program and I'm trying to keep a pure KDE4 system (aside from gimp, inkscape and firefox) but if it's just an issue of getting a generic network connection then I would suggest to use the regular Archlinux /etc/rc.d/network system for now, see http://wiki.archlinux.org/index.php/Configuring_network. Maybe someone else has tried knetworkmanager, or tinkered with KDE4s network system, and can offer some direct help.

I suspect it'll be many weeks before a KDE4 network configuration system is in place and, even then, it'll need wide testing before it's reliable.

mini wrote:

BTW How can I ignore to update all kde-svn pakages, I have tried put "IgnorePkg = kde-svn" into /etc/pacman.conf, but it doas not help.

If I understand what you mean you just need to remove, or comment out, the [kde] and [gui] lines plus the associated Server lines. As noted in the initial posting for this thread, the best way to use these packages is to have, or create with qtparted, a separate partition and use the "alinit" script (or anything that will install AL from scratch, like a liveCD etc) and have a clean unpolluted kde-svn-all KDE4 install in that dedicated partition. I never intended for these packages to work with a current KDE install by simply adding them and upgrading to these packages. No doubt there will be official KDE4 packages in [extra] a week or 2 after KDE 4.1 is released and KDEmod4 will probably have point releases between now and then so if anyone wants a reliable upgrade path to KDE4 then please use those options.

ddoan wrote:

I still have the checkered background... nothing else... no panel, nada, rien... strangely, KDE 4.0.1 works for me.

KDE 4.0.1 uses Qt 4.3.4 whereas the current qt-copy in Subversion trunk uses a pre-release Qt 4.4.0-beta1 which has features particularly needed by plasma (desktop/dashboard) for the upcoming 4.1 release. Also, on Mondays in general, large changes can often be committed that can break basic functionality and I think this past week was a doozy. As to the background problem, I "cheated" by creating a totally fresh Archlinux system and re-installing the kde-svn packages from scratch so I'm not sure what parts of the system cause the problem you are still seeing. It may be worth trying a pacman -Rd qt-copy kdelibs && pacman -S qt-copy kdelibs to try and get rid of whatever causes the hiccup.

Last edited by markc (2008-03-21 03:00:54)

Offline

#47 2008-03-21 10:27:29

miggols99
Member
Registered: 2007-06-10
Posts: 424

Re: Daily KDE4 Subversion Packages

Ahh finally! The icons are back to normal smile I was having a problem with icons being "?" everywhere..ugh it was getting a bit annoying.

Offline

#48 2008-03-21 19:26:54

Maki
Member
From: Skopje, Macedonia
Registered: 2007-10-16
Posts: 345
Website

Re: Daily KDE4 Subversion Packages

I installed KDE4 & installed xfce as a backup, everything works fine except for bug with nvidia cards when plasma has trouble painting the desktop while gtk apps are runing.
All in all, great job, how often you will upgrade ?


If it ain't broke, broke it then fix it.

Offline

#49 2008-03-22 06:15:57

markc
Member
From: Gold Coast, Australia
Registered: 2007-05-15
Posts: 496
Website

Re: Daily KDE4 Subversion Packages

Maki wrote:

how often you will upgrade ?

Every 24 hours and at this point in time I intend to always provide these packages and even extend the "daily updates" concept to include some server orientated packages as well. I want to create a small distribution that specializes in a KDE4 desktop and a PHP based backend server/ISP system. Rather than provide a wide range of packages for all situations I want to move in the opposite direction and narrow the focus to a comfortable (primarily for me) subset so that it can be really fine tuned with tutorials and screencasts that are very specific. FWIW.

Todays 20080322 package set should be pretty good. The past week has been rough and the i686 packages were not being built properly for the last 2 days as I use x86_64 myself so they get checked by me personally whereas I don't even use the i686 packages. Some noticable improvements are that Kickoff menu now has a sliding tabs animation and webkitkde is included (needs to be specifically installed) so konqueror can view pages using KHTML or Webkit via Konqueror -> View -> View Mode -> WebKit|KHTML. Apparently Gmail works better with Webkit but I can't figure out how to get the webkit kpart to recognise font size config settings so I still use KHTML. I still get a few crashes, particularly with akregator when it updates it's feeds. Viewing attachments in kmail is much improved. All round I'd say this is the best build since I started a month ago.

Offline

#50 2008-03-22 08:04:07

laleshii
Member
Registered: 2008-03-22
Posts: 7

Re: Daily KDE4 Subversion Packages

please upgrade the package database ... it points out to the packages on 20-03-2008 which do not exist anymore.

Offline

Board footer

Powered by FluxBB