You are not logged in.

#51 2008-03-23 12:57:15

srimalik
Member
Registered: 2007-09-16
Posts: 65

Re: Daily KDE4 Subversion Packages

KDE4 is not remembering the size of my taskbar(I like it "tiny"), Every time I log in the default size is small, I have to manually cahnge it every time I login.
Any ideas?

Offline

#52 2008-03-23 15:12:03

markc
Member
From: Gold Coast, Australia
Registered: 2007-05-15
Posts: 496
Website

Re: Daily KDE4 Subversion Packages

laleshii wrote:

please upgrade the package database ... it points out to the packages on 20-03-2008 which do not exist anymore.

Thanks for the notice, should have been fixed a few hours after you posted this.

srimalik wrote:

KDE4 is not remembering the size of my taskbar(I like it "tiny"), Every time I log in the default size is small, I have to manually cahnge it every time I login.
Any ideas?

The size of the panel will be stored in the geometry field of a [Containments] that includes plugin=panel in ~/.kde/share/config/plasma-appletrc but you are right, it does not seem to respect the changes even though they do get written to that file. To test it out try this... use grep geom ~/.kde/share/config/plasma-appletrc to check the current setting, the panel geometry will probably be the second entry, then change the panel size to something else, then kquitapp plasma to quit out of plasma and check the grep command again and note that the vertical geometry index will change. Then use /usr/bin/plasma to restart plasma and it will default back to the normal size. It's a bug so if you care to report it to http://bugs.kde.org/query.cgi then someone will hopefully fix it sooner than later.

Offline

#53 2008-03-23 16:37:49

miggols99
Member
Registered: 2007-06-10
Posts: 424

Re: Daily KDE4 Subversion Packages

The Oxygen icon SVGs have disappeared! What happened to them? I was using them for my website..

Offline

#54 2008-03-23 17:20:54

Maki
Member
From: Skopje, Macedonia
Registered: 2007-10-16
Posts: 345
Website

Re: Daily KDE4 Subversion Packages

When i try to run gwenview i get

[maki@archer ~]$ gwenview
gwenview: error while loading shared libraries: libexiv2.so.2: cannot open shared object file: No such file or directory

i have libexiv installed

extra/libkexiv2 0.1.6-1 [installed]
    an exiv2 library wrapper

If it ain't broke, broke it then fix it.

Offline

#55 2008-03-23 18:16:32

Belitsky.A
Member
From: Russia, Zelenograd
Registered: 2008-01-10
Posts: 57

Re: Daily KDE4 Subversion Packages

Maki wrote:

When i try to run gwenview i get

[maki@archer ~]$ gwenview
gwenview: error while loading shared libraries: libexiv2.so.2: cannot open shared object file: No such file or directory

i have libexiv installed

extra/libkexiv2 0.1.6-1 [installed]
    an exiv2 library wrapper

Same problem here. BTW, current exiv2 package provides libexiv2.so.0, not libexiv2.so.2

Last edited by Belitsky.A (2008-03-23 18:18:20)

Offline

#56 2008-03-23 18:52:45

ph0tios
Member
Registered: 2008-02-23
Posts: 126

Re: Daily KDE4 Subversion Packages

Just wanted to mention that Konqueror is completely dead for me now. Initially it worked, and I was using webkit. I switched to khtml, and opened a new tab. When I opened the new tab, konqueror crashed, and I was unable to restart it...even after restarting kde.

Offline

#57 2008-03-23 22:13:56

laleshii
Member
Registered: 2008-03-22
Posts: 7

Re: Daily KDE4 Subversion Packages

Maki wrote:

When i try to run gwenview i get

[maki@archer ~]$ gwenview
gwenview: error while loading shared libraries: libexiv2.so.2: cannot open shared object file: No such file or directory

i have libexiv installed

extra/libkexiv2 0.1.6-1 [installed]
    an exiv2 library wrapper
ln -sf /usr/lib/libexiv2.so /usr/lib/libexiv2.so.2

Offline

#58 2008-03-24 01:48:17

markc
Member
From: Gold Coast, Australia
Registered: 2007-05-15
Posts: 496
Website

Re: Daily KDE4 Subversion Packages

miggols99 wrote:

The Oxygen icon SVGs have disappeared! What happened to them? I was using them for my website..

They are now in kdebase-doc along with most other wallpapers except the default EOS. This reduces kdebase from around 96Mb to 31Mb which is quite a significant saving for something so large that could be downloaded every day. I'm setting up a forum that will have a frontpage with the "latest news" and Git commits but it'll take me another month at the rate I'm going.

Maki wrote:

gwenview: error while loading shared libraries: libexiv2.so.2

And to Belitsky.A, hopefully laleshiis' suggestion works anyway. The actual exiv2 used in the build is version 0.16 in the [dev] repo section rather than the AL extra/exiv2 v0.15. It was a few days ago now but something wouldn't build properly with the standard extra/exiv2 so I hunted around and found the later version and the build proceeded, so I quickly made a package for it in [dev] thinking it would only be needed when building kde4. It's the kind of thing that should be in kdesupport so I will try to find the right mailing-list to suggest that. For now, add a [dev] section with Server = http://pkg.eth-os.org/dev/i686 (or x86_64).

ph0tios wrote:

Just wanted to mention that Konqueror is completely dead for me now.

Perhaps start konqueror from the konsole and it should be obvious why it's crapping out. Try installing the above mentioned exiv2 package then reinstalling kdebase. Obviously good old firefox2 is a lifesaver at times. Speaking of firefox, I'll start adding firefox3 in the [gui] section tomorrow... but some important extensions have not been ported yet so firefox2 is still almost mandatory.

Latest News: The 20080324 packages are still being uploaded as I write this so give them a couple of hours after this post. Also, I just noticed gcc 4.3.0 arrived this morning so 20080325 will be built with that compiler version for the first time. Put it this way, I'll be impressed if all packages build okay.

Last edited by markc (2008-03-24 01:56:44)

Offline

#59 2008-03-24 08:53:58

loon
Member
From: Frensh
Registered: 2008-03-23
Posts: 2

Re: Daily KDE4 Subversion Packages

error:
mime-types: /etc/mime.types
kdelibs: /etc/xdg/menus/applications.menu

i rename this file in /etc/mime.types2 and   /etc/xdg/menus/applications.menu2
and after pacman -S kde-all-svn is OK

Offline

#60 2008-03-24 11:45:54

Maki
Member
From: Skopje, Macedonia
Registered: 2007-10-16
Posts: 345
Website

Re: Daily KDE4 Subversion Packages

Every time i upgrade i get this error.

/usr/include/phonon/abstractaudiooutput.h exists in both 'kdelibs-dev' and 'qt-copy-dev'                                      
/usr/include/phonon/abstractmediastream.h exists in both 'kdelibs-dev' and 'qt-copy-dev'                                      
/usr/include/phonon/abstractvideooutput.h exists in both 'kdelibs-dev' and 'qt-copy-dev'                                      
/usr/include/phonon/addoninterface.h exists in both 'kdelibs-dev' and 'qt-copy-dev'                                           
/usr/include/phonon/audiooutput.h exists in both 'kdelibs-dev' and 'qt-copy-dev'                                              
/usr/include/phonon/audiooutputinterface.h exists in both 'kdelibs-dev' and 'qt-copy-dev'                                     
/usr/include/phonon/backendcapabilities.h exists in both 'kdelibs-dev' and 'qt-copy-dev'                                      
/usr/include/phonon/backendinterface.h exists in both 'kdelibs-dev' and 'qt-copy-dev'                                         
/usr/include/phonon/effect.h exists in both 'kdelibs-dev' and 'qt-copy-dev'                                                   
/usr/include/phonon/effectinterface.h exists in both 'kdelibs-dev' and 'qt-copy-dev'                                          
/usr/include/phonon/effectparameter.h exists in both 'kdelibs-dev' and 'qt-copy-dev'                                          
/usr/include/phonon/effectwidget.h exists in both 'kdelibs-dev' and 'qt-copy-dev'                                             
/usr/include/phonon/mediacontroller.h exists in both 'kdelibs-dev' and 'qt-copy-dev'                                          
/usr/include/phonon/medianode.h exists in both 'kdelibs-dev' and 'qt-copy-dev'                                                
/usr/include/phonon/mediaobject.h exists in both 'kdelibs-dev' and 'qt-copy-dev'                                              
/usr/include/phonon/mediaobjectinterface.h exists in both 'kdelibs-dev' and 'qt-copy-dev'                                     
/usr/include/phonon/mediasource.h exists in both 'kdelibs-dev' and 'qt-copy-dev'                                              
/usr/include/phonon/objectdescription.h exists in both 'kdelibs-dev' and 'qt-copy-dev'                                        
/usr/include/phonon/objectdescriptionmodel.h exists in both 'kdelibs-dev' and 'qt-copy-dev'                                   
/usr/include/phonon/path.h exists in both 'kdelibs-dev' and 'qt-copy-dev'                                                     
/usr/include/phonon/phonon_export.h exists in both 'kdelibs-dev' and 'qt-copy-dev'
/usr/include/phonon/phonondefs.h exists in both 'kdelibs-dev' and 'qt-copy-dev'
/usr/include/phonon/phononnamespace.h exists in both 'kdelibs-dev' and 'qt-copy-dev'
/usr/include/phonon/seekslider.h exists in both 'kdelibs-dev' and 'qt-copy-dev'
/usr/include/phonon/streaminterface.h exists in both 'kdelibs-dev' and 'qt-copy-dev'
/usr/include/phonon/videoplayer.h exists in both 'kdelibs-dev' and 'qt-copy-dev'
/usr/include/phonon/videowidget.h exists in both 'kdelibs-dev' and 'qt-copy-dev'
/usr/include/phonon/videowidgetinterface.h exists in both 'kdelibs-dev' and 'qt-copy-dev'
/usr/include/phonon/volumefadereffect.h exists in both 'kdelibs-dev' and 'qt-copy-dev'
/usr/include/phonon/volumefaderinterface.h exists in both 'kdelibs-dev' and 'qt-copy-dev'
/usr/include/phonon/volumeslider.h exists in both 'kdelibs-dev' and 'qt-copy-dev'

i solve it with -Suf, but could you fix it ?


If it ain't broke, broke it then fix it.

Offline

#61 2008-03-24 12:15:44

markc
Member
From: Gold Coast, Australia
Registered: 2007-05-15
Posts: 496
Website

Re: Daily KDE4 Subversion Packages

srimalik wrote:

KDE4 is not remembering the size of my taskbar(I like it "tiny"), Every time I log in the default size is small, I have to manually cahnge it every time I login.
Any ideas?

I think you submitted bug #159773 (thanks) so you probably noted this. The 20080325 build will contain this revision 788869 change. The current 20080324 is at revision 788238.

------- Additional Comment #4 From Chani 2008-03-22 22:56 -------  
whoops, forgot there was a report for this. fixed in revision 788869 

 ------- Additional Comment #5 From Chani 2008-03-24 06:48 -------  
*** Bug 159773 has been marked as a duplicate of this bug. ***
loon wrote:

error:
mime-types: /etc/mime.types
kdelibs: /etc/xdg/menus/applications.menu

I think once you get past this the first time it won't happen again. pacman -Sf mime-types kdelibs and then proceed with the kde-svn install would have done the same thing. Thanks for pointing it out and I'll see if I can catch this the next time I do a fresh install.

Maki wrote:

(lot's of phonon header file conflicts) i solve it with -Suf, but could you fix it ?

This one is a bit tricky as the header files, and libphonon.so, are available in both packages and the KDE devs have not yet split it up properly. Kdelibs will be the eventual home for Phonon so at the moment I simply remove libphonon.so from qt-copy before the package build is completed. I got your error once a few weeks ago but not every time I do an update so I'm not sure why you get this after the first time. Perhaps try a pacman -Rd kdelibs-dev qt-copy-dev && pacman -S kdelibs-dev qt-copy-dev and see if that sorts it out. It is vaguely possible it may be a side affect of the recent pacman upgrades too. All I do know is that I am not seeing this problem on a fresh AL + KDE svn install from a week ago but if you are still getting it over the next few days then I'll look into specifically removing the header files from the qt-copy build as well (as the libphonon.so lib).

Offline

#62 2008-03-24 12:23:58

Maki
Member
From: Skopje, Macedonia
Registered: 2007-10-16
Posts: 345
Website

Re: Daily KDE4 Subversion Packages

I reinstalled the pakages but again i get the same error message. But i think its no problem cause -Syuf will solve it ...


If it ain't broke, broke it then fix it.

Offline

#63 2008-03-25 03:26:48

ph0tios
Member
Registered: 2008-02-23
Posts: 126

Re: Daily KDE4 Subversion Packages

Well, konqueror still crashes when I open a new tab, but now it at least will open back up. I'm sending this from firefox(in xfce), because for some reason I can't type "e"...haha  Also, strangely enough, flash seems to work with konqueror...at least for me using the i686. I was watching youtube videos in it. This update seemed to work better than yesterdays.

Offline

#64 2008-03-25 04:05:45

markc
Member
From: Gold Coast, Australia
Registered: 2007-05-15
Posts: 496
Website

Re: Daily KDE4 Subversion Packages

ph0tios wrote:

Well, konqueror still crashes when I open a new tab, but now it at least will open back up. I'm sending this from firefox(in xfce), because for some reason I can't type "e"...haha

Ah.. the missing "e".. I thought I was going crazy a few days ago when I also had this, and I think some folks on IRC also thought I was crazy for asking WTF! All I can suggest is that it has been nearly a week since my "e" went missing and what eventually solved it, and a crashing plasma, was to do a fresh install of AL into another partition and swap over to using that new one. I'm not sure how many folks are using these svn packages, maybe about 10 I guess from bandwidth usage, so one would think the missing "e" and crashing plasma would have affected more folks... but you are the only other person I know of that has this particular fault. For me, kmail won't reliably show attachments, klauncher dies after a while so konqueror can't surf to a new site and since I removed a sus feed from akregator it hasn't crashed on me for quite a few days. Konquerors form widgets are sometimes messed up but I can use it to post here. Definitely getting better these past few days.

Also, strangely enough, flash seems to work with konqueror...at least for me using the i686. I was watching youtube videos in it. This update seemed to work better than yesterdays.

Good one. What flash package?

FWIW I thought the panel resize save on restart problem would have been fixed today but mine still won't recognise a changed size on restart using 20080325.

Offline

#65 2008-03-25 05:05:19

ph0tios
Member
Registered: 2008-02-23
Posts: 126

Re: Daily KDE4 Subversion Packages

I have the flashplugin binary...nothing special. The plugins are enabled in konqueror.

From the directory: /usr/lib/mozilla/plugins/libflashplayer.so


I'll see if I can get to the bottom of this "e" mess.

Edit: here is something that might help with the flash. I noticed if you are using webkit...it seems to run as default if you have it installed...if you go to a site with flash using webkit, and then try to switch to khtml it crashes. However, if I go to say google first, switch from webkit to khtml, and then go to say youtube flash works(sometimes when you first go to a video it gives an error, but if you refresh is works fine).

Also, I managed to work around konq crashing when I open a new tab. I disabled "Open new tabs in the background"  in settings>configure konqueror>general.

Another Edit: I don't know what happened, but now the "e" key is mysteriously working. I'm posting from konqueror now. big_smile haha

Last edited by ph0tios (2008-03-25 05:39:23)

Offline

#66 2008-03-25 15:04:35

srimalik
Member
Registered: 2007-09-16
Posts: 65

Re: Daily KDE4 Subversion Packages

I think you submitted bug #159773 (thanks) so you probably noted this. The 20080325 build will contain this revision 788869 change. The current 20080324 is at revision 788238.

Yes and this is marked at duplicate of
http://bugs.kde.org/show_bug.cgi?id=159394

I updated my system yesterday...will do one more update tomorrow to have the fix.

Thanks
Sri

Offline

#67 2008-03-25 21:58:14

Rasi
Member
From: Germany
Registered: 2007-08-14
Posts: 1,852
Website

Re: Daily KDE4 Subversion Packages

markc wrote:
ph0tios wrote:

Well, konqueror still crashes when I open a new tab, but now it at least will open back up. I'm sending this from firefox(in xfce), because for some reason I can't type "e"...haha

Ah.. the missing "e".. I thought I was going crazy a few days ago when I also had this, and I think some folks on IRC also thought I was crazy for asking WTF! All I can suggest is that it has been nearly a week since my "e" went missing and what eventually solved it, and a crashing plasma, was to do a fresh install of AL into another partition and swap over to using that new one. I'm not sure how many folks are using these svn packages, maybe about 10 I guess from bandwidth usage, so one would think the missing "e" and crashing plasma would have affected more folks... but you are the only other person I know of that has this particular fault. For me, kmail won't reliably show attachments, klauncher dies after a while so konqueror can't surf to a new site and since I removed a sus feed from akregator it hasn't crashed on me for quite a few days. Konquerors form widgets are sometimes messed up but I can use it to post here. Definitely getting better these past few days.

The corrupt 'e' thing can be fixed by deleting the file "kglobalshortcutsrc"... dont know where it can be found exactly, but i am sure you will sort it out smile


He hoped and prayed that there wasn't an afterlife. Then he realized there was a contradiction involved here and merely hoped that there wasn't an afterlife.

Douglas Adams

Offline

#68 2008-03-26 05:59:22

Belitsky.A
Member
From: Russia, Zelenograd
Registered: 2008-01-10
Posts: 57

Re: Daily KDE4 Subversion Packages

Trying to make upgrade today:

error: failed to commit transaction (conflicting files)
kdepimlibs: /usr/share/dbus-1/interfaces/org.kde.Akonadi.AgentManager.xml exists in filesystem
kdepimlibs: /usr/share/dbus-1/interfaces/org.kde.Akonadi.NotificationManager.xml exists in filesystem
kdepimlibs: /usr/share/dbus-1/interfaces/org.kde.Akonadi.Tracer.xml exists in filesystem
Errors occurred, no packages were upgraded.

Offline

#69 2008-03-26 06:41:58

markc
Member
From: Gold Coast, Australia
Registered: 2007-05-15
Posts: 496
Website

Re: Daily KDE4 Subversion Packages

@Rasi, thanks, looks like it is ~/.kde/share/config/kglobalshortcutsrc. Interesting config file as I always (in KDE3) use Ctrl-Left|Right to switch desktops but in KDE4 it won't accept that as it's used by applications to shift a cursor to the next or previous word, which I never use, so I set the Keyboard & Mouse -> Keyboard Shortcuts -> Switch to Next Desktop to Ctrl+Shift+Right and will diidle with that file to see if I can drop the Shift and get back to what I'm used to. Switching tabs in Konsole is Shift+Left|Right so Ctrl+Left|Right to switch desktops is very convenient... one of the main things I've missed since using KDE4 fulltime.  It worked when I restarted my desktop, I can now use Ctrl+Left|Right to switch desktops by manually editing this file! Yeah, so thanks for pointing out that global shortcuts config file.

@Belitsky.A, Maki's trick of using -Syuf might have to be used every now and then as the KDE developers move some parts of the Subversion repo around. These files were in kdepim and obviously just got moved to kdepimlibs between 20080325 and 20080326.

#pacman -Qo /usr/share/dbus-1/interfaces/org.kde.Akonadi.NotificationManager.xml
/usr/share/dbus-1/interfaces/org.kde.Akonadi.NotificationManager.xml is owned by kdepim 4.1.0-20080325

And as far as Webkit being the default konqueror kpart, you can go to Settings -> Configure Konqueror -> File Associations -> text -> html -> Embedding and move KHTML back up to the top if you want it to be the default after installing webkitkde.

Ah yes! And the panel size gets saved now. But, I notice I can't put application icons from Kickoff onto the panel, to the desktop but not the panel.

Last edited by markc (2008-03-26 07:13:23)

Offline

#70 2008-03-26 17:46:06

srimalik
Member
Registered: 2007-09-16
Posts: 65

Re: Daily KDE4 Subversion Packages

srimalik wrote:

I think you submitted bug #159773 (thanks) so you probably noted this. The 20080325 build will contain this revision 788869 change. The current 20080324 is at revision 788238.

Yes and this is marked at duplicate of
http://bugs.kde.org/show_bug.cgi?id=159394

I updated my system yesterday...will do one more update tomorrow to have the fix.

Thanks
Sri

This is fixed in the latest update(26March2008)

-Sri

Offline

#71 2008-03-26 21:38:51

Reasons
Member
From: Washington
Registered: 2007-11-04
Posts: 572

Re: Daily KDE4 Subversion Packages

Belitsky.A wrote:

Trying to make upgrade today:

error: failed to commit transaction (conflicting files)
kdepimlibs: /usr/share/dbus-1/interfaces/org.kde.Akonadi.AgentManager.xml exists in filesystem
kdepimlibs: /usr/share/dbus-1/interfaces/org.kde.Akonadi.NotificationManager.xml exists in filesystem
kdepimlibs: /usr/share/dbus-1/interfaces/org.kde.Akonadi.Tracer.xml exists in filesystem
Errors occurred, no packages were upgraded.

I'm having the same problem and I've done a pacman -Syuf and pacman -Sf qt-copy kdelibs.

Offline

#72 2008-03-27 00:53:48

miggols99
Member
Registered: 2007-06-10
Posts: 424

Re: Daily KDE4 Subversion Packages

Could you add the GTK-Qt engine? It now works with KDE4 smile

http://gtk-qt.ecs.soton.ac.uk/index.php

I'm sick of ugly Gtk apps.

Offline

#73 2008-03-27 02:14:46

Reasons
Member
From: Washington
Registered: 2007-11-04
Posts: 572

Re: Daily KDE4 Subversion Packages

Reasons wrote:
Belitsky.A wrote:

Trying to make upgrade today:

error: failed to commit transaction (conflicting files)
kdepimlibs: /usr/share/dbus-1/interfaces/org.kde.Akonadi.AgentManager.xml exists in filesystem
kdepimlibs: /usr/share/dbus-1/interfaces/org.kde.Akonadi.NotificationManager.xml exists in filesystem
kdepimlibs: /usr/share/dbus-1/interfaces/org.kde.Akonadi.Tracer.xml exists in filesystem
Errors occurred, no packages were upgraded.

I'm having the same problem and I've done a pacman -Syuf and pacman -Sf qt-copy kdelibs.

I got it to work by doing a pacman -Syuf qt-copy kdelibs kde-svn. I'm not sure what happened next, but it worked for a while and then went down the toilet. I am reinstalling now, but going with gnome. However, I did love the theme so if anyone running it could do me a quick favor. Seven screenshots is all it would take.

http://bbs.archlinux.org/viewtopic.php?id=46067

Offline

#74 2008-03-27 12:49:32

Belitsky.A
Member
From: Russia, Zelenograd
Registered: 2008-01-10
Posts: 57

Re: Daily KDE4 Subversion Packages

Don't know where i should post this bug. If i start xmoto from "Application launcher menu" it works with russian interface. If I start it from konsole or with "run command" (alt+f2) it works with english interface. Running command "locale" from console gives this:

LANG=ru_RU.UTF-8
LANGUAGE=en_US
LC_CTYPE="ru_RU.UTF-8"
LC_NUMERIC="ru_RU.UTF-8"
LC_TIME="ru_RU.UTF-8"
LC_COLLATE=C
LC_MONETARY="ru_RU.UTF-8"
LC_MESSAGES="ru_RU.UTF-8"
LC_PAPER="ru_RU.UTF-8"
LC_NAME="ru_RU.UTF-8"
LC_ADDRESS="ru_RU.UTF-8"
LC_TELEPHONE="ru_RU.UTF-8"
LC_MEASUREMENT="ru_RU.UTF-8"
LC_IDENTIFICATION="ru_RU.UTF-8"
LC_ALL=

Part of /etc/rc.conf :

LOCALE="ru_RU.UTF-8"
HARDWARECLOCK="UTC"
TIMEZONE="Europe/Moscow"
KEYMAP="ru-utf"
CONSOLEFONT=
CONSOLEMAP="cp866_to_uni.trans"
USECOLOR="yes"

Last edited by Belitsky.A (2008-03-27 19:53:24)

Offline

#75 2008-03-29 16:43:36

SoftVision
Member
Registered: 2007-11-12
Posts: 64

Re: Daily KDE4 Subversion Packages

Hi. I'm using KDE 4.0.3 right now via KDEmod. I'd like to know how you'll find the KDE 4.1 (svn version) at the moment? How stable is it? I'm happy with 4.0.2 so far.

Offline

Board footer

Powered by FluxBB