You are not logged in.

#26 2004-06-09 16:56:24

colnago
Member
From: Victoria, BC
Registered: 2004-03-25
Posts: 438

Re: wacky font spacing

I was able to replicate this problem by screwing around in /usr/X11R6/lib/X11/fonts/.  Then I just deleted the  fonts.cache-1 file (and also the ones in the subdirs), and regenerated the cache file and everything was okay again.

cd /usr/X11R6/lib/X11/fonts/; rm -rf fonts.cache-1; rm -rf */fonts.cache-1;fc-cache -v

Offline

#27 2004-06-09 18:02:52

Zym0tiC
Member
Registered: 2004-01-17
Posts: 40
Website

Re: wacky font spacing

colnago wrote:

I was able to replicate this problem by screwing around in /usr/X11R6/lib/X11/fonts/.  Then I just deleted the  fonts.cache-1 file (and also the ones in the subdirs), and regenerated the cache file and everything was okay again.

cd /usr/X11R6/lib/X11/fonts/; rm -rf fonts.cache-1; rm -rf */fonts.cache-1;fc-cache -v

that didn't worked for me....neither a upgrade to kde3.2.3

Offline

#28 2004-06-09 20:33:19

super_duper_linux_guy
Member
Registered: 2004-05-28
Posts: 42

Re: wacky font spacing

Unfortunattely it didn't work for me either.

The thing is I don't have that much knowledge about Linux to actually be able to solve it with experimenting. I think I'm going to stop screwing around with my system until somebody actually knows what the hell is wrong.

Offline

#29 2004-06-10 11:45:36

inklingx
Member
From: Belgium
Registered: 2004-05-30
Posts: 18

Re: wacky font spacing

I don't know if it is related, but when i use mozilla to open http://www.macosx.nl i notice an non-aliased font.
After some investigation i found this site uses the helvetica font family (i believe this is also the font which causes the KDE problems).

Normaly this font family should be mapped to an anti-aliased font in /etc/fonts/font.conf but it didn't.
I also noticed an helvetica font in /usr/X11R6/lib/X11/fonts/100dpi/ and /usr/X11R6/lib/X11/fonts/75dpi/ .
After editing /etc/fonts/fonts.conf and replacing the section

<!-- Font directory list configured on Thu Oct 16 00:26:44 PDT 2003 -->

        <dir>/usr/share/fonts</dir>
        <dir>/usr/X11R6/lib/X11/fonts</dir>
        <dir>~/.fonts</dir>

<!--

with

<!-- Font directory list configured on Thu Oct 16 00:26:44 PDT 2003 -->

        <dir>/usr/share/fonts</dir>
        <dir>/usr/X11R6/lib/X11/fonts/TTF</dir>
        <dir>/usr/X11R6/lib/X11/fonts/ttf-ms-fonts</dir>
        <dir>~/.fonts</dir>

<!--

and running fc-cache -fv as root, the helvetica problem was solved in mozilla.

What i essentialy did was omitting the root /usr/X11R6/lib/X11/fonts/ directory and only adding the truetype font directories in the fonts.conf file.

Offline

#30 2004-06-10 19:21:09

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: wacky font spacing

you guys rock! I am going to give this a shot, because I was experiencing many of the same issues. Sites that used helvetica just sucked.
maybe this will fix it!


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#31 2004-06-10 19:26:53

dpb
Member
From: Cyperspace?
Registered: 2004-04-11
Posts: 231

Re: wacky font spacing

Thanks inklingx!

That fixed the problem with Xine.

Offline

#32 2004-06-11 07:29:46

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: wacky font spacing

still no luck. I am getting crappy webpage font renderings...with both konqueror and mozilla-firefox.

What resolution are you guys running at. I am running 1024x768. Fonts look fine in Fedora 1, Suse 9.1, and Mandrake 10...
I have been fussing with this for a while now...
:x

here are some images...
here is a forum page that uses helvetica for the fonts...notice the K's look wonky..

here] is a portion of slashdot..notice the numbers look all wonky...

*throws up hands*...


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#33 2004-06-11 07:37:36

dpb
Member
From: Cyperspace?
Registered: 2004-04-11
Posts: 231

Re: wacky font spacing

cactus: that doesn't seem like it's related to the problems on this thread.

This is about strange spaces between characters. You can see a screenshot about it here.

Have you tried installing the extra fonts in arch?

Offline

#34 2004-06-11 08:05:25

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: wacky font spacing

dpb wrote:

cactus: that doesn't seem like it's related to the problems on this thread.

oops..sorry

Have you tried installing the extra fonts in arch?

yes


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#35 2004-06-11 12:38:12

murpheus40
Member
Registered: 2004-03-04
Posts: 77

Re: wacky font spacing

Hello,

Did you find a solution about the fonts? I mean the K's wonky?
I have the same problem here....

Thanks


cactus wrote:

here are some images...
here is a forum page that uses helvetica for the fonts...notice the K's look wonky..

here] is a portion of slashdot..notice the numbers look all wonky...

*throws up hands*...

Offline

#36 2004-06-11 12:43:21

dpb
Member
From: Cyperspace?
Registered: 2004-04-11
Posts: 231

Re: wacky font spacing

Yes, there's a temp solution to it atleast. Look at page 2 at this same thread.  smile

Offline

#37 2004-06-11 13:03:08

inklingx
Member
From: Belgium
Registered: 2004-05-30
Posts: 18

Re: wacky font spacing

I see there is a new fontconfig package which inludes only the TTF and Type1 font subdirectories...
Beware: if you install this new package the helvetica problem wil be solved, but you'll loose a lot of fonts... (even the ones in the ttf-ms-fonts directory)
I've looked at the ttf-ms-fonts package, but i'm not sure if it adds the necessary <dir>...<dir> line to the fonts.conf?

btw: my personal fonts.conf includes:

        <dir>/usr/share/fonts</dir>
        <dir>/usr/X11R6/lib/X11/fonts/TTF</dir>
        <dir>/usr/X11R6/lib/X11/fonts/Type1</dir>
        <dir>/usr/X11R6/lib/X11/fonts/artwiz-fonts</dir>
        <dir>/usr/X11R6/lib/X11/fonts/cyrillic</dir>
        <dir>/usr/X11R6/lib/X11/fonts/misc</dir>
        <dir>/usr/X11R6/lib/X11/fonts/ttf-ms-fonts</dir>
        <dir>/.fonts</dir>

Offline

#38 2004-06-11 14:19:13

murpheus40
Member
Registered: 2004-03-04
Posts: 77

Re: wacky font spacing

I forgot to say I'm using xfce4 and the issue seems to be for kde?!  Is it going to fix the problem (the only problem I have is some char. like "k" and "x" are wonky)?

Thanks again!



dpb wrote:

Yes, there's a temp solution to it atleast. Look at page 2 at this same thread.  smile

Offline

#39 2004-06-11 14:41:32

inklingx
Member
From: Belgium
Registered: 2004-05-30
Posts: 18

Re: wacky font spacing

About the wonky characters: try to rebuild the freetype2 package without the bytecode patch.  For some reason the fonts are looking better on my TFT without the bytecode patch...

Offline

#40 2004-06-11 14:48:17

apeiro
Daddy
From: Victoria, BC, Canada
Registered: 2002-08-12
Posts: 771
Website

Re: wacky font spacing

cactus wrote:

here are some images...
here is a forum page that uses helvetica for the fonts...notice the K's look wonky..

here] is a portion of slashdot..notice the numbers look all wonky...

*throws up hands*...

Try disabling anti-aliasing for fonts under a certain size.  I use this in my /etc/fonts/local.conf:

<fontconfig>
    <match target="pattern">
        <test qual="any" name="size" compare="less_eq"><int>12</int></test>
        <edit name="antialias" mode="assign"><bool>false</bool></edit>
    </match>
</fontconfig>

Then run fc-cache -fv

This chunk will be in local.conf for the next fontconfig package, but disabled.  Just uncomment it if you don't want small fuzzy fonts.

Offline

#41 2004-06-11 19:22:09

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: wacky font spacing

apeiro wrote:

Try disabling anti-aliasing for fonts under a certain size.  I use this in my /etc/fonts/local.conf:

<fontconfig>
    <match target="pattern">
        <test qual="any" name="size" compare="less_eq"><int>12</int></test>
        <edit name="antialias" mode="assign"><bool>false</bool></edit>
    </match>
</fontconfig>

Then run fc-cache -fv

This chunk will be in local.conf for the next fontconfig package, but disabled.  Just uncomment it if you don't want small fuzzy fonts.

I did a re-install of arch, and updated to the new packages...
The changes to the font.conf and local.conf were in there...I uncommented the disable anti-aliasing section, and the enable sub-pixel rendering sections in local.conf...and it fixed the problem! *does happy dance*
thanks apeiro!

ps. what does sub-pixel rendering do? do i really need that?


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#42 2004-06-11 19:49:33

apeiro
Daddy
From: Victoria, BC, Canada
Registered: 2002-08-12
Posts: 771
Website

Re: wacky font spacing

cactus wrote:

ps. what does sub-pixel rendering do? do i really need that?

To the best of my knowledge, sub-pixel rendering doesn't do a whole lot on CRTs.  If you have an LCD monitor, it can improve font appearances.

Offline

#43 2004-06-16 12:19:48

murpheus40
Member
Registered: 2004-03-04
Posts: 77

Re: wacky font spacing

Hello,

I also did a fresh install with the lastest  fontconfig (fontconfig 2.2.1-2) installed.  Then I ran xfce4. I'm not lucky like you because my fonts are still wonky. Maybe I forgot something? It's sad because if I use Slackware with dropline, the fonts are just fine.

Thank you in advance if you have some tips!


cactus wrote:
apeiro wrote:

Try disabling anti-aliasing for fonts under a certain size.  I use this in my /etc/fonts/local.conf:

<fontconfig>
    <match target="pattern">
        <test qual="any" name="size" compare="less_eq"><int>12</int></test>
        <edit name="antialias" mode="assign"><bool>false</bool></edit>
    </match>
</fontconfig>

Then run fc-cache -fv

This chunk will be in local.conf for the next fontconfig package, but disabled.  Just uncomment it if you don't want small fuzzy fonts.

I did a re-install of arch, and updated to the new packages...
The changes to the font.conf and local.conf were in there...I uncommented the disable anti-aliasing section, and the enable sub-pixel rendering sections in local.conf...and it fixed the problem! *does happy dance*
thanks apeiro!

ps. what does sub-pixel rendering do? do i really need that?

Offline

#44 2004-06-16 17:47:24

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: wacky font spacing

murpheus40 wrote:

Hello,

I also did a fresh install with the lastest  fontconfig (fontconfig 2.2.1-2) installed.  Then I ran xfce4. I'm not lucky like you because my fonts are still wonky. Maybe I forgot something? It's sad because if I use Slackware with dropline, the fonts are just fine.

Thank you in advance if you have some tips!

The main problem I was having was with helvetica fonts. I used the info that apeiro suggested in my /etc/fonts/local.conf, rebuilt the font cache, and restarted X. I also had to properly set my dpi. Once I had done that, all fonts below a certain threshold were no longer anti-aliased. It looked fine to me.
Then, to just try and see what kind of difference it would make to have only the helvetica font non-anti-aliased, i changed the /etc/fonts/local.conf to select only the Hevletica fonts, and force those to be non-anti-aliased, but allow anti-aliasing of the other fonts.

I decided to just go back to everything under a certain threshold being non-anti-aliased, because some other fonts appeared a bit blurry at small sizes...

I am not at my arch box right now, so I can't post the modified version that only non-anti-aliased the helvetica fonts...but I can get to it later if anyone desires...


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#45 2004-06-16 19:14:58

murpheus40
Member
Registered: 2004-03-04
Posts: 77

Re: wacky font spacing

I'll appreciate if you can post your  /etc/fonts/local.conf file. But I still don't understand why my fonts in my slackware box are fine? 

Thanks!

cactus wrote:
murpheus40 wrote:

Hello,

I also did a fresh install with the lastest  fontconfig (fontconfig 2.2.1-2) installed.  Then I ran xfce4. I'm not lucky like you because my fonts are still wonky. Maybe I forgot something? It's sad because if I use Slackware with dropline, the fonts are just fine.

Thank you in advance if you have some tips!

The main problem I was having was with helvetica fonts. I used the info that apeiro suggested in my /etc/fonts/local.conf, rebuilt the font cache, and restarted X. I also had to properly set my dpi. Once I had done that, all fonts below a certain threshold were no longer anti-aliased. It looked fine to me.
Then, to just try and see what kind of difference it would make to have only the helvetica font non-anti-aliased, i changed the /etc/fonts/local.conf to select only the Hevletica fonts, and force those to be non-anti-aliased, but allow anti-aliasing of the other fonts.

I decided to just go back to everything under a certain threshold being non-anti-aliased, because some other fonts appeared a bit blurry at small sizes...

I am not at my arch box right now, so I can't post the modified version that only non-anti-aliased the helvetica fonts...but I can get to it later if anyone desires...

roll  roll  roll  roll

Offline

#46 2004-06-16 19:40:59

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: wacky font spacing

i also would be interested in your local.conf, if you don't mind (with the fun with Helvetica)

if someone is interested in a nicely configured local.conf with bitstream-fonts:
http://daperi.home.solnet.ch/linux/local.conf
-> note that i use 132dpi as screen resolution (UXGA@15"), so you need to addapt this to your screen resolution (what is in most cases 75dpi or something around this)

edit: for any ideas how to make it better, feel free to contact me - always open for ideas


The impossible missions are the only ones which succeed.

Offline

#47 2004-06-17 03:28:27

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: wacky font spacing

ok..lazy ass finally got to his machine and turned it on..  tongue

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file for local customizations -->
<fontconfig>

<!-- Disable anti-aliasing for fonts that are size <=12 -->
        <match target="pattern">
                <test qual="any" name="size" compare="less_eq">
                        <int>12</int>
                </test>
                <edit name="antialias" mode="assign"><bool>false</bool></edit>
        </match>


<!-- just disables anti-aliasing for helvetica -->
<!--
<match target="pattern" name="family">
        <test qual="any" name="family">
                <string>Helvetica</string>
 </test>
        <edit name="antialias" mode="assign"><bool>false</bool></edit>
</match>
-->

<!-- Enable sub-pixel rendering -->
<!--
        <match target="font">
                <test qual="all" name="rgba">
                        <const>unknown</const>
                </test>
                <edit name="rgba" mode="assign"><const>rgb</const></edit>
        </match>
-->

</fontconfig>

As you can see, I left the info in there, just commented it out. I was trying different stuff to see what I liked most.

further, my .xfce/xinitrc file contains the following section

xrdb -nocpp -merge - << EOF
Xft.dpi: 72
Xft.hinting: 1
Xft.hintstyle: hintmedium
EOF

I had to change the dpi from the 96 specified initially in the file to 72 (my fonts were wicked huge before making that change).

I run at 1024x768 resolution..

I also noticed a few differences the fonts.conf file on my arch linux box, and my fedora/redhat ws3 boxen...
I posted them here. I did not highlight the differences...exercise left to the reader..

I will post more if I discover something else that adds to beutification..


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#48 2004-06-17 12:05:42

murpheus40
Member
Registered: 2004-03-04
Posts: 77

Re: wacky font spacing

Thanks cactus, I'll try it tonight to see the difference! Is it possible for you to post a screenshot what your fonts look like before and after the modification in your local.conf? 

cactus wrote:

ok..lazy ass finally got to his machine and turned it on..  tongue

Offline

#49 2004-06-17 18:08:41

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: wacky font spacing

murpheus40 wrote:

Thanks cactus, I'll try it tonight to see the difference! Is it possible for you to post a screenshot what your fonts look like before and after the modification in your local.conf?

well, I can post what they look like now...but each time I login I try something new. The latest attempt involved straight copying the fedora /etc/fonts/fonts.conf and local.conf from a fedora installation to arch, then rebuilding the font cache. Gave me some interesting results. I had to manually change the font dirs section, but no biggie.
They look a little silly though, all short and fat. It did fix a problem I was having with some of the fonts only displaying the top half of the characters (Utopia font was a bad one).

I did notice on a redhat mailing list somewhere (old one, might have the link somewhere) that redhat had patches to freetype rendering that never made it upstream. That might explain why redhat (and fedora) renders fonts slightly different from other distros...
It may be useful to anlayze the fonts.conf and local.conf for another distro, like slack or mandrake. Maybe this weekend I will be productive..
wink


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#50 2004-06-18 01:49:06

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: wacky font spacing

I updated my /etc/fonts/local.conf like this:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file for local customizations -->
<fontconfig>
<!--
    <match target="font">
        <edit name="antialias" mode="assign">
            <bool>true</bool>
        </edit>
        <edit name="hinting" mode="assign">
            <bool>false</bool>
        </edit> 
    </match>
-->
<!--
    <match target="pattern">
          <edit name="autohint" mode="assign">
               <bool>true</bool>
        </edit>
     </match>
-->
    <match target="pattern"> 
        <edit name="dpi" mode="assign">
            <double>96</double>
        </edit> 
    </match> 
    <match target="pattern">
                <test qual="any" name="size" compare="less_eq">
                        <int>7</int>
                </test>
                <edit name="antialias" mode="assign">
                        <bool>false</bool>
                </edit>
        </match>
        <match target="pattern" name="family">
                <test qual="any" name="family">
                        <string>fixed</string>
                </test>
                <edit name="family" mode="assign">
                        <string>mono</string>
                </edit>
        </match>
        <match target="pattern" name="family">
                <test qual="any" name="family">
                        <string>console</string>
                </test>
                <edit name="family" mode="assign">
                        <string>mono</string>
                </edit>
        </match>
        <match target="pattern" name="family">
                <test qual="any" name="family">
                        <string>mono</string>
                </test>
                <edit name="spacing" mode="assign">
                        <int>100</int>
                </edit>
        </match>
        <match target="pattern" name="family">
                <test qual="any" name="family">
                        <string>Helvetica</string>
                </test>
                <edit name="family" mode="assign">
                        <string>sans-serif</string>
                </edit>
        </match>
    <alias>
        <family>serif</family>
        <prefer>
            <family>Bitstream Vera Serif</family>
         </prefer>
    </alias>
    <alias>
        <family>sans-serif</family>
        <prefer>
            <family>Bitstream Vera Sans</family>
         </prefer>
    </alias>
    <alias>
        <family>monospace</family>
        <prefer>
            <family>Bitstream Vera Sans Mono</family>
        </prefer>
        </alias>
        <match target="font">
                <test qual="all" name="rgba">
                        <const>unknown</const>
                </test>
                <edit name="rgba" mode="assign">
                        <const>rgb</const>
                </edit>
        </match>
</fontconfig>

Most of the info I used to merge into my local.conf is from:
freebsd handbook http://www.freebsd.org/doc/en_US.ISO885 … fonts.html,
dropline faq http://www.dropline.net/forums/viewtopic.php?t=825,
freetype autohinter page http://freetype.sourceforge.net/autohinting/,
and bitstream fonts page http://www.gnome.org/fonts/.

Notice that I decreased the nonantialiased font size to 7 (you just have to experiment). I'm using 19" crt philips monitor with nvidia drivers at 1280x1024. I also disabled autohint section (it's commented out at the bottom of the config) because I didn't like its effect on the font rendering: fonts got stronger colours (like black was more black) but they were also too fat (bolder?) and too fuzzy IMO. I'm quite satisfied now with the look of the fonts. I'm not of course saying that this is the best possible set of options :-)

Another good effect I got by using this config is that the web pages which use helvetica look much better now (the config converts bad looking fonts to bitstream fonts). An example of such webpage is http://www.linux-magazine.com/

EDIT: I updated the config above. Everything inside comments is not active. You can try to experiment with different settings by changing the values (dpi, nonantialiased font size, etc.) and uncommenting/commenting some parts of the config. I use only standard arch fontconfig, fonts and xfce4 with xfree86 package (no experience with x.org - but AFAIK there shouldn't be any difference really).

Offline

Board footer

Powered by FluxBB