You are not logged in.

#26 2004-07-17 01:50:23

khazdar
Member
From: ohio
Registered: 2003-11-06
Posts: 123

Re: udev experience and tips

looks like i am all fixed up. very wierd indeed. i just updated to the latest package of udev, and now my cdrom is mounting just fine.

hey DB.. if you havent already done so, update to the latest udev. might fix some of your unexplainable problems.

hey xerxes2, thanks for all your help man!

-Khaz.

Offline

#27 2004-07-17 02:01:12

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: udev experience and tips

That's nice. Udev uses static scheme hd* and so on but there are symlinks made in the udev.rules file that makes it possible to use devfs scheme instead.
Maybe that file was not installed at first.

dp seems to be in a little more trouble!!!! :shock:


arch + gentoo + initng + python = enlisy

Offline

#28 2004-07-17 02:08:52

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Re: udev experience and tips

dp, my keyboard didn't work either, but the problem was GDM. If you're using a log in manager, you should probably disable it.
I couldn't get network working at the beggining either, and I fixed it, putting "hotplug" in the daemon array in rc.conf before  "network", but I see you have it first. Don't know what it might be in your case.
I think 2.4 kernels can't use udev, so it's not so strange that they don't boot.


And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

#29 2004-07-17 02:21:40

wdemoss
Member
From: WV - USA
Registered: 2004-01-18
Posts: 222

Re: udev experience and tips

dp wrote:

4 things:
- apache is not starting ([FAILED])

I don't think this is related to udev, but to the apache update a couple of days ago. fix by creating the directory in /var/log/httpd for apache logs, or at least that was my problem

Also, there were some weird errors when starting up that I seemed to fix by removing the commented out sysfs entry in /etc/fstab and replacing it with

none                   /sys          sysfs     defaults            0      0

I got it from somewhere else on the web for what distro I don't know.  Is this right with the way arch works? I mean, is this even reasonable?

Either way udev is working pretty well for me so far.

EDIT:
Also, i use gdm/gnome and I haven't had any problems I wonder what the difference between my setup and people having the problems. Setup is all current with arch: xorg / gnome / gdm / nvidia drivers on a Dell D800 pM 1.7.

-wd


Hobbes : Shouldn't we read the instructions?
Calvin : Do I look like a sissy?

Offline

#30 2004-07-17 02:25:19

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: udev experience and tips

kakabaratruskia wrote:

dp, my keyboard didn't work either, but the problem was GDM. If you're using a log in manager, you should probably disable it.

done - keyboard is back - thanx :-)

kakabaratruskia wrote:

I couldn't get network working at the beggining either, and I fixed it, putting "hotplug" in the daemon array in rc.conf before  "network", but I see you have it first. Don't know what it might be in your case.

very strange - i had a closer look, and it seems that when udev is working, IRQ11 is disabled somehow - i changed to eepro100 but still the same, then i tried to initiate the device by hand and i can load the module (forcing it), but dhcpcd timeouts (as if it has no connection to the router), but the cable and all is ok, because rebooting to devfs-enabled-kernel brings network back --- very strange ... but i keep searching for the trouble

kakabaratruskia wrote:

I think 2.4 kernels can't use udev, so it's not so strange that they don't boot.

yes, exactly


The impossible missions are the only ones which succeed.

Offline

#31 2004-07-17 02:36:03

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: udev experience and tips

wdemoss wrote:
dp wrote:

4 things:
- apache is not starting ([FAILED])

I don't think this is related to udev, but to the apache update a couple of days ago. fix by creating the directory in /var/log/httpd for apache logs, or at least that was my problem

/var/log/httpd exists and in the error_log there is no entry of failure - nor in the system or kernel logs ::: i'm hunting ghosts :-)

wdemoss wrote:

Also, there were some weird errors when starting up that I seemed to fix by removing the commented out sysfs entry in /etc/fstab and replacing it with

none                   /sys          sysfs     defaults            0      0

I got it from somewhere else on the web for what distro I don't know.  Is this right with the way arch works? I mean, is this even reasonable?

i have /sys working ... but this brings me to the idea to look there for more infos ... going to boot in the udev kernel to have a look at the infos there

wdemoss wrote:

Either way udev is working pretty well for me so far.

EDIT:
Also, i use gdm/gnome and I haven't had any problems I wonder what the difference between my setup and people having the problems. Setup is all current with arch: xorg / gnome / gdm on a Dell D800 pM 1.7.

-wd

i used gdm, but i do not use gnome and i had de localisation in gdm - maybe the original english works --- anyway, gdm is history and we are back to the nice framebuffer login :-)


The impossible missions are the only ones which succeed.

Offline

#32 2004-07-17 03:10:10

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: udev experience and tips

network - solved: i reinstalled udev, and now eth0 works

apache - still only working, if i boot in devfs, but not if udev is working - no idea why - maybe permissions? what ones i dont know

keyboard - gdm is on holidays

external harddisks: funny, but after reinstallation of udev, they are back on /dev/sdX

sound also came back after reinstallation of udev
(by the way: why are the permissions in the official pkg set to root:root for sound? why would any administrator forbid users to use sound? would it be better to have it root:users as default instead? any idea why it is not good making it default?)

so i'm quite happy with udev now - only apache makes trouble and as the logs tell nothing, i have no idea where to search - what devices are used by apache?

xerxes2, khazdar, kakabaratruskia, wdemoss - thanx for the help and your comments


The impossible missions are the only ones which succeed.

Offline

#33 2004-07-17 03:31:54

wdemoss
Member
From: WV - USA
Registered: 2004-01-18
Posts: 222

Re: udev experience and tips

dp wrote:

apache - still only working, if i boot in devfs, but not if udev is working - no idea why - maybe permissions? what ones i dont know

Quick question. Have you tried starting apache with apachectl atart? Instead of /etc/rc.d/httpd start? That was how I figured out my problem i mentioned earlier because no message would print when i started it with the init script, but it would if I just called /usr/sbin/apachectl start

-wd


Hobbes : Shouldn't we read the instructions?
Calvin : Do I look like a sissy?

Offline

#34 2004-07-17 06:10:38

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: udev experience and tips

dp wrote:

(by the way: why are the permissions in the official pkg set to root:root for sound? why would any administrator forbid users to use sound? would it be better to have it root:users as default instead? any idea why it is not good making it default?)

Probably the same reason you had to update your devfsd.conf file with devfs.  It's explicit rather than implicit.

Personally, I use an audio group.  I like being able to control who I give access to the sound card.  Wouldn't want any remote users blasting nasty messages over my speakers wink

About 2.4, the init scripts make an assumption that sysfs is mountable, when really, it's not safe to do that.  If you try to mount sysfs with a 2.4 kernel, it'll just sit there.  I should probably submit a bug report for that, though I did mention it to Judd already.  I just don't know if he saw it...


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#35 2004-07-17 06:15:20

kakabaratruskia
Member
From: Santiago, Chile
Registered: 2003-08-24
Posts: 596

Re: udev experience and tips

I don't have remote users on my PC.


And where were all the sportsmen who always pulled you though?
They're all resting down in Cornwall
writing up their memoirs for a paper-back edition
of the Boy Scout Manual.

Offline

#36 2004-07-17 07:12:45

uberGeek
Member
From: Near Chicago
Registered: 2004-01-07
Posts: 65
Website

Re: udev experience and tips

My network failed to start until I moved hotplug to right AFTER network. Without this forum I would have spent hours, with your help it was a 10 minute fix.

I started right off with a backup grub entry to start without udev...experience, LOL.

Next was audio, again 2 minutes in the forums...solved.  TV tuner...same deal as audio, replace a few root's with users...HBO is back!

I have not even tried to burn a DVD since I put the drive in, so that might take a little more work.

I'm going to look into this, as it makes sense:
Xentac's post:
"The way that I configured udev is to have a whole permissions and rules directory. This lets you have custom permissions and rules files that will never be overwritten.

If you want to add permissions to devices that aren't listed in udev.permissions, just create your own .permissions file in the same directory.

Same goes for rules."

Thank you all for the help, I hope I can return the favor in the future.


carb $ now; uname -a; uptime
Sun 03Jul11 14:54:25 CDT -0500
Linux carb 2.6.17-ARCH #1 SMP PREEMPT Fri Jul 7 09:15:53 CEST 2006 i686 Pentium III (Coppermine) GenuineIntel GNU/Linux
14:54:25 up 1463 days,  9:24,  1 user,  load average: 1.00, 1.00, 1.00

Offline

#37 2004-07-17 08:25:38

rasat
Forum Fellow
From: Finland, working in Romania
Registered: 2002-12-27
Posts: 2,176
Website

Re: udev experience and tips

I noticed udev doesn't make devices in /dev if modules are loaded by /etc/rc.local. Net card module is fine but sound, usb-storage, lp, etc. must run by /etc/rc.conf.

Offline

#38 2004-07-17 12:41:19

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: udev experience and tips

apache:

i had a look at udev and devfs, but as i had 2 installations and one using devfs (not really up-to-date) and the other up-to-dated using udev, i wondered why apache do not load in the udev-installation, but (!!!) it was not udev, but php that was updated to 5.0

/usr/sbin/apachectl start 
Syntax error on line 262 of /etc/httpd/conf/httpd.conf:
Cannot load /usr/lib/apache/libphp4.so into server: /usr/lib/apache/libphp4.so: cannot open shared object file: No such file or directory

apache is waiting for the php4 to load, but only php5 is available -> http://bugs.archlinux.org/index.php?do=details&id=1141


The impossible missions are the only ones which succeed.

Offline

#39 2004-07-17 12:42:02

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: udev experience and tips

wdemoss wrote:
dp wrote:

apache - still only working, if i boot in devfs, but not if udev is working - no idea why - maybe permissions? what ones i dont know

Quick question. Have you tried starting apache with apachectl atart? Instead of /etc/rc.d/httpd start? That was how I figured out my problem i mentioned earlier because no message would print when i started it with the init script, but it would if I just called /usr/sbin/apachectl start

-wd

thanx for the hint of using  /usr/sbin/apachectl start instead of the init script


The impossible missions are the only ones which succeed.

Offline

#40 2004-07-17 18:54:27

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,771

Re: udev experience and tips

you guys figured out Udev yet ?

I want to give it a go...

dp/xerxes2 maybe start a Wiki guide before there are loads of posts....

come to think of it I might post one myself


Mr Green


Mr Green

Offline

#41 2004-07-17 21:46:02

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: udev experience and tips

Just follow the steps in the announcement and it should work green.
Don't forget to edit your boot conf!!!! big_smile


arch + gentoo + initng + python = enlisy

Offline

#42 2004-07-18 04:31:19

uberGeek
Member
From: Near Chicago
Registered: 2004-01-07
Posts: 65
Website

Re: udev experience and tips

To get VMWare working I had to do two things:

Change udev.rules from this:

# tty devices
KERNEL="tty[0-9]*",    NAME="vc/%n"

to this:

# tty devices
KERNEL="tty[0-9]*",    NAME="vc/%n", SYMLINK="%k"

Use a script (mkvmdev) to create /dev/vmnetn and /dev/vmmon.  If there is a better way, please enlighten me.

With devfs I used this (per: http://bbs.archlinux.org/viewtopic.php? … ht=vmware) in my devfsd.conf:

REGISTER .* MKOLDCOMPAT
UNREGISTER .* RMOLDCOMPAT
LOOKUP ^vmnet([0-9])$ EXECUTE mknod /dev/vmnet1 c 119 1

It worked great, but from what i've read so far udev can't create vmnet type entries. True?  Also, devfsd.conf had no mention of vmmon, so I'm wondering if I need it in the mkvmdev script.


carb $ now; uname -a; uptime
Sun 03Jul11 14:54:25 CDT -0500
Linux carb 2.6.17-ARCH #1 SMP PREEMPT Fri Jul 7 09:15:53 CEST 2006 i686 Pentium III (Coppermine) GenuineIntel GNU/Linux
14:54:25 up 1463 days,  9:24,  1 user,  load average: 1.00, 1.00, 1.00

Offline

#43 2004-07-18 17:33:30

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,771

Re: udev experience and tips

xerxes2 wrote:

Just follow the steps in the announcement and it should work green.
Don't forget to edit your boot conf!!!! big_smile

Is that why people are having problems because it works ?

I have loaded udev but this permission thing is worrying my a little ,knowing what to change to users & what not to change  :?

xerxes2 you are the main man when it comes to udev tell us what you know ....

Mr Green


Mr Green

Offline

#44 2004-07-18 17:58:51

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: udev experience and tips

/etc/udev/permissions.d/udev.permissions

for alsa

snd/*:root:users:0660

for nvidia

nvidia*:root:users:0660

arch + gentoo + initng + python = enlisy

Offline

#45 2004-07-18 19:28:43

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,263

Re: udev experience and tips

nvidia*root:users is the default in the standard package
you have to reset your cdrom cdrw dvd drives to be able to
get it run with cdrecord and k3b and not the symbolic links
the drive itself eg. hdc,hdd,hdb etc.

Offline

#46 2004-07-18 19:40:01

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,771

Re: udev experience and tips

Yes

nvidia is the only one thats users... so what about things like scanner,printers etc...

or do you just change them all to users ?

Sorry for asking but I want to be sure...

Mr Green  :?


Mr Green

Offline

#47 2004-07-18 22:35:59

mctavish
Member
From: Australia
Registered: 2004-03-22
Posts: 48

Re: udev experience and tips

For the record, I have also had problems...

Sound and serial ports are not functional and I guess there may be more devices I haven't seen.

Re sound, I have spotted a couple of times a 'soundcard not found' error on boot, same as that chap earlier in this thread.

I have changed permissions as recommended. Alsamixer appears when I run it, I can use my regular mixer to change the sound setting, but I get no sound. I have the correct module for my soundcard in rc.conf and sound works fine in devfs.

As for my serial port (which my modem uses) in my /var/log/errors log, I have this appearing:

Jul 18 23:22:03 localhost pppd[1164]: In file /etc/ppp/peers/ihug: unrecognized option '/dev/ttyS0'

In the /dev/ directory I have no ttys* entries (if my memory serves me right. 99% sure on that)

I don't really have time to fiddle with it at the moment, devfs works fine and anyway I have to work in windows today (boo!) but I just thought I'd add to the available info.

Offline

#48 2004-07-19 00:29:43

mctavish
Member
From: Australia
Registered: 2004-03-22
Posts: 48

Re: udev experience and tips

and now I've lost sound in devfs. Damn. Don't know how that happened. It was working one reboot (i've been rebooting like crazy switching between udev and devfs), but not now.

All I did that may have changed things was  to try hotplug as a daemon in rc.conf, but removed it again pretty quickly after it didn't help anything.

I've tried uninstalled udev totally, but that didn't bring it back.

Shit.

Offline

#49 2004-07-19 01:40:15

zeppelin
Member
From: Athens, Greece
Registered: 2004-03-05
Posts: 807
Website

Re: udev experience and tips

eventhough /dev/discs/blablah have now symlinks to the correct /dev/hd* that is not the same with MODEMS

first of all I had to add myself to group tty (I saw that group from udev.permisions file)

but then again
/dev/ttyS1 SHOULD symlink to /dev/tts/1 but it does NOT

those were my 2 EuroCents

Offline

#50 2004-07-19 02:45:49

mctavish
Member
From: Australia
Registered: 2004-03-22
Posts: 48

Re: udev experience and tips

Good stuff zeppelin.

I didn't know tty and tts were the same thing. I did a symlink /dev/ttyS0 ->/dev/ttl/0 and now my modem is going. I had already changed udev permissions for all of those ppp/serial entries.

I still have my sound problems for now though, but at least  I'm pretty sure that udev is working, just not yet configured.

Offline

Board footer

Powered by FluxBB