You are not logged in.

#1 2008-10-15 20:10:59

Heller_Barde
Member
Registered: 2008-04-01
Posts: 245

Internet does not work after kernel upgrade (quite strange)

Hi guys

My internet (only at home) does not work anymore with kernel 2.6.27. at university it works just fine. isn't that funny big_smile
it has something to do with packet sizes interestingly enough... because i can ping "the internet" (i.e. kernel.org) just fine at home but wget kernel.org fails. ping -s 1000 fails as well, so it's probably really related to packet size.

I use DSL which has a strange value for MTU i heard, but it works just fine with lower kernel versions. I am a bit lost by now...

Btw: it's actually not arch-patch-related, so sorry for posting this here (i already mailed it to the lkml) but i thought maybe there are people here who are interested in strange problems smile

cheers Barde

PS: what i meant to say actually is that if you're not interested in my problem, just ignore this thread smile

Offline

#2 2008-10-16 06:27:22

nGerrit
Member
From: Aachen [GER]
Registered: 2006-09-27
Posts: 36

Re: Internet does not work after kernel upgrade (quite strange)

i can confirm this on two machines..
ping www.kernel.org works fine but actually going there doesn't.

pidgin etc. doesn't work either..

this is related to the kernel 2.6.27 update. downgrading solves this problem.

Offline

#3 2008-10-16 08:15:10

Heller_Barde
Member
Registered: 2008-04-01
Posts: 245

Re: Internet does not work after kernel upgrade (quite strange)

yay, someone else actually has this problem big_smile

I have the exat same symptoms. downgrading solves the problem. try ping -s 1000 , that won't work either (sometimes it does though. the threshold is not constant, absurdly enough)

Offline

#4 2008-10-16 09:10:20

handy
Member
From: Oz
Registered: 2008-03-26
Posts: 719

Re: Internet does not work after kernel upgrade (quite strange)

I have similar problem, though it is not identical.

I have this thread running which gives details:

http://bbs.archlinux.org/viewtopic.php?id=57102

I am using adsl, two other machines in the house have no problem with the external internet hardware.

[Edit:]

I downgraded the kernel & dependant files & it fixed the problem on both of my machines.

Last edited by handy (2008-10-18 00:07:43)


I used to be surprised that I was still surprised by my own stupidity, finding it strangely refreshing.
Well, now I don't find it refreshing.
I'm over it!

Offline

#5 2008-10-16 09:59:30

brain0
Developer
From: Aachen - Germany
Registered: 2005-01-03
Posts: 1,382

Re: Internet does not work after kernel upgrade (quite strange)

Any of you guys happen to have an old NETGEAR router (like, say, a NETGEAR RP114)? This helped for someone on the German forums:

echo 0 >/proc/sys/net/ipv4/tcp_sack
echo 0 >/proc/sys/net/ipv4/tcp_dsack

This settings can be added to sysctl.conf if they help. Anyone speaking German, see http://forum.archlinux.de/?page=Posting … read=10096

Offline

#6 2008-10-16 11:27:49

JonnyJD
Member
From: Berlin
Registered: 2007-11-05
Posts: 45

Re: Internet does not work after kernel upgrade (quite strange)

I can also ping, but I can't open any webpages.

For me downgrading the kernel to the last version (and corresponding nvidia) solved the problem. Note: I still have installed the new dhcp. Didn't see a problem here, because I was getting an IP address fine.

I don't have time to recheck things now, but I would be free to test things in general with wireshark or similar. I use a Gigabit Network card and a router to connect to ADSL. I have a quite old PC (PIII based). That german link is not working, looks like they are testing on the server, because I can ping archlinux.de, but not connect through http..

By the way, is there a faster way to change the kernel than installing it with pacman, given the fact, that you already did that once? Preparing the images takes up quite some time for me.

If you posted this on lkml, could you pleas give a link to the corresponding archive-entry?

Last edited by JonnyJD (2008-10-16 11:33:16)

Offline

#7 2008-10-16 11:37:22

handy
Member
From: Oz
Registered: 2008-03-26
Posts: 719

Re: Internet does not work after kernel upgrade (quite strange)

If you keep your pacman cache, then you go to:

/var/cache/pacman/pkg/desired_package

Find your package & use:

sudo pacman -U /var/cache/pacman/pkg/desired_package

Having done that to downgrade the kernel & other associated files, it did fix my internet problem?

Last edited by handy (2008-10-18 00:09:10)


I used to be surprised that I was still surprised by my own stupidity, finding it strangely refreshing.
Well, now I don't find it refreshing.
I'm over it!

Offline

#8 2008-10-16 12:55:30

nGerrit
Member
From: Aachen [GER]
Registered: 2006-09-27
Posts: 36

Re: Internet does not work after kernel upgrade (quite strange)

did you reboot after the kernel downgrade?

i don't have an netgear router, but i can test the solution this weekend

Offline

#9 2008-10-16 14:25:04

JonnyJD
Member
From: Berlin
Registered: 2007-11-05
Posts: 45

Re: Internet does not work after kernel upgrade (quite strange)

handy wrote:

If you keep your pacman cache, then you go to:

/var/cache/pacman/pkg/desired_package

Find your package & use:

sudo pacman -U /var/cache/pacman/pkg/desired_package

This is exactly what I did to downgrade the kernel, but doing this two .img need to be rebuilt and several hooks parsed. This is what takes quite some time on my machine.

I rebootet the system after the kernel upgrade (no web connection) and the kernel downgrade (web browsing works again).

My router is a "Teledat DSL Router Komfort" from the german Telekom, my network card on the other hand is only like 1 year old. I had a problem the other way around last year. My old network card couldn't cope with some switch or router in the university net and I bought a new network card.

I didn't try the tcp_sack=0 thing yet. I will do that.

Offline

#10 2008-10-16 15:21:49

JonnyJD
Member
From: Berlin
Registered: 2007-11-05
Posts: 45

Re: Internet does not work after kernel upgrade (quite strange)

Okay, I did some testing:

When I am running linux 2.6.26 with the tcp_sack option set to 1 (standard) I send TCP SYNs with the SACK option and get a TCP SYN/ACK as a reply rightaway.

When I do the same on linux 2.6.27 I don't get a SYN/ACK back for some reason.
I have to disable tcp_sack and my TCP SYNs are without the SACK option then and I get a reply rightaway.


Note:
HTML uses TCP connections. A TCP SYN is sent to ask for a connection and a SYN/ACK is sent back from the other host then.
SACK = selective ACK
see http://en.wikipedia.org/wiki/Transmissi … l_Protocol


So I don't understand what exactly a router has to do with this, since TCP operates at a higher layer than a router if I remember that correctly.
Actually, I don't understand why this fix works at all, because I was able to use the SACK option before.

Any ideas where to go from here? The site where the SACK tip came from (archlinux.de) is still offline. According to this thread, somebody already mailed to the lkml, but I can't find anything in the archives there.

Offline

#11 2008-10-16 16:04:51

Misfit138
Misfit Emeritus
From: USA
Registered: 2006-11-27
Posts: 4,170

Re: Internet does not work after kernel upgrade (quite strange)

nGerrit wrote:

i can confirm this on two machines..
ping www.kernel.org works fine but actually going there doesn't.

pidgin etc. doesn't work either..

this is related to the kernel 2.6.27 update. downgrading solves this problem.

Same problem here. I can ping sites, but they are unreachable for the most part. for some reason, google works somewhat, but not much else...
I have downgraded dhcpcd to 3.2 to no avail. I have also tried static ip unsuccessfully.
Will try downgrading kernels later, but pacman is rendered inoperable..(what a time to clear cache tongue )
Appears to be an upstream .27 bug at this point...although there may be multiple issues here since handy may have something else going on.

Offline

#12 2008-10-16 16:15:17

JonnyJD
Member
From: Berlin
Registered: 2007-11-05
Posts: 45

Re: Internet does not work after kernel upgrade (quite strange)

What do you mean with "google works somewaht"? I couldn't access any webpages whatsoever, because I couldn't get a TCP connection to work.

Offline

#13 2008-10-16 16:23:09

Misfit138
Misfit Emeritus
From: USA
Registered: 2006-11-27
Posts: 4,170

Re: Internet does not work after kernel upgrade (quite strange)

What I mean is, I can ping sites, including google.
When I attempt to navigate to sites through a browser, the browser will infinitely loop, trying to load the page. If I dhcpcd -k eth0 and then dhcpcd eth0, I can navigate to google, search, and then click on links...some of which work, some of which infinitely loop.l...now that I think of it, the reason I may be able to get to google is because I have pinged it first, and then visited it!
I'm on  a windows box atm, and won't be home till later. But perhaps this clue will add a piece to the puzzle.

(moving this to package upgrade issues)

Offline

#14 2008-10-16 16:47:17

JonnyJD
Member
From: Berlin
Registered: 2007-11-05
Posts: 45

Re: Internet does not work after kernel upgrade (quite strange)

I can access everything with ping fine. Didn't try anything with dhcp, though and didn't check nameserver and routing table. It is still possible that this problem is connected to dhcp and the kernel not cooperating. I did not downgrade dhcpd.

Why was this moved to Pacman and Upgrad Issues? This is not an upgrade issue, but an issue with the kernel. Upgrading with pacman works fine, but what we are upgrading to doesn't work. At least in my understanding.

Offline

#15 2008-10-16 17:10:34

Misfit138
Misfit Emeritus
From: USA
Registered: 2006-11-27
Posts: 4,170

Re: Internet does not work after kernel upgrade (quite strange)

It was moved because the meaning of 'upgrade issues' is along the lines of 'something worked before an upgrade but broke after'. Perhaps I can clarify this in the subforum's description..
edit: done.

Last edited by Misfit138 (2008-10-16 17:13:13)

Offline

#16 2008-10-16 19:51:09

RabidWolf
Member
From: WI,USA
Registered: 2007-01-20
Posts: 31
Website

Re: Internet does not work after kernel upgrade (quite strange)

I am having similar troubles. although it seems not quite as bad as some of you. My success in reaching sites varies, I've tried with firefox, opera and dillo, opera seems to work best, although: some sites load very fast, some sites chug along and if I wait, they eventually come up, some won't come up at all. I'm on cable, not dsl, using a linksys router. I cannot get google to load at all but can ping it, and archlinux sites take 40 to 60 seconds to load, heh I was beginning to think I was the only person experiencing this. I hope some fixes something soon or I'll need to dual boot till it gets sorted out, I'm not loading up windows again, there are too many other options. smile

Offline

#17 2008-10-16 20:19:06

nGerrit
Member
From: Aachen [GER]
Registered: 2006-09-27
Posts: 36

Re: Internet does not work after kernel upgrade (quite strange)

has someone posted a bug report on this?

Offline

#18 2008-10-16 20:29:38

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: Internet does not work after kernel upgrade (quite strange)

Heller_Barde wrote:

Btw: it's actually not arch-patch-related, so sorry for posting this here (i already mailed it to the lkml) but i thought maybe there are people here who are interested in strange problems smile

Do you have a link to the thread on lkml? I cannot find it.

Last edited by pressh (2008-10-16 20:30:10)

Offline

#19 2008-10-16 22:10:32

Misfit138
Misfit Emeritus
From: USA
Registered: 2006-11-27
Posts: 4,170

Re: Internet does not work after kernel upgrade (quite strange)

nGerrit wrote:

has someone posted a bug report on this?

I have not done so yet, as I am still at work. I cannot personally confirm if it is an upstream issue, (in my case) because I have not had a chance to downgrade kernels yet.
At least one person claims that kernel downgrading fixes it, but another (handy) claims it did not.
I can say for sure that downgrading dhcpcd does not fix it, nor does using static IP.

Offline

#20 2008-10-16 22:55:34

brain0
Developer
From: Aachen - Germany
Registered: 2005-01-03
Posts: 1,382

Re: Internet does not work after kernel upgrade (quite strange)

JonnyJD wrote:

So I don't understand what exactly a router has to do with this, since TCP operates at a higher layer than a router if I remember that correctly.
Actually, I don't understand why this fix works at all, because I was able to use the SACK option before.

The router does NAT, it has to know TCP for that. Some crappy broken routers occasionally break when the Linux TCP/IP stack changes. This is mostly the router vendor fault anyway.

Offline

#21 2008-10-16 23:10:09

Heller_Barde
Member
Registered: 2008-04-01
Posts: 245

Re: Internet does not work after kernel upgrade (quite strange)

the SACK trick did it for me. it works now.
as for misfit: I can confirm that this at least ALSO kernel related since  i had exactly the same behaviour for all the previous release candidates (yes i compiled all of them myself from rc2 - rc8 with occasional -gitX versions)
also downgrading works for most people here, handy might have some other additional problem... sad

cheers Barde

PS: there you go, whoever wanted it big_smile
http://lkml.org/lkml/2008/10/11/131

Last edited by Heller_Barde (2008-10-16 23:15:25)

Offline

#22 2008-10-17 00:42:09

handy
Member
From: Oz
Registered: 2008-03-26
Posts: 719

Re: Internet does not work after kernel upgrade (quite strange)

I will very carefully downgrade again & report back.


I used to be surprised that I was still surprised by my own stupidity, finding it strangely refreshing.
Well, now I don't find it refreshing.
I'm over it!

Offline

#23 2008-10-17 02:34:12

Misfit138
Misfit Emeritus
From: USA
Registered: 2006-11-27
Posts: 4,170

Re: Internet does not work after kernel upgrade (quite strange)

Ok, downgrading to 2.6.26 (and nvidia 173.14.12-2) fixes this right up for me.
I hope it does for you too, handy.

Offline

#24 2008-10-17 03:10:46

handy
Member
From: Oz
Registered: 2008-03-26
Posts: 719

Re: Internet does not work after kernel upgrade (quite strange)

Ok, I downgraded again, very carefully wink & rebooted to an internet working as it should be. cool

Sorry for throwing some confusion on the matter, I had, had a very long day with an Arch install that went wrong(!)  the day before & must have been brain addled when downgrading yesterday.

I will now have another look at the machine that's install is stuck & see if I can understand why, with my new found knowledge.

Thanks to all for your much needed help. smile

[Edit:]

My 2nd machine was suffering the same problem which it caught during a fresh install of Arch! smile

I have edited some of my previous posts to try to remove confussion created by my failed first downgrade attempt. {embarrassment}

Last edited by handy (2008-10-18 00:14:44)


I used to be surprised that I was still surprised by my own stupidity, finding it strangely refreshing.
Well, now I don't find it refreshing.
I'm over it!

Offline

#25 2008-10-17 08:22:49

Heller_Barde
Member
Registered: 2008-04-01
Posts: 245

Re: Internet does not work after kernel upgrade (quite strange)

good. did you guys tried this TCP_SACK thingie? it worked for me *shrug*

cheers Barde

Offline

Board footer

Powered by FluxBB