You are not logged in.

#3376 2011-11-13 09:07:58

handy
Member
From: Oz
Registered: 2008-03-26
Posts: 719

Re: The AMD/ATI Bar & Grill

Looks functional:

http://www.desura.com/


I used to be surprised that I was still surprised by my own stupidity, finding it strangely refreshing.
Well, now I don't find it refreshing.
I'm over it!

Offline

#3377 2011-11-13 09:25:03

ChemBro
Member
Registered: 2008-10-22
Posts: 674

Re: The AMD/ATI Bar & Grill

handy wrote:

Looks functional:

http://www.desura.com/

Doesn't answer my question. For non closed beta user the site looks the same. But they aren't able to install and play games. I am in the closed beta and therefore can't tell, if it is out of closed beta until I see an official announcement.

Offline

#3378 2011-11-13 16:46:19

szebenyib
Member
From: LHBP
Registered: 2011-10-18
Posts: 64

Re: The AMD/ATI Bar & Grill

I have installed catalyst-total, it starts normally, but gdm and gnome 3 flickers. Does anyone else experience this?
I have just moved to use catalyst instead of open source drivers. They were fine, however, now my laptop is 10°C cooler on idle, so I really-really need catalyst drivers.

Offline

#3379 2011-11-13 17:17:02

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

Package signing
I signed packages in [catalyst] repository, can some [testing] user confirm that it's working fine? :>

szebenyib wrote:

I have installed catalyst-total, it starts normally, but gdm and gnome 3 flickers. Does anyone else experience this?
I have just moved to use catalyst instead of open source drivers. They were fine, however, now my laptop is 10°C cooler on idle, so I really-really need catalyst drivers.

it's because catalyst still sux in GNOME3 support, and nobody knows when it will be fixed <yeeeeeeeeeeeeeeeeeeeey>

Offline

#3380 2011-11-13 17:38:02

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 672

Re: The AMD/ATI Bar & Grill

On my system, catalyst-daemon 11.10-3 compiles fglrx every time I boot, even when using the same kernel I used in previous boot. Does anyone experience the same? BTW, I'm using linux 3.1.

Offline

#3381 2011-11-13 18:15:44

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

snack wrote:

On my system, catalyst-daemon 11.10-3 compiles fglrx every time I boot, even when using the same kernel I used in previous boot. Does anyone experience the same? BTW, I'm using linux 3.1.

Thanks, should work fine in daemon -4.
I also made remove function better in generator -4.
All updates are available on AUR, and soon will land on repo

Offline

#3382 2011-11-14 10:53:45

Turris
Member
Registered: 2011-09-26
Posts: 12

Re: The AMD/ATI Bar & Grill

The update to the 3.1 kernel using the [catalyst]-repo was very smooth for me, thank you Vi0L0 for doing such a good job!

Offline

#3383 2011-11-14 11:01:24

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 672

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:
snack wrote:

On my system, catalyst-daemon 11.10-3 compiles fglrx every time I boot, even when using the same kernel I used in previous boot. Does anyone experience the same? BTW, I'm using linux 3.1.

Thanks, should work fine in daemon -4.
I also made remove function better in generator -4.
All updates are available on AUR, and soon will land on repo

Now it works correctly, thanks Vi0l0!

Offline

#3384 2011-11-14 22:26:50

MaTachi
Member
From: Göteborg, Sweden
Registered: 2011-06-07
Posts: 52
Website

Re: The AMD/ATI Bar & Grill

I run Arch with Gnome 3 and the open ATI drivers currently. But I would really like to try Catalyst, since only OpenGL version 2.1 is supported in the open drivers. Do you think Catalyst would work if I ran it in another desktop environment? Like XFCE?


 (\_/)
(o.o)
(___)0

Offline

#3385 2011-11-15 06:55:20

szebenyib
Member
From: LHBP
Registered: 2011-10-18
Posts: 64

Re: The AMD/ATI Bar & Grill

Catalyst is OK for anything else here. Some very very minor disturbances with KDE, with LXCE, XFCE, Openbox it is perfect.

Offline

#3386 2011-11-15 11:10:52

SiD
Member
From: Germany
Registered: 2006-09-21
Posts: 729

Re: The AMD/ATI Bar & Grill

Hi,

I am trying to install Catalyst from the [catalyst] Repo but get a dependency error and it fails.

# pacman -S catalyst-utils catalyst
resolving dependencies...
warning: dependency cycle detected:
warning: xorg-server-catalyst-maximize-fix will be installed before its catalyst-utils dependency
looking for inter-conflicts...
error: failed to prepare transaction (conflicting dependencies)
error: unresolvable package conflicts detected
:: xf86-input-evdev and xorg-server-catalyst-maximize-fix are in conflict (xorg-server<1.10.99.902)

xorg and xf86-input-video from official Repos are not installed.

Last edited by SiD (2011-11-15 11:15:42)

Offline

#3387 2011-11-15 12:34:48

null
Member
Registered: 2009-05-06
Posts: 257

Re: The AMD/ATI Bar & Grill

I guess xf86-input-evdev from official repos is installed? Try the xf86-input-evdev package from the [xorg110] repo wink


⚑★⚓ my dotfile repo ⚓★⚑

Offline

#3388 2011-11-15 13:07:44

SiD
Member
From: Germany
Registered: 2006-09-21
Posts: 729

Re: The AMD/ATI Bar & Grill

No, xf86-input-evdev wasn't installed at all, but i forgot to activate [xorg110] repo in pacman.conf ...

works now

Offline

#3389 2011-11-15 13:46:39

myro
Member
From: Italy
Registered: 2011-10-07
Posts: 3
Website

Re: The AMD/ATI Bar & Grill

szebenyib wrote:

Catalyst is OK for anything else here. Some very very minor disturbances with KDE, with LXCE, XFCE, Openbox it is perfect.

I have just installed catalyst 11.10-3 with xorg110 and confirm that gnome shell is pretty buggy.
Now I'm running LXDE and I can confirm you that everything works really well.

Last edited by myro (2011-11-15 13:47:17)

Offline

#3390 2011-11-15 20:36:34

ChemBro
Member
Registered: 2008-10-22
Posts: 674

Re: The AMD/ATI Bar & Grill

Catalyst 11.11 is out. Phoronix and Co say, that it supports xorg 1.11 and kernel 3.1 and 3.2.

Offline

#3391 2011-11-16 01:20:53

sublimepua
Member
Registered: 2011-02-02
Posts: 12

Re: The AMD/ATI Bar & Grill

I can't wait for it to hit the repos.

Offline

#3392 2011-11-16 01:42:49

\〠/
Member
Registered: 2011-02-26
Posts: 29

Re: The AMD/ATI Bar & Grill

ChemBro wrote:

Phoronix and Co say, that it supports xorg 1.11 and kernel 3.1 and 3.2.

I just tried this and it blows kde (kwin) when I try to use mplayer, works fine with xorg 1.10

note to self: never trust Phoronix ^_^

Offline

#3393 2011-11-16 07:53:46

Edward E. Edwardson
Member
Registered: 2011-11-01
Posts: 33

Re: The AMD/ATI Bar & Grill

I'm using GNOME3 with catalyst and it has ugly artifacts and crashes betimes. In fallback mode the top panel is thrice as high as it should be, occupying my screen with black nothingness. Where can I complain again? Maybe we should complain more, for something to change. Or just buy another graphics card. meh.

Offline

#3394 2011-11-16 11:05:42

nemolivier
Member
Registered: 2010-09-24
Posts: 12

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

Oh and:

nemolivier wrote:

Hum… strange.
After the 3.1 kernel update, my fglrx re-start working (check my later posts, 11.9 worked but 11.10 never) BEFORE updating the catalyst…
After the catalyst update, I still have a working card, but I still have the flickering screens sad

A locate fglrx give me thate :

locate fglrx.ko
/lib/modules/3.0-ARCH/video/fglrx.ko
/lib/modules/3.1.0-4-ARCH/video/fglrx.ko
/lib/modules/extramodules-3.1-ARCH/fglrx.ko

It’s look like I have two fglrx modules for 3.1… Is there something I can do to know witch module is used (lsmod don’t seems to give me that information)

[EDIT] after renaming /lib/modules/3.1.0-4-ARCH/video/fglrx.ko to bak_fglrx.ko and rebooting… no acceleration.
So it seems that 11.10 still don’t work on my Radeon HD 4350 (RV710).

Yeah, guess you could experience this when using hook or daemon or total + `catalyst_build_module all` command hmm
Please as root type `catalyst_build_module remove_all`, then try to locate fglrx.ko, still there? remove manually and update to -3 version of 11.10

Thank’s a lot for the answer.
Since the last update my fglrx is back… but with all the flicks. The fglrx.ko is in /lib/modules/extramodules-3.1-ARCH I still don’t know what version is used. I’m gonna try your trick.
And I see yesterday that the 11.11 just went out, hope I can help me with this flicks on screen… http://support.amd.com/us/gpudownload/l … ng=English

Offline

#3395 2011-11-16 21:47:38

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

like i said on AUR:
aaaaah such a fast update! sorry guys and lads - i'm on company's delegation, hundreds miles away from my pc... hope to get soon like tomorrow, till then there will be no update sad

Offline

#3396 2011-11-16 22:24:48

scullder
Member
Registered: 2011-04-27
Posts: 21

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

like i said on AUR:
aaaaah such a fast update! sorry guys and lads - i'm on company's delegation, hundreds miles away from my pc... hope to get soon like tomorrow, till then there will be no update sad

It's ok, we will have the time to see reports from other distros about 11.11 and its set of probably new bugs wink

Offline

#3397 2011-11-17 03:56:21

damacas
Member
From: Ontario, Canada
Registered: 2011-05-27
Posts: 50

Re: The AMD/ATI Bar & Grill

Well, I am hoping to get some assistance getting catalyst to play nice with KDE 4.7.3/X and the 3.1 kernel.  I have gotten catalyst 11.10-3 installed (catalyst-hook) and working fine with the 3.0.7-1 kernel, but whenever I try a 3.1 kernel everything starts up fine until KDM takes over, and then I get a black screen...and no nothing. 

Downgrade the kernel, and no problem KDE starts up just fine. 

Any ideas?

Thanks, damacas

Offline

#3398 2011-11-17 11:26:19

stratovarius
Member
Registered: 2011-11-07
Posts: 6

Re: The AMD/ATI Bar & Grill

ChemBro wrote:

Catalyst 11.11 is out. Phoronix and Co say, that it supports xorg 1.11 and kernel 3.1 and 3.2.

i can confirm 11.11 is work with kernel 3.1 and xorg 1.11

fglrxinfo
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Mobility Radeon HD 3400 Series
OpenGL version string: 3.3.11251 Compatibility Profile Context
uname -a
Linux xxx 3.1.1-1-ARCH #1 SMP PREEMPT Fri Nov 11 22:28:29 CET 2011 x86_64 Intel(R) Core(TM)2 Duo CPU P8400 @ 2.26GHz GenuineIntel GNU/Linux
pacman -Q xorg-server
xorg-server 1.11.2-1

Last edited by stratovarius (2011-11-17 11:27:05)

Offline

#3399 2011-11-17 13:52:20

matse
Member
Registered: 2011-04-27
Posts: 276

Re: The AMD/ATI Bar & Grill

@damacas have you added the "nomodeset" kernel parameter?

Offline

#3400 2011-11-17 14:19:31

damacas
Member
From: Ontario, Canada
Registered: 2011-05-27
Posts: 50

Re: The AMD/ATI Bar & Grill

matse wrote:

@damacas have you added the "nomodeset" kernel parameter?

Yes.  This is my kernel line:

kernel /boot/vmlinuz-linux root=/dev/sda2 ro nomodeset quiet 

Offline

Board footer

Powered by FluxBB