You are not logged in.

#3526 2011-12-15 23:48:42

ideogon
Member
From: Arlington, VA
Registered: 2010-04-10
Posts: 24
Website

Re: The AMD/ATI Bar & Grill

I'm trying to find xorg-server 1.10 from http://arm.konnichi.com/extra/os/x86_64/ in order to be able to use catalyst-firepro from AUR (http://aur.archlinux.org/packages.php?I … mments=all). Can someone please tell me which versions of its dependencies I need?

Offline

#3527 2011-12-16 03:39:57

securitybreach
Member
From: In front of my computers
Registered: 2007-11-18
Posts: 409
Website

Re: The AMD/ATI Bar & Grill

ideogon wrote:

I'm trying to find xorg-server 1.10 from http://arm.konnichi.com/extra/os/x86_64/ in order to be able to use catalyst-firepro from AUR (http://aur.archlinux.org/packages.php?I … mments=all). Can someone please tell me which versions of its dependencies I need?

Look here for how to install xorg-server 1.10 packages: https://wiki.archlinux.org/index.php/AT … positories


"Every normal man must be tempted at times to spit upon his hands, hoist the black flag, and begin slitting throats." -- H.L. Mencken
Website      Configs
Forum Admin: Bruno's All Things Linux   
securitybreach<a>archlinux.us

Offline

#3528 2011-12-16 12:24:25

ratcheer
Member
Registered: 2011-10-09
Posts: 517

Re: The AMD/ATI Bar & Grill

Hmmm. I'm running Xorg 1.11.2 and Catalyst 11.12. No problems.

Tim

Offline

#3529 2011-12-16 13:04:39

sleepforlife
Member
Registered: 2011-09-27
Posts: 95

Re: The AMD/ATI Bar & Grill

I'm running Xorg 1.11.2 and Catalyst 11.12 too. i can use only gl with smplayer for 1048p video format. others are working very badly.

Offline

#3530 2011-12-16 14:08:50

logomancer
Member
Registered: 2011-11-01
Posts: 3

Re: The AMD/ATI Bar & Grill

Here we go again. I lost 3D acceleration after upgrading to 11.12. dmesg is telling me that the CMMQS handle is not valid, and the Xorg logs seem to tell me that the kernel driver may be missing or incompatible. I've tried rebuilding the kernel driver, it seemed to build OK, but didn't work. I also tried removing the package and reinstalling it, no dice. Help?

Offline

#3531 2011-12-17 11:31:14

CyrIng
Member
From: France
Registered: 2010-07-17
Posts: 76
Website

Re: The AMD/ATI Bar & Grill

CMMQS issue solved by adding in /etc/rc.conf
MODULES=(... fglrx)

Offline

#3532 2011-12-17 13:20:53

fraantik
Member
Registered: 2011-01-02
Posts: 10

Re: The AMD/ATI Bar & Grill

To fix 3d acceleration it you have to REMOVE from /etc/mkinitcpio.conf MODULES and HOOKS fglrx if you had it there.
Regenerate mkinitcpio (with pacman -S linux), also you could add module it to rc.conf (but think that this is unnecessary).

Offline

#3533 2011-12-17 16:36:33

cdprincipe
Member
Registered: 2011-11-29
Posts: 22

Re: The AMD/ATI Bar & Grill

Offline

#3534 2011-12-17 17:40:52

Imperion
Member
Registered: 2010-08-23
Posts: 3

Re: The AMD/ATI Bar & Grill

I have an ancient system with a Radeon 9600 card, and all graphical performance sucks. Is there any easy way to install Xorg 7.4 and the old Catalyst 9.3 driver? The system is really terrible with any DE, unusable with compositing (xf86-video-ati). I've followed tons of guides to very little effect. And, yes, direct rendering is active according to glxinfo:

OpenGL vendor string: X.Org R300 Project
OpenGL renderer string: Gallium 0.4 on ATI RV350
OpenGL version string: 2.1 Mesa 7.11.2

Last edited by Imperion (2011-12-17 17:44:27)

Offline

#3535 2011-12-17 17:44:30

logomancer
Member
Registered: 2011-11-01
Posts: 3

Re: The AMD/ATI Bar & Grill

fraantik wrote:

To fix 3d acceleration it you have to REMOVE from /etc/mkinitcpio.conf MODULES and HOOKS fglrx if you had it there.
Regenerate mkinitcpio (with pacman -S linux), also you could add module it to rc.conf (but think that this is unnecessary).

I fixed it, and you're somewhat right. The module was loading in two places -- in the mkinitcpio image and in the modules from rc.conf. It has to be one or the other, and both work just fine. I chose putting it in the mkinitcpio image so it'll be rebuilt with each kernel upgrade.

Catalyst 11.12 seems to work fine with X.org 1.11.3. All other things being equal, of course.

Thanks for your help!

Offline

#3536 2011-12-18 01:41:26

wassup
Member
Registered: 2010-03-16
Posts: 12

Re: The AMD/ATI Bar & Grill

Hello everyone.

Does anyone has any news about Skype? It crashes for me with Xorg 1.11.3 & catalyst 11.12.1, any chance it will get fixed?

Offline

#3537 2011-12-18 08:20:21

mouse256
Member
From: Antwerpen, Belgium
Registered: 2005-08-24
Posts: 247

Re: The AMD/ATI Bar & Grill

Imperion wrote:

I have an ancient system with a Radeon 9600 card, and all graphical performance sucks. Is there any easy way to install Xorg 7.4 and the old Catalyst 9.3 driver? The system is really terrible with any DE, unusable with compositing (xf86-video-ati). I've followed tons of guides to very little effect. And, yes, direct rendering is active according to glxinfo:

I've been using a radeon 9600 up untill a couple of months now on my seconds pc. Also using the opensource driver since amd stopped supporting it. And it worked pretty well for me.

Offline

#3538 2011-12-20 10:53:01

whitethorn
Member
Registered: 2010-05-02
Posts: 153

Re: The AMD/ATI Bar & Grill

wassup wrote:

Hello everyone.

Does anyone has any news about Skype? It crashes for me with Xorg 1.11.3 & catalyst 11.12.1, any chance it will get fixed?

I switched to radeon because of this, but it seems it keeps running really hot even when forced to the low profile. Anyone know of a fix for skype to use x11 instead of xv?

Offline

#3539 2011-12-20 10:57:15

luz1
Member
From: Germany
Registered: 2011-12-14
Posts: 20

Re: The AMD/ATI Bar & Grill

wassup wrote:

Hello everyone.

Does anyone has any news about Skype? It crashes for me with Xorg 1.11.3 & catalyst 11.12.1, any chance it will get fixed?


Hi,

I think the only verified method to use "xv" and get a working skype webcam is to downgrade to xorg 1.10.

For me everything works fine -- xorg 1.10 and catalyst 11.12

Offline

#3540 2011-12-20 11:07:11

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 672

Re: The AMD/ATI Bar & Grill

whitethorn wrote:
wassup wrote:

Hello everyone.

Does anyone has any news about Skype? It crashes for me with Xorg 1.11.3 & catalyst 11.12.1, any chance it will get fixed?

I switched to radeon because of this, but it seems it keeps running really hot even when forced to the low profile. Anyone know of a fix for skype to use x11 instead of xv?

Skype 2.2.0.35-2 works fine for me on i686 with catalyst-daemon 11.12-1 from Vi0l0's repo and xorg-server 1.11.3-1. I did a video call just yesterday without any crash.

Offline

#3541 2011-12-21 18:43:50

Rixx
Member
Registered: 2010-10-02
Posts: 9

Re: The AMD/ATI Bar & Grill

I have crashes with catalyst 11.12 and xorg 1.1.13 and xv. But with every another output (gl, gl2, gl_nosw) I have tears in video. GPU is 6470m. Have can I fix this? Will downgrade of xorg helps?

Offline

#3542 2011-12-21 20:35:54

luz1
Member
From: Germany
Registered: 2011-12-14
Posts: 20

Re: The AMD/ATI Bar & Grill

Rixx wrote:

I have crashes with catalyst 11.12 and xorg 1.1.13 and xv. But with every another output (gl, gl2, gl_nosw) I have tears in video. GPU is 6470m. Have can I fix this? Will downgrade of xorg helps?

xorg 1.10 should work

Offline

#3543 2011-12-22 19:14:19

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,472
Website

Re: The AMD/ATI Bar & Grill

I just tried Catalyst again after I found xf86-video-ati to run too hot. I did as told in the Wiki:

1. Add the repo;
2. Install packages;
3. Run aticonfig --initial.

However, after rebooting, my screen went black as soon as X started. I can login in CLI just fine but once I start X, blackness. I have to reboot in order to fix this. Can anyone perhaps point me to a fix? I'm fully up-to-date, Xorg version 1.11.3


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#3544 2011-12-22 23:37:01

ratcheer
Member
Registered: 2011-10-09
Posts: 517

Re: The AMD/ATI Bar & Grill

@unia, did you put fglrx in the MODULES array of /etc/rc.conf?

Tim

Offline

#3545 2011-12-23 10:47:50

achilleas.k
Member
From: Sol 3
Registered: 2011-10-30
Posts: 115

Re: The AMD/ATI Bar & Grill

@Unia: nomodeset on kernel boot line? That's how I solved it when I switched to catalyst.

Offline

#3546 2011-12-23 11:42:28

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,472
Website

Re: The AMD/ATI Bar & Grill

Achilleas.k, you're right. The instructions didn't tell me that so I forgot.

Ratcheer, I have never added the module before (last Catalyst I used before switching to xf86-video-ati was 11.10 I believe). Do I have to now?


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#3547 2011-12-23 11:53:50

ratcheer
Member
Registered: 2011-10-09
Posts: 517

Re: The AMD/ATI Bar & Grill

@Unia, I'm not sure, but I did and it works for me. It seems like I had to do it before it would work correctly, but maybe not.

And yes, I also had to add nomodeset to the kernel boot line.

Tim

Offline

#3548 2011-12-23 12:57:20

ChemBro
Member
Registered: 2008-10-22
Posts: 677

Re: The AMD/ATI Bar & Grill

Unia wrote:

Achilleas.k, you're right. The instructions didn't tell me that so I forgot.

Which instructions? Installing catalyst gives you all the information, including the "nomodeset" thing:

----------------------------------------------------------------
You can use the tool 'aticonfig' to generate an xorg.conf file.
--------------------- ^^^^^^^^^ --------------------------------
Add nomodeset to your kernel line in /boot/grub/menu.lst , ie.:
kernel /boot/vmlinuz-linux root=/dev/sda1 ro nomodeset
----------------------------------------------------------------
For more info and troubleshooting visit:
http://wiki.archlinux.org/index.php/ATI_Catalyst
----------------------------------------------------------------

Offline

#3549 2011-12-23 13:05:39

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,472
Website

Re: The AMD/ATI Bar & Grill

ChemBro wrote:
Unia wrote:

Achilleas.k, you're right. The instructions didn't tell me that so I forgot.

Which instructions? Installing catalyst gives you all the information, including the "nomodeset" thing:

----------------------------------------------------------------
You can use the tool 'aticonfig' to generate an xorg.conf file.
--------------------- ^^^^^^^^^ --------------------------------
Add nomodeset to your kernel line in /boot/grub/menu.lst , ie.:
kernel /boot/vmlinuz-linux root=/dev/sda1 ro nomodeset
----------------------------------------------------------------
For more info and troubleshooting visit:
http://wiki.archlinux.org/index.php/ATI_Catalyst
----------------------------------------------------------------

Not when you install from the repository. At least, I didn't see them. But it's all working now, I just forgot to add it. Thanks guys!


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#3550 2011-12-23 15:08:14

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,472
Website

Re: The AMD/ATI Bar & Grill

Ok so now Catalyst is working, but I'm presented with another issue: I can't watch videos (.avi's to be specific). I tried both kdemultimedia-dragonplayer and vlc, but Xorg crashes as soon as the video starts playing. Using VLC I can listen to music perfectly fine so it's not VLC specific I guess. It also isn't this specific .avi file as it happens with another one too.

I've read some about different video outputs (xv and another one?) but I'm not knowledgeable enough in this area so I need your help. Thanks in advance, guys!


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

Board footer

Powered by FluxBB