You are not logged in.

#3901 2012-04-29 17:38:35

PhotonX
Member
From: Munich
Registered: 2008-08-10
Posts: 434

Re: The AMD/ATI Bar & Grill

32.

edit: Could it be due to the version of linux-api-headers?

2 core/linux-api-headers 3.3.2-1 [installed]
    Kernel headers sanitized for use in userspace
3 core/linux-headers 3.3.3-1 [installed]
    Header files and scripts for building modules for linux kernel

Last edited by PhotonX (2012-04-29 17:40:35)


Desktop: http://www.sysprofile.de/id15562, Arch Linux    |    Notebook: Thinkpad X200 Tablet, Manjaro

The very worst thing you can do with free software is to download it, see that it doesn't work for some reason, leave it, and tell your friends that it doesn't work.  -  Tuomas Lukka

Offline

#3902 2012-04-29 22:08:09

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,335
Website

Re: The AMD/ATI Bar & Grill

PhotonX
I just wrote:
manually remove /lib/modules/extramodules-3.2-ARCH/ directory

and then saw your last post: lol, how is it possible to have same package but in 2 different versions? oh wait - not same package smile
so anyway follow my 1st advice

Last edited by Vi0L0 (2012-04-29 22:10:57)

Offline

#3903 2012-04-30 08:13:23

PhotonX
Member
From: Munich
Registered: 2008-08-10
Posts: 434

Re: The AMD/ATI Bar & Grill

Thanks for your advice, but unfortunately removing /lib/modules/extramodules-3.2-ARCH/ and rebooting didn't solve the problem. Maybe I need to reinstall catalyst-hook and catalyst-utils, too... I'll try it in ~10 hours when I'm back home and report back.


Desktop: http://www.sysprofile.de/id15562, Arch Linux    |    Notebook: Thinkpad X200 Tablet, Manjaro

The very worst thing you can do with free software is to download it, see that it doesn't work for some reason, leave it, and tell your friends that it doesn't work.  -  Tuomas Lukka

Offline

#3904 2012-04-30 08:26:43

xorgx3
Member
From: Poland
Registered: 2011-11-29
Posts: 197

Re: The AMD/ATI Bar & Grill

For me working only downgrade catalyst-utils, after upgrade still this same troubles. I use catalyst-hook too. Any ideas?

Offline

#3905 2012-04-30 12:15:15

Amarus
Member
From: Damascus - Syria
Registered: 2010-09-19
Posts: 6

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

i'm also concerned about 3.4 kernel support for which there's no patch but just an ugly workaround which is also engaging a patching of kernel's headers, and there's kernel 3.4 rc4 already, guess there could be a problem with it in near future.

So I suppose that, for the time being, I should pass the offer that pacman have just made to me to update my kernel to 3.3.4 on my production machine right?

Last edited by Amarus (2012-04-30 12:16:19)

Offline

#3906 2012-04-30 17:11:19

qubital
Member
Registered: 2012-01-26
Posts: 1

Re: The AMD/ATI Bar & Grill

Upgrading to 3.3.4-1 caused a fallback to the default radeon driver.  Really surprised it didn't crash altogether.   Had to downgrade.

Offline

#3907 2012-04-30 18:03:44

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,476
Website

Re: The AMD/ATI Bar & Grill

qubital wrote:

Upgrading to 3.3.4-1 caused a fallback to the default radeon driver.  Really surprised it didn't crash altogether.   Had to downgrade.

Same here...


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#3908 2012-04-30 20:03:00

PhotonX
Member
From: Munich
Registered: 2008-08-10
Posts: 434

Re: The AMD/ATI Bar & Grill

Removing /lib/modules/extramodules-3.2-ARCH/, updating to 3.3.4 and rebuilding catalyst-hook and catalyst-utils fixed the problem. Maybe something was unnecessary, but that's what I did. smile


Desktop: http://www.sysprofile.de/id15562, Arch Linux    |    Notebook: Thinkpad X200 Tablet, Manjaro

The very worst thing you can do with free software is to download it, see that it doesn't work for some reason, leave it, and tell your friends that it doesn't work.  -  Tuomas Lukka

Offline

#3909 2012-05-01 09:51:58

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,476
Website

Re: The AMD/ATI Bar & Grill

PhotonX wrote:

Removing /lib/modules/extramodules-3.2-ARCH/, updating to 3.3.4 and rebuilding catalyst-hook and catalyst-utils fixed the problem. Maybe something was unnecessary, but that's what I did. smile

Do you mean /lib/modules/extramodules-3.3-ARCH? That's the only extramodules I have

Last edited by Unia (2012-05-01 09:53:07)


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#3910 2012-05-01 10:20:06

mpnordland
Member
Registered: 2011-11-29
Posts: 46

Re: The AMD/ATI Bar & Grill

If you're using catalyst generator, just rebuild the module.

Offline

#3911 2012-05-01 10:41:31

PhotonX
Member
From: Munich
Registered: 2008-08-10
Posts: 434

Re: The AMD/ATI Bar & Grill

Unia: I had still /lib/modules/extramodules-3.2-ARCH/ (and /lib/modules/extramodules-3.3-ARCH, too) before the update to 3.4 for some reason. After removing the 3.2 directory I still have the 3.3 one left, but fglrx works again in spite of this fact.


Desktop: http://www.sysprofile.de/id15562, Arch Linux    |    Notebook: Thinkpad X200 Tablet, Manjaro

The very worst thing you can do with free software is to download it, see that it doesn't work for some reason, leave it, and tell your friends that it doesn't work.  -  Tuomas Lukka

Offline

#3912 2012-05-01 15:06:38

Amarus
Member
From: Damascus - Syria
Registered: 2010-09-19
Posts: 6

Re: The AMD/ATI Bar & Grill

Decided to give the kernel upgrade a shot, and it worked without any hassle for me.
I use catalyst-hook and didn't have to do anything, it rebuilt the module by itself and everything is fine after a restart.

Offline

#3913 2012-05-01 22:17:02

achilleas.k
Member
From: Sol 3
Registered: 2011-10-30
Posts: 115

Re: The AMD/ATI Bar & Grill

I also use Catalyst hook without problems, but sometimes I need to rebuild it myself. Dunno why that is, but it's been doing it on and off for a while so I just rebuild anyway.

Offline

#3914 2012-05-02 18:42:22

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 677

Re: The AMD/ATI Bar & Grill

Hi, I'm facing an innocuous but annoying problem. I once tried the open source driver and now I use fglrx. Everything works perfectly but every time I boot I get this error from udev:

udevd[162]: Error running install command for radeon

with varying number between parentheses. I think I have blacklisted the radeon module by creating /etc/modprobe.d/radeon.conf which contains:

install radeon /bin/false

Still I wonder why I get the udev error at boot. Maybe blacklisting is not the correct thing to do to remove the error? Sorry for the maybe-naive question but I don't know udev well.
Thanks

ps. I'm posting here because maybe some Catalyst user faced this before.

Offline

#3915 2012-05-02 19:08:40

GERGE
Member
From: Turkey
Registered: 2008-09-29
Posts: 157
Website

Re: The AMD/ATI Bar & Grill

I wasn't aware that you could blacklist like that. I just write blacklist radeon.

Offline

#3916 2012-05-02 19:42:32

ChemBro
Member
Registered: 2008-10-22
Posts: 691

Re: The AMD/ATI Bar & Grill

$ cat /etc/modprobe.d/blacklist.conf 
blacklist radeon
blacklist radeonfb

Offline

#3917 2012-05-02 21:35:58

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 677

Re: The AMD/ATI Bar & Grill

GERGE wrote:

I wasn't aware that you could blacklist like that. I just write blacklist radeon.

I found that method in this news post:

http://www.archlinux.org/news/changes-t … cklisting/

Anyway, I put the lines ChemBro suggested in my /etc/modprobe.d/radeon.conf. Now I go to bed, tomorrow morning I will reboot and then see what happens...
Meanwhile, thanks for the suggestions! smile

Offline

#3918 2012-05-04 06:52:44

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 677

Re: The AMD/ATI Bar & Grill

OK, doing like ChemBro suggested made it work, thanks. Evidently there's something wrong in the news I mentioned in my previous post...

Offline

#3919 2012-05-04 10:44:22

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,476
Website

Re: The AMD/ATI Bar & Grill

Gotta say that I reinstalled Archand everything is working OOTB with Catalyst 12.4 and the latest kernel


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#3920 2012-05-04 11:54:42

ratcheer
Member
Registered: 2011-10-09
Posts: 531

Re: The AMD/ATI Bar & Grill

Unia wrote:

Gotta say that I reinstalled Archand everything is working OOTB with Catalyst 12.4 and the latest kernel

Did you have to downgrade Xorg to 1.11? The Wiki still says that Catalyst will not work with 1.12.

Tim

Last edited by ratcheer (2012-05-04 11:54:58)

Offline

#3921 2012-05-04 13:05:40

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,476
Website

Re: The AMD/ATI Bar & Grill

ratcheer wrote:
Unia wrote:

Gotta say that I reinstalled Archand everything is working OOTB with Catalyst 12.4 and the latest kernel

Did you have to downgrade Xorg to 1.11? The Wiki still says that Catalyst will not work with 1.12.

Tim

Oh, excuse me. I was aiming for the compatibility between Catalyst 12.4 and kernel 3.3.4. I wasn't talking about xorg versions - but to answer your questions: I am still on xorg111


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#3922 2012-05-04 13:49:07

ratcheer
Member
Registered: 2011-10-09
Posts: 531

Re: The AMD/ATI Bar & Grill

Unia wrote:
ratcheer wrote:
Unia wrote:

Gotta say that I reinstalled Archand everything is working OOTB with Catalyst 12.4 and the latest kernel

Did you have to downgrade Xorg to 1.11? The Wiki still says that Catalyst will not work with 1.12.

Tim

Oh, excuse me. I was aiming for the compatibility between Catalyst 12.4 and kernel 3.3.4. I wasn't talking about xorg versions - but to answer your questions: I am still on xorg111

Ok, thank you. But you said you reinstalled Arch, so that should have given you Xorg 1.12. So, I figured you were either on 1.12 OOTB or you downgraded it.

Tim

Last edited by ratcheer (2012-05-04 13:49:40)

Offline

#3923 2012-05-04 14:24:46

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,476
Website

Re: The AMD/ATI Bar & Grill

^ I did quickly try the opensource driver so initially I was on xorg112, yes. The opensource driver gave me artifacts and terrible performance though, so either it's not fully functional (what I don't expect) or I missed something (what I'd rather expect tongue). Hence I installed Catalyst again and downgraded to xorg111

Is there any expectation for xorg112 support? I heard it's gonna be 12.6 as earliest...


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#3924 2012-05-09 14:30:15

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,476
Website

Re: The AMD/ATI Bar & Grill

I would like to try GNOME Shell again - but before I install it, I'd like to know how the performance currently is with Catalyst. Is it worth testing, or is it still unstable/slow/artifacts etc?


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#3925 2012-05-09 14:55:58

xsmile
Member
Registered: 2012-03-31
Posts: 21

Re: The AMD/ATI Bar & Grill

It performed quite well on my netbook with an AMD E-350 / Radeon 6320 chipset.
You will probably need to set 'export CLUTTER_VBLANK=none' in your profile for better performance though.

Offline

Board footer

Powered by FluxBB