You are not logged in.

#4976 2013-03-20 02:27:29

freestyler7
Member
Registered: 2010-11-02
Posts: 33

Re: The AMD/ATI Bar & Grill

Since yesterday using hd234k repo:

error: failed retrieving file 'amdoverdrivectrl-1.2.3-1-x86_64.pkg.tar.xz' from catalyst.wirephire.com : The requested URL returned error: 404 Not Found

I'm a bit confused. I have an hd4870 card. I'm on catalyst 13.1. Is this correct?
Why the person some posts above uses 12.6 with the same card?

Offline

#4977 2013-03-20 04:03:48

32reg
Member
Registered: 2012-08-06
Posts: 23
Website

Re: The AMD/ATI Bar & Grill

Why the person some posts above uses 12.6 with the same card?

Because i don't to play wine games with catalyst 13.1 from catalyst-hd234 repo.


http://linux32.ru - blog about linux

Offline

#4978 2013-03-20 07:50:02

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,305
Website

Re: The AMD/ATI Bar & Grill

kanazky wrote:

but fglrxinfo returns:

No display found(null)

Good, the log is clean now. What DE are you usiing? What GPU you have? Can you paste /etc/X11/xorg.conf (and ~/.xsession-errors if exists)?

freestyler7 wrote:

Since yesterday using hd234k repo:

error: failed retrieving file 'amdoverdrivectrl-1.2.3-1-x86_64.pkg.tar.xz' from catalyst.wirephire.com : The requested URL returned error: 404 Not Found

Thanks, i will fix it later today.

Offline

#4979 2013-03-20 21:21:54

Zucca
Member
From: KUUSANKOSKI, Finland
Registered: 2009-02-26
Posts: 135

Re: The AMD/ATI Bar & Grill

I have just bought Radeon 7850. Now I want to use it for few tasks that need OpenCL (boost).
I have read here and there a lot of things and let me say: This sure ain't KISS. big_smile
It seems to me that man must go trough the quest of PITA before man can utilize the power of OpenCL! I hope I'm at least half way there.
Being user of FOSS drivers before this day was bliss...

So far I have downgraded my xorg-server to 1.13. I have also booted my machine more than enough.
I thought I had something wrong with my X configs... Logs say that all are ok... Because the nature of my problem I ran

aticonfig --acpi-services=off

and I thought I could handle it. No way. That didn't change anything.
Now the problem: X won't start. It just hangs, no bad lines on logs. X sits on one core utilizing it fully... for nothing. wink
I can kill X (with -9), but my monitors stay blank.

The exotic part: I have one old CRT with max resolution of 640x480, connected via VGA. CRT does not tell anything reasonable to my machine. It actually states that it can display 1080i resolution. I think this is just X server guessing things. It's -89 CRT, a RELIC almost. The other monitor is my TV connected via HDMI with max resolution on 720p but it tells X that it has better cababilities (also).
CRT is connected via DVI using VGA adapter.

Still I don't think X should freeze there.

ANY clues?

Last edited by Zucca (2013-03-20 21:29:42)


K.i.s.s. <3

Offline

#4980 2013-03-20 22:37:06

Ephexeve
Member
From: Amsterdam
Registered: 2012-03-21
Posts: 13
Website

Re: The AMD/ATI Bar & Grill

Hey, I am having this error after installing catalyst! Anyone also has? Cheers!

/h/ephexeve # ❯❯❯ pacman -S catalyst catalyst-utils
warning: catalyst-13.3-2 is up to date -- reinstalling
warning: catalyst-utils-13.3-2 is up to date -- reinstalling
resolving dependencies...
looking for inter-conflicts...

Targets (2): catalyst-13.3-2  catalyst-utils-13.3-2

Total Installed Size:   144.93 MiB
Net Upgrade Size:       0.00 MiB

Proceed with installation? [Y/n] 
(2/2) checking package integrity                                                                     [############################################################] 100%
(2/2) loading package files                                                                          [############################################################] 100%
(2/2) checking for file conflicts                                                                    [############################################################] 100%
(2/2) checking available disk space                                                                  [############################################################] 100%
(1/2) upgrading catalyst-utils                                                                       [############################################################] 100%
----------------------------------------------------------------
PLEASE NOTE:
For these drivers to work, you must install kernel modules.
Depending on your kernel, these module packages are named
catalyst-$kernel and stock kernel module is catalyst

OR simply use packages that provides auto re-compilation:
catalyst-hook

OR use catalyst-generator package to generate catalyst-{kernver}
packages
----------------------------------------------------------------
You can use the tool 'aticonfig' to generate an xorg.conf file.
--------------------- ^^^^^^^^^ --------------------------------
Add nomodeset to your kernel line in /boot/grub/menu.lst , ie.:
kernel /boot/vmlinuz-linux root=/dev/sda1 ro nomodeset
----------------------------------------------------------------
IMPORTANT:
fglrx was added into /etc/modules-load.d/catalyst.conf
----------------------------------------------------------------
	atieventsd (needs acpid pkg) on systemd:
systemctl enable atieventsd
systemctl start atieventsd
----------------------------------------------------------------
For more info and troubleshooting visit:
http://wiki.archlinux.org/index.php/ATI_Catalyst
----------------------------------------------------------------
(2/2) upgrading catalyst                                                                             [############################################################] 100%
/tmp/alpm_STRGS2/.INSTALL: line 35: unexpected EOF while looking for matching `"'
/tmp/alpm_STRGS2/.INSTALL: line 37: syntax error: unexpected end of file
error: command failed to execute correctly

- Ephexeve M
Python - C - Bash - Perl - Ruby - Linux - Security
Archlinux - i3 - Emacs

Offline

#4981 2013-03-21 07:51:24

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,305
Website

Re: The AMD/ATI Bar & Grill

@Zucca:
I would start with one display connected.
Tv could be better for the first run, you can specify it's resolution in same way i mentioned below. But before changing this check out how it will behave with clean aticonfig's generated xorg.conf.
As for crt : have you tried fighting with your crt via xorg.conf and some of it's options, like resolution, horizontal and vertical refresh etc?
In Screen Section you can precise resoultion, ie:

    SubSection "Display"
        Depth        16
        Modes      "1024x768_75.00"
    EndSubSection

In Monitor Section you can precise refresh [but be carefull with it, you should paste your monitor' real values, info about that is often available in user's manual], ie:

    HorizSync     31-101
    VertRefresh    60-160

@Ephexeve:
thanks for the info! I will fix it after getting back home
edit: should be fine

btw meanwhile AMD has updated 13.1, changed files are in /etc/ati/:
- amdpcsdb.default
- control
- signature
and so, also i have updated AUR's catalyst-total* packages and [catalyst-stable] repo's utils*

Last edited by Vi0L0 (2013-03-21 20:10:28)

Offline

#4982 2013-03-21 11:17:55

Zucca
Member
From: KUUSANKOSKI, Finland
Registered: 2009-02-26
Posts: 135

Re: The AMD/ATI Bar & Grill

Nope. Same result.
As I thought... X doesn't ever start wm there. So it gets stuck on infinite loop (100% usage on one core) after reading xorg.conf but before starting any other programs such as wm.
I have to kill X with -9 since normal -15 won't help. And even after that my monitors are blank. TV actually says that it does not receive any signal.
I strongly believe, that it's not the configs that are creating the mess here...

+

# pacman -Q catalyst xorg-server
catalyst 13.1-5
xorg-server 1.13.3-1

Xorg.0.log

[   309.554] 
X.Org X Server 1.13.3
Release Date: 2013-03-07
[   309.554] X Protocol Version 11, Revision 0
[   309.554] Build Operating System: Linux 3.8.2-1-ARCH x86_64 
[   309.554] Current Operating System: Linux zelan 3.8.3-2-ARCH #1 SMP PREEMPT Sun Mar 17 13:04:22 CET 2013 x86_64
[   309.554] Kernel command line: root=UUID=589b4295-a423-4d21-8e96-3dd5bc846524 ro init=/usr/lib/systemd/systemd btrfs fglrx nomodeset mii r8169 video=VGA-1:640x480-16 initrd=../initramfs-linux.img BOOT_IMAGE=../vmlinuz-linux 
[   309.555] Build Date: 09 March 2013  08:45:37AM
[   309.555]  
[   309.555] Current version of pixman: 0.28.2
[   309.555] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[   309.555] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   309.557] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Mar 21 14:36:32 2013
[   309.569] (==) Using config file: "/etc/X11/xorg.conf"
[   309.569] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   309.569] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   309.590] (==) ServerLayout "aticonfig Layout"
[   309.590] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[   309.590] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[   309.590] (**) |   |-->Device "aticonfig-Device[0]-0"
[   309.590] (==) Automatically adding devices
[   309.590] (==) Automatically enabling devices
[   309.591] (==) Automatically adding GPU devices
[   309.639] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[   309.639] 	Entry deleted from font path.
[   309.639] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[   309.639] 	Entry deleted from font path.
[   309.639] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[   309.639] 	Entry deleted from font path.
[   309.639] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[   309.639] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[   309.639] 	Entry deleted from font path.
[   309.639] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[   309.639] (==) FontPath set to:
	/usr/share/fonts/misc/,
	/usr/share/fonts/TTF/
[   309.639] (==) ModulePath set to "/usr/lib/xorg/modules"
[   309.639] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[   309.639] (II) Loader magic: 0x7fcc20
[   309.639] (II) Module ABI versions:
[   309.639] 	X.Org ANSI C Emulation: 0.4
[   309.639] 	X.Org Video Driver: 13.1
[   309.639] 	X.Org XInput driver : 18.0
[   309.639] 	X.Org Server Extension : 7.0
[   309.640] (II) config/udev: Adding drm device (/dev/dri/card0)
[   309.671] (--) PCI:*(0:1:0:0) 1002:6819:1682:3264 rev 0, Mem @ 0xc0000000/268435456, 0xfea00000/262144, I/O @ 0x0000e000/256, BIOS @ 0x????????/131072
[   309.671] Initializing built-in extension Generic Event Extension
[   309.672] Initializing built-in extension SHAPE
[   309.672] Initializing built-in extension MIT-SHM
[   309.672] Initializing built-in extension XInputExtension
[   309.672] Initializing built-in extension XTEST
[   309.672] Initializing built-in extension BIG-REQUESTS
[   309.672] Initializing built-in extension SYNC
[   309.672] Initializing built-in extension XKEYBOARD
[   309.672] Initializing built-in extension XC-MISC
[   309.672] Initializing built-in extension SECURITY
[   309.672] Initializing built-in extension XINERAMA
[   309.672] Initializing built-in extension XFIXES
[   309.672] Initializing built-in extension RENDER
[   309.673] Initializing built-in extension RANDR
[   309.673] Initializing built-in extension COMPOSITE
[   309.673] Initializing built-in extension DAMAGE
[   309.673] Initializing built-in extension MIT-SCREEN-SAVER
[   309.673] Initializing built-in extension DOUBLE-BUFFER
[   309.673] Initializing built-in extension RECORD
[   309.673] Initializing built-in extension DPMS
[   309.673] Initializing built-in extension X-Resource
[   309.673] Initializing built-in extension XVideo
[   309.673] Initializing built-in extension XVideo-MotionCompensation
[   309.673] Initializing built-in extension XFree86-VidModeExtension
[   309.673] Initializing built-in extension XFree86-DGA
[   309.674] Initializing built-in extension XFree86-DRI
[   309.674] Initializing built-in extension DRI2
[   309.674] (II) "glx" will be loaded by default.
[   309.674] (II) LoadModule: "glx"
[   309.695] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   309.718] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[   309.718] 	compiled for 6.9.0, module version = 1.0.0
[   309.719] Loading extension GLX
[   309.719] (II) LoadModule: "fglrx"
[   309.730] (II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
[   309.913] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[   309.913] 	compiled for 1.4.99.906, module version = 9.1.11
[   309.913] 	Module class: X.Org Video Driver
[   309.928] (II) Loading sub module "fglrxdrm"
[   309.928] (II) LoadModule: "fglrxdrm"
[   309.928] (II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
[   309.961] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[   309.961] 	compiled for 1.4.99.906, module version = 9.1.11
[   309.961] (II) AMD Proprietary Linux Driver Version Identifier:9.01.11
[   309.961] (II) AMD Proprietary Linux Driver Release Identifier: 9.012                                
[   309.961] (II) AMD Proprietary Linux Driver Build Date: Dec 19 2012 14:41:10
[   309.961] (++) using VT number 1

[   309.963] (WW) Falling back to old probe method for fglrx
[   310.053] (II) Loading PCS database from /etc/ati/amdpcsdb /etc/ati/amdpcsdb.default
[   310.055] ukiDynamicMajor: found major device number 249
[   310.055] ukiDynamicMajor: found major device number 249
[   310.056] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[   310.056] ukiOpenDevice: node name is /dev/ati/card0
[   310.056] ukiOpenDevice: open result is 9, (OK)
[   310.145] ukiOpenByBusid: ukiOpenMinor returns 9
[   310.145] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[   310.160] (--) Chipset Supported AMD Graphics Processor (0x6819) found
[   310.161] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:0:0) found
[   310.161] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:2:0) found
[   310.161] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:4:0) found
[   310.161] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:5:0) found
[   310.162] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:6:0) found
[   310.162] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:9:0) found
[   310.162] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:10:0) found
[   310.162] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:17:0) found
[   310.162] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:0) found
[   310.162] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:2) found
[   310.162] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:0) found
[   310.162] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:2) found
[   310.162] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:0) found
[   310.162] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:1) found
[   310.162] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:2) found
[   310.162] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:3) found
[   310.162] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:4) found
[   310.162] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:5) found
[   310.162] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:21:0) found
[   310.162] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:22:0) found
[   310.162] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:22:2) found
[   310.162] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
[   310.163] (II) AMD Video driver is running on a device belonging to a group targeted for this release
[   310.174] (II) AMD Video driver is signed
[   310.175] (II) fglrx(0): pEnt->device->identifier=0x1bab040
[   310.175] (II) fglrx(0): === [xdl_xs113_atiddxPreInit] === begin
[   310.175] (II) Loading sub module "vgahw"
[   310.175] (II) LoadModule: "vgahw"
[   310.175] (II) Loading /usr/lib/xorg/modules/libvgahw.so
[   310.188] (II) Module vgahw: vendor="X.Org Foundation"
[   310.188] 	compiled for 1.13.3, module version = 0.1.0
[   310.188] 	ABI class: X.Org Video Driver, version 13.1
[   310.188] (**) fglrx(0): Depth 24, (--) framebuffer bpp 32
[   310.188] (II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[   310.188] (==) fglrx(0): Default visual is TrueColor
[   310.188] (**) fglrx(0): Option "DPMS" "true"
[   310.188] (==) fglrx(0): RGB weight 888
[   310.188] (II) fglrx(0): Using 8 bits per RGB 
[   310.188] (==) fglrx(0): Buffer Tiling is ON
[   310.188] (II) Loading sub module "fglrxdrm"
[   310.189] (II) LoadModule: "fglrxdrm"
[   310.189] (II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
[   310.189] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[   310.189] 	compiled for 1.4.99.906, module version = 9.1.11
[   310.191] ukiDynamicMajor: found major device number 249
[   310.191] ukiDynamicMajor: found major device number 249
[   310.191] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[   310.191] ukiOpenDevice: node name is /dev/ati/card0
[   310.191] ukiOpenDevice: open result is 12, (OK)
[   310.191] ukiOpenByBusid: ukiOpenMinor returns 12
[   310.191] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[   310.191] (**) fglrx(0): NoAccel = NO
[   310.191] (**) fglrx(0): AMD 2D Acceleration Architecture enabled
[   310.191] (--) fglrx(0): Chipset: "AMD Radeon HD 7800 Series " (Chipset = 0x6819)
[   310.191] (--) fglrx(0): (PciSubVendor = 0x1682, PciSubDevice = 0x3264)
[   310.192] (==) fglrx(0): board vendor info: third party graphics adapter - NOT original AMD
[   310.192] (--) fglrx(0): Linear framebuffer (phys) at 0xc0000000
[   310.192] (--) fglrx(0): MMIO registers at 0xfea00000
[   310.192] (--) fglrx(0): I/O port at 0x0000e000
[   310.192] (==) fglrx(0): ROM-BIOS at 0x000c0000
[   310.208] (II) fglrx(0): AC Adapter is used

Last edited by Zucca (2013-03-21 12:51:38)


K.i.s.s. <3

Offline

#4983 2013-03-21 15:27:37

32reg
Member
Registered: 2012-08-06
Posts: 23
Website

Re: The AMD/ATI Bar & Grill

I can prepare such update, maybe later today i will find time.
edit: done. I've removed catalyst and catalyst-lts packages, please use hook or generator

Vi0L0 thanks. now everything is well


http://linux32.ru - blog about linux

Offline

#4984 2013-03-21 18:45:34

Zucca
Member
From: KUUSANKOSKI, Finland
Registered: 2009-02-26
Posts: 135

Re: The AMD/ATI Bar & Grill

So... Stupid mistakes are hard to find when you don't get proper error output (ie. nothing). So I finally found out what was it freezing my X.
Radeon module. Found it by grepping lsmod. So. Simple solution:

modprobe.blacklist=radeon

to kernel parameters on my bootloader config.

Problem solved! Waiting another to come... wink Propably something OpenCL related. Hopefully it goes by first shot.


K.i.s.s. <3

Offline

#4985 2013-03-21 21:47:04

DarksideEE7
Member
From: Arkansas, United States
Registered: 2009-06-06
Posts: 356

Re: The AMD/ATI Bar & Grill

Well this bug is quite the pain in the ass.  This is the second time X has completely crashed while minimizing and/or restoring konsole.  Really hard to work like this.....here is the info from .xsessions-errors if anyone is having the problem.  This only happens with konsole.

X Error: BadValue (integer parameter out of range for operation) 2
  Major opcode: 53 (X_CreatePixmap)
  Resource id:  0x0
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 14 (X_GetGeometry)
  Resource id:  0xc0009c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 3 (X_GetWindowAttributes)
  Resource id:  0xa053d0
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Extension:    140 (RENDER)
  Minor opcode: 4 (RenderCreatePicture)
  Resource id:  0xc0009c
X Error: RenderBadPicture (invalid Picture parameter) 143
  Extension:    140 (RENDER)
  Minor opcode: 7 (RenderFreePicture)
  Resource id:  0xc0009c
X Error: BadValue (integer parameter out of range for operation) 2
  Major opcode: 53 (X_CreatePixmap)
  Resource id:  0x0
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 14 (X_GetGeometry)
  Resource id:  0xc0009e
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 3 (X_GetWindowAttributes)
  Resource id:  0x387dbf20
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Extension:    140 (RENDER)
  Minor opcode: 4 (RenderCreatePicture)
  Resource id:  0xc0009e
X Error: RenderBadPicture (invalid Picture parameter) 143
  Extension:    140 (RENDER)
  Minor opcode: 7 (RenderFreePicture)
  Resource id:  0xc0009e
X Error: BadValue (integer parameter out of range for operation) 2
  Major opcode: 53 (X_CreatePixmap)
  Resource id:  0x0
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 14 (X_GetGeometry)
  Resource id:  0xc000a0
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 3 (X_GetWindowAttributes)
  Resource id:  0xa053f8
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Extension:    140 (RENDER)
  Minor opcode: 4 (RenderCreatePicture)
  Resource id:  0xc000a0
X Error: RenderBadPicture (invalid Picture parameter) 143
  Extension:    140 (RENDER)
  Minor opcode: 7 (RenderFreePicture)
  Resource id:  0xc000a0
X Error: BadValue (integer parameter out of range for operation) 2
  Major opcode: 53 (X_CreatePixmap)
  Resource id:  0x0
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 14 (X_GetGeometry)
  Resource id:  0xc000a2
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 3 (X_GetWindowAttributes)
  Resource id:  0x387dbf20
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Extension:    140 (RENDER)
  Minor opcode: 4 (RenderCreatePicture)
  Resource id:  0xc000a2
X Error: RenderBadPicture (invalid Picture parameter) 143
  Extension:    140 (RENDER)
  Minor opcode: 7 (RenderFreePicture)
  Resource id:  0xc000a2
X Error: BadValue (integer parameter out of range for operation) 2
  Major opcode: 53 (X_CreatePixmap)
  Resource id:  0x0
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 14 (X_GetGeometry)
  Resource id:  0xc000a4
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 3 (X_GetWindowAttributes)
  Resource id:  0xa053e8
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Extension:    140 (RENDER)
  Minor opcode: 4 (RenderCreatePicture)
  Resource id:  0xc000a4
X Error: RenderBadPicture (invalid Picture parameter) 143
  Extension:    140 (RENDER)
  Minor opcode: 7 (RenderFreePicture)
  Resource id:  0xc000a4
X Error: BadValue (integer parameter out of range for operation) 2
  Major opcode: 53 (X_CreatePixmap)
  Resource id:  0x0
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 14 (X_GetGeometry)
  Resource id:  0xc000a6
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 3 (X_GetWindowAttributes)
  Resource id:  0xa08b00
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Extension:    140 (RENDER)
  Minor opcode: 4 (RenderCreatePicture)
  Resource id:  0xc000a6
X Error: RenderBadPicture (invalid Picture parameter) 143
  Extension:    140 (RENDER)
  Minor opcode: 7 (RenderFreePicture)
  Resource id:  0xc000a6

Offline

#4986 2013-03-21 23:02:07

kanazky
Member
From: Vancouver, Canada
Registered: 2011-11-02
Posts: 60

Re: The AMD/ATI Bar & Grill

Thanks Vi0L0, Everything is working great big_smile Thanks for the maintenance, the Catalyst-Hook worked perfect.


Archlinx + DWM big_smile I love Wingo-WM Bring it back!!

Offline

#4987 2013-03-22 11:40:50

pYrO1v1aniac
Member
Registered: 2011-11-03
Posts: 46

Re: The AMD/ATI Bar & Grill

As of the latest catalyst-test, the atiwatermark.sh file (to remove the unsupported hardware watermark) is now causing X to fail.

I shouldn't have the unsupported hardware watermark anyway given my card is a 5470 but I've always had to use this script to remove it.

Offline

#4988 2013-03-22 12:50:36

MadNoob
Member
Registered: 2013-03-10
Posts: 18

Re: The AMD/ATI Bar & Grill

I've some problems when i try to switch to internal VGA.

System freezes before login manager(it happens with every login manager). I can't go graphical... can anyone help me?

I can use internal only with 13.2beta...

Offline

#4989 2013-03-23 16:56:03

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,305
Website

Re: The AMD/ATI Bar & Grill

Maybe 13.3 beta 3 will work better for you? I've just updated catalyst-test@AUR and [catalyst] repo.
Release Notes

Offline

#4990 2013-03-24 00:01:48

jik779
Member
From: Germany
Registered: 2012-08-04
Posts: 17

Re: The AMD/ATI Bar & Grill

Hey Vi0l0, I appreciate your Work very much! big_smile

I have a question though: Would you make your pkgbuilds for the packages of the backported xorg-113 in your repo available for us?

I would be really grateful, because i'd like to compile them by myself tongue

Offline

#4991 2013-03-24 11:44:07

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,305
Website

Re: The AMD/ATI Bar & Grill

Packages in xorg113 are just copy-pasted from [extra] repo.
I can give you a pkgbuilds of the packages from abs snapshot that i have taken some time ago, xorg-server is in version 1.13.2.901, so kinda close, just update version and md5 sum and you are ready to compile.

Offline

#4992 2013-03-24 13:12:36

Robotman
Member
Registered: 2013-03-15
Posts: 56

Re: The AMD/ATI Bar & Grill

Trying to upgrade gives me this error:

:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: catalyst-utils and xorg-server are in conflict (xorg-server>=1.14.0)

Offline

#4993 2013-03-24 13:27:42

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,472
Website

Re: The AMD/ATI Bar & Grill

Robotman wrote:

Trying to upgrade gives me this error:

:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: catalyst-utils and xorg-server are in conflict (xorg-server>=1.14.0)

Catalyst can't get along with xorg-server 1.14. You have to keep xorg 1.13.


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#4994 2013-03-24 22:11:05

Robotman
Member
Registered: 2013-03-15
Posts: 56

Re: The AMD/ATI Bar & Grill

Is there a way to "pin" packages in Arch, like in Debian?

Offline

#4995 2013-03-25 03:30:25

Robotman
Member
Registered: 2013-03-15
Posts: 56

Re: The AMD/ATI Bar & Grill

You know, keep one package at a certain version, but upgrade the rest of the system?

I googled, but I didn't see anything.

Offline

#4996 2013-03-25 03:35:59

DarksideEE7
Member
From: Arkansas, United States
Registered: 2009-06-06
Posts: 356

Re: The AMD/ATI Bar & Grill

Robotman wrote:

You know, keep one package at a certain version, but upgrade the rest of the system?

I googled, but I didn't see anything.

--ignore <package>

Man pages!

Offline

#4997 2013-03-25 03:41:32

Robotman
Member
Registered: 2013-03-15
Posts: 56

Re: The AMD/ATI Bar & Grill

Thanks!

Doing "pacman -Syu --ignore xorg-server --ignore xf86-input-evdev" let me upgrade.

Guess I'll have to keep doing that for as long as I keep using the catalyst driver. Drag.

Offline

#4998 2013-03-25 03:47:06

DarksideEE7
Member
From: Arkansas, United States
Registered: 2009-06-06
Posts: 356

Re: The AMD/ATI Bar & Grill

I'm about to give catalyst-test a shot....hopefully it will fix my xorg crash problem :\

Robotman wrote:

Thanks!

Doing "pacman -Syu --ignore xorg-server --ignore xf86-input-evdev" let me upgrade.

Guess I'll have to keep doing that for as long as I keep using the catalyst driver. Drag.

It would be easier to just enable the xorg113 repo using the directions here:
https://wiki.archlinux.org/index.php/Ca … xorg113.5D

Make sure to put it before the other repos in pacman.conf so it won't try to upgrade when it pacman sees a newer version.

Last edited by DarksideEE7 (2013-03-25 03:52:37)

Offline

#4999 2013-03-25 04:04:55

Robotman
Member
Registered: 2013-03-15
Posts: 56

Re: The AMD/ATI Bar & Grill

Cool. Only thing is, it gives this error:

error: database 'xorg113' is not valid (invalid or corrupted database (PGP signature))

Offline

#5000 2013-03-25 04:19:02

DarksideEE7
Member
From: Arkansas, United States
Registered: 2009-06-06
Posts: 356

Re: The AMD/ATI Bar & Grill

Robotman wrote:

Cool. Only thing is, it gives this error:

error: database 'xorg113' is not valid (invalid or corrupted database (PGP signature))

Trying clearing cache and syncing again I suppose.  I got that when I tried a few minutes ago when I added it before updating. 

sudo pacman -Scc
sudo pacman -Syy

Offline

Board footer

Powered by FluxBB