You are not logged in.

#5126 2013-04-11 14:54:13

gh403
Member
Registered: 2012-09-15
Posts: 22

Re: The AMD/ATI Bar & Grill

Okay... I have a PowerXpress A+I setup and I want to try the Catalyst 13.3 beta because I saw that they've fixed a bunch of bugs.  I'm slightly confused by all the myriad ways to try to get Catalyst working though.  As I see it, you need

- X.org 1.13 from [xorg113]
- Some package of Catalyst, with special support for PXP.

What is the "best" (subjective I know but) way to get my A+I setup working?

Offline

#5127 2013-04-11 16:41:22

pYrO1v1aniac
Member
Registered: 2011-11-03
Posts: 46

Re: The AMD/ATI Bar & Grill

I caved and switched back to xf86-video-ati

Too much fixing broken system, too many bugs and hard system freezes (like switching to fullscreen in minecraft causes Xorg to crash on Catalyst-test) and a horrible AMD Unsupported Hardware watermark (even though the card is 5000 series).

I just wanted to thank Violio for his efforts helping all of us out. I might try catalyst again in the future, but for now it's definitely a no-go.

On the plus side Xf86-video-ati is managing only 20FPS less than Catalyst now in TF2 and Minecraft, and video playback is much much smoother.

Offline

#5128 2013-04-11 17:40:43

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,300
Website

Re: The AMD/ATI Bar & Grill

Ok, so with the new fixed catalyst-hook i have update AUR and repos: [catalyst], [catalyst-stable], [catalyst-12.10], [catalyst-12.8], [catalyst-hd234k], [catalyst-hd234k-12.4], [catalyst-hd234k-12.6]


snack wrote:

It seems that most of the recent problems with catalyst reported in this thread boil down to old fglrx kernel modules, and that a simple module rebuild fixes everything most of the times. Vi0l0, should you put back Angela on post install message to make everyone aware of this thing?? wink

Naaaaaah, Angela should not be used to every case, she's not that easy! She's The Slayer Of The Daemons, you know. The ASCII art could show her in a bad light, here's her real face tongue smile
But you are right - catalyst package became problematic, maybe simple Wiki note will do the magick...


@ringtail:
well... I red windows' users posts who were backporting catalyst's 11.x libraries into 12.x, because as they said 12.x bring many many bad things into the driver - maybe same situation touched you?


@gh403:
read this note about pxp, if you want fresh beta drivers use [catalyst] repo and catalyst-utils-pxp (+ ecentually lib32-catalyst-utils-pxp) package from it. If it won't start on linux 3.8, downgrade to 3.7 and let us know if this helped


BTW: i'm wondering what's phoronix doing by presenting oldie 13.3 beta 3 as a fresh driver, heh...

Last edited by Vi0L0 (2013-04-11 17:43:10)

Offline

#5129 2013-04-11 17:50:54

GordonGR
Member
From: Thessaloniki, Greece
Registered: 2011-11-07
Posts: 235

Re: The AMD/ATI Bar & Grill

Hallo guys.

I bought a shiny new Sapphire 5450. I installed in on the motherboard, connected it to the monitor, informed my BIOS not to use my onboard Intel GPU and starting following the wiki's instructions to install the Catalyst driver, from vi0l0's unofficial repository.

I did everything as the wiki said (I opted for Catalyst-generator). The system boots, X starts, video plays but I have no OpenGL. glxinfo gives

nikos@Russell:~$ glxinfo
name of display: :0.0
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  16
  Current serial number in output stream:  16

Also:

nikos@Russell:~$ lsmod | grep fglrx
fglrx                5089735  94 
amd_iommu_v2            7188  1 fglrx
button                  4701  1 fglrx
nikos@Russell:~$ lsmod | grep i915
nikos@Russell:~$ fgl_glxgears
Using GLX_SGIX_pbuffer
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  16
  Current serial number in output stream:  16
nikos@Russell:~$ glxgears
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  16
  Current serial number in output stream:  16

I'm really tired and can't read 200 pages, for which I apologise right from the start. What do I do wrong?

Oh, my /etc/X11/xorg.conf is:

nikos@Russell:~$ cat /etc/X11/xorg.conf
Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:4:0:0"
	Option      "OpenGLOverlay" "0"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "DRI"
	Mode 0666
EndSection

Also, per wiki instructions:

nikos@Russell:~$ grep '(EE)' /var/log/Xorg.0.log
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    49.786] (EE) AIGLX error: failed to load OpenGL driver
[    49.786] (EE) AIGLX: reverting to software rendering
nikos@Russell:~$ grep '(WW)' /var/log/Xorg.0.log
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    48.857] (WW) Falling back to old probe method for fglrx
[    49.009] (WW) fglrx: No matching Device section for instance (BusID PCI:0@4:0:1) found
[    49.203] (WW) fglrx(0): board is an unknown third party board, chipset is supported
[    49.658] (WW) fglrx(0): Option "VendorName" is not used
[    49.658] (WW) fglrx(0): Option "ModelName" is not used

Thanks in advance, everyone.

EDIT:

nikos@Russell:/usr/lib/xorg/modules/dri$ LIBGL_DEBUG=verbose glxinfo > /dev/nulllibGL: AtiGetClientDriverName: 9.1.11 fglrx (screen 0)
libGL: OpenDriver: trying /usr/lib/xorg/modules/dri//fglrx_dri.so
libGL: OpenDriver: trying /usr/lib32/xorg/modules/dri/fglrx_dri.so
libGL error: dlopen fglrx_dri.so failed
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  16
  Current serial number in output stream:  16

The files are, of course, there.

Last edited by GordonGR (2013-04-11 20:49:09)


Intel(R) Celeron(R) CPU E3400 @ 2.60GHz, 1878 MB, XFCE 4.12, x86_64. AURs.

“No one without the knowledge of geometry may enter.“ Plato.

Offline

#5130 2013-04-11 19:50:54

kanazky
Member
From: Vancouver, Canada
Registered: 2011-11-02
Posts: 60

Re: The AMD/ATI Bar & Grill

Just came to thank you for upping Catalyst to 13.3-9 Beta big_smile Works great with catalyst-hook! Thanks for the timely updates smile Making ATI video card not a massive hassle haha!


Archlinx + DWM big_smile I love Wingo-WM Bring it back!!

Offline

#5131 2013-04-12 00:06:17

Beelzebud
Member
From: Illinois, U.S.
Registered: 2010-07-16
Posts: 154

Re: The AMD/ATI Bar & Grill

I just updated my catalyst-hook drivers with the 13.3-9 Beta, and it worked great!   Just like it used to.   Thank you very much for the work you put in to this.

Offline

#5132 2013-04-12 12:15:42

GordonGR
Member
From: Thessaloniki, Greece
Registered: 2011-11-07
Posts: 235

Re: The AMD/ATI Bar & Grill

Argh! I tried as the people above (switching [catalyst-stable] to [catalyst] and catalyst to catalyst-hook), but the same problems remains. Argh!


Intel(R) Celeron(R) CPU E3400 @ 2.60GHz, 1878 MB, XFCE 4.12, x86_64. AURs.

“No one without the knowledge of geometry may enter.“ Plato.

Offline

#5133 2013-04-12 20:30:53

GordonGR
Member
From: Thessaloniki, Greece
Registered: 2011-11-07
Posts: 235

Re: The AMD/ATI Bar & Grill

Hmm... I don't know if I made it better or worse, but, I tried catalyst-total from the AUR, and now I get:

nikos@Russell:~$ LIBGL_DEBUG=verbose glxinfo > /dev/null
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  155 (ATIFGLEXTENSION)
  Minor opcode of failed request:  66 ()
  Serial number of failed request:  13
  Current serial number in output stream:  13

That is, instead of complaining it can't find the .so files, it just claims "bad request".

Which makes sense, since

nikos@Russell:/usr/lib/xorg/modules/dri$ ls -l /usr/lib/xorg/modules/dri/fglrx_dri.so
lrwxrwxrwx 1 root root 38 Απρ  12 21:59 /usr/lib/xorg/modules/dri/fglrx_dri.so -> /usr/lib/xorg/modules/dri/fglrx_dri.so
nikos@Russell:/usr/lib/xorg/modules/dri$ whereis fglrx_dri.so
fglrx_dri:

WTH am I doing wrong here?


Intel(R) Celeron(R) CPU E3400 @ 2.60GHz, 1878 MB, XFCE 4.12, x86_64. AURs.

“No one without the knowledge of geometry may enter.“ Plato.

Offline

#5134 2013-04-12 22:07:45

GordonGR
Member
From: Thessaloniki, Greece
Registered: 2011-11-07
Posts: 235

Re: The AMD/ATI Bar & Grill

Okay, I apologise. I'm a complete idiot. I forgot I had made some changes in order for my onboard Intel to work better. I reverted them, reinstalled catalyst-hook from the unofficial repo and everything is fine. :-D


Intel(R) Celeron(R) CPU E3400 @ 2.60GHz, 1878 MB, XFCE 4.12, x86_64. AURs.

“No one without the knowledge of geometry may enter.“ Plato.

Offline

#5135 2013-04-13 09:03:45

Primoz
Member
From: Ljubljana-Slovena-EU
Registered: 2009-03-04
Posts: 661

Re: The AMD/ATI Bar & Grill

Anyone tested newest driver with wine, especially 3D directX games? I'm asking because I tried to play Medieval 2: Total War yesterday and the shaders in the game went nuts.
Now I don't know if that's because I did something wrong while migrating from catalyst in Arch repos to ViOLO's, or is it just because it's not completely compatible.
I don't have many 3D games installed so I can't really say, but Age of Empires 2 works as good as always.

I'm using catalyst-hook, from catalyst.

Maybe I should mention, that I used a "dirty trick" when migrating from catalyst-dkms to catalyst-hook, I was to lazy to remove all those dependencies on it and just removed .so which prevented the new catalyst to install.
So it might be that my method was to dirty and there are things left from the previous catalyst versions somewhere. I did uninstall it once I installed the new catalyst, and everything else works.


Arch x86_64 ATI AMD APU KDE frameworks 5
---------------------------------
Whatever I do, I always end up with something horribly mis-configured.

Offline

#5136 2013-04-13 14:58:23

BotoX
Member
Registered: 2013-04-13
Posts: 4

Re: The AMD/ATI Bar & Grill

I am trying to overclock my monitor from 60 Hz to 80 Hz.
I've achieved this with simple commands with the open source radeon driver:

xrandr --newmode "2560x1440_80.00"  425.00  2560 2760 3040 3520  1440 1443 1448 1510 -hsync +vsync
xrandr --addmode DVI-0 "2560x1440_80.00"
xrandr -r 80

but these do not work with the proprietary driver. It gives me this errormessage:

xrandr --addmode DFP3 "2560x1440_80.00"
    X Error of failed request:  BadMatch (invalid parameter attributes)
      Major opcode of failed request:  141 (RANDR)
      Minor opcode of failed request:  18 (RRAddOutputMode)
      Serial number of failed request:  47
      Current serial number in output stream:  48

Specifying the modeline in the X server config and adding various lines like IgnoreEDID wont help aswell.
Any idea how to get 2560x1440@80Hz working with the catalyst driver? The open source one has no problems.
It lets me set lower refresh rates but that's obviously not what I want. So there's some lock which prevents me on setting higher refresh rates than the ones in the EDID.

Offline

#5137 2013-04-13 16:10:57

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,718

Re: The AMD/ATI Bar & Grill

Just out of curiosity.  Are you using a CRT based monitor, or is it an LCD?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#5138 2013-04-13 16:40:39

BotoX
Member
Registered: 2013-04-13
Posts: 4

Re: The AMD/ATI Bar & Grill

ewaller wrote:

Just out of curiosity.  Are you using a CRT based monitor, or is it an LCD?

It's a LCD monitor with a PLS panel, see http://www.overclock.net/t/1374065/kore … -pls-panel for details.

Offline

#5139 2013-04-13 17:41:16

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,718

Re: The AMD/ATI Bar & Grill

I do not want our discussion to hijack this thread, so lets keep this brief or start a new thread.  Changing the refresh rate of an LCD is pretty pointless.  The LCD panel itself is only capable of running at one rate. period.  The front end in front of the panel may well be able to accommodate higher or lower frame rates than the rate that is intrinsic to the LCD.  The incoming frames are kept in a buffer to display once they have been received.  If frames arrive faster than the panel can display them, then the occasional frame is dropped (and never displayed).  On the other hand, if the incoming frame rate is lower than the intrinsic frame rate, then the occasional frame is displayed twice while waiting for the next full frame to arrive.  I really suggest you select a frame rate that is the frame rate that is native to the LCD.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#5140 2013-04-15 16:35:18

iceTwy
Member
Registered: 2013-04-15
Posts: 4

Re: The AMD/ATI Bar & Grill

I've installed the most recent catalyst drivers from the default [catalyst] repo. They've been working just fine, however catalyst-utils requires the following dependency: xorg-server<1.14.0. Hence why I can't run a full pacman upgrade (pacman -Syu) without ignoring xorg-server & xf86-input-evdev.

Is there any update as to when the support for the newest versions of xorg-server will be implemented?

Offline

#5141 2013-04-15 16:38:02

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 672

Re: The AMD/ATI Bar & Grill

iceTwy wrote:

I've installed the most recent catalyst drivers from the default [catalyst] repo. They've been working just fine, however catalyst-utils requires the following dependency: xorg-server<1.14.0. Hence why I can't run a full pacman upgrade (pacman -Syu) without ignoring xorg-server & xf86-input-evdev.

Is there any update as to when the support for the newest versions of xorg-server will be implemented?

https://wiki.archlinux.org/index.php/Ca … positories

95% of posted problems have their solution in the wiki. Please read it before posting.

Offline

#5142 2013-04-15 16:39:49

BotoX
Member
Registered: 2013-04-13
Posts: 4

Re: The AMD/ATI Bar & Grill

ewaller wrote:

I do not want our discussion to hijack this thread, so lets keep this brief or start a new thread.  Changing the refresh rate of an LCD is pretty pointless.  The LCD panel itself is only capable of running at one rate. period.  The front end in front of the panel may well be able to accommodate higher or lower frame rates than the rate that is intrinsic to the LCD.  The incoming frames are kept in a buffer to display once they have been received.  If frames arrive faster than the panel can display them, then the occasional frame is dropped (and never displayed).  On the other hand, if the incoming frame rate is lower than the intrinsic frame rate, then the occasional frame is displayed twice while waiting for the next full frame to arrive.  I really suggest you select a frame rate that is the frame rate that is native to the LCD.

I'm sorry but you should've informed yourself before posting even though your post applys to 99$% of LCD monitors out there.
This one is different and I've managed to overclock it with the open source driver and could immediately see the higher refreshrate since there were a lot more cursors drawn when moving it.
Just take a look at this thread: http://www.overclock.net/t/1382348/post … t_19756582

So, back to my question: Any way to get a higher refreshrate than what the EDID says is supported with Catalyst?
Edit: It can't do lower refresh rates aswell... When trying to change to 48Hz it wouldn't do anything through xrandr and amdcccle would tell me that there isn't enough video memory.
Maybe file a bug/feature request on the bugzilla? hmm

Last edited by BotoX (2013-04-16 23:08:11)

Offline

#5143 2013-04-15 17:57:07

iceTwy
Member
Registered: 2013-04-15
Posts: 4

Re: The AMD/ATI Bar & Grill

snack wrote:
iceTwy wrote:

I've installed the most recent catalyst drivers from the default [catalyst] repo. They've been working just fine, however catalyst-utils requires the following dependency: xorg-server<1.14.0. Hence why I can't run a full pacman upgrade (pacman -Syu) without ignoring xorg-server & xf86-input-evdev.

Is there any update as to when the support for the newest versions of xorg-server will be implemented?

https://wiki.archlinux.org/index.php/Ca … positories

95% of posted problems have their solution in the wiki. Please read it before posting.

Thanks for the help!

Offline

#5144 2013-04-15 20:05:47

felipense
Member
Registered: 2013-04-05
Posts: 62

Re: The AMD/ATI Bar & Grill

i tried to install catalyst from comunity but he needed the old linux-headers for complete installation. Also i guess i have to downgrade the kernel to.

Offline

#5145 2013-04-15 20:15:05

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,471
Website

Re: The AMD/ATI Bar & Grill

felipense wrote:

i tried to install catalyst from comunity but he needed the old linux-headers for complete installation. Also i guess i have to downgrade the kernel to.

Look up a few posts on this very page....


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#5146 2013-04-17 08:40:17

acgtyrant
Member
From: Hangzhou, China
Registered: 2013-04-09
Posts: 54
Website

Re: The AMD/ATI Bar & Grill

Help me~

When I execute aticonfig --initial, it says error:error while loading shared libraries: libGL.so.1: connot open shared object file: No such file or directory

I have installed xorg-server xorg-server-utils xorg-xinit from xorg113 repository, catalyst-hook catalyst-utils-pxp from catalyst-stable repository, linux-headers, lib32-catalyst-utils.

I have enable the catalyst-hook.service.

By the way, my laptop is ThinkPad E420, which have Intel-AMD video, and my Arch Linux is 64-bit.

Forgive my poor English, thank you!


I am Chinese! I love Arch Linux!

Offline

#5147 2013-04-17 08:42:23

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 672

Re: The AMD/ATI Bar & Grill

acgtyrant wrote:

Help me~

When I execute aticonfig --initial, it says error:error while loading shared libraries: libGL.so.1: connot open shared object file: No such file or directory

I have installed xorg-server xorg-server-utils xorg-xinit from xorg113 repository, catalyst-hook catalyst-utils-pxp from catalyst-stable repository, linux-headers, lib32-catalyst-utils.

I have enable the catalyst-hook.service.

By the way, my laptop is ThinkPad E420, which have Intel-AMD video, and my Arch Linux is 64-bit.

Forgive my poor English, thank you!

It seems /usr/lib/libGL.so.1 is missing in your system. Reinstall catalyst-utils, since that file should come with this package.

Offline

#5148 2013-04-17 09:10:44

acgtyrant
Member
From: Hangzhou, China
Registered: 2013-04-09
Posts: 54
Website

Re: The AMD/ATI Bar & Grill

snack wrote:
acgtyrant wrote:

Help me~

When I execute aticonfig --initial, it says error:error while loading shared libraries: libGL.so.1: connot open shared object file: No such file or directory

I have installed xorg-server xorg-server-utils xorg-xinit from xorg113 repository, catalyst-hook catalyst-utils-pxp from catalyst-stable repository, linux-headers, lib32-catalyst-utils.

I have enable the catalyst-hook.service.

By the way, my laptop is ThinkPad E420, which have Intel-AMD video, and my Arch Linux is 64-bit.

Forgive my poor English, thank you!

It seems /usr/lib/libGL.so.1 is missing in your system. Reinstall catalyst-utils, since that file should come with this package.

But catalyst-utils is conflict with catalyst-utils-pxp.

When I removed catalyst-utils-pxp and installed catalyst-utils, it says:
...
(1/1) reinstalling catalyst-utils
/tmp/alpm_00J4G7/.INSTALL: line 44: systax error near unexpected token '}'
/tmp/alpm_00J4G7/.INSTALL: line 44: '}'
/usr/bin/bash: post_upgrade: command not found
error:command failed to execute correctly

And when I executed aticonfig --initial, it says:
Found fglrx primary device section
PowerXpress erorr: Cannot stat '/usr/lib64/fglrx/switchlibGL': No such file or directory
Failed to initialize libglx for discrete GPU
Using /etc/X11/xorg.conf
Saving back-up tp /etc/X11/xorg.conf.fglrx-0


I am Chinese! I love Arch Linux!

Offline

#5149 2013-04-17 09:13:18

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 672

Re: The AMD/ATI Bar & Grill

@acgtyrant: at least now aticonfig starts and does not complain about missing libGL anymore. For what concerns the current error, I'm sorry but I can't help you. I never used aticonfig to set up my xorg.conf, it's better to wait for some good advice from Vi0l0 or some other catalyst expert.

Offline

#5150 2013-04-17 09:14:42

acgtyrant
Member
From: Hangzhou, China
Registered: 2013-04-09
Posts: 54
Website

Re: The AMD/ATI Bar & Grill

@snack Ok, thanks anyway.


I am Chinese! I love Arch Linux!

Offline

Board footer

Powered by FluxBB